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Part 1 Using ElecRoc Server 

Chapter 1 Server UI 
The server-side control program can be started by choosing Start > All Programs > 
Founder ElecRoc > ElecRoc 6 Server, or by double-clicking the program icon on your 
desktop. The main interface then appears.  

 
Figure 1-1 

Main menu: provides commands for you to control and configure the ElecRoc Server.  

Toolbar: represents part of the menu commands, for you to quickly perform some 
common operations and configurations.  

Processor list: lists all the processors in your ElecRoc system, displaying related 
information such as ID, name, type, version, host, and status.  

Status bar: shows the status of your selected item in processor or font list.  

 

The table below shows the main menu commands and their functions:  
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Menu Item Function 

Operation 

Start Processors Start all the processors in the list.  

Stop Processors Stop all the processors in the list.  

Exit Exit the server, and stop all the processors.  

Settings 

General 
Configure ElecRoc’s system directories, input directories, 
and image path.  

Database 
Automatically cleanup the process record in the database 
prior to specified days.  

Authorization 
Control the authorities for Clients to access the Server and 
those for ElecRoc users to access the shared folders on the 
server.  

Space Alert Alert when free disk space is less than specified value.  

Resources PPD Creator 
Create PPD file specific to certain device, for PC or MAC 
platform.  

Font 

Font List List all fonts installed in ElecRoc system. 

Add Font File Install fonts into ElecRoc.  

Delete Fonts Delete unneeded fonts in ElecRoc.  

Reset Fonts 
Check the fonts installed, and update the font configuration 
in ElecRoc.  

Start/Stop 
Installing Fonts 

Install fonts into ElecRoc. 

View 

Refresh Refresh the processor status.  

Toolbar Show or hide the toolbar.  

Status bar Show or hide the status bar.  

Window 

Cascade Arrange all opened windows in cascade.  

Horizontal Tiling Arrange all opened windows in horizontal tiles.  

Arrange Icons Arrange the minimal icons when all windows are minimized.  

Help 

About Founder 
ElecRoc 6 

View the version and copyright information about ElecRoc.  

ElecRoc 6 License 
Information 

View the license information.  

Table -1 

 

The icons and their functions in the toolbar  from left to right: start 
processors, stop processors, font list, add font file, delete fonts, reset fonts, and 
refresh.  
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Chapter 2 Using ElecRoc Server 

2.1 Processor control 

2.1.1 Start processor 
By default, all the processors are offline after the Server is started. At this moment, you 
can login ElecRoc, but cannot run the processors to process files. Before you can run the 
processors, you must start them.  

Choose Operation > Start Processors from the main menu, you can start all the 
processors. If you want to start only one or some of the processors, choose these 
processors in the list, then right-click and choose Start. The Shift or Ctrl key helps you to 
choose more than one processor one time. If the processor is installed on a different 
computer, make sure the computer is powered on.  

2.1.2 Stop processor 
Choose Operation > Stop Processors from the main menu, you can stop all the 
processors. If you want to stop only one or some of the processors, choose these 
processors in the list, right-click and choose Stop.  

2.1.3 Delete processor 
With the right-click menu item Delete, you can remove unneeded processor from the 
list. 

2.1.4 Configure PDF Generator 
PDF Generator is one of the core processors in ElecRoc, required in each job. Its 
processing speed influences the overall efficiency of ElecRoc workflow. To improve this 
speed, especially its parallel processing speed, ElecRoc enables you to configure multiple 
synchronous sub-processors. Theoretically speaking, more sub-processors enable higher 
speed, as long as your machine provides sufficient computing capacities.  

Choose PDF Generator, right-click and choose Configure.  

 
Figure 1-2 

By default, each PDF Generator is composed of two sub-processors, Normalizer and 
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NCPreview. The former is designed to generate PDF (i.e. converts standard PDF, or 
non-PDF such as PS, EPS, Tiff, to PDF), the latter is used to generate thumbnail image for 
preview. You can base on the quantity your dongle permits, the computer’s capacity, and 
your actual production needs, to re-configure the quantity of the two sub-processors.  

Click Config. Input the quantity separately in the Normalizer and GenPreview edit boxes.  

 
Figure 1-3 

Return to the configuration window. You can use the Enable/Disable button to 
individually enable or disable each of the sub-processors. And you can use the Up and 
Down button to change their priority. The Delete button is used for deleting unneeded 
sub-processor.  

The configuration takes effect after you reboot the PDF Generator.  

2.2 Font Setting 

When a file itself doesn’t provide the fonts it uses, you must install these fonts in ElecRoc, 
so as to output the file correctly with the fonts it asks. ElecRoc supports three types of 
fonts: 1) Founder-developed CID fonts; 2) Third party PostScript fonts including Type1 
font on Macintosh, developed by other font vendors; 3) TrueType fonts available in your 
operating system. ElecRoc provides 35 basic fonts by default.  

Operations below are available only when you stop and choose PDF Generator, and can 
be performed by using either the menu items, or toolbar icons, or right-click menu items.  

2.2.1 View Font 
Choose Font > Font List from the main menu to view all the fonts installed in ElecRoc.  

 
Figure 1-4 



Using ElecRoc Server 

 5 

2.2.2 Install Font 
Choose Font > Add Font File if the font is provided in PS file. In the pop-up dialog box, 
browse and open the PS file, ElecRoc will then automatically complete the installation. 

Choose Font > Start Installing Fonts if the font is provided via CD. Then insert the CD 
into CD-ROM drive. And then ElecRoc starts the install program to install the fonts. After 
the installation, choose Font > Stop Installing Fonts.  

Reset the fonts after the installation.  

2.2.3 Reset Font 
Perform this operation after you install or delete a font. It will check all the fonts installed, 
and update the font configuration in ElecRoc. Choose Font > Reset Fonts to perform.  

Reset TrueType fonts: It pops up the following dialogue before the resetting. Click Yes 
to add the TrueType fonts from your operating system to ElecRoc, otherwise, click No.  

 
Figure 1-5 

2.2.4 Delete Font 
Choose Font > Delete Fonts to delete unneeded font from the font list.  

2.3 System Settings 

2.3.1 General Setting 
You can choose Settings > General from the main menu to configure ElecRoc’s system 
directory, input directory and image paths.  

1. ElecRoc Directory 
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Figure 1-6 

Upload: Refers to a location where you can upload source files. The default location is a 
shared folder on the server, named Upload. ElecRoc users can access it via the path 
\\Servername\Upload, and upload source files in it.  

Jobs: A directory that stores job data. Be cautions in changing this directory since it may 
result in loss of all the job data. If needed, we strongly recommend you to change it at 
the very beginning, even before the first job, and never change it from then on.  

Ink Key: This directory stores ink control files.  

To change above directories, click the button  to open a dialog box, and then specify 
new directory, either local directory on the Server or network directory over the LAN 
(network directory must be a shared one available for users to write).  

2. Input Directory 

It refers to a directory that stores source files, and the source files are files that can enter 
into ElecRoc workflow for being processed. At the time you submit files manually at the 
PDF Generator node, or automatically by way of a hot folder, you need to look for source 
files under a certain directory. The Upload mentioned above is just one of the input 
directories. It requires the user to upload the source files in advance. If you don’t want to 
upload, you can provide only the path for the source files, instead.  

Click Add to add a path. Input the path in the pop-up dialog box appeared later on. The 
Delete button enables you to delete a selected path.  
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Figure 1-7 

3. Image Path 

Here you provide the options for PDF Generator’s Image Path parameter. With the 
image path, ElecRoc can correctly locate the images the source file contains. In case that 
the source file and the images it contains are stored together (not including composite PS 
file that contains DCS images), you do not need to specify image path.  

 
Figure 1-8 

2.3.2 Database Cleanup 
ElecRoc uses a database to store process data. To prevent the stored data from lowering 
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the overall efficiency after a long time running, ElecRoc can automatically clean up the 
earlier data for you. By default, it cleans up the data 3 days ago. You can choose 
Settings > Database from the main menu to specify another.  

 
Figure 1-9 

2.3.3 Authorization 
Choose Settings > Authorization from the main menu. Here you can control if a Client 
can login the Server, and if an ElecRoc user can access the shared folders on the server.  

 
Figure 1-10 

Under the Client tab, you can control the authorities for the Clients to login the Server. 
Only Clients having been authorized can log on the Server. To authorize, input the client 
name (not IP address) into the edit box, and click Add to include it into the Authorized 
Computer List, and then click Apply. The Delete and Clear buttons are used to remove 
the authorities. Click Apply after the deletion or clearing.  

Under the Shared Folder tab, you can control the authorities for ElecRoc users to access 
the shared folders on the Server. Only users having been authorized can access the 
shared folders. Methods for authorizing and un-authorizing are the same as above. By 
default, there is an Everyone in the Authorized Users list, indicating that everyone is 
authorized to access the shared folders. For reasons of security, you may need to restrict 
this authority. For this, you can click Delete to delete Everyone, and then input the user 
name into the edit box, click Add and then Apply.  
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Figure 1-11 

2.3.4 Space Alert 
Choose Settings > Space Alert from the main menu. Here you can specify a threshold. 
ElecRoc will alert you when the free disk space is less than this threshold.  

 
Figure 1-12 

2.4 License Information 

Choose Help > ElecRoc 6 License Information from the main menu to open the 
license information window.  

In this window, you can view the license information. Take the case of using a physical 
dongle as example, you can see such information as dongle ID, expiration date, whether 
the processors are licensed, the quantity of PDF Generators and Clients allowed, and the 
quantity and levels as to print and proof.  
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Figure 1-13 

If needed, you can choose File > Print to print out the above information. Before you 
print, you can configure the print setup.  

2.5 Configuration Tools 

On ElecRoc server, choose Start > All Programs > Founder ElecRoc > Configuration 
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Tools, and there you can see such menu items as Dongle Extension, License 
Manager, Processor Configuration, Restart Dongle Services, and Disconnect 
Remote Desktop, their functions are as follows.  

2.5.1 Dongle Extension 
The dongle extension tool is used when you want to extend the expiration date of your 
ElecRoc dongle. It is not needed if your dongle has no time-limited.  

If your dongle is time limited, ElecRoc will generally pop up a related hint like ”This timer 
version ElecRoc 5 will be expired in xx days, please contact your service provider for 
upgrade as soon as possible”, within 30 days before the expiration. After you see this hint, 
please make an extension in time, so that your ElecRoc can continue to work properly. 
Steps to extend are as follows:  

1. Before the extension, please contact Founder’s sales representative to gain a KEY file.  

2. Stop running your ElecRoc Server and Client, and then run this tool.  

3. Check if the dongle-related information is correct. The tool can automatically read the 
dongle ID, device ID, and expiry time, and you can also manually click Check to read it.  

 
Figure 1-14 

4. Click Browse, find out and open the KEY file. Or copy the content of the KEY file onto 
the Key Data area.  
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5. Click Update.  

2.5.2 License Manager 
You can use this tool when you need more value-added features or modules for your 
ElecRoc system. Steps to use this tool:  

1. Before you run this tool, please contact Founder’s sales representative to gain the 
License Key file.  

2. Stop running your ElecRoc Server and Client, and then run this tool.  

 
Figure 1-15 

3. Check if the dongle ID and device ID is correct. The tool can automatically read the 
dongle ID and device ID, and you can also manually click Query to read them.  

4. Click Browse, find out and open the License Key file.  

5. Click Update.  

2.5.3 Processor Configuration 
During the process of using ElecRoc, in cases that the location of your dongle is changed, 
or that you need to add more ElecRoc processors, you can use this tool.  
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Figure 1-16 

In case that the dongle location is changed, please re-input the name or IP of the 
computer where your dongle is located, and then click Apply.  

In case that you need to add more ElecRoc processors, please make sure that the 
computer name or IP of your dongle is correct, and then click Next to enter in the 
processor install window, where you can then add more processors as needed. For details 
on processor installation, refer to Founder ElecRoc 6 Installation Guide.  

2.5.4 Restart Dongle Services 
This tool is used to restart dongle service in cases such as when the dongle service was 
stopped by accidental cause.  

2.5.5 Disconnect Remote Desktop 
By using Windows’ Remote Desktop Connection, you can remotely control and use 
ElecRoc’s server machine from a network connected computer. At the time when you exit 
the remote desktop connection, after you have done your operations on the server, 
please choose Start > All Programs > Founder ElecRoc > Configuration Tools > 
Disconnect Remote Desktop to exit, instead of simply clicking the Close icon  
on the Remote Desktop Connection window.  

This can avoid a potential problem occurring at the moment you select source files (see 
section 3.3.1 in part 2). If you simply click the Close icon to exit, your ElecRoc Client 
users may NOT normally browse some of the available source files.  
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Chapter 3 Using Console 
When you have installed one or more ElecRoc processors with the Server install program, 
regardless of locally or non-locally, you will see a shortcut icon named ElecRoc 6 
Console appearing on the computer desktop. By double-clicking this icon, you can open 
the ElecRoc’s Console window shown as follows. From this window, you can start or stop 
the processors you have installed into ElecRoc system, and configure such processor 
properties as the frame bitmap storage directory, and RIP temporary storage directory. 

Moreover, as to the proof processors, here you can perform the color-related operations, 
including color solution making, spot color measuring, Delta E comparing, re-calibrating, 
and remote calibrating.  

 
Figure 1-17 

The Server edit box displays the server that the processors belong to. Once you input 
the server name here, the table below will list all processors you have installed into this 
server. Click the Refresh button, and you can display the processors’ latest status.  

Divert Dongle: Click this button in case that the computer where the dongle is installed 
(generally i.e. the server) is changed, and then input the name or IP address of the 
computer in the follow-up dialog box, so as to ensure that all the installed processors can 
continue to run normally.  

3.1 Processor Control 

3.1.1 Start Processor 
Choose a processor in Offline status from the processor list, and then click Start at the 
right of the list, and the processor will be started, with the status turning to Online. A 
processor can be used to process files only when it has been started.  

A process can be started from ElecRoc Server as well. The Server control program 
manages all the processors in your ElecRoc system, not only the local ones residing on 
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the server, but also the non-local ones installed from other connected computers. The 
console manages only the processors installed from the current computer. In other words, 
a processor can be started from both ElecRoc Server and the console. If you have started 
it from the Server, you can see the status change on the console; in reverse, if you start 
it from the console, you can see the status change on the Server.  

The Refresh button enables you to know the latest processor status.  

3.1.2 Stop Processor 
Choose a processor in Online status from the processor list, and then click Stop at the 
right of the list, and the processor will be stopped, with the status turning to Offline. A 
processor can also be stopped from ElecRoc Server.  

3.1.3 Terminate processor 
In case that a processor cannot be stopped for some reason, you can click Terminate to 
forcibly stop it. Perform this operation with caution, for it may result in unexpected error.  

3.2 Processor Properties 

Choose a processor in the Console window, then click Properties, and you can open the 
property setup window for this processor, configuring parameters like frame bitmap 
storage directory and RIP temporary storage directory. Such property window for the 
proof processor provides also buttons for you to access the color tools.  

3.2.1 Most processors 
The properties for most processors, including PDF Generator, Imposer, Ganging, Preflight, 
Trap, PDF Export and 8 Bit TIFF Export, are inalterable. If you choose one of them and 
click Properties, ElecRoc will pop up message, hinting that properties are not editable.  

3.2.2 Printer processors 
Include mono and color printers.  

 
Figure 1-18 

Frame bitmap storage directory: Under this directory, ElecRoc stores the frame 
bitmap files generated in printing. You can click the button at the right to choose another. 

RIP temporary storage directory: The storage directory for temporary files in RIP 
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process. 

Printer: It is the actual printing device used by the processor. Options in the dropdown 
list are the printers installed in your current computer, including those shared printers 
from other connected computers.  

3.2.3 PDF Rasterizer 
Generate Thumbnail: If checked, during the rasterizing process, this processor will 
generate a thumbnail image for you to preview the bitmap.  

 
Figure 1-19 

3.2.4 Winprint 
If you open the property window for a Winprint post-RIP proof processor, you can see an 
Advanced button. With it, you can open the device’s advanced parameter setup window.  
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Figure 1-20 

The advanced parameters are specific to the device, i.e. those for another Winprint 
device may be significantly different. Take Epson 9908 as example, here you can not only 
configure such general parameters as paper size, paper source, type, copies, direction, 
and color mode, but also perform adjustments like nozzle check, printing head cleaning, 
printing head calibration, and etc. For details, refer to the instructions attached to the 
device.  

3.2.5 Digital & Inkjet printing 
Here we take the digital printing device Indigo C3500 and Founder’s EagleJet inkjet 
printing device P5200 as examples.  
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Figure 1-21 

Number Font: This parameter controls the font for the module automatic numbering. If 
you click the button Default Font, you can reset the font to the default one.  

Output Path File: This parameter is applied to the Indigo series. It refers to the output 
path for the generated jlt files.  

Temp File Path/Temp Path: This parameter is applied to the Indigo and EagleJet series. 
It refers to the storage directory for the intermediate files or temporary files.  

IP, Port: This parameter is applied to the devices such as K6250 and K110. In case that 
the IP address or port of the device changes, here you can specify it over again.  

3.3 Create a print template 

Template here refers to the device parameter template for use by the mono printer 
processor. In the ElecRoc’s Console window, click PrinterSet to open the following 
window.  
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Figure 1-22 

Steps for creating a device parameter template:  

1. Choose a printer. Choose the actual printer used by the current processor from 
Choose Printer list. This list includes all the printers installed in current computer.  

2. Choose a paper. Click the button GenPaperLst at the bottom of the window to 
generate paper sizes that can be supported by current printer in Paper Type Full. And 
then choose a paper you want to use from the list.  

3. Configure print template. This template refers to the printer device parameter 
template configured at Printer Setting dropdown list.  

1) Create new template. Click AddNewSetting to open the printer’s device parameter 
setup window, and define the properties such as if to enable bi-directional print, the 
paper tray, paper size, direction and copies.  

After that, click OK to enter in the following dialog box. Input the name of the print 
template, by default, it is named with the paper size.  

And then click OK to finish. The newly-created template then appears in Printer Setting 
list. In case that you have added more than one template as per the above method into 
the list, make sure that you have chosen the right template in the list.  

2) Check template. You can click CheckSetting to view the parameter settings of the 
currently-selected template in Printer Setting list. 

3) DelSettingFile: This button is used only when you want to delete the 
currently-selected template in the Printer Setting list.  

4. Specify the server path. If the current computer is not the ElecRoc server, please use 
the format \\LocalServer\Elecroc\Sysdata, LocalServer referring to the actual server 
name. If the current computer is the ElecRoc server, use the format such as 
D:\Founder\ELECROC\SERVER\Sysdata, D:\Founder referring the actual disk partition 
and root directory where your ElecRoc is located.  

5. Generate template file. Click GenSettingIni to open a dialog box.  
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There would be more than one mono printer processor on the server; in this case, you 
need to specify the one with ID number. Input the ID and click OK to complete the 
creation of the device parameter template.  

 

After you have created a device parameter template for the mono printer processor, you 
can start the Client, enter in the Administrator > Processor Management or a job 
window, to open the mono printer’s processor or node parameter setup window, and then 
find out the Media parameter under the Print tab, you can see an option named Use 
device template. Checking it, and then you can see in the above dropdown list the 
created device parameter template. If your template is selected, the size and the device 
parameters it defines will then be applied in the file printing.  

 
Figure 1-23 
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Part 2 Using ElecRoc Client 

Chapter 1 ElecRoc Client 

1.1 Client Login 

Start up ElecRoc Client, and the login interface appears:  

 
Figure 2-1 

Enter correctly the server name (or IP address, or choose a server name from the 
dropdown list), the user name and password, and then click OK. If successfully, the main 
interface of ElecRoc Client then appears.  

Exceptions or other responses during the login may include:  

1) If you enter an invalid or incorrect server name, or user name, or password, ElecRoc 
will display corresponding message, such as Cannot connect to the selected server 
or Incorrect username or password. Enter a valid one to retry.  

2) If the Client is not authorized, it displays This machine has no authority to access 
the server, in this case, authorize the Client on the Server (main menu Settings > 
Authorization).  

3) If you cannot use a Mac Client to connect the Server, you can try to run the command 
in Terminal: sudo scutil -set HostName xxx.local, xxx refers to the computer name. And 
use this xxx.local as computer name to authorize (from the Server, choose Settings > 
Authorization > Client).  

4) If the ElecRoc Server is installed and running on Windows 7, when you start up a Client 
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to login, your Windows Firewall will pop up a dialog box asking whether to block or 
unblock ElecRoc. When your client system is Windows XP or 2003, choose Unblock in the 
pop-up dialog box; when it is Mac OSX, choose Always Allow;  

 
Figure 2-2 

and when it is Windows 7, in case that you are in a domain network, check Domain 
networks …, in case that you are NOT in the domain, you need to check the other two 
options Private networks … and Public networks ….  

 
Figure 2-3 

5) If you still cannot login when you have excluded the above reasons, you can click the 
button Check on the login interface, and perform an overall checkup, such as the 
computer and network configuration, so as to find out the reason why you cannot login.  
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Figure 2-4 

The window displays the check items at the left, including local machine’s configuration, 
the server’s status and configuration. Click Start to begin the checkup, and you can then 
see the result at the right of the window. According to the result, you can easily know the 
reason why you cannot login.  

A click on Reset can clean the result. The server in checklist item Check server 
hostname, and the user name and password in the item Check the user name and 
password, refer to the server, user, and password currently input in the login interface.  

1.2 Main Interface 

Main interface of the Client is composed of three parts:  

Main menu: at upper-right, provides menu items for you to control/configure the Client. 

Navigator: below the main menu, contains five icons, Jobs, Status, Resources, 
Administrator, and Statistics.  

Workplace: the body of the interface is the operating area of the module you select in 
the Navigator area. The default operating interface every time when you login is that of 
the module Jobs.  
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Figure 2-5 

1.3 Main Menu 

The main menu contains the following commands:  

Menu Item Function 

System 

Change 
Password Change or create the password for current user.  

Switch User Log off the current user, and return to the login dialog box.  

Exit Log off and exit the Client.  

Tools 

Backup 
Manager 

Completely backup all or some of the jobs.  

Preferences 
Configure system preference specific to current user, such as 
appearance, unit, scale and preferences.  

Alert 

Alerting Info 
Dialog 

Open the Alert information dialog box, in which you can view the 
alter information existing in system, and open the abnormal job. 
Here you can also clear the alert information.  

Display 
Alerting Icon 

If checked, a twinkling alert icon  appears at the navigator 
when exception or error occurs during the job process.  

Pop Alerting 
Info Dialog 

If checked, ElecRoc pops up the Alert information dialog box 
when exception or error occurs during the job process.  

Sound 
Alerting 

If checked, ElecRoc issues sound alert when exception or error 
occurs during the job process.  

Alerting 
Option 

Configure to which job, processor, user the alert is applied, and 
define the alert sound.  

Help About Display the version number and copyright information.  
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Readme 
Open the readme file, in which you can find out the introduction to 
ElecRoc, description of the new & key features, and content 
summary on the installation DVD.  

Table -2 

1.3.1 Backup Manager 
Choose Tools > Backup Manager. Here you can completely backup all or some of the 
jobs in ElecRoc, including nodes, node parameter setup, files the job contains, and 
resources applied in the job such as color solution and profiles.  

The backup manager not only provides all the capacities that the archive management 
(Administrator > Archive Management) does, but also enables you to backup Tiff 
resource, as well as information about users, user groups and processors. But the 
archive management brings more flexibility when it comes to the selection of jobs and 
profile resource, and more ease for you to upgrade. Note that the upgrade from lower to 
higher version with backup manager or archive management does not recover the node 
parameter setup.  

1. Backup 

Perform under the Backup tab, as follows:  

1. Choose backup mode. Full Backup enables you to backup all jobs currently existing 
in system, while Selective Backup backups only the selected one(s). Here we take 
selective backup as example. And then, click Next.  

 
Figure 2-6 

2. Choose the jobs. In the next window, you can see all the jobs existing in system. Check 
the jobs from the Backup column. At the PDF & Signature and the 1-bit TIFF columns, 
you can further decide whether to backup the PDFs and signatures, and 1-bit tiff files 
available in the job. And then click Next.  
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Figure 2-7 

3. ElecRoc calculates and displays the disk space needed for the backup. Reserve enough 
free disk space and click Next.  

 
Figure 2-8 

4. Specify the location for the backup file.  
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Figure 2-9 

5. ElecRoc starts to backup, and displays the progress with a bar.  

 
Figure 2-10 

6. When the bar reaches 100%, it displays Backup has completed.  
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Figure 2-11 

2. Restore 

Switch to the Restore tab. Here you can restore the backup resource to ElecRoc.  

1. Choose the backup file. The table lists the backups made on current Client. The 
Refresh button is used to update the table, and the Add button to add more backup files 
to the table. Click Next when you have chosen a backup file.  

 
Figure 2-12 

2. If more than one processor of same type exists in current system, you need to link the 
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old processor with one of the current processors in the follow-up table.  

 
Figure 2-13 

At the time you backup jobs, whether in full or selective backup mode, ElecRoc backups 
also the resource files applied in processors. Therefore, at the time they are being 
restored, you should assign corresponding processors for these resource files. If more 
than one processor of same type exists in system, click the corresponding cell in the 
Current JTP column and choose a processor. Click Next after the assignment.  

3. Determine whether to replace or remain jobs with same name in system.  

 
Figure 2-14 
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4. ElecRoc starts to restore, and displays the progress.  

 
Figure 2-15 

5. When the bar reaches 100%, it displays Restore has completed.  

 
Figure 2-16 
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1.3.2 System Preferences 
Choose Tools > Preferences. Here you can configure the system setting related to the 
appearance, unit, scale, and preference specific to the current user.  

 
Figure 2-17 

 Appearance 

The Client user interface employs three sorts of fonts: Big Font, Default Font and Small 
Font. Here you can specify the type, style and size for each font. You can apply the fonts 
installed in your operating system to display the Client.  

 Units 

ElecRoc supports three length units: mm, inch and point.  

 Scale 

It refers to the initial scale for the page and surface previews.  

Preview display border: If checked, the border of the preview image will be displayed 
when you preview any PDF page or surface.  

 Preference 

Retain previous settings after submitting: If checked, when you submit files from 
current node to another node in job window, ElecRoc remains displaying the current node 
and its files.  

Change JTP to new settings after submitting: If checked, when you submit files 
from current node to another node, ElecRoc switches to display the new node and its 
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files.  

Pop out run information dialog when submitting: If checked, ElecRoc pops up the 
job process window once the job is submitted. Otherwise, the window will not 
automatically appear.  

Pop out confirming dialog when submitting: If checked, at the time you submit files 
in job window by clicking the Run icon , ElecRoc pops up a dialog for you to confirm the 
submission.  

Disable magnification in processor list when mouse moves on processor: When 
you move the mouse onto the processor list at the left of the job window, you may see an 
animated visual effect. It is designed to highlight the processor that your cursor rests on. 
If needed, you can check this option to disable this effect.  

Disable node sharing (to optimize process speed): ElecRoc supports you to share a 
node across various jobs (see section 3.2.3 in this part for details). This sharing operation 
is performed with the node’s right-click menu item Share node (and Cancel shared) in 
job window. But this function may slow the speed you open the right-click menu or the 
process speed of other nodes in case that there are too many nodes and files existing in 
your job. In this case, you may check this option to disable the node sharing. If checked, 
the items Share node and Cancel shared will disappear in the node right-click menu.  

Default priority of Hot Folders: The default priority for jobs submitted by way of hot 
folder.  

Login set: Options here are used to control whether or not to enable the options 
Remember Password and Auto Login in the Client login window. Only when you have 
checked the two options in the Client login window, the two options here can then be 
activated. The enabling or disabling for the option Remember Password can also be 
controlled in the Client login window. As to the option Auto Login, when enabled, it will 
hide the login window at the time you login ElecRoc, therefore, you need to come here to 
disable when you want to disable it.  

 Quick Position 

This setting is designed for you to specify the table columns that are to be used when you 
quickly position your job in the job list. In quick positioning, input a keyword, and ElecRoc 
will then search for the jobs that contain this keyword, from the columns that you have 
specified here. The columns that can be specified include job id, job name, customer, 
creator, time created, order number, bill number, plan end time, description, and order 
detail. When you specify the columns, you can use the button Select All or Clear to 
select or unselect all the columns at one time, or you can also use the button Restore to 
restore the setting to its default state.  

 Net Config 

Net Config parameters are available only for ElecRoc Client running on Mac computer. You 
need to configure them before you want to use the preflight and trap plug-ins and open 
the PDF page files.  
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Figure 2-18 

Domain or Workgroup Name: The name of the domain or workgroup where your 
ElecRoc system is deployed.  

User Name: Any user with whom you can access your ElecRoc server machine online 
from the current Mac computer.  

Pass Word: The password for the user defined above, if any.  

1.3.3 Alert 
ElecRoc provides you with many means to inform the exception or error occurred during 
the process, including the alert information dialog, alert icon, and alert sound. The alert 
information dialog employs a table to display the errors and exceptions. With the buttons 
in the dialog, you can open a job’s process information window to view detailed alert 
information, and you can also open a job’s operating window. Besides, you can clear the 
alert information. The alert icon here refers to an icon  twinkling at the navigator.  

From the main menu, choose Alert > Alerting Option. Here you can specify not only 
the job, JTP and user that the alerting is applied to, but also the alert sound to be issued.  
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Figure 2-19 

Job: If you choose All Jobs, ElecRoc alerts once exception or error occurs in any job. If 
you choose Current opened jobs, ElecRoc alerts only when exception or error occurs in 
currently opened jobs. In addition, you can choose specific jobs from the job list below.  

JTP: If you choose All JTPs, ElecRoc alerts once exception or error occurs at any 
processor node. Here you can also choose specific node from the node list below.  

User: If you choose All Users, ElecRoc alerts all the users login on ElecRoc. If you 
choose Current User, ElecRoc alerts only to the current user. In addition, you can 
choose specific users from the user list in the below.  

Ignore alert information: If checked, ElecRoc ignores the process information in pink, 
and alerts only when information in red appears. If not, ElecRoc always alerts as long as 
the information appears, regardless of whether it is in pink or red.  

Sound File: Here you can customize a .wav audio as the alter sound.  
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Chapter 2 Administrative Tools 
Administrative tools as a whole refer to the tools for administrator to manage ElecRoc 
system, and they are classified under three navigator modules, i.e. Resources, 
Administrator, and Statistics.  

 
Figure 2-20 

Resources Administrator Statistics 

Profile Resource 
Imposer Template 

Digital Proof 
Traditional Press 

Digital Press 
Job Ticket 

User Management 
Processor Management 
Archive Management 
Client Management 

Ink Amount 

Table -3 

2.1 Users Management 

In the module Administrator > Users Management, you can create, edit or delete a 
user or user group, and control its authority to use the modules of ElecRoc.  
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Figure 2-21 

2.1.1 User Management 
1. View Users 

You can view all users in your ElecRoc system, learning its name, description, time 
created, group it belongs to, and the status. The administrator is the system-defined 
user to administer ElecRoc.  

The Refresh button enables you to manually update the information in real time.  

2. Create a User 

Click New to open the New User dialog box, see the left figure below.  

   
Figure 2-22 
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Input the user name, and if needed, the description and password. And then click OK. 
Note that the upper and lower case letters are distinct for the user name, for example, 
User1 and user1 are two different names.  

3. Edit a User 

To add a user into one or more user groups, or to modify its description, double-click the 
user in the user list, or choose it and click Edit. The Edit User dialog box then appears. 
See the right figure above.  

At the left lists all the user groups in your ElecRoc system; at the right shows the group(s) 
the user belongs to. Choose a group from the left and click the arrow , the group will be 
added to the right. Choose a group from the right and click the arrow , the group will be 
removed from the right.  

You can modify the description in the Description edit box.  

4. Authorize a User 

To manage the user’s authority for using ElecRoc’s functional modules, click Authorize.  

 
Figure 2-23 

The left column shows all the groups and users in ElecRoc, the right list displays ElecRoc’s 
modules. Choose a user or group at the left, and you can see at the right the authority the 
user or group has. The modules authorized are checked. Some checked modules may not 
be canceled; this must be that the user belongs to a group and the group has been 
authorized for these modules. You can cancel these modules when you choose the group 
at the left.  

To re-define the user or group’s authority, you can check or uncheck the modules as 
needed. And then click OK to confirm.  

Modules that can be authorized include:  
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PDF Management 
Proof Management 

Output Management 
Digital Management 
Ticket Management 
Users Management 

Groups Management 
Processor Management 
Archive Management 

Ink Statistic Management 

They represent the administrative modules 
under the three navigator icons Resources, 
Administrator and Statistics. If checked, the 
user can access corresponding modules. E.g., if 
you leave the box Processor Management 
unchecked, after the user logins ElecRoc he or 
she cannot see and use the module 
Administrator > Processor Management. 

Ganging Resource Management 

It controls if the user can see and use the 
administrative module Resources > Imposer 
Template, and if the user can see and use the 
Composer modules, including the tabs Plate, 
Paper, Template and the resource explorer.  

Backup Management 

It controls if the user can access the item 
Backup Manager under the Tools menu. Only 
the user who has been authorized can see and 
execute this menu item. 

Jobs Management It controls if the user can open and delete jobs. 

Jobs Resource Deletion 

It controls if the user can delete the resource in 
jobs. In case that this module is NOT checked 
but the user has been authorized for modifying 
jobs in job authorization, the user can not delete 
the resource in the jobs created by other users, 
but can still delete the resource in the job 
created by him or her. 

Page Replace 
It controls if the user can use the Substitution 
function when he or she uses the Page Compare/ 
Substitution module in the job.  

Status Monitor Management 

It controls if the user can perform operations in 
ElecRoc Client’s Status monitor. The user who 
has not been authorized for this module cannot 
control any other user’s jobs, such as to stop 
jobs submitted by other user, however, he or she 
can still view all other users’ operations. 
Irrespective of whether the user has been 
authorized or not for this item, he or she can 
always control his or her own jobs. 

Imposer Template Management 
It controls if the user can use the template 
module in Imposer.  

Inx Management 
It controls if the user can use the VDP (variable 
data print) module in the job.  

Table -4 

5. Change Password 

Here the administrator can reset other user’s password.  

6. Delete a User 
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Choose a user from the list and click Delete, if you want to remove it from ElecRoc 
system.  

2.1.2 Group Management 
The group management is the same as the user management on the whole.  

A little difference lies in that you should specify the users the group contains. In the New 
Group or Edit Group dialog box, choose the user(s) from the left and click the arrow  
to add the user(s) into the group. Choose the user(s) from the right, and then click the 
arrow  to delete the user(s) from the group. In addition, as to the group authorizing, 
note that the authorized modules are available for all the users the group contains. 

 
Figure 2-24 

2.2 Processor Management 

In the module Administrator > Processor Management, you can view all the 
processors available in your ElecRoc, start or stop their running, define their default 
parameter setting, and control if ElecRoc users can use them.  

2.2.1 View Processors 
You can view what processors are installed in your ElecRoc, their names, types, versions, 
servers, and status. The Refresh button enables you to manually update the processor 
information.  
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2.2.2 Start or Stop 
Click the button Start, and you can start all the processors. The processors can be used 
to process files only when they have been started. Click the button Stop, and you can 
stop all the processors. If you want to start or stop only one of the processors, please 
choose the processor and right-click your mouse, and then choose the item Start or 
Stop from the pop-up menu.  

 
Figure 2-25 

2.2.3 Define Default Parameter Setup 
Double-click a processor in the list, or choose it and click Open, to open its parameter 
setup window, and then configure the parameters as needed. After the configuration, 
click Apply to save the setting as the global parameter setup, i.e. the default parameter 
setup for this processor when you add it as a node into a job. For details, refer to Chapter 
4 Processor Parameter Setup.  

2.2.4 Authorize 
Choose a processor and click Authorize. In the pop-up window you can control the 
authorities for ElecRoc users to use the processor, view and modify its parameter setup.  
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Figure 2-26 

At the top displays the name of the current processor. The left are ElecRoc users, and the 
right lists authorized users or user groups. To authorize, choose one or more users or 
user groups at the left, and click the button , adding it to the right list. And after that, 
you can control the specific authorities of an authorized user by way of the View, Use 
and Modify checkboxes, i.e. whether the user can view its parameter setup in the job, 
use it in the job, and modify the parameter setup.  

To cancel the authority, choose one or more users or user groups at the right, and click 
the button .  

2.2.5 Proof 
This function is applied to digital proof processors, color digital printing devices, and 
inkjet printing devices. It can start up the Color Tools, with which you can create the CMF 
file for selected processor or printing device, so as to ensure the color consistency and 
improve the quality for your output.  

To create a CMF file, choose an applied processor and click the button Proof, and you can 
see that ElecRoc will automatically create a job and put in related processor nodes in that 
job. Here we take the proof processor as example, the auto-created job will then contain 
a proof node. Double-click the proof node to open its parameter setup window, and then 
define related proof parameters, and after that click the Proof button in the parameter 
setup window. The Color Tools will then be started up.  

For details about the Color Tools, see the manual Color Tools User Guide.  

2.2.6 Load Balancing 
This function is designed to balance the workload among the processors of same type, 
with an aim to avoid overload. It’s applied to such types of processors as PDF Generator, 
Margin Adjustment, Preflight, EcoInk, PDF Export, PDF Rasterizer, 1 bit TIFF Export, 
Printer, and Proof. When there are two or more than two processors of same type existing 
in your ElecRoc system, you can open the following dialog box by choosing one of the 
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processors and clicking the button Load Balancing.  

 
Figure 2-27 

Check the box Enable and choose a processor in the dropdown list. The overload on the 
current processor (if any) will then be assigned automatically to your chosen processor 
here, to realize the workload balancing.  

2.3 Archive Management 

The module Administrator > Archive Management enables you to archive the job 
resource, such as nodes, node parameter setup, pages, signatures, and the system 
resource, including user-defined marks, preflight and trap profiles, proof color solutions, 
curves, and spot color tables, to media like local hard disk. You can also upload the 
archived resource into ElecRoc. 

 
Figure 2-28 
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2.3.1 Archive 
Under the Archive tab lists all the resources currently in system that can be archived, 
classified into two types: Job and Resource, as in the Archive File dropdown list. 
Choose specific resource to be archived (use the right-click menu item View Info to view 
the resource size), and then click the Archive button. After you specify the name and 
location for the archive file in the popup dialog box, ElecRoc will start the archiving. A bar 
appears, showing the progress. The archiving completes when the bar reaches 100%.  

Archive files for jobs and resources are suffixed respectively with .arc1 and .arc2. The 
archived files are all displayed under the Resume tab. At the time you specify the name 
and location for the archive file, if found an archive file with same name existing under 
the specified location, ElecRoc will prompt you whether to overwrite the file. In addition, 
do not perform other operations while the archiving is under way, such as modifying 
parameter setup, processing files, for these operations may slow down the archiving 
speed, and may result in unexpected error.  

2.3.2 Upload 
Switch to the Resume tab. Here lists all the archived resources, accordingly in two types: 
Job and Resource, as in the Archived File dropdown list.  

 
Figure 2-29 

To upload the archived resource into ElecRoc system, choose the archive file and click 
Restore (or right-click and choose Restore). If the archive file you want to upload is not 
listed here, you can click Add to add it into the list.  

If found a job or resource file with same name existing in system, ElecRoc will prompt you 
whether to overwrite the job or file. The uploading progress is shown with a bar. You can 
cancel the uploading when the bar doesn’t reach 100%.  

The Add and Delete buttons under the Resume tab are used to add and delete archive 
resources into or from the list. Refresh can update the list. Restore, Add, Delete are 
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also available in right-click menu.  

2.4 Client Management 

In the module Administrator > Client Management, you can view what clients are 
connecting your ElecRoc server. The information includes computer name, IP address, 
and the latest login time. The Refresh button enables you to manually refresh the 
information in real time. And if needed, you can forcibly disconnect any of the clients. To 
do this operation, please choose the client you want to disconnect, and then click the 
button Force Disconnect.  

 
Figure 2-30 

2.5 Profile Resource 

In the module Resources > Profile Resource, you can manage the resource applied in 
PDF process, including preflight profiles, trap profiles, ICC profiles, spot color tables, and 
EcoInk solutions, for use by processor nodes like 3rd Party Preflight, Trap, PDF CMS, PDF 
Rasterizer, and EcoInk in your job.  
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Figure 2-31 

2.5.1 Preflight 
ElecRoc integrates with the preflight module from the third-party Enfocus. Here you can 
view, import, export or delete the preflight profiles and action files used by this preflight. 

To import these two types of files into ElecRoc, click Import. Enfocus preflight profiles 
have the file extension of .ppp, while action files have an extension of .eal. To export for 
some reasons e.g. backup, click Export. And click Delete to remove unneeded files.  

Enfocus preflight profile and action file are available at Enfocus’ website:  

http://www.enfocus.com/contentpage.php?id=918 

http://www.enfocus.com/contentpage.php?id=929 

2.5.2 Trap 
Here you can create, edit, delete, import or export the ink profiles used by the Trap 
processor.  

At the time you configure the ink setting in the Trap processor parameter setup window, 
you need to apply an ink profile. This profile defines the separations in job files, the ink 
densities and ink types.  
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Figure 2-32 

In each ink profile, the four basic separations, C, M, Y and K, are absolutely necessary. 
They cannot be renamed or deleted, their ink types are fixed to normal, and only their ink 
densities can be edited. The spot colors can be added or deleted without limit. Their ink 
densities, ink types and trap sequence can all be edited. There are four ink types for spot 
color, normal, transparent, opaque, and ignore opaque. For details on ink density, ink 
type and trap sequence, refer to Chapter 4.6 Trap.  

The window for creating an ink profile can be opened by clicking the New button. The 
adding, deleting and sequence adjusting of spot colors can be performed with the 
buttons , ,  and . The window for editing an ink profile is the same, which can be 
opened by double-clicking the profile, or by clicking Edit.  

In addition, you can export the ink profiles from ElecRoc to a specified location, or import 
ink profiles into ElecRoc. Before exporting, you can choose one profile, or more than one 
profile, at the same time.  

2.5.3 ICC 
Here you can import or export various types of ICC profiles that can be used later when 
you configure the color management parameters for the PDF CMS or PDF Rasterizer node, 
or when you make an EcoInk solution.  

The ICC Type dropdown box lists 7 ICC profile types, CMYK, CMYKLink, RGB, RGBLink, 
Gray, GrayLink and DeviceN. Among them, xxxLink refers to Device Link, and DeviceN 
refers to the optional ICC profiles when the output mode is set to HiFi in PDF CMS’s 
processor parameter setup.  
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Figure 2-33 

2.5.4 Spot Color Table 
Spot color table is used to control the output color value for each spot color when it is 
output by way of CMYK simulation. Classified into two types, Custom and System, the 
spot color tables are widely used in digital proof, rasterizing, and digital printing.  

 
Figure 2-34 
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Here you can create, edit, delete, import and export the user-defined spot color tables, 
which can be used later in configuring the color parameters for digital proof, the PDF 
Rasterizer parameters, or the color parameters for the digital printing devices.  

Here you can also view the system-provided spot color tables.  

1. Create spot color table 

Switch the type to Custom Spot Color, and click New.  

 
Figure 2-35 

First, input the table name in the Spot Color Table Name edit box.  

Then, click New to add spot color. You need to specify the spot color name and its CMYK 
values. After you add a spot color, you can click Edit to modify the values, or Delete to 
remove unneeded spot color. You can also click Import to import spot colors from other 
spot color tables.  

And then, click OK to save the table. 

2. System spot color table 

This table collects the system-provided spot colors that aren’t allowed to be edited or 
deleted.  

You can import the system spot color to a specified custom spot color table. Open the 
system spot color table and choose any spot color, then right-click and choose Import to 
custom spot color table.  
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3. Apply spot color table 

For digital proof or digital printing, please perform as follows:  

1. Create a custom spot color table according to the introduction above (for simpleness, 
you can also directly use the system-built-in spot color table Default).  

2. Submit your file to PDF Generator in your job. After PDF Generator’s processing, 
choose the generated PDF page, right-click and choose Page Info, and then you will see 
all the spot colors contained in your file. Composite file usually contains complete spot 
color names and color values, while separation file usually doesn’t. In case that the 
source file doesn’t contain detailed spot color values, by default, ElecRoc will define the 
values as C=M=Y=0 K=100.  

 
Figure 2-36 

3. Confirm if the color values are exactly the ones you want the spot colors to be output 
with. If not, please click the values to modify. This step is especially necessary for 
separation file that hasn’t defined the spot color values.  

 
Figure 2-37 
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4. At the Custom spot color table dropdown list, choose the table that you want to use. 
And then choose the modified job spot color(s), and click the button  to add them into 
the table.  

 
Figure 2-38 

5. Repeat the operations above to examine the spot colors on other pages. Modify their 
values if needed, and then add them to the spot color table.  

6. At the time when you modify the output values for the spot colors, you can also first 
add the spot colors into the spot color table, and then switch to the module Resources > 
Profile Resource > Spot Color Table, to modify the color values.  

7. Double-click the proof node or digital printing device node in your job, find out the 
parameter Color > Spot Color Table, or Color Calibration > Spot Color Replace, 
and then choose your spot color table.  

8. Rules for ElecRoc to process the spot colors when you have applied a spot color table: 
1) if you have applied a CMF file and have defined the spot colors within the applied CMF 
file, ElecRoc will first use the color values defined within the CMF file to output spot colors; 
otherwise 2) use the values defined in spot color table to output spot colors, but as to 
spot colors with same name, if the color values pre-defined in source file are different 
from those defined in the spot color table, ElecRoc will still use those defined in the table 
to output spot colors; 3) in case that you haven’t added spot colors into your spot color 
table, ElecRoc uses the values pre-defined in the source file to output spot colors.  

For PDF rasterizing:  

The steps to apply a spot color table are similar to those above. When you have added the 
spot colors from the source page to your spot color table, double-click the PDF Rasterizer 
node in your job, and under the Screen tab, click  to import the spot colors from the 
spot color table. After the importing, you can configure the output mode, color values, 
and screen setting for the spot colors, and after the configuration, you can click  to save 
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the modified color information, including color name and values, back into the table.  

2.5.5 EcoInk 
Here you can create, edit, delete, import and export EcoInk solutions, which can be used 
when you configure the parameter EcoInk Solution for the processor EcoInk.  

To create a new solution, click New. Define the parameters in the pop-up window, 
including the solution name, and then click OK.  

 
Figure 2-39 

 Solution Name 

The name of EcoInk solution. It becomes non-editable when you edit the solution.  

 Profile 

EcoInk process changes color values, and therefore, you need to provide the input and 
target ICC profiles, to ensure the color quality and consistency. ElecRoc builds in a few 
ICC profiles for you to choose, some of them are industry standard ICC profiles. You can 
also use custom profiles, but need to import them into ElecRoc beforehand, under the 
module Resources > Profile Resource > ICC.  

 Rendering Intent 

You can separately configure the rendering intent for CMYK and RGB. There are 4 options, 
Perceptual, Saturation, Relative, and Absolute.  

 Set the Parameters 

CMYK Total Ink Amount: To limit the total amount of CMYK inks to the value specified 
here. This limit can maximize the ink saving, but if the value is set too low, it may reduce 
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the color space, resulting in color loss.  

Black Max: The maximum amount of black ink.  

Black Start: It controls from which point the black substitution starts, and it determines 
the shape of the black substitution curve. The start point for black substitution in the tone 
is also called GCR start point. The range of black substitution is from the start point to the 
darkest in the shadow. The bigger this value, the less the GCR is applied to the gray in 
high light.  

Chromatic Zone: It controls the range of CMY chroma space. Bigger value enables 
wider range.  

Chromatic Level: 0-100, the bigger the value, the higher the level will be, and the more 
the color inks remain, less ink is thus saved.  

EcoInk Level: The higher the level, the more the black ink can be used for CMY. The 
default value is 50.  

 Color Purity 

During the EcoInk process, you can keep the purity of some colors unchanged. These 
colors may include:  

C-M-Y-K Retain: only one of CMYK is unequal to 0, the rest three all equal 0.  

CM-MY-CY-CK-MK-YK Retain Color Purity: any two of CMYK are unequal to 0, the 
rest two both equal 0.  

CMK-CYK-MYK Retain: any three of CMYK are unequal to 0, the rest one equals 0.  

100% Retain Solid: i.e. the color value for at least one separation is 100%.  

Here ElecRoc also supports you to import or export the EcoInk solutions. You can export 
a selected EcoInk solution as a ZIP file from ElecRoc to your specified location, such as 
local hard disk, for backup or for use in upgrade. And you can import an EcoInk solution 
from an outside source into ElecRoc. When you import, you can choose whether or not to 
import the original ICC profiles at the same time, i.e. ICC profiles applied in the solution. 
Note that, if you choose to import the profile, you may replace existing profile with same 
name in your ElecRoc system, if any.  

2.6 Imposer Template 

In the module Resources > Imposer Template, you can create, edit or modify the 
imposer templates and composer templates that can be used by all ElecRoc clients.  
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Figure 2-40 

Note: We will no longer provide the old imposer module and related maintenance since 
ElecRoc 6. For both our new and old customers, we strongly recommend the new imposer 
integrated in 6, i.e. the formerly named Imposer in v5.x. For our old customers using the 
old imposer, although we will remain this module for you during the upgrade, so as to 
ensure the consistency between original and renewed publications after the upgrade, we 
still strongly recommend you to use the new imposer to handle your new jobs. Old 
imposer templates can be converted to the format that the new imposer supports.  

2.6.1 Imposer 
The operating window is shown above. The imposer templates refer to the templates 
used by ElecRoc Imposer processor. They are classified into system ones and job-level 
ones. System templates can be used in any job, by any user, on any Client, while the 
job-level templates are available only to one or more specific jobs.  

Templates listed here are system ones. As shown at the left of the window, they are 
sorted and managed under a template directory, in which the Imposition Template is the 
root directory. Under this root directory, you can directly store your templates (by default, 
system built-in templates are stored under this directory), or you can create 
sub-directory. Click the icon  aside, and you can expand a shortcut menu, and by using 
the items therein, you can create, delete, or rename a subdirectory.  

 
Figure 2-41 
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Choose one directory, and you will see all the templates under that directory at the right 
of the window, where you can view detailed information about the templates, including 
template names, time created, creator, page count, and comment.  

The Preview area shows the preview image of your selected template.  

Here you can create, edit, delete, import, export and convert templates, by using the 
buttons above the template list.  

New, Edit: By clicking the button New, you can start up the imposer template editing 
program. After the editing, you can upload it to ElecRoc server. A click on Edit also starts 
the editing program, and in this case, you can edit selected template.  

Import, Export: The exported file is suffixed with .tplxz, named as outputTplx.tplxz by 
default. You can customize the file name, and you can export more than one templates at 
one time.  

2.6.2 Preps 
ElecRoc imposer also supports you to use Preps templates.  

Here you can create, delete, import, and export Preps templates. By clicking the button 
New, you can start up the Preps program. Make sure that you have installed the Preps 
software in your computer, or ElecRoc will report an error after you click New.  

2.6.3 Composer 
Templates here refer to the templates used by ElecRoc Composer processor.  

Same as imposer templates, the composer templates are also sorted and managed 
under a template directory, in which you can create, delete and rename subdirectory. 
Choose a directory, and you can see all the templates under that directory. Information 
displayed about the templates includes template name, time created, creator, page count, 
and comment. Choose any template, and you can see its preview image. And by using 
the buttons above the template list, you can create, edit, delete, import, export, and 
refresh the templates.  

2.7 Digital Proof 

In the module Resources > Digital Proof, you can manage two types of resource 
involved in pre/post-RIP proof: CMF calibration files and color tune curves. Among them, 
the CMF files can be made by the Color Tools, while the color tune curves can be created 
here.  
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Figure 2-42 

2.7.1 CMF Correction 
A color calibration solution refers to a set of color management parameters, used for the 
user to proof with ease and efficiency. ElecRoc provides many built-in color solutions for 
each proof device model it supports. They are designed for the diverse environments the 
user may encounter, and can effectively meet their demands.  

1. View Color Solution 

Under the CMF Correction tab, choose a proof device from the Device Mode dropdown 
list, and then you can see in the below all the color solutions available for the device, 
including the system-defined ones and user-added ones. Double-click a solution, or 
choose it and click Param, to view its detailed information, such as applicable devices, 
color mode, resolution, ink type, media type, total ink, and etc.  
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Figure 2-43 

2. Remote Proof 

Remote proof is designed to employ a time-saving and effort-saving method, to ensure 
your proof devices, of same model but from different locations, able to output proof 
samples consistent with each other. The general steps for remote proof are as follows:  

1. Enter in Resources > Digital Proof > CMF Correction, choose a solution and then 
click Export Remote.  

2. Send the exported solution file to your nonlocal colleague or customer.  

3. Receive the solution at the remote location, then enter in Resources > Digital 
Proof > CMF Correction, choose Import Remote, importing the solution into ElecRoc. 

4. Enter in Administrator > Processor Management, choose the processor and start 
up the Color Tools. Use it to perform a re-calibration on the solution. The solution can 
then be used as a formal and local solution after the calibration.  

2.7.2 Color Tune 
Curves here are applied to digital proof, and can be used when you configure the proof 
parameter Color > Color Tune. Operations on curves like creating, editing, deleting, 
importing and exporting are all supported.  
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Figure 2-44 

Steps for you to create a new curve:  

1. Click New in the window to open the curve setup window.  

 
Figure 2-45 

2. Input a name in the Curve Name edit box.  
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3. Choose a color separation in the Separation dropdown list. By default, options include 
CMYK, Cyan, Magenta, Yellow and Black. If you need to define curve for spot color, click 
Add, and then in the pop-up dialog box, choose spot color from spot color table existing 
in your ElecRoc system. In case that you haven’t added the spot color into ElecRoc 
system, please switch to Profile Resource > Spot Color Table, to add the spot color.  

 
Figure 2-46 

Note: If you have defined a common curve for CMYK and meanwhile have also defined 
a curve separately for each separation, C, M, Y and K. At the time ElecRoc outputs, it will 
apply the separately-defined curve to output the corresponding separation, and only 
apply the common curve to those separations that you haven’t separately define a curve.  

4. And now define the curve. You can drag any point on the curve to make a rough 
adjustment, or base on a print sample or even a measurement, to type accurate output 
values into the percentage boxes. The Reset button enables you to restore the default 
curve shape.  

5. Click OK to save the curve.  

2.8 Traditional Press 

With the tool Resources > Traditional Press, you can manage resource related to the 
traditional printing, such as the linear curves, color tune curves, intended and actual 
press curves, all of which can be used in PDF rasterizing. Managing operations include 
create, save as, edit, import, export, delete, and recalibration. 
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Figure 2-47 

2.8.1 Linear Curve 
It refers to the calibration curve in PDF Rasterizer processor parameters, sorted into two 
modes, CMYK and Gray.  

1. Create a curve 

As indicated by the options in the Color Mode dropdown list, linear curves are sorted in 
two modes, CMYK and Gray. Before you perform curve operations like viewing, creating, 
editing, or importing and exporting, you need first to choose a proper color mode.  

Click New to open the following dialog box, define the parameters and then click OK.  
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Figure 2-48 

Curve Name: Here you can specify the curve name.  

Curve setting: Totally there are 24 pairs of checkboxes and edit boxes. The percentage 
at checkbox represents original dot density, while value in edit box represents actual dot 
density. The actual dot percentage can be measured with a photometer on printed 
linearization chart. Tick the checkbox to activate corresponding edit box.  

Separation: You can define a curve for each separation. In CMYK mode, the default 
separations include Cyan, Magenta, Yellow, Black and Default Separation. The former 
four are process color separations, and the latter represents spot color. The curve defined 
for Default Separation is the default curve for all spot colors. In Gray mode, the default 
separations include Gray and Default Separation. The latter is the same as above.  

Add/Delete: In addition to the default separations, you can also add a specific spot color 
separation to define a curve for it. The spot color separation can be deleted, but the 
process color separations and the Default Separation cannot be deleted.  

Reset: To reset the curve for the currently-elected separation to original curve shape.  

Use same data for all separations: If checked, apply current curve to all the other 
separations.  

Direct Curve: If checked, ElecRoc will directly use the data entered by the user, without 
RIP calculation. For example, if you want 10% area to be output 8%, check this option, 
and then input 8 in the 10% edit box.  

Negative: Check this option in case that the printed linearization chart for you to 
measure the actual dot percentage is negative.  

Resolution: Here you can label the applicable screen resolution of your curve.  

Dot Shape: Here you can label the applicable screen dot shape.  

Frequency: Here you can label the applicable screen frequency.  
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2. Save As 

Return to the main interface of the Linear Curve tool. Choose a curve and click Save As. 
In the follow-up dialog box, input the curve name and click OK. In this way, you can save 
the curve with another name and another location.  

3. Recalibration 

Recalibration aims to update a curve, making it adapt to the latest change in the proof 
environment. Choose a curve and click Recalibration to open the recalibration window. 
The window is same as that for creating or editing a linear curve.  

 
Figure 2-49 

First, apply the curve to print out a chart and measure it. Then, input the measured 
values into corresponding dot percentage edit boxes in the recalibration window. And 
then, you can apply the calibrated curve to print out the chart again, to check the 
calibration effect. Repeat the printing and measuring till you get satisfactory result.  

2.8.2 Color Tune 
The tool Traditional Press > Color Tune helps you to manage the color tune curves 
that can be used by PDF Rasterizer. It supports you to create, save as, edit, delete, 
import, and export the curves.  

Please see the introductions above for the operations and parameter settings, for they 
are similar to the linear curve. When you create or edit a tune curve, you will see a 
parameter named Use same data for all separations, if you check it, you can apply 
the current curve to all the rest separations.  

2.8.3 Press Curve 
The tool Traditional Press > Press Curve helps you to manage the intended and actual 
press curves that can be used by PDF Rasterizer. It supports you to create, save as, edit, 
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delete, recalibrate, import, and export the curves.  

Please see the introductions above for the operations and parameter settings, for they 
are similar to the linear curve.  

2.9 Digital Press 

In the module Resources > Digital Press, you can manage the resource applied in 
digital printing, such as the CMF color solution files, the color tune curves, and the linear 
curves.  

2.9.1 CMF Correction 
Digital printing also employs the CMF color solution file to manage the color output. In 
digital printing, the CMF file can be put to use through the processor parameter Color 
Calibration > Use CMF file.  

Here you can view, delete, import, and export this file. If you want to create a new 
solution file for digital printing, please use the Color Tools. For details, see the manual 
Color Tools User Guide.  

 
Figure 2-50 

2.9.2 Color Tune 
Here you can create, edit, delete, import, and export the color tune curves that can be 
used in digital printing. The tune curve is put to use through the processor parameter 
Color Calibration > Curve.  
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Figure 2-51 

Steps for creating a new curve:  

1. Click New to open the curve setup window.  

2. Input the name of the curve into the Curve Name edit box.  

3. Choose a separation. By default, options include CMYK, Cyan, Magenta, Yellow, Black, 
and Default Separation. Default Separation represents default spot color separation. If 
you want to define a curve for a specific spot color, please click Add, and then in the 
pop-up dialog box, type the spot color name.  

Use same data for all separations: If checked, all the separations including spot 
colors will use a same curve.  

4. And now define the curve. You can drag any point on the curve to make a rough 
adjustment, or type accurate output values into the percentage boxes. The Reset button 
enables you to restore the default curve shape.  

5. Click OK to save the curve.  

2.9.3 Linear Curve 
Curves here are applied to black & white digital printing devices. It can be created in a 
manner similar to that for the color tune curve. Note that, because this curve is applied 
to white and black printers, therefore in general, you need to check the option Use same 
data for all separations, or define the curve only for the Black separation.  

Moreover, the internal calculation logics for the linear curve and the tune curve are 
different, so their shapes may come to be in reversed appearance. For instance, in order 
to reduce the ink output and thus make the color lighter, the tune curve may decrease the 
values in the percentage boxes, making the curve sunk in the lower-right direction, while 
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the linear curve may increase the values in the percentage boxes, making the curve rise 
in the upper-left direction.  

 
Figure 2-52 

2.10 Job Ticket 

In the module Resources > Job Ticket, you can manage the job tickets in your ElecRoc 
system. Job ticket can be generated in the job window, by clicking the icon  from the 
top toolbar. It stores all the nodes and their parameter settings in your job as a template, 
for ease in later re-use.  

Here you can delete, import, and export these job tickets.  
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Figure 2-53 

Delete job ticket: Choose the job ticket(s) that you want to delete, and then click Delete.  

Export job ticket: Choose the job ticket(s) that you want to export, and then click Export. 
Specify the destination and file name in the pop-up dialog box. The file is saved with a 
suffix .jt.  

Import job ticket: Click Import, and then choose the .jt file from the pop-up dialog box. 
In case that it finds out a job ticket with same name existing in your system, it will ask 
you whether or not to overwrite it.  

2.11 Ink Amount 

In the module Statistics > Ink Amount, you can obtain the ink-saving data across a 
specified time period, in all the jobs, from the files processed by the processor Ink Save 
Report.  

The only thing you need to do is to specify the starting and ending time at the Time From 
and To dropdown-lists, and after that, it automatically displays the ink-saving data. The 
icon  can help you to choose a frequently-used time period, such as latest week, latest 
two weeks, latest month, and etc.  
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Figure 2-54 

The statistic data comes from the system database, therefore, even if you may have 
deleted some of the files processed by the node Ink Save Report in your job, or you may 
even have deleted the node Ink Save Report, but as long as you haven’t deleted the 
corresponding ink-saving data in the system database, you will still get the data as usual.  

If needed, you can click the button Export Excel to export the statistic data as an Excel 
datasheet. The datasheet shows the detailed data comparison for each file before and 
after the ink-saving.  

If needed, you can click the button Delete Data to delete unneeded ink-saving data of a 
specified time period from the system database. A dialog box will pop up, asking you to 
specify the time period.  

Ink-saving statistic can also be carried out in your job, so as to obtain the ink-saving data 
for one or more files in your job.  

1. Add the nodes PDF Rasterizer and Ink Save Report into your job, the latter node can 
be directly connected behind the former.  

 
Figure 2-55 



Using ElecRoc Client 

 67 

2. At the PDF Rasterizer’s processor parameter ICC > Screen EcoInk Solution, you 
need to choose an EcoInk solution.  

3. Submit your file for rasterizing, and after that, continue to submit for ink saving. The 
process on big and complex file may take a relatively longer time, please wait a little 
while till the process ends up.  

4. Choose the Ink Save Report node, and you can see that there is only an input file 
queue under the node. Choose one or more files, then right-click and choose Ink Save 
Report Result.  

5. A window pops up, showing the statistic result, including the number of files being 
counted, the ink data before and after the ink-saving, and the ink-saving percentages.  

 
Figure 2-56 
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Chapter 3 Workflow 
Founder ElecRoc is a digital workflow management application. The ElecRoc workflow 
enables various pre-press and printing processes or procedures to work smoothly and 
efficiently, as in a pipeline.  

3.1 Create a Job 

3.1.1 About Job 
The processes on files in ElecRoc, such as imposing, composing, rasterizing, proofing, are 
all implemented by way of a job. Job, or called job ticket, is the platform to build a 
pre-press and printing file process workflow. It defines the specific procedures 
constituting the workflow, the sequence of the procedures, each procedure’s processing 
manner, and enables the user to submit, process, monitor and output files, and manage 
the input and output files of each procedure.  

Here the procedures, or processes, are performed by ElecRoc processors, or called JTP. 
Each processor independently takes responsibility for a specific procedure. ElecRoc 
processor family grows to a lot of members in years of innovation and development, such 
as PDF Generator, Imposer, Composer, Preflight, Trap, Rasterizer, Proof, Digital Printing, 
Inkjet Printing, with the total number coming close to 30, covering the various aspects in 
pre-press and printing. These processors in a detailed job are called processor nodes, or 
nodes. They can produce very flexible combination and connection, forming various 
workflows to meet diverse business requirements.  

In the job window, each job is composed of one or more processor nodes. These nodes 
can not only link each other, but can also exist independently. The quantity of jobs is not 
limited in ElecRoc, so you can create more than one job as needed, and you can manage 
the authority for ElecRoc users to access or control each of the jobs, so as to enhance the 
security of your critical business data.  

3.1.2 Job Management 
The job creation and management are performed in ElecRoc’s Jobs window. After you 
login to ElecRoc from the Client, by default, you will enter in this user interface. 
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Figure 2-57 

1. Job list 

Job list displays all the jobs in ElecRoc, providing job information such as job ID, job 
name, customer, creator, time created, bill No. and description. By clicking the head of 
the table on any column, you can sort the list in ascending or descending order.  

Job ID: ElecRoc assigns an ID once a job is created. It is unique and non-editable.  

Job Name: The job name is specified at the time you crate the job. It cannot be edited 
once specified.  

Customer: The customer name filled in by the user when the job is created.  

Creator: The name of the user who created the job.  

Time Created: The time when the job is created.  

Bill No.: The bill number filled in by the user when the job is created. It can be edited.  

Description: The description filled in by the user when the job is created. It can be 
edited.  

Order No.: The number of online order, auto-produced by the online print system.  

Plan End Time: The date on which you plan to end the tasks of the order.  

Order Detail: Only the online order comes with an icon in the job list, and by clicking on 
this icon, you can view the details on the order, including the printing requirement, 
distribution information, and charge summary.  

2. Create a job 

Click New on top of the job list to open a pop-up dialog box.  
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Figure 2-58 

Job Name is a required item, thus cannot be empty, and cannot be the same with an 
existing job. Other items are optional. Click OK when you complete the filling-in. The 
job’s operating window then appears automatically.  

If needed, you can base on a job ticket to create your job, in this case, please choose a 
suitable ticket in the Job Ticket dropdown list. See section 3.2.3 for details on how to 
create and apply a job ticket.  

After you have created a job, choose the job in the job list and then click Edit, you can 
edit the job’s bill number, description, order number, plan end time, and etc.  

3. Open a job 

To open a job and enter into its operating window, double-click the job in the job list, or 
choose the job and then click Open. An icon  appears at the upper-right corner of the 
job window when you have opened a job. With this icon, you can close the opened job.  

You cannot open a job in case that the access to the job is limited and you are not 
authorized.  

4. Authorize a job 

Choose a job in the job list and click Authorize. Here you can configure the authority for 
ElecRoc users to access the job.  
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Figure 2-59 

At the top of the dialog box is the name of the job you want to authorize, at the left are 
ElecRoc users, and at the right are authorized users. Choose a user or user group at the 
left, and then click the arrow  to add it into the right list. The added user or user group 
now can use the nodes in the job to process files. The Modify box controls if the user or 
user group can modify the nodes’ parameter setup.  

To cancel the authorization, choose the user or user group at the right, and then click the 
arrow .  

Note: Choose the directory User or Group at the left, and then click , you can 
add all users or user groups to the right, in a batch.  

5. Search Job 

In case that there are too many jobs in your ElecRoc system, you can use the search 
combo box to quickly find out your job.  

 
Figure 2-60 

The Search combo box is located on top of the job list. First you should check the box at 
the leftmost, then type a keyword behind, and specify a period of time. If the job ID, 
name, customer name, bill number or description (i.e. the search scope) contains the 
keyword, and the job is created in the specified time period, such jobs will be displayed 
in the job list.  

You can click the icon  to define the search scope. If you limit the scope to specific 
columns, e.g., Job Name only, ElecRoc will only search the jobs whose names contain 
the keyword. The icon  at the right-most enables you to choose a frequently-used 
time period, such as latest week, latest two weeks, latest month, and etc.  

Make sure that you have specified proper time period. If you don’t specify, the end date 
can update itself. ElecRoc can help you remember the search conditions and the time 
period. You can see the latest search configuration if you reboot the Client. Therefore, in 
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case that you don’t see your job in the job list, please take a look at the Search combo 
box, to see if your job has been filtered.  

6、Rapid Positioning 

Press key combination Ctrl + F while you have chosen a job in the job list, and you can 
see an activated Rapid position control. Input a keyword that has something to do with 
the job you want to position, such as the job name, full name or part of the name, 
starting with the first character, and then you can immediately see the job in the job list, 
being highlighted by ElecRoc.  

 
Figure 2-61 

In case that the job list contains more than one qualified job, you can press the direction 
key ↓and ↑ to switch over.  

7. Other operations 

Delete job: Choose the job(s) you want to delete, and click Delete. This operation 
deletes all data related to the job(s) from your ElecRoc system.  

Refresh job list: The job list can be updated manually if you click Refresh.  

3.1.3 Job Window 
As shown in the below, the job window is composed of three parts.  

At the left displays the processor list and shared resource list. The former contains all 
processors installed in your ElecRoc system. If the processor is online, i.e. has been 
started on the Server, it appears in color. In this case, if you add it into a job and submit 
files, it can immediately process the files. If the processor is offline, i.e. has not been 
started or has been stopped, it appears in gray. If you add it into a job and submit files, 
it cannot process the files immediately. The shared resource refers to shared processor 
nodes and workflows.  

The upper-right area is used for you to create and manage the workflow. It may contain 
one or more independent or connected nodes. ElecRoc provides a toolbar and right-click 
menu in this area, for you to perform workflow-related operations.  
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Figure 2-62 

The lower-right area is designed for you to manage and process node-specific files. It can 
display each node’s input and output files, and also can display all the files in the 
workflow of a specific file format, such as all the source files, all the PDF pages, and all 
the signatures. The management and operation on these files, such as submitting, 
previewing, downloading, can also be performed with the toolbar icons on the top and the 
right-click menu items.  

You can freely adjust the sizes of the three areas above, and hide or expand them with 
the icons , , and .  

3.2 Create a Workflow 

3.2.1 Create a new workflow 
You can create a workflow in the job window now that you have created a job. This 
operation can be divided into three steps. 1, add the nodes, i.e. to specify the procedures 
constituting the workflow; 2, connect the nodes, i.e. to determine the sequence of the 
procedures; 3, configure the node parameter setup, i.e. to define how each procedure 
processes. For processor parameter setup, refer to Chapter 4.  

1. Add Nodes 

A node represents a procedure. A processor can be added into the job as a node in two 
ways. 1) Choose a processor in the processor list (just place the cursor over the 
processor), and then drag it into the upper-right area. 2) Right-click any place in the 
upper-right area and choose New, and then choose a node from the node list.  
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You can add more than one node of same type into the job, e.g. more than one PDF 
Generator. In this case, ElecRoc will automatically add an ID in the node name to identify 
the nodes of the same type. The added node can be dragged anywhere in the job window. 
If you choose more than one node, you can drag them together. You can also change the 
node position, making them appear in order, with the Align and Auto Arrange 
commands from the right-click menu.  

 
Figure 2-63 

2. Connect nodes 

Connect the added nodes in sequence, so as to form a workflow like a pipeline. In this 
way, when a node finishes its task, it can automatically send the processed files to the 
next node in the workflow, till all the nodes in the workflow finish their tasks. Workflow 
enables fully-automated processes, and improves the production efficiency.  

 
Figure 2-64 

Method 1, choose the Connect tool  in the toolbar, place the cursor on the beginning 
node, click and hold your left mouse button, and then drag the cursor to the node you 
want to connect. If the two nodes can connect, an arrow appears between them, showing 
the process sequence. If not, ElecRoc pops up warning message.  

Method 2, at the time you add a node, drag the node to an existing node. If they can 
connect, ElecRoc can automatically add the node behind the existing node after you 
release your mouse.  

Method 3, choose an added node, right-click and choose New. Now ElecRoc will list all 
the nodes that can be added behind the node. Choose any of them as needed.  

It’s flexible for you to create workflow. You can connect all or part of the nodes, or you 
can also make all or part of them independent. ElecRoc builds in powerful logic to judge 
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if two nodes can connect or not, and it will pop up warning in time for the user to avoid 
error.  

We call the node before a node in the workflow as parent node, and the node behind it as 
child node. The first node in the workflow is called root node. Each node can have only 
one parent node in front, but may have more than one child node behind. The root node 
has no parent node.  

3.2.2 Manage Workflow 
You may make some management or control to the workflow after you have created it.  

1. Toolbar 

There is a toolbar on top of the workflow. The icons and their functions are as follows: 

Icon Function 

 

Refresh manually the processing status of the nodes in current job, and the 
online/offline status of the processors displayed at the left of the job 
window.  

 
Open the Run List window to view the running information of the nodes in 
current job.  

 View the page substitution record.  

Job list 
It lists the latest jobs opened by current user for a fast switch-over among 
them.  

 
When checked, you can choose, move one or more nodes in the workflow 
freely.  

 
Used for connecting nodes. Double-clicking any blank place in the workflow 
area switches to the  tool.  

 
Lock the node in the job window. Click this icon once again to cancel the 
locking.  

 Save the workflow as a job ticket, for public use in ElecRoc system.  

Table -5 

2. Node right-click menu 

A shortcut menu is available when you right-click a node in the workflow. It contains the 
following menu items.  

Item Function 

Select File 
Used for selecting the source files you want to process, this item appears 
only when you right-click the node PDF Generator. It will then open the 
Select Files dialog box, see section 3.3.1 for details.  

New 
Automatically list all the nodes that can be connected behind. By simply 
choosing one from the list, you can add the node into the job and make it 
connected behind the current one.  

Hold 
Stop processing the files automatically-submitted by the preceding node in 
the workflow.  

Parameters 
Open the processor parameter setup window to view or modify the node’s 
parameter setting.  

Remove Delete the currently selected node from the workflow. This operation 
deletes the input and output files under the node, or even the input files 
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under the next node, as well. ElecRoc pops up message for you to confirm 
before the deletion.  

Rename 
Re-define the name of the node. There may be more than one node with 
same name and of same type in your job.  

Disconnect 
with Parent 

Disconnect the parent node.  

Disconnect 
with Child 

Disconnect the child node.  

Replace by Replace the current node with another node of same type.  

Stop 
Running 

Stop the current node running the files you submitted last time. ElecRoc 
allows you to submit one or more than one file at one time. If you have 
submitted more than one file last time, this item will stop running all the 
files you submitted that time.  

Stop All 
Process 

Stop the current node running all the files you submitted, i.e. all the running 
files and all the waiting files under the current node.  

Share node 
/Cancel 
shared 

Share the current node in ElecRoc. The shared node can be added into any 
other job. A shared node can also be cancelled.  

Table -6 

Note: The item Share node above and the item Import the shared node mentioned 
below are available only when you haven’t checked the Client menu option Tools > 
Preferences > Preference > Disable node sharing.  

3. Right-click Menu 

Right-click any blank place in the workflow area, you will get a shortcut menu. It contains 
the following menu items.  

Item Function 

New 
It lists all the available nodes in your ElecRoc system at this moment. You 
can choose any of them to add it into the job.  

Empty Delete all the nodes and the files they will or did process in current job.  

Refresh Refresh the nodes and their status in the job.  

Align Automatically align the out-of-order nodes.  

Auto 
Arrange 

Automatically arrange the nodes in the job as per workflow, or type.  

Import the 
shared 
node 

Add a shared node into the job. ElecRoc will list all the shared nodes behind 
this item for you to choose. 

Table -7 

4. Interrupt 

It’s necessary to interrupt the workflow at a specific point, in case that you want to check 
and confirm the process result of a certain node before it submits the result to the next 
node. If interrupted, the node will not automatically process the files from its preceding 
node, after these files enter in its input file queue. At this moment, you can check and 
confirm the result of the preceding node timely. After this, you can manually submit the 
files to the current node for process.  

To interrupt at a certain node in the workflow, choose this node, right-click and choose 
Hold. An interrupted node is shown with a sign . Right-click the node and choose 
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Resume to cancel the interruption.  

3.2.3 Share Node and Workflow 
1. Share node 

You can share the node, the node parameter setup, the node’s input and output files in 
ElecRoc, for use by other jobs. The sharing and using shared nodes are only available for 
users who are authorized for using the processors and modifying the jobs. If you have 
shared a node and used it in other jobs, when you alter the node’s parameter setup in 
current job, change its input or output files, or submit new files, you or other users can 
simultaneously see all these changes in other jobs. The modifying node parameters and 
adding/deleting files are allowed only in the job that you share the node. In the jobs that 
you use the shared node, you can only submit files.  

Share a node: Choose a node, right-click and choose Share node. When shared, the 
node is shown with a sign . Right-click and choose Cancel shared to cancel the 
sharing.  

Use a shared node: You see all the shared nodes under Resource Share > Share 
Nodes at the left of the job window. Choose the node and drag it into the job. Or you can 
right-click any blank place in the workflow area, choose Import the shared node, and 
then select the node from the node list, as needed.  

Note: If you have checked the Client menu option Tools > Preferences > 
Preference > Disable node sharing, the right-click menu items Share node and 
Import the shared node will disappear.  

2. Share workflow 

You can share the workflow by way of job ticket. The ticket can refer to an aggregation of 
one or more nodes and their parameter setup. It defines the process workflow that the 
files will go through and the process manner, helping the user to batch process files of 
same type.  

Click the toolbar icon Export Job Ticket , input the ticket name in the pop-up dialog 
box, and then click OK. Except the input and output files, this operation will fully export 
the nodes, node sequence, node parameter setup, even the space between them in the 
job window.  

 
Figure 2-65 

To import one of the shared workflows into the job, please switch to Resource Share > 
Job Tickets at the left of the job window, choose the shared job ticket and then directly 
drag it into your job.  

Note: In the administrative module Resources > Job Ticket, you can perform 
managing operations to all the job tickets in your ElecRoc system, such as deleting, 
importing and exporting.  
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3.3 Run and Monitor 

3.3.1 Select Source Files 
It refers to the operation of providing source files to ElecRoc. ElecRoc supports various 
types of files, including PDF, PS, EPS, TIFF, PRN files. These files can get into ElecRoc 
workflow in two ways: the Select Files interface of PDF Generator, and the hot folder.  

1. PDF Generator 

Choose the PDF Generator node to activate the icon Select Files  in the toolbar below. 
Click this icon to open the Select Files dialog box.  

 

 
Figure 2-66 
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 Select Files 

Choose the files under certain directory, and let them get into ElecRoc workflow system. 
Here the optional directories must be specified beforehand on the Server (main menu 
Settings > General). The Upload directory is the default folder shared on the server for 
public use. You can upload the source files into this folder. Other directories are those 
defined at General Settings > Input Directory.  

To add source files into ElecRoc system, double-click the files under some directory, or 
select the files and then click Select. The files you choose will then enter into the input 
file queue under the PDF Generator node.  

The File Type dropdown box lists the file types ElecRoc supports. When a file type is 
selected, the dialog box will only display the files of that type. The Refresh button 
enables you to refresh the files under the current directory in real time.  

 Auto Submit 

This is an important option. If checked, ElecRoc will automatically submit the source files 
to PDF Generator for process, once you have chosen the source files and closed the 
current dialog box. If not, after the source files enter into the input file queue of the PDF 
Generator node, ElecRoc will not automatically submit them for process. By default, this 
option is checked.  

 Common directories 

You can save your commonly-used source file directories into a dropdown list, which can 
be triggered with the triangle icon  at the right-most of the Location column. To save 
the current directory into the list, click  and then choose add to often-used directory 
list. Click  once again, and you will see the current directory in the list. Next time you 
can quickly open this directory to choose source files. If you want to delete a directory 
from the list, or change its position in the list, choose manage often-used directories.  

2. Hot Folder 

When you use a hot folder as the root node of your workflow, you can upload the source 
files into the folder specified by your Hot Folder node. ElecRoc can automatically detect 
the folder, and if it finds new files, it will automatically submit the files to the next node 
connected with the hot folder node, such as PDF Generator.  

3.3.2 Submit Files 
1. Auto Submit 

As to the source files, those entering into the hot folder will automatically be submitted 
to the next connected node behind the hot folder. Those chosen from the Select Files 
dialog box from the PDF Generator node, when the Auto Submit option is checked, can 
also be submitted automatically to the PDF Generator for process.  

In your workflow, if you don’t Hold any node, each node can automatically submit the 
files after its process, to the next connected node.  

2. Manual Submit 

When the Auto Submit option is NOT checked, after you have chosen the source files, 
you need to manually submit them under the PDF Generator node, so that the generator 
can start the process. There are three ways to submit.  

1) Click the toolbar icon . All the source files under the node will be submitted.  
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2) Choose the files in the source file queue, right-click and choose Submit. Only those 
files you choose will be submitted.  

3) Choose the files you want to submit, and then drag to the PDF Generator node.  

Manual submit is also applied to cases when some node is held, or when your job 
contains independent nodes, or when files need to be processed cross nodes, or 
re-processed. In such cases, you can also use the toolbar icon  or right-click menu item 
Submit, to submit all or part of the input files under any node to itself for process. You 
can also choose the input files or output files under any node, and then drag them to 
current node or any other node in the workflow for process.  

3.3.3 Process Files 
The node starts the process once the files are submitted. The process information 
window now appears.  

 
Figure 2-67 

1) You can learn the progress from the color changes on the node icons, or from the 
messages displayed in the below.  

2) You can use the Stop button to interrupt the ongoing process at any time. You can also 
right-click the node and choose the item Stop Running or Stop All Process to interrupt. 
The former item stops the files submitted last time, while the latter stops all the ongoing 
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files submitted many times.  

3) You may see that the node icon turns to red, or that the messages turn to pink or red, 
or that a warning window pops up, or even that the process is terminated, if some 
exception or error occurs during the process.  

4) In general, the error of a single file has no influence on the rest of other files 
simultaneously-submitted, but the error file will NOT be submitted automatically to the 
next node in your workflow.  

5) You can send an email to Founder technician for support in case that an exception or 
error occurs during the process. Click Send Error Report to email.  

3.3.4 Run List 
The run list is designed for you to monitor the processes of the nodes in current job. On 
top of the workflow area, click the toolbar icon Run List  to open the Run List window.  

 
Figure 2-68 

Here you can view each process’s status. There are 6 types of statuses: waiting, running, 
finished, cancelled, error, and abnormal. In running or waiting status, you can click Stop 
to terminate the node’s process.  

Choose any row of information and then double-click or click Open to view the detailed 
process information. The Refresh button enables you to manually update the list. The 
Open, Refresh and Close operations can also be performed with right-click menu items. 

3.3.5 Status Monitor 
The status monitor enables you to fully monitor the processes of all the jobs in your 
ElecRoc system. You can not only view the process information, such as the overall job 
progress, the node status, the resource involved in the process, but also can control 
these processes, such as to adjust the priority of a waiting process, to cancel a waiting or 
running process.  

1. Monitor Process Information 
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Figure 2-69 

1) Process list 

The list displays processes performed by single node at one time, unrelated with the file 
quantity. For example, if you submit a batch of files to a workflow like PDF Generator  
PDF Rasterizer, although the two nodes are connected and you submit once, here ElecRoc 
would display it as two processes in the list: one is PDF Generator  PDF Rasterizer, and 
the other is a single PDF Rasterizer.  

The displayed process-related information includes job ID, job name, submitted time, 
finished time, priority, status and the user submitting the files. You can click the head of 
any column to sort the whole table in ascending or descending order. The Refresh button 
is used to manually update the progress and status of all the processes.  

The displayed processes in the process list are results that meet certain search conditions. 
You can define the search conditions on top of the list. The processes can be searched as 
per name, processor, status, user and type. Among them, the status is divided into all, 
waiting, running, finished, cancelled, error, and abnormal, and the type is classified into 
current and history.  

2) View process information 

Double-click any row in the process list to open its process information window, in which 
you can view the detailed process information.  

3) Progress and resource 

Choose any record in the process list, and then you will see the progress and status of all 
the nodes involved in the process, in the Processing Status area at the bottom of the 
monitor window. The Resource area will then list all the files involved in the process.  

2. Control the Processes 

1) Change priority 
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Priority controls the order of the waiting processes. As to processes in waiting status, the 
one with a higher priority will be processed prior to the one with a lower priority. To 
change a waiting process’ priority, choose it in the process list and click Priority, then 
input a new value in the pop-up dialog box, and then click OK. The value range is 1-100. 
Higher value represents higher priority. For processes with same priority, the order is 
sorted by the submitted time.  

2) Stop a process 

Choose one or more running processes in the process list and click Stop.  

3) Backup, restore and repair 

The Backup button enables you to back up the process information. The Restore button 
enables you to restore the backup information into the monitor. And the Repair button is 
used for you to clean up the processes that are not normally ended.  

3.4 Manage Job Resource 

The lower-right area of the job window is designed for you to view and manage the job 
files, and to perform various processes on these files. This area is composed of a toolbar 
and files of various types. Its appearance is specific to the toolbar icon and the job node 
you currently select.  

 
Figure 2-70 

Processes on the files, both the input and output files, are mainly implemented with the 
toolbar icons and the right-click menu items.  

3.4.1 Files 
When the Files icon  in the toolbar is selected, you can view all the source files in the 
current job, i.e. the input files under the PDF Generator and Hot Folder nodes.  
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Figure 2-71 

3.4.2 Pages 
When the Pages icon  in the toolbar is selected, you can see all the PDF page files in 
the current job, i.e. the output files under such nodes as PDF Generator, Preflight, and 
Trap.  

 
Figure 2-72 

3.4.3 Files and Pages 
When the Files and Pages icon  in the toolbar is selected, you can see all the source 
files and PDF page files in the current job.  
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Figure 2-73 

3.4.4 Signatures 
When selected, the Signatures icon  in the toolbar enables you to view all the 
signature files in the current job, i.e. the output files from the Imposer, Composer and 
Ganging nodes.  

 
Figure 2-74 

3.4.5 Job Resource Clearing 
All the input and output files in your job can be cleared off if you click the toolbar icon 
Clear Resources . Be careful to perform this operation. Before the clearing, you need 
to stop all the ongoing processes (if any), and ElecRoc will ask you to confirm.  

3.4.6 View Control 
A status indicator and a thumbnail image appear in front of each file if you have the 
Thumbnail icon  in the toolbar selected. The sign  indicates the file has been 
submitted to the node for process, while  indicates it has NOT been submitted.  

The file name can be simplified in the display if the Toggle File Name icon  is selected. 
If needed, you can click the Refresh icon  to manually update the job resources.  
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3.5 File Process 

3.5.1 Source File Process 
Under the PDF Generator node, or when the Files icon  in the toolbar is selected, you 
can use the right-click menu items to perform a series of processes to the source files.  

Item Function 

File Information Learn information on the file location.  

Submit 
Submit the selected files to current node for 
process.  

Copy Copy the selected files.  

Paste Paste the copied files under the current node.  

Delete Delete the selected files.  

Empty Delete all the source files under the node.  

Sort Auto-arrange the files in the list.  

By Name Sort files by file name.  

By Type Sort files by file type.  

By Time Up 
Sort files by date modified, starting from the 
earliest.  

By Time Down 
Sort files by date modified, starting from the 
latest.  

Refresh 
Refresh the file status, such as whether it has 
been submitted.  

Select File 
Select more than one file at the same time 
from the list. 

By Odd 
Select more than one file in the odd positions at 
the same time from the list.  

By Even 
Select more than one file in the even positions 
at the same time from the list.  

Table -8 

1. Learn File Information 

Learn the current file’s name and location.  

 
Figure 2-75 

2. Submit Files 

Submit the selected files to the current node for process. You can select more than one 
file each time.  
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3. Adjust File Process Sequence 

If file priorities are equal, ElecRoc processes your submitted files in the sequence as they 
are in the file list. To change the file sequence in the file list under PDF Generator node, 
choose one or more files and then click the icon  or .  

4. Refresh, Copy, Paste, Delete, Empty 

Refresh: Manually refresh the source file status, i.e. submitted or not.  

Copy, Paste: You can carry out the copy & paste operation across nodes, or even across 
jobs. First, under the node PDF Generator A, choose one or more source files and use the 
right-click menu item Copy. Then, switch to the node PDF Generator B, right-click in the 
source file area and choose Paste. In this way, you copy source files from node A to node 
B. The two nodes may belong to two different jobs.  

Delete: Delete the selected files.  

Empty: Delete all the source files.  

5. Sort Files 

You can direct ElecRoc to auto-arrange the file positions in the list by file name, or by file 
type, or by date modified. With this operation, you can view the files more clearly. But 
note that it changes the file process sequence. If file priorities are equal, ElecRoc 
processes your submitted files in the sequence as they are in the file list. Therefore, this 
operation may change the process sequence of the source files.  

6. Select Files 

Select more than one source file in the file list at the same time. Select File By Odd 
enables you to select all the files that are in the odd positions, while Select File By Even 
enables you to select all the files that are in the even positions.  

3.5.2 PDF Process 
Processes to single-page or multi-page PDF files are also performed with right-click menu 
items. The PDF files here may be the PDF pages generated by PDF Generator, also may 
be the files in PDF format that result from a further process 
on such PDF pages. Therefore, the processes introduced in 
the below and are enabled with right-click menu items, are 
available to files such as: the output files under PDF 
Generator; the PDF pages displayed when the Pages 
toolbar icon  is selected; the input and output files under 
other PDF nodes like Preflight, Trap, PDF CMS, and even 
the input files under PDF Rasterizer.  

The following command table and figure at the left are only 
an example of the right-click menu on PDF Generator’s 
output PDF page file. For more PDF operation commands 
and their functions, please see the introductions in the 
sections behind the table.  

Item Function 

Page Info Learn page size, file size and spot colors.  

Preview Preview PDF pages.  

Add as Mark Add a page as a mark that can be used in Imposer and 
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Composer.  

Separation Adjust Adjust the logic page numbers of a separation file.  

Download Download the PDF files to local disk.  

Copy Copy the selected files.  

PDF Compare Compare two PDF files to find out their difference.  

Set as page before 
modification 

Set the file as the old file in the comparison.  

Set as page after 
modification 

Set the file as the new file in the comparison.  

Page Compare 
/Substitution 

Compare two files for page substitution.  

Mark as finished 
Mark the file as the finished file in the comparison and 
substitution.  

Mark as modified 
Mark the file as the modified file in the comparison and 
substitution.  

Change color Change the color mode to gray or color.  

Delete Delete the selected files.  

Empty Delete all the files in the current queue.  

Sort 
Auto-arrange the files in the list by file name, or by date 
modified, or by page type.  

By Name Sort files by file name.  

By Time Up Sort files by date modified, starting from the earliest.  

By Time Down Sort files by date modified, starting from the latest.  

Reverse Sort files in reverse order.  

By Page Type Sort files by page type.  

Select File Select more than one file at the same time.  

Select File By Odd Select the files in odd position at the same time. 

Select File By Even Select the files in even position at the same time. 

Refresh Refresh manually the file status.  

Table -9 

1. Preview Pages 

1) Normal Preview 

You can open an independent window to preview the PDF pages generated by PDF 
Generator, or PDF pages output by other PDF processors.  
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Figure 2-76 

Enable preview: The PDF Generator parameter Parameters > Enable Preview 
controls if ElecRoc generates a thumbnail image for preview purpose during the PDF 
Generator process. If unchecked, the preview becomes unavailable. Besides, in case that 
the file name contains invalid characters, the preview may become unavailable either.  

Preview image resolution: The resolution is controlled by the PDF Generator 
parameter Parameters > Thumbnail Parameters > Resolution.  

Refresh preview image: Click the icon  in the preview window to manually refresh in 
case that the page is changed during the preview.  

Zoom display: Fixed zoom options include Suitable, 25%, 50%, 75%, 100%, 200%, 
300%, 500%, and 800%. The default is Suitable. You can also zoom in and out by 
dragging with the right mouse button.  

Switch previews: The page list at the left shows all the pages under current node, 
providing you with ease to switch among the previews of these pages.  

2) Fast Preview 

Under the PDF Generator node or any other PDF node in the job window, you can fast 
preview the PDF pages by holding down the left mouse button on the thumbnail image 
located at the lower-right corner of the window. A zoomed-in thumbnail image will then 
immediately spread out on the window. Like the normal preview mode, you need also to 
check the PDF Generator parameter Parameters > Enable Preview before the PDF 
Generator process, and can also control the thumbnail image resolution through the PDF 
Generator parameter Parameters > Thumbnail Parameters > Resolution.  

In addition, you can customize the zoom percentage of the pop-up thumbnail image. To 
do this, right-click on the thumbnail image located at the lower-right corner of the 
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window, and then choose a proper zoom option from the pop-up list. Options include 
25%, 50%, 100%, 150%, 200%, and 300%.  

 
Figure 2-77 

3) 3D Preview 

This capability requires you to install .NET Framework 3.5 or later version in your client. 

Under the Imposer node, choose one or more PDF pages (may include blank page) from 
the input file queue, click the toolbar icon , or right-click and then choose 3D Preview. 
The follow-up preview window differs for Clients running on MAC and PC platforms.  

 On PC Client 

As shown in the below, the 3D Preview window displays the PDF pages in the sequence as 
they are in the input file queue, two pages each time. To simply turn pages backward, 
click on the right page; to turn pages forward, click on the left page. Or place the cursor 
on the left corners of the left page or the right corners of the right page to roll up a page 
corner, then hold down the left mouse button and drag in any direction (left, right, 
upward, or downward), and then release, and in this way you can gain an experience like 
you are turning pages with fingers.  
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Figure 2-78 

The icons at the bottom are designed to help you turn the pages.  

Icon Function 

Auto Turn Turn all the pages automatically for you to preview.  

 Cover Turn to the first page.  

 Back Cover Turn to the last page.  

Previous Turn a page forward.  

Next Turn a page backward.  

 Go to Turn to a specified page.  

Full Screen Display the preview window in full screen mode.  

Table -10 

Icons are also seen at the top of the 3D Preview window, including:  

Exit: To close the 3D preview window.  

Zoom: You can choose a commonly-used zoom option from the dropdown list, or you can 
also hold down and drag the right mouse button to zoom in and out the pages.  

3D Preview: To open an independent window, as shown in the below (the left figure), in 
which you can drag the page (always the first and last pages separately on the front and 
back sides) in any direction, at any angle, to produce the 3D preview effect. The page can 
be zoomed in and out by holding down and dragging the right mouse button.  
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Figure 2-79 

Setting: To open a pop-up dialog box to make the setting as follows (the right figure). 
Time Interval refers to the time interval between two page turns in auto turning. 
Background of the 3D Preview window can be a Pure color (the Color 1), a Gradient 
(Color 1 and Color 2), or a Photo (three optional background patterns are available, or 
you can click More to specify other photo). The Turn setting provides two turning modes, 
in Turn page mode, you turn the pages fore and back; in Turn over mode, you turn 
pages up and down.  

Navigation: If checked, a navigator appears at the upper-left corner of the window, 
showing a thumbnail image of the pages being previewed. Click on this thumbnail, and 
you can quickly navigate on the zoomed-in pages.  

 On Mac Client 

The preview window is shown as follows.  
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Figure 2-80 

You can also manually click to turn the pages forward and backward, or hold down and 
drag the pages to roll up and turn. The toolbar icons at the upper-left corner  
help you to turn pages forward and backward as well. And with the icon AutoFlip , the 
pages can be automatically turned.  

4) Remote 3D Preview 

This capability is based on the 3D preview, enabling 3D preview outside ElecRoc system. 
With it, you can save your PDF pages as a single or a series of .zip files, and then email 
them to a remote user. After receiving these .zip files, the remote user can use a separate 
tool to unzip them, and then the user can do the 3D preview as that on ElecRoc Client.  

Under the Imposer node, choose one or more PDF pages (may include blank page) from 
the input file queue, right-click and then choose Remote 3D Preview. Specify the file 
name and path for the .zip file, and then click Save.  

 
Figure 2-81 
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Now you can email the .zip files to a remote user.  

The remote user can then unzip and do the 3D preview. For details on the unzip tool, refer 
to Appendix C.6.  

2. Page Information 

PDF Generator can read such page information as page size, separation color, and spot 
color, during its process. You can learn such information in the PDF page information 
window, which can be opened with the right-click menu item Page Info. And in this 
window, you can also import the spot colors found in the page into a spot color table.  

 
Figure 2-82 

1) PDF Page Information 

Source File: The full path of the source file.  

Page ID: The page number of the page in the source file.  

File Size: The size of the PDF file.  

Page Size: The size of the PDF page.  

Separate Color List: The colors contained in the separation file.  

Date Modified: The latest time the PDF page was processed.  

2) Spot Color Information 

ElecRoc displays the spot colors contained in the page. You can see the spot color name 
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and its cmyk values. In general, if the source file is a composite file, you can get the full 
information, but if it is a separation one, you may only get the spot color name, its color 
value is assigned by default as K=100.  

3) Spot Color Process 

You can not only view the spot colors in the page, but also can import them into any trap 
ink profile or spot color table, for use in the later-on spot color processes.  

Before you perform such operation, you can change the spot color value. Double-click 
any of the CMYK value to activate an edit box for this change. If you check Update all 
Pages, the change on the color value will apply to all the rest pages generated from the 
same source file.  

1) Import to spot color table: Choose a table in the Custom spot color table 
dropdown box (displaying the colors with same name in the below, if any), and then 
choose the spot colors in the page at the left, click the arrow . Color substitution occurs 
if such color with same name exists in the table (a message pops up for you to confirm 
prior to the substitution). If you choose spot colors in the table and then click the arrow , 
you can substitute for the page spot colors conversely.  

2) Import as system spot color: To import the spot colors into the system spot color 
table, choose all or part of the spot colors (choose color name) in the page, right-click 
and choose Import to system spot.  

3) Import to trap ink profile: Choose the spot colors in the page, click the first icon  
in the below, or right-click and choose Import to trap ink. And then, choose a trap ink 
profile in the pop-up dialog box, click Add.  

4) Copy spot color name: Choose one spot color in the page, click the third icon  in 
the below, or right-click and choose Copy Spot Name. In this way, you can copy the 
name of the spot color into clipboard, for you to paste anywhere later-on as needed, e.g., 
as the name of new spot color in spot color table, or in Windows’ notepad.  

3. Define Page Type 

Under the PDF Generator node, after files are processed in multiple-page mode, choose 
a page of any file in the output file queue, then right-click and choose Custom page 
type. 

Now you can define a book page type for the currently selected page. There are four such 
types here, Cover, Preface, Text and Illustration. The File option refers to the pages apart 
from these four types. All the PDF pages in ElecRoc are of this type by default. After you 
define the page type, please further define the page number of the page under the 
specified type, with the Start page No. parameter.  

 
Figure 2-83 

When you have defined proper page types, you can then submit them to Page Compare 
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/Substitution for the intelligent compare.  

In addition, you can sort such pages by page type. As you can see the following figure, 
the left list shows pages that you have NOT defined page type, sorted by name; the 
middle shows pages that you have defined page type, sorted by name; the right shows 
pages that you have defined page type, but sorted by page type, i.e. arranged according 
to a sequence of Cover, Preface, Text and Illustration.  

 
Figure 2-84 

4. PDF Compare 

ElecRoc enables you to compare two PDF files, each of which may consist of more than 
one page, so as to find out their difference. It’s useful especially when you want to 
compare a revised PDF to an earlier one, in order to know the change made in the file 
modification.  

To use this feature, you need to install Adobe Acrobat 9.0 or higher version and 
Microsoft .NET Framework 3.5 or later version in your computer.  

1) Objects and Range for Comparison 

The objects applicable for the comparison must be PDF files that have been processed at 
least by PDF Generator, regardless of single-page or multiple-page mode, and their full 
names can NOT be the same.  

You must specify the two PDF files before the comparison. Separately choose two files, 
then right-click and choose PDF Compare > Set as page before modification or Set 
as page after modification. The comparison is based on the old file (i.e. before 
modification), with an aim to check the modification on the new file (i.e. after 
modification).  

Click the toolbar icon PDF Compare  above the file queues to open the setup window.  
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Figure 2-85 

The window shows the old and new files for you to confirm. The page range parameters 
are designed for you to specify the pages to compare. E.g. you can compare the first 
page from the old file with the second page from the new file. The page range can be 
freely specified, but note that each range must be continuous, and the value shall be no 
more than the actual total page number.  

2) Compare Option 

ElecRoc classifies the PDF files into three categories: 1) Reports, spreadsheets, magazine 
layouts, 2) Presentation decks, drawings or illustrations, 3) Scanned Documents. Please 
choose a category that best describes your files.  

3) Compare Report 

After comparing the two PDF files, ElecRoc shows the result in the form of a compare 
report. In the above window, you can choose if you want to immediately view the report, 
or to save it in a specified path, such as a folder in your local disk.  

The compare report is shown as follows:  
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Figure 2-86 

The first page is the summary of the compare result. The rest are pages from the new file, 
with annotations indicating the changes. ElecRoc also adds marks to show the change, 
the deleted content, the pages that were altered, and the pages that were removed.  

On the Compare panel at the left, you can do any of the following:  

To hide the annotations, click Hide Results. To define the display setting, click Show 
Options. You can specify the type of changes to display, the color scheme, and opacity 
of the annotations. To return to the page thumbnails, click Hide Options.  

The Options menu  provides more commands, including Show/Hide Results and 
Show/Hide Options. To show each of the documents in its own window, choose Show 
Documents Tiled or Show Documents Side By Side. To synchronize the relevant 
pages while showing the documents in their own windows, choose Synchronize Pages.  

Click a page thumbnail to go to that page. To change the size of the page thumbnails, 
choose Thumbnail Size > [option] from the Options menu . Drag the splitter bar  
at the bottom of the Compare panel up to show thumbnails of the old document. Click a 
thumbnail from the old document to open it in a new window.  

5. Page Compare/Substitution 

This manager enables you to substitute one page for another, and before the substitution, 
it can compare the pages for the difference, so as to help you avoid any substitution error. 

1) Choose Pages 

Before the comparison and substitution, you need to specify the finished pages, or old 
pages, i.e. those that are finished already, and the modified pages, or new pages, i.e. 
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those that are modified.  

To specify the finished pages, switch to the output file queue under PDF Generator node, 
or the PDF file queue under any other node, choose one or more pages or files, regardless 
of single-page or multiple-page, then right-click and choose Page Compare 
/Substitution > Mark as finished. To specify the modified pages, choose Mark as 
modified. 

You can add in batches more PDF pages from other nodes as the finished or modified 
pages. The quantity of the finished and modified pages is not limited. Note that, all such 
specifying will be cleaned after you reboot the Client.  

2) Compare Pages 

Click the toolbar icon Page Compare/Substitution  located above the file queue to 
open the compare & substitution window.  

 
Figure 2-87 

The compare operation is performed under the Compare tab.  

 Sequence Compare 

Compare page by page according to the page sequence in the Finished Pages/ 
Modified Pages lists.  

In this mode, the page sequence in the two lists plays a critical role. You must ensure that 
the finished and modified pages are corresponding to each other in the two lists. The 
page sequence can be adjusted with the icons and , or the right-click menu items Sort 
and Move To. And you can choose more than one continuous or discontinuous pages at 
the same time to adjust. But note that, in case that the pages are from multiple-page file, 
their sequence in the list can NOT be adjusted. The icons and menu items mentioned 
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above would be grayed.  

When the leftmost icon in the toolbar is displayed as , the finished and modified pages 
become related according to the sequence. In this case, if you choose or move a page in 
one list, you will see that the page with the same sequence number in the other list will 
be chosen or moved at the same time. E.g. if you move down the second finished page by 
1 row, meanwhile the second modified page will be moved down by 1 row as well, vice 
versa. Click  to turn it to , then you can separately choose and move the pages in the 
two lists, to adjust their sequence in the list.  

You can use proper right-click menu items as you determine the pages and their 
sequence. You can use Page Info to view the page size, file size, spot colors and 
separation colors; or use Download to open the page with Acrobat, or use Delete or 
Delete All to remove unneeded pages from the lists.  

Click the Sequence Compare toolbar icon  to compare. The result is shown as 
follows: 

 
Figure 2-88 

Two signs appear in front of the pages. The sign  indicates no difference, while  
indicates difference. Blank indicates that the page has NOT been compared. Click the 
toolbar icon  and choose in the follow-up dropdown list the items Difference 
Resource, Same Resource, Did not deal with, to display only one type of the pages 
at one time.  

Choose a page with difference, then click the toolbar icon Flat Differences  and 
choose a color in the pop-up dropdown list. Rectangles in your chosen color then appear 
on the thumbnails at the right, showing the contents with difference. With the options 
from the toolbar icon , you can redefine the line width of these rectangles. The Scale 
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tool  enables you to zoom in or out the thumbnails.  

 Intelligent Compare 

This feature (when the toolbar icon  is selected) is applied only to the PDF pages which 
are from the output file queue of the PDF Generator node, and for which you have defined 
page types, such as cover, preface, text, and illustration.  

In this compare mode, ElecRoc compares page by page according to the page type, 
regardless of the page sequence in the two lists, and it compares only the pages that 
have been defined page types. E.g. the first Text page from the finished page list will 
therefore be compared with the first Text page from the modified page list, and the 
second Cover page from the finished page list will therefore be compared with the second 
Cover page from the modified page list.  

 Perspective Differences 

This operation can be performed before or after the comparing. Choose a finished and 
modified page, and then click the toolbar icon . 

 
Figure 2-89 

If the Highlight status (showing the icon ) is enabled, ElecRoc applies the color 
specified with Different Color (click ) to highlight the contents with difference. If you 
move the Transparency button to the left, you can see more content from the finished 
page; if you move it to the right, and you can see more content from the modified page. 
During the process of moving this button, you can visually check their difference.  

 Compare Accuracy 

Click the Setting icon  in the toolbar to define the compare accuracy.  
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Area: ElecRoc divides the page into many equal areas for the comparing. The area 
quantity can be defined with five levels: 10, 20, 30, 50, and 100. The smaller the value, 
the less the quantity would be. If you want to gain the highest accuracy, choose 100.  

Dissimilarity Number: In each of the areas divided as above, if the quantity of the 
pixels that are different is bigger than the number specified here, ElecRoc will consider 
such area as an area with difference. The range is 1-100. The less the value, the higher 
the accuracy is.  

3) Page Substitution 

The substitution is performed under the Substitution tab.  

 
Figure 2-90 

Choose a finished page and a modified page, and then click the Substitution icon  in 
the toolbar to build a replace relation. Such relations are all displayed at the bottom of 
the window. If you want to cancel any relation, choose it and then click .  

Click  when you have determined all the relations.  

Return to the file queue under the job node. The pages substituted are shown in pink. You 
can also check such substitutions in the Page Substitution Record window (click the 
toolbar icon  on top of the job workflow area.  

6. Download PDF 

By choosing the right-click menu item Download, you open a dialog that contains three 
options: Open, Save and Cancel.  

Open: Use Acrobat to open the PDF page immediately.  

Save: Save the PDF page to your specified location, such as local disk. 



Using ElecRoc Client 

 103 

7. Separation Adjust 

The logical page numbers for some separation files may be special, and thus can NOT be 
normally identified by PDF Generator. ElecRoc provides this feature for you to manually 
solve the problem.  

 
Figure 2-91 

Separation List: Located at the left of the window, and composed of ID and separation 
names, this list displays all the color separations from a same source file in current job. 
You can double-click the separation name to edit it.  

Sibling Separation Space: A page may consist of 1 to N separations. The sibling 
separation space refers to the space difference between two sibling separations, i.e. from 
separation 1 to separation 2, from separation 2 to separation 3, from separation N to 
separation N+1… For example, if the separations are “cyan, cyan, magenta, magenta…” 
here you can input “2”.  

Separation per Page: The number of separations per page.  

When you configure Sibling Separation Space and Separation per Page, make sure 
that 1) each separation name is unique in each page; 2) separation numbers per page 
are equal for all pages; 3) the separation sequence is the same for all pages.  

Prefix of Adjusted File: The file name prefix for the new page file generated after the 
adjustment. We recommend you to specify a prefix different from that of the current file.  

Blank Separation Setting: To insert a blank separation before a separation in the 
separation list, choose the separation and then click . You can also input the insert 
position in the edit box behind. To delete one separation from the list, choose this 
separation and then click .  



                      User Guide 

 10
 

104 

Example A: see the left figure below, if you set Separation per Page is 5, Sibling 
Separation Space to 1, you will get two new pages after the adjustment, with each in 
such separation sequence as Cyan, Magenta, Yellow, Black, New Color Swatch. 

Example B: see the left figure below, if you set Separation per Page is 5, Sibling 
Separation Space to 2, you will get two new pages as well, with each in such separation 
sequence as Cyan, Magenta, Yellow, Black, New Color Swatch. 

    
Figure 2-92 

Example C: see the left figure below, if you set Separation per Page is 4, Sibling 
Separation Space to 1, you will get two new pages, but with different separation 
sequences. The separation sequence for the first page is as Cyan, Magenta, Yellow, Black. 
That for the second is as Cyan, Yellow, Black. In this case, you may need to insert a blank 
separation between the fifth and sixth separations, i.e. the Magenta separation. 

    
Figure 2-93 

If the adjustment fails, ElecRoc pops up error message. If succeeds, it generates new 
page files in the PDF page file queue.  

8. Change Color 

This feature is generally used in digital printing. With this feature, you can easily change 
the color mode of the PDF pages before the printing. When the toolbar icon  is 
selected, each PDF page in the input and output file queues will appear with an icon 
indicating its color mode: icon  refers to color while icon  refers to gray.  

Choose one or more pages, right-click and then choose Change color. If the color mode 
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was color, by choosing this menu item, you will change it to gray; if it was gray, you will 
change it to color.  

9. Add as Mark 

You can add the currently selected PDF page into ElecRoc system, as a custom mark for 
Imposer and Composer to use. This feature is available only to single-page PDF pages.  

 
Figure 2-94 

10. Readiness for Imposing & Ganging 

You can perform the following operations or configurations to the PDF pages from the 
input file queue under the Imposer, Composer and Ganging nodes.  

Start: This box is used for you to specify the starting sequence number for the pages in 
the left file queue. Input proper number in the box, as needed, and then press Enter key.  

Sequence adjustment: When your imposer or ganging template defines page numbers, 
the page file sequence in the input file queue will directly determine the page sequence 
on the signature. In addition to the right-click menu item Sort, you can also use the icons 

and  above the input file list, and the right-click menu items Move To, Top, and 
Bottom to adjust the page file sequence.  

Define as part: Choose one or more pages, right-click and choose Part > Custom part, 
and then you will open a dialog box, in which you can specify a part, for use in imposing. 
If you need to cancel the part specification, you can choose the page, right-click and then 
choose Part > Clean part.  

 
Figure 2-95 

Insert blank page: Before you start the Imposer process, you can insert blank pages as 
needed in the input file queue to substitute for missing pages, so as to prevent the 
missing pages from affecting the positions of the rest pages on the signature. To do this, 
click the icon  above the input file list, and then specify the position and quantity of the 
blank pages in the follow-up dialog box.  



                      User Guide 

 10
 

106 

 
Figure 2-96 

11. Submit, Copy, Paste, Delete, Empty, Sort, Refresh, Select File 

Submit: submit the selected PDF pages to the current node for process.  

Copy, Paste: Copy the PDF pages or PDF files (multi-page mode) currently selected. The 
paste operation can be performed across nodes and jobs. E.g. you can copy the PDF 
pages under the PDF Generator node in job A, and then paste them under the Preflight 
node in job B. Please note that, if you delete the original file being copied, you will 
meanwhile delete the copy file, i.e. in the previous example, if you delete the copied PDF 
pages under the node PDF Generator in job A, you will meanwhile delete the copy PDF 
pages under the Preflight node in job B.  

Note: When you have copied one or more PDF pages, if you switch to the output file 
queue under the PDF Generator node, right-click and then you will see a menu item 
Paste File. It also enables you to paste the copied file into the queue where you 
right-clicked, but the difference from the Paste menu item lies on that, the copy would 
not be deleted if you delete the copied page file.  

Delete: Delete the selected PDF pages. Be careful to perform this operation, for it may 
delete the input files under the node that connected behind.  

Empty: Delete all the PDF pages under current node.  

Sort: Sort the files by name, or by time (up or down).  

Refresh: Manually refresh the PDF pages.  

Select File: This right-click menu item enables you to select more than one file at the 
same time. Using the sub item Select File By Odd, you can select all the page files in the 
odd position, while using the sub item Select File By Even, you can select all the page 
files in the even position. 

3.5.3 Signature Process 
Here we take the signature (or surface) processes under the Imposer node as example. 
The processes can also be implemented with right-click menu items.  

The right-click menu on any signature file contains items such as Surface Info, 
Preview, Copy, Delete, Empty, Refresh, Ganging, and Preview Front and Back.  
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Figure 2-97 

Compared with the source file and PDF page file processes, signature processes differ in 
the following features. 

1. Surface Info 

Show the information on the signature/surface: name, front/back, dimension, date 
modified, and input pages. 

 
Figure 2-98 
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2. Signature preview 

Normal preview and fast preview: They are the same as the PDF page previews. In 
normal preview mode, you can use the right-click menu item Preview to open an 
independent signature preview window. In the fast preview mode, you can fast preview 
the signature in the job window if you hold down the left mouse button on the thumbnail.  

Front & Back Preview: When you choose two signatures at the same time, you can use 
the right-click menu item Preview Front and Back to check the composite effect of the 
front and back surfaces, and check if the register marks are in alignment, and etc. Click 
the transparency icon  at the top of the preview window, you will activate a slider in 
the below, with which you can adjust the composite proportion.  

 
Figure 2-99 

3. Gang after imposing 

With the right-click menu item Ganging > [Composer], you can submit the signature 
generated after the Imposer process to ElecRoc ganging program, in which you can gang 
the pages being imposed on the signature.  

3.5.4 Tiff Process 
Tiff files exist in the output file queue of the PDF Rasterizer node, or in the input file queue 
of the 1 Bit TIFF Export or Post-RIP Proof node. Similarly, you can use the right-click 
menu items to perform related operations, such as previewing, deleting, emptying, 
sorting, and refreshing.  
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1. Tiff information 

 
Figure 2-100 

You can learn detailed information about each separation, including separation name, 
path, file size, dimension, date modified, and the screen setting such as resolution, shape, 
angle, frequency, levels, and curves.  

2. Tiff preview 

1) Normal Preview and Fast Preview 

In normal preview mode, you can use the right-click menu item Preview to open an 
independent preview window. A difference from signature or page preview lies in that 
you can preview the whole file, or preview only one of the separations. And in the fast 
preview mode, you can fast preview the tiff in the job window if you hold down the left 
mouse button on the thumbnail.  
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Figure 2-101 

2) Tiff Preview 

Choose the right-click menu item Tiff bitmap preview to open the dot preview window. 

 
Figure 2-102 



Using ElecRoc Client 

 111 

Separation preview: From the color list at the upper-left corner, you can choose any 
one, or some, or all of the separations to preview.  

Thumbnail navigation: A green little box appears if you click on the thumb image 
located at the lower-left corner of the window. The content centered on this box will then 
be scaled up at the right area of the window. Therefore, by clicking, or by moving the 
little box, you can easily navigate and switch the content displayed at the right.  

Zoom Display: You can click the first icon in the toolbar to choose a commonly-used 
zoom option, such as Whole Image, 25%, 100%, 200%, and etc. You can also zoom in or 
out the display by holding down the right mouse button on the thumb image and 
dragging.  

Resolution: Click Default Resolution in the toolbar, and then choose a resolution from 
the dropdown list. In this way, you can preview the bitmap image in a different 
resolution.  

Rotate: This icon enables you to rotate the thumbnail image.  

Negative: This icon produces the negative effect.  

Mirror: This icon produces the mirror effect.  

Spot: This icon enables you to view and edit the spot colors.  

Dot Image/Preview Image: Click Dot Image in the toolbar to open the dot image. 
Click Preview Image to return.  

 
Figure 2-103 

In the dot image mode, you can also use the toolbar icons to perform the operations 
mentioned above. Besides, you can also add guidelines for you to better navigate on the 
dot image.  
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Guideline: ElecRoc provides rulers at the left and top of the dot image. To add a 
guideline, hold down the left mouse button on the ruler, drag to proper place on the dot 
image and then release. You can customize the line color with the toolbar icon Color of 
Guideline, and use Clear Guidelines to delete all added guidelines.  

3. Ink Histogram 

ElecRoc enables you to generate an ink histogram for a specific press. If there is no 
available press prior to the generation, it will hint you to add. Determine the name, the 
ink funnel quantity, maximum ink key, and media size, and then click OK.  

 
Figure 2-104 

Choose a press printer and then you can generate the ink histogram, as shown in the 
below.  
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Figure 2-105 

1) The Dot Percentage Histogram varies according to the printer’s ink count and Max Ink 
Key. And it can be generated for the whole file or for a single separation as well. Please 
choose the separation from the separation list located at the upper-left corner and the 
figure above shows an example for that of the Cyan separation.  

2) To change the display proportion, you can hold the right mouse button and drag on the 
dot percentage histogram.  

3) With the options in the Job rotate dropdown list at the top of the window, you can 
rotate the bitmap, and see the change on the dot percentage histogram as the bitmap 
rotates.  

4) The dropdown list at the upper-right corner of the window enables you to switch the 
view among dot percentage histogram, ink key map, and thumb histogram. The following 
figure is an example of the ink key map.  
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Figure 2-106 

5) When you have generated the dot percentage histogram, or the ink key map, or the 
thumb histogram, you can click the Print button at the upper-right corner of the window, 
to print out the displayed diagram and data. Before the print, please specify in details the 
diagram type (dot percentage histogram, or ink key map, or thumb histogram), and the 
separations (it’s best to choose the file name, if you choose only a separation, the pop-up 
dialog box will then only display that separation for you to choose). After you click the 
Print button, a dialog box appears, see the left figure below, asking you to choose the 
content to be printed.  

Click Confirm to enter in the print setup window, see the right figure below. Here you can 
configure some of the commonly-used printing parameters, such as printer, copies, 
direction, paper size, color mode, and etc. Click Print after you have configured these 
parameters.  

  
Figure 2-107 
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6) Moreover, you can click the button Press Management to add or delete a printer, or 
modify a printer’s name, printable size, ink fountain quantity, and max ink key. 
Double-click each of the above mentioned items to turn it editable, and then re-enter a 
proper value.  

 
Figure 2-108 
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Chapter 4 Processor Parameter Setup 
This chapter will introduce you to the parameter setup of the processors in ElecRoc. The 
introductions on Preflight, Trap, Imposer, Imposer, and Composer are NOT provided in 
this chapter, considering their rich features and paper length. Refer to chapters 5-8 for 
their parameter setup.  

4.1 How to Configure 

In ElecRoc workflow management system, a job workflow is completed by one processor 
singly or more than one processor together. Each processor processes files in a manner 
as a set of parameters define. Different parameter setups produce different results. How 
to efficiently and correctly define processor parameters is a key to use ElecRoc system.  

1. Global and local parameters 

In ElecRoc system, processor parameter setup can be defined at two places.  

The one is in the module Administrator > Processor Management, as mentioned in 
Chapter 2. Here you can define globally applicable processor parameter setup, i.e. the 
setting is applied in the entire ElecRoc system, becoming the default parameter setting 
for processors in each of your newly-created jobs.  

The other is in the job window, mentioned in Chapter 3. You can define locally applicable 
processor parameter setup, i.e. the setting is only applied in the current job when the 
node is NOT shared, having no influence on the setting of the processors of same type in 
current or any other job.  

Irrespective of global or local, their functions are the same, and so are ways of 
configuring them. In this chapter, we take the global parameter setup as example.  

2. Save setup 

In any processor’s parameter setup window, you can save your defined processor 
parameter setting by clicking the Apply button at the bottom of the window, so as to 
make it take effect and become up-to-date global or local setting.  

3. Apply parameter template 

For the user to apply various global or local parameter setups easily, ElecRoc introduces 
parameter template. A template is a combination of related parameter setting. For any 
processor, in the global parameter setup window, the user can save the current setting as 
a parameter template.  

In this way, according to different environments and production demands, the user can 
establish multiple and different combinations of parameter setting for any processor, and 
save them as different templates. In practice, by loading the saved template, the user 
can quickly apply the corresponding setting, thus avoiding repetitive configurations of all 
the parameters, and gaining better efficiency.  

All the template operations are implemented by way of the Load Parameters button. 
When this button is clicked, as in a global parameter setup window, a menu will appear, 
providing three menu items for you to load, save and delete a template.  

1) Save as parameter template 

Choose Load Parameters > Save As to open a dialog box. Input the template name 
and then click OK.  
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2) Load parameter template 

You can load the saved templates or the original setting for use or modification. Click 
Load Parameters > Load, and then choose the template to be loaded from behind. 
After you load a template, you can click the Save button to save it as global or local 
parameter setup; and if you make some modifications, you can click Load 
Parameters > Save As and then choose the same template to save your modifications.  

3) Delete parameter template 

Click Load Parameters > Delete, and then choose the template to be deleted from 
behind.  

Note: In any processor’s local parameter setup window, the Load Parameters button 
only enables the user to load a template, i.e. the global parameter setup. Available 
templates include your saved templates and default one. If the template is updated after 
you load, and you want the job node parameter setup to keep up with the updated 
template setup, please re-load the template.  

Now we introduce you in details to each processor’s parameter setup.  

4.2 PDF Generator 

 
Figure 2-109 
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As the required processor node in ElecRoc workflow, and usually located at the beginning, 
PDF Generator converts source files of various types such as PS, EPS, PDF, TIFF, and PRN 
into PDF page files, a standard file type employed inside ElecRoc. During the conversion, 
PDF Generator can also perform font substitution if needed, and image compression. 
Most of the processors in ElecRoc accept only the PDF page files generated by PDF 
Generator.  

The PDF Generator processor parameter setup window is shown as above, consisting of 
four tabs: Parameters, Fonts, PS and Advanced. 

4.2.1 Parameters 
1. Single Page/Multiple Page 

These two options refer to the file shape and external form for the PDF Generator’s 
output PDF pages (when the source file is composed of many pages). 

In single page mode, each page is shown as a file, as shown in the real line box below, 
page files from a same source file are listed in the same rank. In simplified view (the 
toolbar icon  is checked), a pair of brackets is employed to indicate the page number. 
In full view, a suffix _p000x is added at the end of the file name, meaning the page 
number, e.g. _p0001 means page 1, _p0002 means page 2. The suffix page number 
matches strictly that in the source file, even if you choose to output discontinuously only 
part of the pages. E.g. if you choose only to output the page 3 and page 6, then the 
suffixes become _p0003 and _p0006.  

In multiple page mode, multiple pages are shown as a file, as shown in the dashed line 
box below, page files from a same source file are listed in two ranks: the first rank shows 
the multiple-page PDF file; by clicking the  in front, you expand the second rank, 
showing the pages the file contains. To submit the multiple-page PDF file to other node in 
the job for process, you need to choose the whole file instead of certain page or pages.  

 
Figure 2-110 

You can apply one mode all the time, or apply the two modes by turns, on a same PDF 
Generator node. E.g. you can choose the single-page mode to process one or batch of 
files, and then choose the multiple-page mode to process the next or batch of files.  

Note: When the process policy for the file with same name is set to override, if you apply 
only one mode for two files with same name, the latter overrides the former. But if you 
apply different modes for them, both of them appear in the file list. In the latter case, 
their thumbnail images for preview will be the same.  

2. Page Range 
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Specify the page range of the file to be processed. There are three options:  

All: To process all pages of the file.  

Range: To process a range of pages (continuously from one page to another). Here you 
can manually input the page numbers.  

Pages: You can customize the pages that you want to process. The valid separators 
allowed in the Pages edit box include “,” and “-“, which mean “and” and “to” respectively. 
For example, you may input “1, 2, 4-7”, which means to process page 1, page 2, and 
pages 4 to 7.  

3. Margin Adjustment 

PDF Generator enables you to change the file size by way of increasing or reducing the 
top, left, bottom and right page margins. Positive value adds margin and thus increases 
the file size, while negative value reduces margin and the file size.  

Bleed Symmetry: With this option, pages are processed in such a way that in duplex 
printing, the front and back pages on each piece of paper will be symmetric, i.e. be 
registered. When checked, the left and right margin of the odd pages will be adjusted as 
per the Left and Right values specified here, while the left margin of the even pages are 
adjusted as per the Right value, the right margin as per the Left value.  

4. Thumbnail Parameters 

Choose any PDF page, double-click or right-click and choose Preview, you can display a 
thumbnail image to check the page content, or preview the process result.  

Enable Preview: When checked, PDF Generator produces thumbnail image for preview.  

Resolution: The resolution of the thumbnail image, 36, 72, 144 DPI.  

5. Other Parameters 

Stop running when occur spot color: If checked, ElecRoc issues warning and stops 
processing the file in case that the file contains spot colors. This feature can effectively 
notice you pay attention to the spot colors in the file, so as to avoid any spot color output 
error.  

Deliver pages once processed: If checked, each page will be immediately delivered to 
the connected next node for process, once it has been generated by PDF Generator. If not, 
pages will be delivered at the same time till all pages from all files have been generated.  

Rotation: To rotate pages. You can rotate pages 90, 180, 270 degrees anti-clockwise. 
The default setting is no rotation.  

Rules for file with same name: You may submit a same file to a same PDF Generator 
more than once. If you choose Override, the PDF page generated at the earlier 
submission will be overridden by that at the later submission. If you choose Add label, 
an ascending numerical suffix will be added to the file name _V01, _V02 … 

Time out: If the file submitted to PDF Generator cannot be processed within the time 
period specified here, ElecRoc stops the process after this time period, preventing single 
file exception from affecting the after files’ processes. By default, it is set to 0, meaning 
no timeout setting.  

6. PDF Parameters 

PDF Password: If the submitted PDF file contains password, you must provide the 
password here so that ElecRoc can correctly process the file. The Adobe Acrobat allows 
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you to set two passwords in a PDF file: Open Password controls permission to open the 
file; and Security Password controls the permission to edit.  

1) The PDF file contains no password: No password is required in PDF Password edit 
box.  

2) It contains only Open Password: You must provide the correct Open Password.  

3) It contains only Security Password: If the PDF file allows to be printed, you do NOT 
need to enter the password. If the PDF allows NOT to be printed, you must provide the 
correct Security Password.  

4) It contains both Open Password and Security Password: If the PDF file allows to 
be printed, you need to provide only one password. If the PDF allows NOT to be printed, 
you must provide the correct Security Password.  

Page Box: PDF Generator identifies the size determined by your specified page box as 
the page size of the new generated PDF page file. Page boxes in a PDF file may include 
Media Box, Crop Box, Bleed Box, Trim Box and Art Box. E.g. suppose there are two 
page boxes defined in the PDF page, Crop Box size is A4 (210x297mm), Bleed Box size 
is 200x287mm (bleed 5mm, so the size is smaller), if you choose Crop Box here, the 
page size of the generated PDF page would be 210x297mm, but if you choose Bleed Box, 
the page size changes to 200x287mm.  

RGB to CMYK: By default, this option is unchecked. If your file contains transparent RGB 
objects, and their output result is not satisfactory, you can try this option to get a better 
transparent output result.  

Only transparent blend CS: This option becomes activated when you have checked the 
RGB to CMYK option. Transparent blend CS refers to two cases, one is the page’s blend 
color space is RGB, the other is the page contains transparent group object whose blend 
color space is RGB. If checked, the above RGB to CMYK process happens only to these 
two cases, while other transparent RGB objects are not processed.  

7. Double Page Spread 

This parameter is applied to the case when each page from your source file consists of 
two pages of content, see the upper-left figure in the below. When you enable this 
feature (check the option Split), PDF Generator will split each page from the source file 
into two pages, see the lower-left figure in the below. As shown in the right figure below, 
the setup window for this parameter can be opened if you click the Settings button.  

Based on different binding positions and types, ElecRoc provides 6 splitting methods, 
with which you can get various page numberings. Please choose a proper method 
according to your actual needs. If you choose one from the right two methods, the first 
and last pages of the source file will not be split.  

Bleed: After the splitting, a bleed as specified here will be added to the left or right side 
of the new page. The default bleed is 3 mm.  
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Figure 2-111 

4.2.2 Fonts 

 
Figure 2-112 
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PDF Generator embeds the fonts used in the source file into the newly-generated PDF 
page file during its process. If the fonts used are embedded in the source file, or these 
fonts are already installed in your ElecRoc system, the embedding operation can run 
normally, and you do NOT need to make any configuration here.  

But if the fonts used are NOT embedded in or provided with the source file, or these fonts 
are NOT yet installed in your ElecRoc system, i.e. these fonts are absent, in these cases, 
you must pay attention to the font setting as follows.  

1. Ignore Absent Font 

If checked, the generated PDF page file may miss the font used in the source file. But the 
missing font must be replaced by the default or any specified substitute font. If not, PDF 
Generator reminds you with error report when it finds a font missing.  

2. PS Parameter 

Error if embedding font is failed: A PS file itself may disable you to embed certain font. 
In this case, PDF Generator will still use the default font to substitute for the missing one, 
but the substitution may result in messy code. If checked, ElecRoc issues warning 
message and stops the process. If not, the PDF Generator process continues and issues 
the warning message in pink.  

3. Embed Basic Font 

ElecRoc builds in 35 basic fonts.  

Embed basic font: If checked, in case that the source file uses a basic font, but doesn’t 
embed it, PDF Generator will embed the absent basic font into the newly-generated PDF 
page file. If not, PDF Generator only embeds other absent fonts.  

Error if font is not embedded: If checked, in case that the source file doesn’t embed 
all its absent fonts, excluding the 35 basic fonts, ElecRoc will issue warning.  

If you check both the two options above, ElecRoc issues warning even when the source 
file doesn’t embed basic font it uses.  

4. Font Substitution 

Default Font: You can specify a font as the default substitute font from the Default Font 
dropdown list. When you check Ignore Absent Font but don’t define any substitute font 
in Substitute Fonts List, PDF Generator uses this default font to substitute for absent 
fonts.  

Max Absent Fonts: This option limits the quantity of the fonts in the absent fonts list. 
This list displays the absent fonts in the source file. The quantity of absent fonts increases 
as the process files increases. When the quantity reaches the limit specified here, 
ElecRoc will auto delete the older one in the list. In this way, the number of absent fonts 
in the list remains within the limit number. It is a global option, thus can be configured 
only in Administrative Tools.  

Absent Fonts List: If PDF Generator finds an absent font in the source file during the 
process, it will display this font in the absent fonts list (click Refresh to manually refresh 
the list). You can also use the Add Absentee, Delete Absentee and Clear Absentee 
buttons to add, delete or clear fonts manually in the list. These operations can only be 
implemented in Administrative Tools.  

Installed Fonts List: This list displays the fonts installed in ElecRoc. You can use them 
to substitute for the absent fonts.  
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Substituted Fonts List: This list is designed for you to define substitute relationships. 
Choose an absent font from the Absent Fonts List, and then choose an installed font 
from the Installed Fonts List, to build a substitute relationship. The relationship is then 
displayed in the Substituted Fonts List. Now, PDF Generator can use the corresponding 
substitute font to substitute for the absent font, and embed the substitute font into the 
generated PDF page file, during its process.  

You can delete one or all substitute relationships by using the Delete Substitute and 
Clear Substitute buttons. A deletion of a font from the Absent Fonts List doesn’t 
delete the involved substitute relationship in the Substituted Fonts List.  

4.2.3 PS 

 
Figure 2-113 

1. PS Parameters 

Preserve overprint settings: If checked, ElecRoc uses the overprint settings defined in 
the source file. If not, the overprint settings will be removed.  

Default is nonzero: This option is specially designed for inverted texts, such as that 
generated by Founder FIT. In case that the source file contains such text, please leave 
this checkbox blank.  

Merge copydot DCS: If checked, PDF Generator can correctly process the overprinting 
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of DCS images. Check it only when DCS does not contain spot color and CMYK are 
complete.  

Merge same images: When checked, if the submitted PS file contains more than one 
same image, PDF Generator ignores the repeated processes to the same images, so as to 
reduce the size of the temporarily-generated file. PDF Generator may fail if the temp file 
is too large. By default, this option is left blank, for concern that it may slow down the 
process speed. We suggest you to check it only in case that your PS file contains lots of 
same and large images.  

Idiom Substitution: If checked, ElecRoc uses PostScript Level 3 smooth gradient 
description to replace the old smooth gradient description in PS. PostScript Level 3 
employs new smooth gradient dictionary and operators to describe smooth gradient, 
greatly improving the speed and quality of generating smooth gradient, and supports 
more types of smooth gradient, for you to easily generate colorful smooth gradient 
graphics.  

Support device spot color: If you want to output spot color as an independent color 
separation in backend, such as PDF Rasterizer, check this option. Otherwise, e.g. use 
CMYK to simulate the spot color, you may leave it unchecked. By default, it is checked.  

Support spot color Level 1: If checked, ElecRoc can better support spot color gradient 
defined by front-end layout application.  

Preserve halftone info: To preserve the halftone settings in the source file.  

Resolution: For most PostScript files, higher resolution results in larger but higher 
quality PDF files, while lower resolution results in smaller but lower quality files. In 
general, you can use the default setting. In case that you want to output PDF files with 
specific printer, or emulate the resolution defined in the original PS file, or in case that 
page elements emerge or miss in some files after being processed, you can try to change 
the resolution to rectify. Note that the resolution cannot be over 6000 DPI.  

Media Size: If the media size of your PS or EPS file is NOT defined, the generated PDF 
will be in the media size specified herein. You can choose a predefined standard size: A0, 
A1, A2, A3, and A4. You can also choose Custom to specify other values.  

Note: If the size you want to customize is close to one of the predefined sizes, you can 
first choose the predefined size, and then choose Custom to modify the values.  

2. Other Parameters 

Ignore absent image: If checked, in case that the source file, e.g. PS file generated by 
Founder FIT without image information, misses image(s), ElecRoc issues warning but 
continues processing, so the generated PDF pages miss images too. If unchecked, 
ElecRoc reports error and stops processing.  

Image Path: To specify the paths of the images referred in source file. You can manually 
input the path, or you can also click Browse to choose a path, optional paths need to be 
predefined at the Server. It supports more than one path, separated by semicolons. 
ElecRoc searches images according to the paths on a first-come first-served basis.  

4.2.4 Advanced 
PDF Generator compresses the images contained in the source file during its process. The 
size of the generated PDF page file can be obviously reduced if you choose proper 
compression modes and resolutions.  

Note: The default settings are suitable for commercial print, and are recommended if 
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your PDF is just for commercial print. If your PDF is for remote proof or network 
transmission, you may modify the settings as needed.  

 
Figure 2-114 

Image Types: Images are classified into three types here, Color images, Grayscale 
images, and Monochrome images.  

Compression: There are five options. None means no compression. Zip is a lossless 
compression technique, supporting PDF and TIFF files, most suitable for images 
containing large single-color areas. It is the default compression mode for color and 
grayscale images. JPEG achieves high compression ratio and has a quite big influence on 
the images. The image quality is controlled by three options, High, Medium, and Low. 
CCITT is a series of lossless compression technologies for black and white images, 
available for PDF and PostScript files. CCITT is the French abbreviation for International 
Telegraph and Telekeyed Consultive Committee. PackBits is a fast, simple lossless 
compression scheme for run-length encoding of data. Apple introduced this format on 
Macintosh computer. It can be used in TIFF files.  

Resolution: If the resolution of the file is bigger than the value specified here, PDF 
Generator will re-sampling the file at your specified resolution.  
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4.3 PDF Processors 

Such processors accept only the PDF page files generated by PDF Generator, and output 
them in PDF file format, including:  

Margin Adjustment Page Clipper PDF Tools  

Double Burn PDF Merger PDF CMS EcoInk 

Preflight Trap 3rd Party Preflight  

Imposer Composer Ganging  

In this section, we introduce the processors except Preflight, Trap, Imposer, and 
Composer. In consideration of the paragraph length, we will introduce them separately in 
sections 4.5 and 4.6, and chapters 5 and 6.  

4.3.1 Margin Adjustment 
This processor enables you to adjust the margins of the PDF pages.  

 
Figure 2-115 

1. Auto Adjustment 
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When Auto Adjustment is checked, you can customize the top, bottom, left and right 
margin to be remained. In the thumbnail image displayed at the right, the yellow area 
indicates the artwork on the page, the white area indicates the original margin, and the 
red dashed lines represent the margin after adjustment.  

Page size after adjusting: If checked, the processor can automatically increase or 
reduce the margin, making the final page size be the size specified here. The diagram 
containing nine tiny circles indicates positions for alignment before and after the 
adjustment. Take the upper-left circle being checked as example, i.e. align the upper-left 
corners of the pages and then increase or reduce the margin, in this case, the right 
and/or bottom margin of the page will be adjusted.  

2. Page Adjustment 

Choose Page Adjustment to activate the parameters below, meanwhile disabling the 
options in the Auto Adjustment area. Input the top, bottom, left and right margin to be 
increased in the corresponding edit boxes. The thumbnail image at the right shows the 
adjusted effect. The area enclosed by real lines represents the original size of the page, 
while the area enclosed by dashed lines represents the page size after the margin 
increase.  

Page size after adjusting: Same as that in Auto Adjustment.  

Bleed Symmetry: If checked, in duplex printing, the front and back pages on each piece 
of paper will be symmetric or registered, i.e. the left and right margin of the odd pages 
will be adjusted as per the Left and Right values specified here, while the left margin of 
the even pages are adjusted as per the Right value, the right margin as per the Left 
value.  

4.3.2 Page Clipper 
Using this processor, you can cut out the page content outside one or more defined crop 
boxes on the page. It helps you to get rid of the unneeded content on the page, and also 
enables you to split one page into several little ones.  

In the job window, find out the Page Clipper icon from the left node list, and drag it into 
the job, then submit a PDF page file from a PDF processor such as PDF Generator to this 
node. After the submission, double-click the node to open the following window.  
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Figure 2-116 

The window shows a toolbar at the top, which is grayed when you don’t submit any page. 
The left lists all the submitted pages, as shown above, you can submit more than one 
page at the same time. The editing interface of the selected page is shown at the body of 
the window.  

To clip a page, you need to define correctly one or more crop boxes. The content inside 
the boxes is remained while that outside of the boxes is removed at the time you clip. 
Now we go to the details on how to define a crop box.  

1. Resize the crop box 

You can define the size of the crop box in any of the following ways:  

1. Hold down the left mouse button on the page and drag to form a dashed-line box. A 
crop box is generated once you release the mouse button. After you define a crop box, 
you can drag the arrows on the four sides or corners to freely adjust the size of the box.  

2. Use the property panel at the bottom of the window to manually input the height and 
width of the crop box. Here you can accurately define the size. You can click the unit 
displayed in the height and width edit boxes to choose a preferred unit.  

3. Use the three icons at the right of the toolbar.  

The actual width of the page : Make the width of the crop box be the same as that of 
the page. 

The actual height of the page : Make the height of the crop box be the same as that 
of the page. 
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The actual size of the page : Make the size of the crop box be the same as that of the 
page. 

The default crop box covers the entire page when you enter in the Page Clipper window.  

2. Position the crop box 

You can define the position of the crop box in any of the following ways:  

1. Use horizontal and vertical coordinates to position the crop box. On the property panel 
for the crop box, the nine-point diagram at the left represent nine positions on the crop 
box. The X and Y values are the horizontal and vertical coordinates of such a position in 
a coordinate system. E.g. we can check the lower-left point in the diagram and set the 
coordinates to (10, 10), which means that the coordinates of the lower-left corner of the 
crop box are (10, 10).  

The default coordinate system originates at the lower-left corner of the page, with the 
positive X axis pointing to the right, while the positive y axis upward. If needed, you can 
change the origin to define another coordinate system. Choose the toolbar icon Set 
custom coordinate system  (the whole page now is grayed, and two intersecting 
white lines appear and move along with the cursor), and move the intersecting lines to a 
proper position (press Ctrl or Alt meanwhile to choose one commonly-used system 
basing on the page or page element, i.e. when you move the axes to some specific 
positions on the page, you can see white coordinate system), and then click the mouse, 
to open the following dialog box.  

 
Figure 2-117 

You can input exact values in the X, Y edit boxes, to precisely determine the position of 
the origin. And you can choose a preferred direction in the coordinate axis diagram aside.  

2. Hold down the left mouse button to drag the crop box to any place as needed. If you 
adopt this way, you can add guide lines for easiness in operation.  

Add a guide. Move the cursor to the rulers located at the top and left of the window, and 
once the cursor turns to an arrow, hold down the left mouse button and drag toward the 
page. Now you will see a white line appearing, drag this line to proper position and then 
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release the mouse button. And then in the pop-up dialog box, specify the position of the 
auxiliary line and click OK. The position here refers to the distance between the line and 
the page side. X refers to the distance off the top side and Y the left side. This dialog box 
can also be opened by clicking the toolbar icon . 

 
Figure 2-118 

Lock guides. Click the toolbar icon , and then choose Lock guides from the dropdown 
list. A locked line can NOT be moved freely any more.  

Capture guides. Choose Capture guides in the  dropdown list. It aligns the crop 
box with the nearest line when you move the box.  

Like Capture guides, you can also choose Capture elements of the border in the  
dropdown list, to align the crop box with the nearest page element box, such as the page 
box, when you move the crop box.  

3. Use the toolbar icon . A dialog box appears when this icon is clicked. Input the 
distance to move leftward or rightward in the horizontal direction, or the distance to 
move upside or downside, and then click OK.  

4. Use the toolbar icon  to make the crop box be at the center of the page. After you 
click this icon, a dropdown list appears, providing three centering options, horizontal & 
vertical, horizontal, and vertical.  

3. Color and Zoom 

ElecRoc also provides features to help you define the size and position of the crop box 
with ease.  

To change the color of the crop box, click the toolbar icon  and choose Trim Box Color 
in the dropdown list. In the follow-up color setup dialog box, choose an appropriate color, 
and then click OK.  

To zoom in or out the page, you can use the zoom icons , ,  in the toolbar, or hold 
down the right mouse button and drag.  

4. Define multiple crop boxes 
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As you drag the mouse on the page to create a crop box, if you press down the Ctrl key 
at the same time, or make the toolbar icon  be checked, you can create more than one 
crop box one time.  

The size and position of each crop box can be separately defined.  

5. Crop to Blocks 

This feature enables you to split a page. There are two manners to divide a page into 
blocks: by auxiliary line and by certain rows and columns, controlled by the Block mode 
parameter. If you choose the Not partition option, then you can define one or more 
independent crop boxes as the methods mentioned above.  

Using the auxiliary line block: To add one or more horizontal or vertical auxiliary lines 
on the page. These lines can further split the crop boxes on the page into multiple 
rectangular blocks, each block then becoming a crop box. E.g. in practice, you may have 
imposed multiple middle-seam pages onto a page. With this feature, you can easily split 
these middle-seam pages, for use later in the composition.  

Set the number of block ranks: when checked, you see new parameters in the below 
of the Block mode list. ElecRoc can split the crop boxes into multiple equal rectangles, 
each becoming a new crop box, as per the rows, columns and distance specified here.  

6. Crop 

Click the icon  at the upper-left corner of the window after you define properly the 
quantity, the size and positions of the crop boxes. A new window now appears. Choose 
the blocks to be cropped, and then click OK. Each of the chosen blocks will then become 
a new page file.  

 
Figure 2-119 
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4.3.3 PDF Tools 
The PDF Tools parameter setup window is shown as follows: 

 
Figure 2-120 

1. Zoom 

This setting enables you to scale flexibly the size of the generated PDF page file. 

No Scaling: If checked, the file size remains unchanged.  

Scaling: If you choose Same Scaling, the file is scaled up or down to the input 
percentage in both horizontal and vertical directions. If you choose Free Scaling, you 
can then separately specify the horizontal and vertical scale percentages.  

Page Size: This option enables the file to be scaled to a specified page size. You can 
choose a predefined size in the Page size list, or choose Custom to define a specific 
size.  

Fit to page: This option enables the file to be scaled in the specified page size, with same 
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scale percentages in both X and Y directions.  

2. Spot Color 

 
Figure 2-121 

1) None 

When the option None is selected, none of the following processing methods will be used 
to your spot colors.  

The following three processing methods are mutually exclusive. You can choose only one 
of them.  

2) Custom spot color 

When the option Custom spot color is selected, the table below it takes effect, 
describing how your spot colors will be processed. Spot colors undefined in the table, if 
any, are processed as per the description for the item Default spot.  

You can click the icon  to add a spot color into the table. After the adding, please specify 



                      User Guide 

 13
 

134 

its name, output manner, and corresponding color values, one by one. Unneeded spot 
color can be removed from the table by clicking the icon . You may click the icon  to 
load spot color(s) from existing spot color tables, accessing the spot color names and 
CMFY values. The spot color in this table can be written back to your spot color table by 
clicking the icon . At the time you define the color values, please double-click the value 
to activate it into editable state.  

There are four manners to output spot colors. Separation refers to output as a 
stand-alone separation, same as a process color. to Press Color refers to output by way 
of transferring the spot color onto press colors. Change Into refers to output the spot 
color with another spot color. In this case, you need to choose the “another spot color” in 
the Replaced by column. Remove refers to no output of the spot color.  

Note: At the time you define the spot color name, please note that the spot color names 
are NOT case-sensitive because of the operating system. Spot colors such as SPOT1 and 
spot1 will be taken as the same one.  

3) Convert specific process color in graphics to spot color 

If selected, it converts the process colors defined here to spot colors. Please define the 
CMYK values at the left of the table, and then define the spot color at the right.  

If it finds out graphics on the page whose color values equal to the definition here, it will 
then convert them into spot colors. The spot color will be named as per what you define 
at the right of the table. Tolerancy refers to tolerable deviation between the actual and 
defined color values. Its unit is percentage, the higher the value is, and the wider the 
scope of colors being converted will be.  

4) Modify the extension 

If the color contains suffix and not __, Rename spot color as: When the option 
Modify the extension is selected, if the spot colors contains a suffix, but not the one 
specified here, it will rename the suffix as the one specified here. If you continue to check 
the option Add a suffix if a separation has no suffix, in case that the spot color has 
no suffix, it will automatically add a one.  

4.3.4 Double Burn 
Double Burn processor allows you to merge two PDF pages into one PDF page. Merging 
is necessary when different parts of a page are designed by different people; perhaps one 
designs graphic part, and another inputs text. Works from different designers need to be 
merged to complete a page design. Double Burn meets this need perfectly. The following 
diagram shows how it works.  
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Figure 2-122 

The Double Burn parameter setup window is displayed as follows: 

 
Figure 2-123 

1. Alignment 
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Page Alignment: The diagram containing nine tiny points indicates positions for 
alignment during the mergence. E.g., if you check the upper-left point, it will align the 
upper-left corners of the two pages, and then merge them. X and Y refer to the horizontal 
and vertical spaces for the second page away the first page under the selected align 
mode. 

Preview: If checked, the processor generates a thumbnail image for the merged page. 

Enable the second job clipping: This option enables you to clip the second job. You 
can input in the Lower Left and Upper Right boxes separately the X and Y coordinates 
both originate at the lower-left corner of the page to define two points, which can then 
form a rectangle on the page. Double Burn cut off the content outside of the rectangle. 

2. Rule 

Parameters under this tab allow you to define two sets of merging rules.  

 
Figure 2-124 

1) Rules for automatic double burn 

 File name tag 

It refers to the name of the file submitted to the Double Burn processor. ElecRoc uses the 
file name to determine if the file is applied to the automatic double burn process.  

File name tag: If the names of the input files are in a standard style: Jobname_tag, 
Double Burn can automatically submit the input files for process. To realize automatic 
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combining, the Jobname part of the two files to be combined must be the same, while the 
tag part can be specified separately in the First job tag and Second job tag edit boxes. 
For example, the user can input A and B, two files like Sample_A and Sample_B can then 
be applicable for the auto process.  

 Multi-page job 

Parameters in this area allow the user to specify the combining rules when one or both of 
the two input files consist of multiple pages.  

Single/Multi-page job: This option is applied to cases when one file contains only one 
page, and the other contains multiple pages. The Combine first page of each job 
option makes the processor to combine the first page of the first file with the first page of 
the second file.  

 
Figure 2-125 

The Combine single page with each page of multiple job option makes the 
processor to combine the page of the first file with each page of the second file 
respectively.  

 
Figure 2-126 

Multi/Multi-page job: This option is applied to cases when both files contain multiple 
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pages. The Combine first page of each job option makes Double Burn to combine only 
first pages of the two files.  

 
Figure 2-127 

The Combine all pages sequentially option makes it to combine pages with the same 
page number, e.g. page 1st of the first file with page 1st of the second file, page 2nd of the 
first file with page 2nd of the second file, and so on.  

 
Figure 2-128 

 Name Rule 

If you choose Preserve tag, Double Burn preserves the tags of both the two input files 
in the name of the combined file. The two tags are connected with a separator “_”. If you 
choose Remove tag, it removes the tags in the file name. And if you choose Append 
tag, it appends a specified tag in the file name. The specified tag and the file name are 
connected with separator “_” as well.  

2) Manual double burn 

There are four processing manners if you manually submit pages to Double Burn:  

Pages are combined sequentially in pairs: This option makes the processor to 
combine pages sequentially in pairs, as shown in the below.  
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Figure 2-129 

First page is combined with following pages: This option makes the first page be 
combined with the following pages, shown as follows.  

 
Figure 2-130 

Merge all files: This option combines all the submitted pages into a single page. The file 
name is composed of the first two page names, separated by “_”.  

Use automatic rules: If checked, it applies the automatic combining rules to process 
the manually-submitted pages.  

4.3.5 PDF Merger 
ElecRoc provides PDF Merger for your convenience in long distance transmitting and 
proofing. With this processor, you can merge multiple PDF files into one PDF. The 
operation is very simple: you need only to submit more than one PDF files (separation 
files are not supported) to PDF Merger.  
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Figure 2-131 

 Set File Name 

Rules for file with same name: Irrespective of how the file is named after the 
mergence, if you choose Override, in case that it generates two files with same name in 
two different processes, the new file will override the old one. If you choose Add Label, 
it adds a suffix like _1, _2 … in the name of the new file.  

Use first page name: This option uses the first page name as the output PDF file’s 
name.  

Rename as: If checked, you can input a name in the edit box, and make it as the name 
of the output file after the mergence.  

 Output Setup 

Split the PDF file if the file size exceeds 2 Gigabyte: If checked, in case that the file 
size after being merged exceeds 2 GB, ElecRoc will automatically split the file, making the 
exceeded part as a new file, so as to ensure that no new file is larger than 2 GB. 

 Merging Option 

Merge Pages: Merge the submitted pages into a single file.  

Merge signatures to multiple pages: Merge each signature into a multipage PDF file.  

Merge signatures to single page: Merge each signature into a single-page PDF file. 
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4.3.6 PDF CMS 
This processor provides the color management capacity at the PDF page level. In job 
workflow, it can be deployed behind PDF Generator, Preflight, Trap, in front of Imposer, 
Rasterizer and etc. Its processor parameter setup window is shown as follows:  

 
Figure 2-132 

1. General Parameters 

1) Override ICC 

The input file may embed ICC color profiles. If you want to use the embedded ICC profiles 
to reproduce the colors of the page objects, keep the Override CMYK ICC and Override 
Non-CMYK ICC boxes empty. If you check these two boxes (both, or any of them), you 
can then use the profiles specified below by Input Parameters.  

2) Input Parameters 

Profiles: You can specify the input ICC profiles for 6 types of page objects, including RGB 
images/graphs, CMYK images/graphs, and Gray images/graphs. The input profiles for 
each type of page objects are further divided into two types: Input Profile and Device 
Link. ElecRoc not only provides some built-in profiles for you to use, but also supports 
you to import more other profiles into ElecRoc in the module Resources > Profile 
Resource > ICC.  
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If you check Use same ICC in image and in graphics, the input profiles for the images 
and graphs in same color mode will be the same. And if you check Use CMYK profile in 
gray image, the input profiles for Gray images and graphs will be the same as those for 
CMYK images and graphs.  

Render Intent: The Main Render Intent parameter controls the render intents for the 
images and graphs in all color modes (RGB, CMYK, Gray and LAB). You can also 
separately define the render intent for each image or graph type. There are four optional 
intents: Perceptual, Saturation, Relative and Absolute.  

3) Output Parameters 

Color Model: ElecRoc CMS supports 4 output color modes, RGB, CMYK, Gray and HiFi. 

Target: Here you can specify the target color profile.  

Embed target ICC: If checked, ElecRoc will embed the ICC profile specified at the 
Target dropdown list, into the PDF file generated after the PDF CMS process.  

Use PDF/X Embedded ICC: This option becomes available when the Color Model is set 
to CMYK. If checked, the output profiles embedded in PDF/X will be used with priority.  

Plane Num: In HiFi output mode, you can further specify the number of the output 
planes. ElecRoc supports 5 planes (CMYKO, CMYKG, and CMYKB), 6 planes (CMYKOG, 
CMYKOB, and CMYKGB) and 7 planes (CMYKOGB).  

4) Color Mapping 

With the Color Mapping setting, you can define how to converse a specific color. Colors 
that are not specially specified here will still be conversed as per the input and output 
parameters specified above.  

 
Figure 2-133 
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Input the source color to be conversed in the From area. You need to provide such 
information as the color space (RGB, CMYK, Gray or LAB) and the color value. Then input 
the target color value that would be after the conversion in the To area. The Color Space 
in the To area is determined by Output Parameters > Color Model under the General 
tab. And then click Add to append the mapping relation into the table above. A tick in 
front indicates the color will be conversed as specified here, while blank indicates not. If 
you check the Apply box, all the mapping setting takes effect.  

If you want to change a mapping relation, choose it, edit the source and target colors and 
then click Apply. If you want to delete it, choose it and just click Delete.  

Tolerance: Using this parameter you form a tolerance range (non-zero color value +- 
tolerance value). Colors within this range will all be conversed as specified here. E.g. if 
you specify specially the mapping relation for a CMYK source color (30 0 100 0), and the 
Tolerance is set to 2, then source colors (28~32 0 98~100 0) in the input file will all be 
conversed like the color (30 0 100 0).  

Image/Graphic: These two options control if the color mapping settings are applied to 
the image or graph objects.  

2. Advanced Parameters 

 
Figure 2-134 

Black Preserve: Settings here are available only when the output color model is set to 
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CMYK. Colors of two black objects can be preserved, one is image or graph of C=M=Y=0 
K=0~100, which will not be conversed, the other is image or graph of R=G=B, which will 
become C=M=Y=0 K＝1-r after being conversed. The r refers to the R (or G, B) value in 
percentage.  

Exception Handling: The overprint or/and transparent image elements contained in 
the input page, if any, would deviate or change after a color conversion. Thus a warning 
mechanism can timely arouse your attention. You can ask ElecRoc to issue error or 
warning in such cases.  

Convert rich black to pure black: If checked, ElecRoc can convert the rich black 
objects (K=100, C, M, Y any value) in your file to pure black objects (K=100, CMY=0).  

4.3.7 EcoInk 
This processor is developed to meet the requirements for energy consumption reduction 
in print industry. It uses a lot of K to substitute for CMY, so as to reduce the ink 
consumption and lower the printing cost. Meanwhile, it applies color management 
technology to ensure the color stability and quality consistency, improving the gray tone 
and making the details and image contrast more obvious.  

In ElecRoc workflow, it accepts PDF pages processed by PDF Generator, or signatures 
generated by Imposer or Composer, process and output them as PDF files. The output 
files can then be submitted to the Rasterizer node.  

Before you define the processor parameters, you should create an EcoInk solution by 
Resources > Profile Resource > EcoInk. This solution takes a precise control of the 
color conversion and management, ink-saving range, ink-saving level, and whether to 
preserve pure colors.  

 
Figure 2-135 
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EcoInk Solution: It refers to the EcoInk solution created by Resources > Profile 
Resource > EcoInk. You can click View to learn the details on your selected solution.  

Ignored Elements: EcoInk processor can selectively ignore certain image elements 
during the ink-saving process. Such elements include: 

1) element whose width or height is less than a specified value;  
2) element whose width/height ratio is greater than a specified value;  
3) element whose height/width ratio is greater than a specified value;  
4) element that contains gradient;  
5) spot color; and  
6) element with specific color value. The corresponding checkbox for the last one is 
Reserved Value. Check it and click Settings, and then you can define colors with 
specific color value.  

 
Figure 2-136 

The Tolerance parameter in the follow-up color defining dialog box refers to the 
difference allowed between the actual and specified color values. E.g. suppose that the 
specified value here is C=a M=b Y=c K=d, and the Tolerance is set to x%, then colors of 
C= (a-ax％)~(a+ax%) M = (b-bx％) ~(b+bx%) Y=(c-cx％)~(c+cx%) 
K=(d-dx％)~(d+dx%) can all be ignored.  

Exception Handling: The overprint or/and transparent image elements contained in 
the input page, if any, would deviate or change after the ink-saving process. A warning 
mechanism can timely arouse your attention and help avoiding possible errors. You can 
ask ElecRoc to issue error or warning in such cases.  

4.3.8 3rd Party Preflight 
ElecRoc enables you to use the third-party Enfocus’ preflight module in ElecRoc workflow. 
The processor parameter setup window is shown as follows.  

Note: The installation of Enfocus PitStop on ElecRoc server is required. ElecRoc currently 
supports only the Server versions.  
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Figure 2-137 

The Profile and Action List dropdown boxes provide all available preflight profiles and 
action list files in ElecRoc system, for you to choose. If you check Enable Preview, it 
generates a thumbnail image for the PDF file during the preflight process.  

After the preflight process, choose the preflight node, then choose a processed file in the 
output file queue, right-click and choose Preflight Report, you can view the process 
result report about the file.  

4.3.9 Ganging 
The Ganging processor is mainly designed for use with the large-format output devices. 
It can automatically gang and output multiple small pages, which may be unsuitable for 
being processed by imposer, on one large sheet of page based on the media size, in an 
optimal layout, saving greatly the media and efficiency. With this processor, you can also 
tile a large page into multiple small pages.  

Note: This processor requires Adobe Acrobat version 8 or higher version being installed 
on your computer.  
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Figure 2-138 

1. Media (mm) 

The media sizes can be classified into two types: pre-defined and custom. You can choose 
a pre-defined option as needed, or choose Custom to define a specific size.  

2. Mark Parameters 

You can add marks in ganging. Mark size is fixed to 10.5 mm.  

Enable surface mark: If checked, surface mark is added outside the surface.  

Enable ganging mark: If checked, ganging mark is added outside the pages.  

3. Tiling Parameters 

Enable Tiling: If checked, it enables the auto tiling. 

Auto Overlap: If checked, ElecRoc automatically controls the overlap width, ignoring 
the Overlap setting.  

Overlap: When Enable Tiling is checked but Auto Overlap is unchecked, Ganging 
uses the values in the Horizontal and Vertical edit boxes as width and height of the 
overlapping area between two neighboring tiled pages.  

4. Preview 

Here you can specify a preview resolution, ranging from 18 to 72 DPI.  



                      User Guide 

 14
 

148 

Hint: In case that pages are very small while signature is very large, e.g. a bisect, you’d 
better set a lower resolution, otherwise, the preview speed may be slow on Mac client.  

5. Ganging Parameters 

Enable Ganging: If checked, it enables the auto ganging.  

Direction: Here you can determine whether to enable ganging in X, Y, or both directions. 

Priority: Here you can control the priority of ganging direction. 

Adjust layout: If you choose Keep layout, the signature size will base on the value 
specified by the parameter Media. And if you choose Keeping only replate area, 
ElecRoc will automatically trim away the blank area on the four sides of the signature, 
therefore the signature size may become smaller than the Media size.  

Interpage: You can input in the Horizontal and Vertical edit boxes to specify the 
inter-page spacing in both horizontal and vertical directions.  

Rotation: You can rotate the pages by choosing a suitable option.  

Repeat Count: Repeat the submission of pages. For instance, if you submit 3 pages and 
set Repeat Count to 2, then you will actually submit 6 pages (3x2) for ganging.  
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4.4 Output Processors 

Such processors accept the PDF pages or signatures processed by PDF processor, and 
output them on real media or as a finished electronic document, including:  

PDF Export PDF Rasterizer 1 Bit TIFF Export 8 Bit TIFF Export 

Mono Printer Color Printer Pre-RIP Proof Post-RIP Proof 

Digital Printing Inkjet Printing Barcode  

Ink Save Report Ink Control Export   

4.4.1 PDF Export 
PDF Export processor allows you to export the PDF page files to a specified location.  

 
Figure 2-139 

Preserve file name: If checked, the name of the PDF page file will be preserved during 
the export. If the source file submitted to PDF Generator contains more than one page, 
PDF Generator may produce more than one PDF page file, and include in their file names 
a page number. If you want to preserve this number in the file name, choose Preserve 
page number from the right dropdown list, otherwise, choose Remove page number.  
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Rename as: If checked, you can specify a name as the name of the exported file(s).  

Rules for file with same name: There are two options. If you choose Override, in 
case that the exported file has the same name as an existing file in the output path, the 
new file will overwrite the old one. If you choose Append Suffix, in such case, it adds an 
ascending numeric suffix like _V01, _V02, _V03… to the name of the new file.  

Change output path: Here you can specify the output path where the PDF pages will be 
exported. You can directly input the path in the edit box or click the Browse button to 
select an optional path. Optional output paths should be pre-defined from the Server.  

Keep file name: If checked, ElecRoc will delete a specified digit number of node id and 
underline before the file name, and all the extensions behind the file name. The digit 
number can be specified, by default its value is 6. This is generally designed for the PDF 
file generated by PDF Merger. For example, if checked, and the digit number is set to 6, 
an input PDF file “13_10_sample_pdf_Merge” would be exported as “sample”, if the digit 
number is set to 8, it would be exported as “mple”.  

4.4.2 PDF Rasterizer 
This processor can convert PDF page files or signatures into bitmap files.  
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Figure 2-140 

1. Screen 

1) Screen Parameters 

Color Mode: CMYK or Gray. By default, CMYK outputs the page and signature into Cyan, 
Magenta, Yellow and Black separations, while Gray outputs only a Gray separation. The 
separations are listed in the table below. The Separation and Remove options in the 
Output column control whether or not to output each separation.  

Both modes support spot color output.  

Resolution: The resolution of the bitmap file is specified here, ranging from 10~12000 
dpi. You can manually input a value, or choose a commonly-used value ranging 1200～
3657 from the dropdown list.  

Shape: ElecRoc supports a wide range dot shapes. As shown in the table below, some 
are provided as standard shapes, and some are optional, available upon additional 
payment. 



                      User Guide 

 15
 

152 

Category Shapes Standard Optional 

Traditional AM 

Round   

Ellipse   

Rhombus   

Diamond   

Square   

Pure Round   

Sharp Ellipse   

EagleAM 
EagleAM_Round   

EagleAM_PureRound   

FM 
FounderFM   

EagleFM   

FAM 
EagleFAM   

EagleFAM-F   

Gravure 

Gravure   

EagleAGS-Pincushion   

EagleAGS-Hexagonal   

EagleAGS-T Shape   

Flexo 
Flexo Round 1   

Flexo Round 2   

Table -11 

Angle: Proper screen angles can effectively minimize the moirés occurred in full-color 
image printing. The default angle is specific to dot shape, e.g. the default C, M, Y, K 
angles for most dot shapes are 15°, 45°, 90° and 75°, but turn to 7.5°, 37.5°, 22.5° and 
67.5° for EagleFAM. You can change the angle by inputting manually a new value or 
choosing simply one from the angle options.  

Frequency: The number of lines per inch, sometimes also called density of dots, with 
the value ranging from 1 to 600 lpi. Higher value enables smaller dots and thus higher 
image quality, but may possibly results in dot enlargement. In practice, its value is 
closely relevant to the resolution, media and ink type. Frequency for the shape EagleFM 
is fixed to 5 optional levels.  

Levels: The level of grayness, with the value ranging 1~35536, affected by resolution, 
frequency, and even the computer memory. Generally, the higher the level, the better the 
image detail is reproduced, especially the gradient. When you choose to use the Gravure 
or AGS shape, you can set it to 512, 1024 or even bigger, to make up the detail loss.  

Dot size: This option appears when the shape FounderFM is selected. It controls the dot 
size, in the unit of micron. Its value range and default value are relevant to the 
resolution.  

Shadows/Highlights dot size: These two options appear when you choose to use the 
shape EagleFM or EagleFAM. They separately control the dot size in shadow and highlight 
areas, in the unit of micron. Their value ranges and default values are relevant to the 
resolution and frequency. 

Screening in Job: If the input file contains pre-defined screen setting, such as 
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frequency, shape, and angle, you may choose to apply these settings. To do so, uncheck 
Override frequency in job, Override dot shape in job, and Override angle in job. 
If you check all, or part, or any of them, you can override the corresponding screen 
setting in the input file, and instead, use the screen setting defined here.  

Deliver pages once processed: If checked, bitmaps for each page will be immediately 
delivered to the connected next node for process, once they have been generated by PDF 
Rasterizer. If not, bitmaps will be delivered at the same time till all pages from all files 
have been processed.  

2) Spot Color Output 

 Output modes for spot colors 

1) Separation: Output the spot color as an independent color separation, like the 
process color separation. In this case, you can separately define the screen shape, 
frequency, angle, level, and dot size for the spot color separation.  

2) to Press Color: Dissolve and transfer the spot color onto process color separations, 
and output as per the screen setting defined for these process color separations. If you 
choose this mode, you need to click the icon  at the upper-right to define definitely the 
cmyk value of the spot color.  

3) Change Into: Replace one spot color with another, and output as per the mode 
chosen for the replacing one. Click the icon  and then choose another spot color in the 
Replaced by column.  

4) Remove: Remove the spot color, i.e. the spot color is not output.  

Default output: The separation named Default spot is designed for you to define the 
default screen setting for all spot colors in the input file, i.e. if not defined specially, all 
spot colors will be output as per the output mode defined for this separation. The default 
mode for CMYK is Separation, and for Gray is to Press Color, i.e. the Gray. Change 
Into is not a default mode.  

Note: By reason of the operating system, the spot color name is NOT case sensitive. Two 
spot colors named like SPOT1 and spot1 may be considered as one same color.  

 Add spot color 

You can separately define the output mode and screen setting for each spot color, in case 
that you don’t want to output all the spot colors as defined for the Default spot 
separation. Click the icon  to add a spot color separation. After this, you can define the 
color name, the output mode, the shape, angle, frequency, and even the cmyk value, one 
by one.  

To delete an unneeded spot color separation, choose it and then click the icon .  

 Edit spot color 

When you choose the mode to Press Color or Change Into, you can click the icon  to 
edit the C, M, Y, K value, or pick out the substitute spot color. Click this icon again to exit.  

 Import/save spot color 

You can click the icon  to import spot colors from a spot color table, copying out the 
name and cmyk value. In reverse, you can click the icon  to save the spot colors here 
into a spot color table.  

3) Curve 

Calibration: Calibration curve is used to calibrate the output device, so as to minimize 
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the inaccuracy of screening and ensure the output quality.  

Tune Curve: This curve can tune the dots value of the separation, so as to rectify the 
color offset occurred.  

Intended Press: If you have made compensation about dot gain, you can employ the 
dot gain curve to remove the compensation.  

Actual Press: You can employ this curve to compensate the dot gain caused by printing.  

You can create, edit, calibrate, import or export the four curves above at Resources > 
Traditional Press. The PDF Rasterizer curves there refer to the calibration curves, and 
press curves refer to the intended/actual press curves.  

4) Zone Screen 

In general, as specified by the Screen Parameters, the screen methods for all the 
separations and all the objects on separation are the same on the whole, i.e. except the 
screen angle, all separations and all objects on the separations will be screened with a 
same shape, frequency, and level. If you enable zone screen, you can then apply various 
screen settings to the separations, to the graphs, the images, or even single text, image, 
graph, shading object.  

ElecRoc zone screen is classified into two types, the Zone Screen at the front end, and 
the Local Screen at the back end.  

The front-end zone screen means to define separately the screen setting for single object 
on PDF page (text, image, graph, or shading), by using a dedicated Acrobat plug-in, 
before the PDF Rasterizer process. In this case, PDF Rasterizer screens corresponding 
objects according to the screen settings defined by the plug-in in front-end, as long as 
you check the option Zone Screen First here. Other page objects that you haven’t used 
the plug-in to define screen settings are then screened as per the settings defined here. 
Refer to appendix C.4 Screen Plug-in for details.  

The back-end local screen means to check the option Enable Local Screen here and 
then define separately various screen settings for the separations, or for the two kinds of 
objects, images or graphs, i.e. the Separation Screen and Photo Screen mentioned 
below.  

 Separation Screen 

Check Separation Screen. In this case, all separations, including the spot color 
separations, can be defined with various screen settings, i.e. except the screen angle, the 
shape, frequency, and level for each separation can be different from each other. Please 
define the settings over again at the Screen Parameters setup area. Note that, at the 
same screen node, the frequency, level and dot size for same shapes must be the same.  

 Photo Screen 

Check Photo Screen. In this case, ElecRoc classifies the page objects into two types, 
images and graphs. Please choose the object type from the dropdown list, and then 
define the screen setting for it at the Screen Parameters setup area. You can 
separately specify the parameters such as angle, shape, frequency, level, dot size, and 
screen curves as well. Other parameters in the setup window, such as color mode, 
resolution, output manner, separation name, spot color process manner, for the two 
kinds of objects, must be set to or kept with a same value.  

Report error if exist Transparency: Images and graphs in transparent file are NOT 
supported here. ElecRoc issues error and stops screening when it encounters a 
transparent page, or signature containing transparent page. If you uncheck this option, 
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in this case, ElecRoc issues only warning message in pink in the information window, but 
continues the screening. Local screen becomes unavailable if the whole page is 
transparent, or such page exists in a signature.  

Gradients are processed as images here.  

2. RIP 

 
Figure 2-141 

1) RIP 

Output Blank: If checked, it will be permitted to output blank sheet.  

Shading Quality: This option controls the quality level for the shading. Higher shading 
quality requires more processing time. If you want to perfectly reproduce the original 
shading effect, choose Higher. If the input files are large in size and quantity, or contain 
too many shading effects, it may take a lot of time in RIP process. In this case, you can 
choose Normal or Fine to save the process time.  

Image Quality: It controls the level of image output quality. If you want to output with 
higher quality, choose Fine, but this may lower processing speed. The Proof option can 
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reduce the processing time, but may result in the loss of output quality. The default 
option is Normal, which is the intermediate option between Fine and Proof.  

Override stroke setting in job: If checked, ElecRoc use a built-in stroke setting. If not, 
ElecRoc uses the setting defined in the input file.  

Stroke Adjustment: If checked, in case that the file is output in a lower resolution, the 
position and lines of the table contained in the file can become smoother. If not, the lines 
may look a little coarse.  

Output HQ pattern: This option controls whether or not to output the Pattern objects in 
the page with the highest quality. By default, it’s unchecked, so that you can get 
comparably higher output speed. 

Rich black to pure black: If checked, the rich black objects (K=100, C, M, Y any value) 
in your file will be output as pure black objects (K=100, CMY=0). 

Override overprint in job: If not checked, ElecRoc uses the overprint setting defined in 
the file by front-end layout application. Whether the 100% black elements are 
overprinted or not is controlled by the Black Only option.  

Overprint in RIP: If you check Override overprint in job, ElecRoc uses the overprint 
setting specified here instead of that defined in the file. The Overprint option allows you 
to print an element of one color over one of another color without removing, or knocking 
out, the material underneath. The Black Only option enables only the 100% black 
elements to be overprinted, it is the default option. The Knockout option enables all the 
separations to be knocked-out. White gaps may appear due to inaccurate alignment.  

Overprint 100% black: This option appears only when the Overprint in RIP is set to 
Black Only. Being checked, overprint takes effect only on 100% black.  

Export proof line: If checked, ElecRoc outputs proof line during the rasterizing process.  

2) Media size 

The dropdown list provides a wide range of pre-defined media size options. You can 
choose anyone as needed, or you can also choose Custom to define a specific size.  

Note: If the file size is larger than the media size here, ElecRoc will issue error. The 
media size is direction sensitive. Take A4 for example, ElecRoc regards 297mmx210mm 
and 210mmx297mm as different sizes.  

2) Device 

Mirror: If checked, the printer produces a mirrored page.  

Negative: If checked, the page printed by the printer is in negative.  

3) Scaling 

X and Y control separately the horizontal and vertical scaling percentages. 

4) Rotation 

You can rotate anticlockwise 90º, 180º, 270º. The default is no rotation. You can also 
choose Auto, enabling ElecRoc to rotate automatically.  

3. ICC 
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Figure 2-142 

Override ICC profile in job: If checked, it overrides the color settings contained in the 
PDF file and uses the settings specified here. If not, ElecRoc searches in the PDF file for 
the color settings, mainly the ICC profile.  

Enable ICC: By default, this option is unchecked. Therefore, parameters in the Profile 
and Output Rendering intents areas are all grayed. These parameters become 
available as long as you check Enable ICC.  

Profile: Here you can specify the source ICC profiles in three color modes, and the 
output ICC profiles. The source profiles in each mode are further sorted to two types: 
Input Profile and Device Link. ElecRoc not only provides some built-in profiles for you to 
use, but also supports you to import more other profiles into ElecRoc by Resources > 
Profile Resource > ICC. If you check Use CMYK profile in gray image, the source 
profiles in Gray mode will be the same as those in CMYK mode. 

Rendering intent: The Main Intent parameter controls the render intents for all the 
objects in the file. You can also separately define the render intent for CMYK and RGB 
images. There are four optional intents: Perceptual, Saturation, Relative and Absolute.  
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Preserve 100% process black: Check this option if you don’t want the 100% 
black-only part of your input file to be converted to a CMYK equivalent color. This option 
is particularly relevant for black text because it avoids colored fringes.  

Use default device calibration: If checked, it applies a built-in device calibration to the 
RGB objects. If not, it activates the Output Control for RGB parameters below for you 
to customize the RGB output settings. Note that, if you have specified a RGB source ICC 
profile in the Profile area above, all Output Control for RGB parameters will be 
disabled.  

Black Generation: It is the process of creating the black channel and its effect on the 
color channels when performing a mode-change from RGB to CMYK. Available options 
include None, Light, Medium, Heavy, Maximum, and UCR, the latter the higher black 
amount. UCR, as the abbreviation of Under Color Removal, can replace a lot of CMY with 
K.  

Override black generation in job: The input file may contain pre-defined black 
generation setting. If you check this option, ElecRoc uses the Black Generation setting 
specified here instead of that pre-defined in the input file.  

Convert RGB black to true black: Some applications especially Microsoft Word, use 
RGB colors for everything, including solid black. ElecRoc converts such blacks into CMYK 
color of (0 0 0 100), if you check this option.  

Max Ink: The maximum amount of all four CMYK colors that are generated in the 
conversion process. Colors specified as black are not affected by this parameter.  

Max Black: The maximum amount of black ink that is generated by the color conversion 
process. Colors specified as black are not affected by this parameter.  

Screen EcoInk Solution: If checked, you can apply an EcoInk solution. EcoInk solution 
will then disable the above ICC settings.  

4. Ink Information 

 
Figure 2-143 

After the screen process, if you want to submit the generated bitmap file to Ink Control 
node for a further process, you need to enable the settings here.  

Thumbnail of ink control file: If checked, it generates one thumbnail image specially 
designed for the ink control process. The Ink Control Export processor can then base on 
this thumbnail image to generate standard CIP3/CIP4 ink file. If not, ElecRoc issues error 
when you submit the rasterized bitmap file to Ink Control Export node.  

Resolution: The resolution level of the generated thumbnail image.  

Same rotation as Tiff file: If checked, the generated thumbnail is rotated with the tiff 
file, i.e. rotated as defined by the Rotation parameter under the RIP tab.  

5. Mark 

The settings here are the same as those described in section 4.4.5 Mono Printer.  
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4.4.3 1-Bit TIFF Export 
This processor enables you to export the Tiff files generated by Rasterizer processor.  

 
Figure 2-144 

1. Output Setup 

Rules for files with same name: When you export the Tiff files to specified location, in 
case that there are files with same name already existing in the specified location, 
ElecRoc provides you with two methods to deal with: the one is to override existing the 
files; the other is to append suffix, i.e. to add a “_X” suffix behind the new files, the “X” 
refers to an integer number increased sequentially.   

Simple display name: If checked, the exported till files are named based on the 
simplified display name of the input file.  

Full display name: If checked, the exported till files are named based on the full display 
name of the input file. 

Rename as: If checked, you can input a name in the right edit box as the file name. You 
can also click the button  to choose if the new name contains such elements as job 
name, node ID, bitmap file name, color name, abbreviated color name, and resolution.  

Change to selected path: If checked, you can specify the location the Tiff files to be 
exported. You can input the path in the right edit box, or click  to choose one.  

Create Subdirectory: If checked, it generates a subdirectory named with the job name 
under the output directory, and exports the till files under this subdirectory.  
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2. For BrainNew 

If checked, the exported Tiff files can be applied to the BrainNew application.  

3. Compress 

Available compression options: CCITT, PackBits and LZW.  

CCITT: CCITT is a series of lossless compression technologies for black and white images, 
supported in PDF and PostScript language file formats. CCITT is the French abbreviation 
for International Telegraph and Telekeyed Consultive Committee.  

PackBits: PackBits is very effective for reducing the size of bitmap files which contain 
large areas of solid color. 

LZW: LZW compression is the compression of a file into a smaller file using a table-based 
lookup algorithm invented by Abraham Lempel, Jacob Ziv, and Terry Welch. Two 
commonly-used file formats in which LZW compression is used are the GIF image format 
served from Web sites and the TIFF image format. LZW compression is also suitable for 
compressing text files. 

4. Others 

Delete proof line: To delete the proof line in the Tiff files.  

Delete processed Tiff files: If checked, the input files submitted to 1 Bit TIFF Export 
will be removed when they have been processed. Otherwise, they will be kept under the 
node as input resources.  

4.4.4 8-Bit TIFF Export 
This processor can generate 8 bit Tiff files based on the PDF files, such as those 
generated by PDF Generator, and export the generated 8 bit Tiff files as you specify.  
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Figure 2-145 

Most of the parameters under the RIP, Device and Mark tabs are the same with those 
mentioned in the previous two sections, except the peculiar Anti Zigzag parameter.  

Anti Zigzag: This parameter is under the RIP tab. Anti-zigzag uses intermediate colors 
or grayscale tones to visually smooth boundaries between different colors, most useful 
for low or medium resolution output. Among the three options, Disable means no 
anti-zigzag, Fine provides more smoothing than Normal, but requires more time.  

Under the Output tab, you can specify the following parameters.  

Preserve file name: If checked, the output file will be named mainly with the name of 
the input file, i.e. the input file name will be preserved. If you submit more than one file 
or submit a same file more than once, the newer exported one will override the older one.  

Rename as: If checked, please type a name into the edit box. The exported file will be 
named as you type. In case that you submit more than one file or submit a same file 
more than once, there would remain only the last exported file under the output file path.  

Rules for file with same name: This option becomes activated when you have chosen 
Rename as. If you choose Override, in case that you submit a same file more than once, 
the newer exported one will override the older one. If you choose Append Suffix, in the 
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same case, it will add additionally an ascending numeric suffix like _p0001, _ p0002, _ 
p0003… to the new exported files.  

Change output path: Here you can specify the output path where the Tiff files will be 
exported. If the output path is not specified here, the files will be exported to the shared 
folder Output_FrameBmp on the server.  

4.4.5 Mono Printer 
The mono printer parameter setup window is shown as follows:  

 
Figure 2-146 

1. Print 

1) Color Separation 

Mode: There are two color modes: Gray and CMYK. Gray is the default option, can 
generate gray separation. CMYK separates colors in CMYK, i.e. Cyan, Magenta, Yellow 
and Black. The color separation table below lists all the separations under your selected 
color mode. The checkbox in front of each separation controls if the separation will be 
printed or not. And you can drag any color to change the order in the list.  
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Spot Color: As for a composite file containing spot colors, when this option is selected, 
ElecRoc will generate spot color separations to output them; otherwise, it converts spot 
colors into Gray or CMYK separations to output.  

Note: The printer resolution is the same as that defined in the printer’s Printing 
Preferences from the Printers and Faxes window of your operating system. You must 
stop the processor in ElecRoc before you change the resolution.  

2) Media 

The Media dropdown list provides a wide range of pre-defined media size options. You 
can choose anyone as needed, or you can also choose Custom to define a specific size.  

If you have used the Console to create a device parameter template, you can see a Use 
device template option here. And if you check this option, you can then see the 
templates available in the Media dropdown list. Choose a template to apply its defined 
media size and device parameters.  

It’s best to create a device parameter template with the Console, or to choose Start > 
Printers and Faxes in your operating system, to define the media size.  

3) Printing 

Center: If checked, the file will be printed in the center of the media. And the left and top 
margin cannot be edited.  

Left Margin: If the box Center is not checked, you can input the value of left margin. 

Top Margin: If the box Center is not checked, you can input the value of top margin. 

Enable exceed media output: In some cases, the output page may exceed the media 
size. If checked, such page will be printed out. If not, such page will not be printed. 

4) Scaling 

X and Y allow you to specify the scaling percentage in both X and Y directions. Value 100 
means that the output page size is the true page size. If you enter 80 for X and Y, the 
page will zoom in 80% of the original size from the axes of X and Y. If you enter 200 for 
X and Y, the original page will be doubled. The default value is 100.  

5) Tiling Parameters 

Enable Tiling: If checked, in case that the page size is larger than the media size, 
ElecRoc can split the page into multiple smaller pages to output. But this capability is 
auto disabled if you check Enable exceed media output.  

Overlap: You can input in the Horizontal and Vertical edit boxes to specify the overlap 
width of tiles.  

Auto Overlap: If checked, ElecRoc automatically determines the overlap width, ignoring 
the Overlap settings.  

6) Others 

Proof Line: If checked, it prints out the proof line.  

Output Blank: If checked, it can output blank sheet.  

Negative: If checked, the page printed by the printer is in negative.  

Mirror: If checked, the printer produces a mirrored page.  

Copies: The quantity of copies you want to print out, ranging from 1 to 255.  
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Density: The density of ink, 1~255. This option is specific to printer models, i.e. not all 
printers support this feature.  

Shrink to page: If checked, ElecRoc adjusts the output content to fit the page. In this 
mode, Scaling and Rotation are disabled. The content is located in the center of the 
page.  

Note: If the original page size is smaller than the media size, the page size will remain 
unchanged.  

Rotation: If the page cannot be printed on the media in the normal orientation, you can 
try to change the output orientation. You can rotate the page anticlockwise 90, 180, 270 
degrees. The default setting is no rotation.  

Override overprint in job: If not checked, ElecRoc uses the overprint setting defined in 
the file by front-end layout application. Whether the 100% black elements are 
overprinted or not is controlled by the Black Only option.  

Overprint in RIP: If you check Override overprint in job, ElecRoc uses the overprint 
setting specified here instead of that defined in the file. The Overprint option allows you 
to print an element of one color over one of another color without removing, or knocking 
out, the material underneath. The Black Only option enables only the 100% black 
elements to be overprinted, it is the default option. The Knockout option enables all the 
separations to be knocked-out. White gaps may appear due to inaccurate alignment.  

2. Mark 
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Figure 2-147 

1) Standard Mark 

Options in this area enable you to add standard marks including registration marks, trim 
marks, folding marks, etc. onto a page.  

Mark Type: ElecRoc supports 15 different types of marks, including Cross Mark, Solid 
Circle, Internal Cutline, External Cutline, Folding Line, Book Spine, Anti Cross, Rect Mark, 
Square Mark, Circle Mark, L Cross, U Cross, Corner Mark, Hollow Circle and T-shape.  

 
Figure 2-148 

Mark Position: The standard marks can be positioned at the following positions on the 
page: the Corner refers to the four corners of the page; the Edge refers to four positions 
close to the four corners on the left and right sides; the Top refers to four positions close 
to the four corners on the top and bottom sides; the Middle refers to the middle of the 
four sides; and the Book middle refers to four positions close to the middles of the top 
and bottom sides. Click Select to add the selected mark on the selected positions, while 
click Deselect to discard the added mark, and you can click Clear All to remove all 
marks.  
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Figure 2-149 

Mark Size: Here you can specify the size of mark and the thickness of the mark line.  

Center Offset: Distance from the mark to the top, bottom, left or right edge of the page.  

Line Offset: The horizontal and vertical distance between cut lines. This option is only 
available for Internal CutLine or External CutLine. 

2) Additional Information 

Additional information include comments, color bar, file information, current time, and 
etc. Using the Additional Information parameters, you can not only control whether to 
output such information, but also specify its font and position on the page.  

Enable: When checked, it activates the parameters in the below.  

Position: The additional information can be output at different positions of the page, 
Top, Bottom, Left or Right. Keep the Default position, if not specially needed.  

File Information: If checked, it adds the file path outside the page content.  

Time: If checked, it adds the current time outside the page content.  

Color Bar: If checked, it adds process step wedges outside the page content.  

Comment: If you check it, you can input a string of comment here, and this comment 
will then be output at the bottom or side of the page.  

Information Map: Located at the right of the Additional Information parameters, 
this area displays a thumbnail image of the defined information in real time.  

3. Curve 

The curve setting is only effective for ink jets.  

Use Curve (Only for ink jet): If checked, you can choose a Gray tune curve from the 
dropdown list for color adjustment.  
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4.4.6 Color Printer 

 
Figure 2-150 

The color printer processor parameter setup window looks basically the same as that of 
the mono printer. For details, refer to the introductions in the previous section.  

Note that the default settings for some parameters may be different, e.g. the default 
option for Color Separation > Mode under the Print tab is CMYK, and some 
parameters may be not available. Moreover, we recommend you to define the media size 
at the Printers and Faxes window in your operating system.  

4.4.7 Pre-RIP Proof 
Pre-RIP proof, also called PDF proof, is applied to proof PDF files output by PDF Generator 
or other PDF processors. The Pre-RIP Proof parameter setup window is shown as follows: 
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Figure 2-151 

1. Color 

1) Color Mode 

Color: CMYK color mode is supported. It separates colors in four separations, Cyan, 
Magenta, Yellow and Black. The color separation table below lists all the separations. The 
checkbox in front of each separation controls if the separation will be printed or not. And 
you can drag any color to change the order in the separation list.  

Output Spot Color: As for a composite file containing spot colors, if checked, ElecRoc 
generates spot color separations to output them. 

Spot color to press color: This option and the above option are mutually exclusive. If 
checked, it converts spot colors into CMYK separations to output.  

Separation Mode: It refers to the separation mode supported by proof device. You can 
choose an option as needed.  

2) Color Solution 
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This dropdown list provides color solutions for you to choose. Many of them are built-in 
solutions designed for color management in various proof environments. You can simply 
choose such a solution, or launch the color calibration tool to create a new solution.  

Details on your selected color solution, including resolution, separation mode, ink type, 
and etc., can be viewed in the window Resources > Digital Proof > CMF Correction. 
This data will automatically override the corresponding parameter setting in the setup 
window and make them appear in gray, after you have chosen a solution.  

3) Spot Color Table 

In order to achieve accurate spot color output, we generally define how to output spot 
colors in the CMF solution file. If your CMF file doesn’t contain such definition, you can 
define it in the spot color table. And if your spot color table still doesn’t contain it, ElecRoc 
will output spot colors as per the definition in the file itself.  

Spot color table: This dropdown list provides all available spot color tables in ElecRoc 
system, including both the system-defined and user-defined ones, which can be added or 
edited in Resources > Profile Resource > Spot Color Table.  

4) Color Tune 

This dropdown list provides all the color tune curves available in your ElecRoc system, 
which can be edited or created in Resources > Digital Proof > Color Tune. You can 
choose any of them as needed to adjust the CMYK colors.  

5) Screen Mode 

Optional screen modes include FM1, FM2, FM3, and Fast Screen. FM1 or FM3 are suitable 
for pre-RIP proof. With FM3, colors would be comparably darker, and richer as to the color 
levels. Fast Screen, as the name implies, is applied for quick proof. The Default is FM1. 
Screen mode will be grayed when you choose color solution. 

6) Others 

Proof Line: If checked, it prints out proof line.  

Override overprint in job: If not checked, ElecRoc uses the overprint setting defined in 
the file by front-end layout application. Whether the 100% black elements are 
overprinted or not is controlled by the Black Only option.  

Overprint in RIP: If you check Override overprint in job, ElecRoc uses the overprint 
setting specified here instead of that defined in the file. The Overprint option allows you 
to print an element of one color over one of another color without removing, or knocking 
out, the material underneath. The Black Only option enables only the 100% black 
elements to be overprinted, it is the default option. The Knockout option enables all the 
separations to be knocked-out. White gaps may appear due to inaccurate alignment.  

Proof on Printing Paper: If checked, you can use printing paper, instead of the paper 
specific to digital proof, to do your digital proof. When checked, please re-choose a color 
solution suitable for coated proof from the CMF File dropdown box. Other settings are 
the same as normal digital proof. By using coated proof, you can lower your proof cost 
significantly without sacrificing the color quality.  

2. Device 
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Figure 2-152 

1) Resolution 

The output resolution of the proof device. Options vary as the connected device differs.  

2) Scaling 

Scale X and Y allow you to specify the scaling percentage in both X and Y directions.  

3) Media Size 

This dropdown list provides a wide range of pre-defined media options. You can choose 
any one as needed. And it provides also the Custom option for you to define a specific 
media size.  

Printable Size: It refers to the size of the actually printable area on the output media. 

4) Margin 

Left/Up: The margin is the blank space bordering the printed area on a page. You can 
specify the left and up margin when the Centering option is disabled.  

Centering: If the media is single page paper, you can choose Center to position the 
page content at the center of the paper; or you can choose Horizontal to print the 
content at the center of the left or right edge of the paper. If the media is roll paper, 
Horizontal is recommended, but you can also choose Center. In the latter case, after a 
file has been printed, the next print would not start on a new page, but in the blank area 
below the printed file on the same page.  

5) Others 

Enable exceed media output: If checked, the output of jobs that exceed the media 
size will be allowed.  

Copies: The number of copies to be output.  

Rotation: If the page cannot be printed on the media in the normal orientation, you can 
try to change the output orientation. You can rotate the page anticlockwise 90, 180, 270 
degrees. The default setting is no rotation. If you choose Auto Rotate, ElecRoc can 
automatically determine whether and how to rotate.  

6) Page Gap 
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Auto page position: If the page size is much smaller than the output paper, such pages 
can be automatically positioned on the output paper in a paper-saving layout. Once this 
option is checked, you can define the space between the individual ganged pages. 

Note: This function is available only in case that the job is being copied.  

3. Mark 

Refer to related introduction on the mark in section 4.4.5 Mono Printer.  

4. Comment 

 
Figure 2-153 

Print Comment: If checked, it outputs the comment defined herein at the lower-left 
corner on the paper. You can design the comment as needed, e.g. the comment can 
contain the print start time, job name, color tune curve, and so on. If unchecked, options 
below are all grayed.  

Print start time: If checked, it outputs the time when the print is started.  

Job Name: If checked, it outputs the file name on the paper.  

Color Solution: If checked, it outputs the name of the applied color solution.  

Tune Curve: If checked, it outputs the path of the applied color tune curve.  

Attached Information: If checked, it can output additional information apart from that 
specified above. To add such information, input it in the edit box at the right.  

5. Advanced 

The advanced parameters vary as the proof device differs. Here we take parameters for 
some commonly-used devices as example. Note that some parameters may differ even 
to a same device family from a same vendor.  

1) For Epson proof device 
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Figure 2-154 

Paper Source: The mode for feeding paper: Roll or Sheet. 

Paper Suction: The intensity for paper suction, your input value should vary according 
to the type and thickness of the output paper.  

Feed Paper Adjustment: This option controls the speed of feeding paper, so as to avoid 
irregular lines in the horizontal direction appearing in print.  

Bidirection Printing: If checked, the printer head prints when moving in both directions, 
so as to get a higher printing speed. In general, this option is not recommended, because 
it may result in quality degradation. 

Auto Cutting: If checked, printer will automatically cut the paper after print.  

Nozzle Check: If checked, printer outputs a built-in image pattern. By observation, you 
can find out if the nozzle is clogged.  

Ink Type: The type of the ink, pigment or dye.  

Black Ink Type: The type of the black ink, photok or mattek.  

Media Type: The type of the output media, such as Plain Paper, Glossy Paper and 
Semi-glossy Paper.  

2) For HP proof device 

Print Mode: Options include 8 Pass Bidir, 8 Pass Unidir, and 12 Pass Unidir.  

3) For Canon proof device 

For Canon devices such as iPF 810, advanced parameters are shown as follows. You can 
configure the ink type, paper source, print quality, auto cut, and etc.  

 
Figure 2-155 
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4.4.8 Post-RIP Proof 
Post-RIP proof, also called dot proof, is applied to proof TIFF files generated by PDF 
Rasterizer.  

 
Figure 2-156 

ElecRoc post-RIP proof supports you to use a wide range of ink-jet proof devices from 
Epson, Hp and Cannon, and the laser proof devices as well. It also supports the Winprint 
mode. In this case, it’s no longer restricted by the device models, which means that you 
can use any printer installed in your operating system to proof (choose the Winprint 
mode and a proper printer when you install the proof processor). Moreover, post-RIP 
proof provides the quick proof capacity.  

As to the parameters, the Color, Comment and Advanced setting is basically the same 
as pre-RIP proof. Refer to section 4.4.7 for details. The Screen Mode for post-RIP is 
generally recommended as FM2 or FM3. FM2 is subject to produce redder colors, while 
FM3 enables richer color levels. The Default is FM2. 

The device related setup for post-RIP proof is also basically the same with that for 
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pre-RIP proof, except for the following parameters:  

Smooth Mode: Used to clear off moiré, options include smooth1, smooth2, smooth3, 
and smooth4. By default, it is set to smooth1. From smooth1 to smooth4, more close to 
smooth4, moiré problems may be avoided more easily; more close to smooth1, the dot 
shape may be kept much better.  

Descreening: Used to clear off the unacceptable moiré patterns appeared on some 
separations, if any. It can reduce moiré patterns, but may result in some loss in dot shape 
at the same time. In practice, when moiré patterns appear, we recommend the user to 
use Smooth Mode parameter to clear off at first; and then use this parameter in case that 
the Smooth Mode option cannot clear off completely moiré patterns on some separation.  

4.4.9 Digital Printing 
ElecRoc supports a wide range of digital printing devices from various device vendors:  

Category Vendor and device models 

Bizhub series 

Konica Minolta bizhub PRO1200 (white & black) 
Konica Minolta bizhub PRO1051 (white & black) 
Konica Minolta bizhub PRO1052 (white & black) 
Konica Minolta bizhub PRO951 (white & black) 

Founder C7000 series 
Bizhub FZC6000 (color) 
Bizhub FZC7000 (color) 
Bizhub FZC8000 (color) 

Océ VP 110/120/135 
Océ VarioPrint 110 (white & black) 
Océ VarioPrint 120 (white & black) 
Océ VarioPrint 135 (white & black) 

Océ VP 2110 Océ VarioPrint 2110 (white & black) 
Océ VarioPrint 6250 (white & black) 

HP Indigo 

HP Indigo 5600 (color) 
HP Indigo 7600 (color) 
HP Indigo 3050 (color) 
HP Indigo 3500 (color) 
HP Indigo 3550 (color) 
HP Indigo 5500 (color) 
HP Indigo 10000 (color) 

 

1. Bizhub series 
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Figure 2-157 

1) Output 

Paper Size: the size of the paper. Options include A3, B4, A4, B5, A5, and Custom. The 
detailed width and height values of your selected option will be displayed then in the 
below. If needed, you can choose Custom to activate the Width and Height edit boxes 
and manually specify the width and height of your paper.  

Edit: Click this button if you want to add, edit, or delete the size options. You can define 
the printable width and height, whose default values are the same to the paper width and 
height.  
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Figure 2-158 

Input Tray: The paper feeding unit on your printing device. Options include Auto Select, 
Tray1, Tray2, Tray3, and Byhands. The default option is Auto Select, which means to let 
ElecRoc automatically select a suitable input tray according to your specified paper size.  

Note: The actual options for the input tray parameter may differ from above if you are 
using additional hardware part such as finisher or high capacity input tray. For example, 
if you have used the high capacity input tray PF-702, the options here will be “Auto Select, 
Tray1, Tray2, Tray3, Tray4, and Tray5”. 

Copies: The number of copies to be output. The default value is 1. A value of bigger than 
one enables output of multiple copies. The value range is 1-9999.  

Collate: An output method for outputting multiple copies. If checked, ElecRoc first 
outputs a complete copy, and then outputs the next copy. If not, ElecRoc will first output 
all the 1st pages, and then all the 2nd pages, and then all the 3rd… till all the rest pages.  

Offset Output: You can further check this option when you have enabled Collate. If 
checked, there will be an offset between two copies at the output tray, so that you can 
easily distinguish and take away each copy. If not checked, all copies will be placed at the 
same position on the output tray.  

File Name: This parameter controls the name of the output file. It can be named with 
the page name, or with the job name, the default option is Page.  

Output Tray: It refers to the paper outputting unit on your printing device. Please 
specify the output tray in case that your device has more than one output tray. Options 
include Main Tray, Subsidiary Tray, and Default. The Default means to let ElecRoc 
automatically choose an output tray.  

Duplex output: This parameter controls whether or not to print on both the front and 
back sides of the paper. None means not printing on both sides, Long Edge means 
turning a page along its long edge when printing on the back side, and Short Edge 
means turning a page along its short edge when printing on the back side.  
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Binding: The actual options for this parameter are determined by the additional 
hardware part you are using, for example, if you have used the finisher FS-521, the 
options here will be “None, Top Left, Top Right, 2 At Left, 2 At Right, and 2 At Top.” None 
means not binding.  

Fold Type: The actual options for this parameter are determined by the additional 
hardware part you are using, for example, if you have used the finisher SD-506, the 
options here will be “None, Center-Fold, Saddle stitch, Saddle stitch and Trim, 
Three-Fold.” None means not folding.  

Output Order: Face down or face up.  

Front Offset: refers to the relative position between the content on the front page and 
the printable area on the paper. The horizontal and vertical edit boxes control the offset 
values in the two directions. Value range is -500.0~500.0 mm.  

Back Offset: refers to the relative position between the content on the back page and 
the printable area on the paper. The horizontal and vertical edit boxes control the offset 
values in the two directions. Value range is -500.0~500.0 mm.  

Please note that, in horizontal, the right is the positive direction, in vertical, the below is 
positive. Improper value may result in unwanted trimming of page content.  

2) Layout 

With this module, you can take the full advantages of the folding and binding capabilities 
provided by the printing device, to automatically calculate and generate signatures, 
based on the layout settings, the page size, and the paper size, and then output them as 
various types of booklets or folds. It doesn't require you to go through the Imposer or 
Composer process, nor to create any imposing template, providing great ease and 
efficiency.  

Layout: Check this box to enable the layout module. It supports two folding and ganging 
types, booklet and stack stitch. As two mutually exclusive options, they have different 
operating interfaces, but in whatever type, each signature can contain only two pages.  

 Booklet 

Booklet is a widely used business type in digital folding. The setup interface is as follows.  
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Figure 2-159 

Bind Type: Supports three commonly-used binding types: Saddle Stitch, Nested saddle 
stitch, and Perfect Bound. If you choose Saddle Stitch, you can further configure the 
Cover parameters in the below, and if you choose Nested saddle stitch, you can 
further specify the Sheet amount in subset parameter.  

Binding position: Supports binding at right side, left side or top side. The Preview area 
at the right can show the schematic diagram for these three positions in real time.  

Sheet amount in subset: This parameter is applied to Nested saddle stitch, a 
binding type that can nest one saddle stitch booklet on top of another saddle stitch 
booklet, so as to produce a bigger booklet. This parameter controls the number of sheets 
for each small booklet. The default value is 2, indicating that each small booklet can 
contain 4 (single sided, 2x2) or 8 (double-sided, 2x2x2) pages.  

Page Alignment: Pages can be aligned with the spine, or centered. The spine refers to 
the folding line at the center of the paper sheet. If you choose Spine Alignment, pages 
will be aligned with the spine, see the left figure in the below. If you choose Center, each 
sheet of paper will be divided into two equal areas, and each page will then be placed at 
the center of that area, see the middle figure in the below.  

   
Figure 2-160 

Bind Area: To reserve a blank area for binding, as per the width specified here. See the 
right figure above.  



Using ElecRoc Client 

 179 

Fit to Page: If checked, ElecRoc automatically scales down the page size according to 
the paper size, on the premise of remaining the aspect ratio, so as to output all of the 
page content. If not checked, pages are output in original page size, and if the page size 
exceeds half of the paper size, the excess may be lost in output.  

Creep: Applied to Saddle Stitch and Nested saddle stitch. As to thick paper, or booklet 
containing too many pages, when signatures are folded, the image area of the inside 
pages may move slightly. To compensate the movement of image area and thus ensure 
all pages are in alignment, you need to set up creep parameters.  

Cover: Applied to Saddle Stitch. It means to take out a piece of paper from a different 
input tray and use it as the cover of your booklet. Therefore, if checked, please first 
choose an input tray from Feeding Paper Tray dropdown list, and then further decide 
whether or not to print content on the cover. On the cover you can print at most 4 pages, 
the front covers (inside and outside) and the back covers (inside and outside). When all 
4 are selected, the options Cover, Inside Front Cover, Inside Back Cover, and Back Cover 
respectively refer to the 1st, 2nd, 2nd to last, and the last page in the pages you submit. 
When the option Cover is not selected, but Inside Front Cover is selected, Inside Front 
Cover refers to the 1st page; and when the option Back Cover is not selected, but Inside 
Back Cover is selected, Inside Back Cover refers to the last page.  

 Stack Stitch 

Stack stitch refers to generate and output signatures according to the page sequence as 
shown in the following figure, and after the printing, cut the signature stack along the 
middle line into two halves, and then pile one half above another, and then stitch to 
finished goods.  

In this type, you can specify the page space, and if needed, you can check the Fit to 
Page option. It means to automatically scale down the page size according to the paper 
size, on the premise of remaining the aspect ratio, so as to output all of the page content. 
If not checked, pages are output in original page size, and if the page size exceeds half 
of the paper size, the excess may be lost in output.  

 
Figure 2-161 

3) Insert 
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Figure 2-162 

Parameters here are used to control whether or not to pick up paper from specified input 
tray, so as to print the front cover, the back cover, or the inset.  

 Cover 

Cover: It refers to the 1st page in the pages you submit. If checked, you can separately 
specify the input tray for the cover and control whether or not to print out the cover.  

Paper Tray: the feeding paper tray for the front cover.  

Note: The actual options for this parameter are determined by the additional hardware 
part you are using, for example, if you have used the high capacity input tray PF-702, the 
options here will be “Tray1, Tray2, Tray3, Tray4, Tray5.”  

Print Options: Controls whether or not to print the front cover.  

 Back Cover 

It refers to the last page in the pages you submit. Settings are similar to the front cover.  

 Inset 

Inset: If checked, you can separately specify the input tray for the insets and control 
whether or not to print out them.  

Add: Click this button to add an inset specification.  

The format for pages is like “1,3-6,9”, no blank space, supporting half-width comma and 
joint mark as the separator in case that multiple pages need to be specified. The 
parameters Paper Tray and Print Options are same to those for the cover and back 
cover.  
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The inset setting can be edited, deleted or emptied.  

4) RIP 

 
Figure 2-163 

 Image Parameter Settings 

Mirror: If checked, the printer produces a mirrored page.  

Negative: If checked, the page printed by the printer is in negative.  

Dot Shape: ElecRoc supports a wide range dot shapes, including Round, Ellipse, 
Rhombus, Diamond, Square, Pure Round, Sharp Ellipse, Line, and Founder FM.  

Resolution: The resolution is set to 1200.  

Frequency: The number of lines per inch, sometimes also called density of dots. Higher 
value enables smaller dots and thus higher image quality, but may possibly results in dot 
enlargement. Options include 87, 100, 133, 150, 175, and 200.  

Color Mode: For black and white digital printers, it is fixed to Gray.  

 Zoom and Rotate 

X, Y: control separately the horizontal and vertical scaling percentages. This value 
ranges from 1.0 to 1000.0, and can be input manually, or given by clicking the triangle 
icon aside. The X and Y values can be different with each other. The default values are 
100.0, meaning no scaling.  

Fit to print size: If checked, the X and Y edit boxes will be grayed. ElecRoc will then 
automatically calculate the scaling percentages according to the printable size.  

Rotate: You can rotate anticlockwise 90º, 180º, 270º. The default is no rotation. You can 
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also choose Auto, enabling ElecRoc to rotate automatically.  

 Advanced Parameters 

Override overprint in job: If not checked, ElecRoc uses the overprint setting defined in 
the file by front-end layout application. Whether the 100% black elements are 
overprinted or not is controlled by the Black Overprint option.  

Knockout parameters in graphics: If you check Override overprint in job, ElecRoc 
uses the overprint setting specified here instead of that defined in the file. The Overprint 
option allows you to print an element of one color over one of another color without 
removing, or knocking out, the material underneath. The Black Overprint option 
enables only the 100% black elements to be overprinted, it is the default option. The 
Knockout option enables all the separations to be knocked-out. White gaps may appear 
due to inaccurate alignment.  

Override line width adjustment in job: If checked, ElecRoc use a built-in line width 
setting. If not, ElecRoc uses the setting defined in the input file.  

Line width adjustment: If checked, in case that the file is output in a lower resolution, 
the position and lines of the table contained in the file can become smoother. If not, the 
lines may look a little coarse. 

Gradual Quality: It controls the level of gradient quality. Higher gradient quality 
requires more processing time. If you want to perfectly reproduce the original gradient 
effect, choose Fine. If the input files are large in size and quantity, or contain too many 
shading effects, it may take a lot of time in RIP process. In this case, you can choose 
Normal or Better to save the process time.  

Thick font fill: If checked, the plain texts in you file such as TrueType and CID texts will 
be thickened. If not checked, they remain the regular face.  

Fonts Line Width Adjustment: This parameter becomes activated when you have 
checked the option Thick font fill. It refers to the line width of font when texts are 
thickened. The default value is 1, if it doesn’t produce the thick effect as you want, you 
can increase this value. The value range is 1-100.  

5) Advanced 
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Figure 2-164 

 Output Mode 

There are two output modes, and they are mutually exclusive.  

TIFF: To output your submitted file as tiff file. The store path for the tiff file is the 
directory \Jobs\JobNumber\tiffs on your ElecRoc server. Users with access rights can go 
there to obtain or view the tiff file.  

Print: To send the file to the digital printer, printing on the paper.  

 Output file name 

It refers to the name of the output file. It can be composed of any or any combination of 
the three name parts, file name, time, and comment. If you check Comment, you will 
then activate an edit box, in which you can input any text as part of the file name.  

 Linearization 

Linearization: ElecRoc supports you to adjust the white & black digital printer’s gradient 
output effect, for example, if the output result of the shallow part looks too light, or even 
invisible, you can use a linearization curve to increase the output amount for that part. 
The curve is applied to multiple device models from Konica Minolta and Océ.  

The linearization curves can be created, edited, imported or exported under the module 
Resources > Digital Press > Linear Curve.  

6) Numbering 
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Figure 2-165 

Targeting at each copy of your file, the automatic numbering can output a string of 
number for each copy (on one specified page). By default, this function is not enabled. If 
needed, please check Automatic Numbering to enable.  

Click Add to define the string of number. (Multiple and different strings of number are 
allowed for each copy, and numbering setting can be edited, deleted or emptied.) The 
numbering parameters include:  

Home Page: If checked, the defined number will be output on the 1st page of each copy.  

End Page: If checked, the defined number will be output on the last page of each copy.  

Specified Page: If checked, the defined number will be output on the specified page of 
each copy. If you check this option, please input the page number in the edit box aside.  

Note: The three options above are mutually exclusive. But note that, ElecRoc supports 
you to define multiple strings of number for each copy. Therefore, you can continue to 
click the Add button, to configure more settings, achieving the effect of printing string of 
number on homepage, end page and specified page at same time, or of printing multiple 
strings of number at different positions on a same page.  

Location: The specific position for the number on the page. It can be output at the 
upper-left, the upper-right, lower-left, or lower-right of the page.  

Length: The number of digits, 1~10.  

First ID: It refers to the starting number, and can be any value.  

Prefix: An arbitrary input string of character that will be placed as a constant in front of 
the number.  
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Suffix: An arbitrary input string of character that will be placed as a constant behind the 
number.  

Character Space: The spacing distance between every two characters in the string of 
number. The string of number here includes the variable numeral, the prefix, and the 
suffix.  

Prefix Space: The spacing distance between the prefix and the variable numeral.  

Suffix Space: The spacing distance between the suffix and the variable numeral. 

X: Refers to the X coordinate with the origin at the upper-left corner of the page. It 
controls the distance between the number and the left edge of the page in the horizontal 
direction.  

Y: Refers to the Y coordinate with the origin at the upper-left corner of the page. It 
controls the distance between the number and the top edge of the page in the vertical 
direction. 

Font Size: Commonly-used size options include 12, 18, 24, 36, 48, 60, and 72. If 
needed, you can manually input any other size.  

Color: Controlled by the parameter RIP > Color Mode. A click on the color block 
switches to another color if the color mode is set to double color, and opens the color 
setup dialog if the mode is set to color.  

Rotate: The number can be rotated 0, 90, 180, or 270 degrees.  

Inverted Sequence: For example, suppose we will output 3 numbers, in normal 
sequence they are 001, 002, 003, and if inverted, they would be 003, 002, and 001.  

Transparent: If checked, the page content underneath will be shown and output.  

7) Status 

A click on the button Refresh Status can refresh the status for the input tray, the paper 
size, maximum capacity, and the current paper amount.  

8) Equipment 

If you have used optional equipment, please choose here the one you are using. The 
operation of configuring this parameter can be performed only when you open the 
processor parameter setup window from the module Administrator > Processor 
Management. If you open it in the job window, you can only view the configuration.  

Finisher: supports the finishers FS-521 and SD-506. The option FS-521+SD-506 
indicates that you are using both the two finishers. None means not using any finisher.  

High capacity input tray: supports the high capacity input tray PF-702 and PF-703. 
The option PF-702+PF-703 indicates that you are using both the two input trays. None 
means not using any high capacity input tray.  

2. FZC7000 series 

The majority of the parameters under the tabs Output, Layout, RIP, Inset, 
Numbering, and Equipment, are the same or similar to the Bizhub introduced 
previously. Please refer to the related introduction above.  
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Figure 2-166 

Use CMF file: The CMF file is the core to implement color management, ensure color 
consistency cross various output devices or locations, and improve the output quality and 
preciseness. If checked, you may see many various CMF files in the dropdown list aside, 
including not only the system built-in files, but also your defined ones. User-defined CMF 
files can be imported into ElecRoc system under the module Resources > Digital 
Press > CMF Correction.  

Spot Color Replace: In order to precisely output spot colors, we usually define the spot 
colors in CMF file. If we haven’t defined them in CMF file, we can define them in spot color 
table; and if we haven’t defined them in spot color table, they will be output as per the 
values pre-defined in the source file. The dropdown list aside contains all the tables in 
your ElecRoc system, both the system built-in and user-defined ones. User-defined table 
and its spot colors can be created or edited under the module Resources > Profile 
Resource > Spot Color Table.  

Curve: The dropdown list aside provides all the color tune curves in your ElecRoc system, 
for you to adjust the CMYK process colors. These curves can be created or edited under 
the module Resources > Digital Press > Color Tune.  

3. Océ VP 110/120/135 

The majority of its parameters are also the same or similar to the Bizhub introduced 
previously. Please note that the value options for some parameters vary according to the 
device model.  

4. Océ VP 2110 
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The majority of its parameters are also the same or similar to the Bizhub introduced 
previously. Please note that the value options for some parameters vary according to the 
device model.  

5. HP Indigo 

The majority of its parameters are also the same or similar to the Bizhub introduced 
previously. Please note that the value options for some parameters vary according to the 
device model.  

 
Figure 2-167 

Apply Socket Type: This option enables ElecRoc to transmit the generated .jlt file to 
Indigo device. The .jlt file is located under the root directory of the disk partition where 
your ElecRoc system is installed.  

The Controller Name dropdown list becomes activated when you have checked this 
option. Please choose the Indigo controller where the .jlt file will be sent. Options in this 
list can be configured by clicking the Edit button. In the pop-up dialog box, you can add, 
edit or delete a controller setting, each setting including the controller name and IP 
address.  



                      User Guide 

 18
 

188 

 
Figure 2-168 

Other parameters under the Advanced tab are usually configured on the device console. 
If specially needed, you can also configure them here.  

4.4.10 Inkjet Printing 
ElecRoc supports Founder’s own inkjet printing devices.  

The majority of its parameters are also the same or similar to the Bizhub introduced 
previously. Please note that the value options for some parameters vary according to the 
device model.  
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Figure 2-169 

Bitmap Depth: It refers to the bit width of the output bitmap. When you define this 
parameter, please take combined account of your business demand, media quality, and 
the device’s hardware configuration. The option 1 Bit enables quick screen speed and 
bitmaps of granular looking, while 2 Bit comparably slows the screen speed but produces 
smooth-looking bitmaps, suitable to output files that require high output quality, and 
thus this option requires higher device configuration.  

Dot Shape: When bitmap depth is set to 1 bit, you can use Founder FM1 or Founder FM2. 
These two types can bring out different screen results. If the bitmaps produced with the 
default dot shape show some shortcomings in details, such as shadings, smoothness at 
image edges or corners, you can try another dot shape. When bitmap depth is set to 2 bit, 
the dot shape is Founder FM.  

Resolution: 600x360, 600x600, 600x960, 600x1200, 1200x1200.  

Color Mode: Color, Double, Gray. The default option is Color. Double refers to magenta 
and black.  

4.4.11 Barcode 
This processor can add the Code 39 barcode onto your PDF page. Code 39 is a barcode 
widely-used in commodity source tracing and logistics tracking. As shown in the following 
figure, the output result is usually a barcode and a corresponding string of numbers, 
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located at the left or right side of the page. The data contains 8 digits, among which the 
first 4 digits are usually the user code or department code.  

 
Figure 2-170 

The Barcode node can appear as a stand-alone or a connected node in your job, 
accepting PDF page files and enabling you to preview the output result immediately after 
the process.  

Its process parameter setup window is as follows.  
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Figure 2-171 

Barcode Attribute: The barcode can exist in any of the two formats: an image 
(supporting two resolution options, 600x600 and 1200x1200); or a graphic (to become 
a vector graphic).  

Barcode Type: Currently supports only Code 39.  

First 4: The barcode data consists of 8 digits. The first 4 digits can be specified here. 
Valid characters include upper case letter, number, and special symbols (-.$/+%). The 
last 4 digits are variable: the 5th and 6th digits are current page number, the 7th and 8th are 
total page number. Considering that each piece of paper contains front and back sides, 
both the two page numbers need to be divided by 2. For example, suppose that you 
submit 16 pages at a time, the total page number is then 8, the 1st and 2nd pages are 
considered as the 1st page, while the 3rd and 4th pages as the 2nd page.  

Note: The total page number refers to the total PDF pages you submit one time, not the 
total pages your source file contains. There are only 2 digits for the page number, 
therefore, if the page number exceeds 100 (i.e. actually 200 pages), ElecRoc will issue 
error report.  

Sequence, Reverse: Sequence indicates that the actual value at the 5th and 6th digits 
will increase one by one; while Reverse indicates that the value will decrease.  

Print Position: Front Paper indicates that the barcode will be output on the front side 
of the paper, i.e. on the odd pages; Back Paper indicates that the barcode will be output 
on the back side of the paper, i.e. on the even pages.  

The dropdown list in the below enables you to specify the left or right position on the page, 
i.e. right side or left side on the paper.  
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Text Position: If you choose No Print, the corresponding number will NOT be output 
together with the barcode; please choose Print On Left or Print On Right to output the 
number and the barcode together.  

4.4.12 Ink Control Export 
This processor generates industry-standard CIP3 and CIP4 ink files, based on the ink 
control thumbnail image generated during the Rasterizer process. The CIP ink file can 
help press worker to reduce the press cycle and minimize the production waste.  

In ElecRoc workflow, it accepts only the tiff files generated by the screen node, usually 
the screened signatures. The screening option Ink Information > Thumbnail of ink 
control file must have been enabled during the screen process. After the process, it 
outputs the ink file under your specified output directory, but doesn’t display the file in 
the job window.  

 
Figure 2-172 

Rename as: You can check this option to specify the name of the generated ink file.  

Save ink file to: This setting enables you to customize the output directory for the 
CIP3/CIP4 ink file. If not checked, the generated ink file will appear under the default 
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directory \\server name\InkFile\. If checked, you can then customize the output 
directory, by manually inputting, such as \\server name\Upload\, or by clicking Browse 
to choose one from optional directories. Here you can specify more than one directory 
separated by the symbol “|”, i.e. you can make the ink file appear under multiple 
directories.  

Create job subdirectory: If checked, ElecRoc creates a subdirectory under the output 
directory, named with the job name, and then generates the ink file under this 
subdirectory. If not, it generates the file directly under the output directory.  

Delete the source ink files: If checked, the source files for generating ink files will be 
deleted from ElecRoc system after the process. If not, these files will remain inside 
ElecRoc, and in this case, you can run again to generate the ink file.  

Ink file version: Ink files in versions below 3.0 are in the .cip format, while in version 
3.0 are in the .ppf format.  

Rotation: If checked, you can customize the rotate angle of the ink file.  

Coding type of ink files: Binary or ASCII.  

Separate PPF file: This setting becomes available when you set the Version to 3.0. If 
checked, it divides one PPF ink file into several files, each file corresponding to a specific 
separation. E.g. if the input file contains 4 separations, CMYK, it would then generate 4 
PPF files, separately describing the ink setting for the C, M, Y and K separations.  

Separator of color plate name: After the separation, characters like C, M, Y, K may 
appear at the end of the PPF file name, representing the separation. A separator may also 
exist in front of this suffix, and it may be “-” or “_”, and can be specified here. Sample of 
PPF file name: 12_10_11_Calibration_Test_pdf_p0001_2540_C.ppf  

Character for gray: A character at the end of the PPF file name, representing the Gray 
separation, and it can be K or G.  

Combine back/front signatures into one PPF: If checked, in case that the input files 
are pairs of back and front signatures, it generates one ink file to describe the ink setting 
of one pair of signatures. If not, it generates two ink files, one describing the front side, 
the other for the back side.  

Related rotation for back/front: If checked, the rotate directions for both the front 
and back sides of the ink file will be related. The front side is rotated according to the 
Rotation setting, while the back side is rotated by the same degree but in an opposite 
direction. For instance, if Rotation is set to 90 Rotate, the front side will be rotated 
clockwise by 90 degree, while the back side will be rotated anticlockwise by 90 degree. 
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4.5 Preflight 

4.5.1 Use Preflight 
Preflight is Founder’s self-developed preflight processing module, providing an optimal 
choice for you to use preflight in ElecRoc. Specially designed for pre-press PDF inspection, 
Founder preflight functions the same as that the third-party preflight does, i.e. to verify 
or check the PDF pages according to your defined checklist, and then generate a preflight 
report, so as to avoid any possible print accident.  

 
Figure 2-173 

Each job may contain more than one Preflight node, and the preflight checklists for these 
nodes may be different from each other. In the job, you can make this node connected 
with other node, or make it stand-alone. If connected, it can form an automated preflight 
workflow, with PDF Generator and other processor node, and accept automatically the 
output files from the prior node in the workflow, regardless of single-page or 
multiple-page files. If it exists as a stand-alone node, you need to manually submit the 
pages for the inspection.  

A job information window pops up during the preflight process, enabling you to monitor 
and control the process progress and relevant process information. The preflight 
processing speed has been optimized for general customer requirements. But the actual 
speed is specific to the page content. It may be slower for some special pages that 
contain transparent objects, large image patterns, complex paths, and etc.  

After the preflight process, you may see pink and/or red page files in the output file 
queue. The page appears in pink if its preflight report contains Warn message, and in 
red if the report contains Error message. The red pages will not be automatically 
submitted to the next connected node in the workflow.  
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E.g. we can define such an entry in the preflight checklist, Page size is A4, and set the 
action to Error. After the preflight inspection, if the page size is exactly A4, i.e. just like 
the entry describes, the preflight report will then contain this result, labeling it as Error, 
and show this page in red in the output file queue. If the page size is not A4, NOT as the 
entry describes, the report will NOT mention this, and the page will then appear in black 
in the output file queue.  

Please view the detailed result in the preflight report. It is an html report. If you want to 
open the report, choose a page (the file instead of the page in case of multiple-page 
mode) in the output file queue, then right-click and choose Preflight Report > Open. 
The other items Save, Print and Send are used to save, print and send out the report. 

 
Figure 2-174 

The top shows a sum of the inspection result, i.e. the quantity of the Errors, Warnings 
and Notifications. Below this, it displays the check entries and the result returned, one by 
one, and page by page. The result is information about the page objects that meet the 
description of the check entries.  

Click the page number at the right, and you can open the file in Acrobat and use the 
preflight plug-in to position these objects.  

Right-click a checked page (any page in case of multiple-page mode) and choose 
Preflight Navigator, and you can then open the file in Acrobat, so that you can position 
the objects with Error, Warning or Notification in the file, by using the Acrobat preflight 
plug-in. The plug-in must be installed beforehand.  
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Figure 2-175 

By choosing from the Acrobat main menu Founder Plug-Ins > ElecRoc Preflight > 
Positioning, you open a floating panel on the Acrobat window. Expand the types of 
Errors, Warnings or Notifications, and double-click one of them, and you can see one of 
the objects in that type on the page, labeled by a solid or dashed line rectangle box. The 
detailed information about the object is then displayed at the lower-right of the panel, 
including size, color space, color, and etc. Click the buttons  or  to switch among the 
objects of same type.  

For more information, refer to Appendix C.2 Preflight Plug-in.  

4.5.2 Preflight Checklist 
1. Define a Checklist 

The setup interface for you to define a checklist is shown as follows:  
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Figure 2-176 

The preflight check entries, i.e. the preflight parameters, are sorted into 6 catalogs, 
General, Page, Image, Color, Font and Rendering, totaling 14 categories. The left are 
catalogs and categories, the right are the items (or entries) contained in a category.  

Action types: There is always an action in front of each check entry, and this action may 
be Ignore, Notify, Warn, or Error. Ignore means no preflight inspection, while the 
other three means to be inspected. These three actions are a classification to the 
messages generated after the inspection, as identifiers to show the degree of importance. 
E.g. you can enable the entry under the category Page Sizes “Page size is A4”, and set the 
action to Warn. After the inspection, if the page size is indeed A4, the report returns a 
result message labeled as Warn, but if the page size is NOT A4, the report returns no 
message.  

Action choosing: The four actions pop up automatically once you place the cursor on 
top of the action icon. You can then choose anyone as needed. You can also click the 
triangle  besides the action icon to get the actions.  

Parameter lock-up: Tick the Lock option at the lower-left corner to lock up all the 
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parameter setting, so as to prevent any casual modification.  

Expand the catalog tree: Tick the Expand Tree option to expand all the catalogs and 
categories at the left, and un-tick it to fold them. If you want to manually unfold certain 
catalog, please click the little icon  in front or double-click the catalog. Choose any 
inferior category to show the check entries it contains at the right.  

Activate a parameter: To enable and define each category of parameters, you need to 
first tick the Enable xxx option at the top, or double-click the category at the left. By 
default, most of such options are disabled, the parameters underneath are all in gray, 
and corresponding entries will not be checked.  

Auto memory: ElecRoc can remember the latest parameter setting in the setup window. 
The setting remains the same if you re-tick the Enable xxx option.  

Parameter look-over: Click the category Summary at the top of the catalog tree to 
view your defined checklist. By default, all the catalogs are folded. You can click the little 
icon  in front or double-click the catalog to expand the entries it may contain.  

2. Preflight Check Entries 

1) General 

The general items for a preflight inspection. The current version supports temporarily 
only the compatibility inspection, i.e. to check the version and format of your PDF file.  

 Compatibility 

 
Figure 2-177 

PDF version: This entry is to check the version number of your PDF file. The condition 
options in the dropdown list include less than, less than or equal to, equal to, more than 
or equal to, more than, and not equal to. The versions include PDF 1.2, 1.3, 1.4, 1.5, 1.6 
and 1.7.  

PDF/X compatibility: To check if your PDF/X is in the specified format. Formats include 
PDF/X-1:2001, PDF/X-1a:2001, PDF/X-1a:2003, PDF/X-2:2003, PDF/X-3:2002, 
PDF/X-3:2003, and PDF/X-4.  

Document: To check if your PDF document is ASCII or Binary.  

2) Page 

To check the properties of a PDF page.  

 Page Size 

To check if the page size is the same as the specified.  
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Figure 2-178 

Page Size: There are two conditions, is and is not. The size dropdown list provides 
standard size options, including A0 (840x1188mm), A1 (594x840mm), A2 
(420x594mm), A3 (297x420mm), A4 (210x297mm), A5 (149x210mm), Legal 
(216x356mm) and Letter (216x279mm). Choose anyone as needed, or you can also 
choose Custom to specify any other size.  

Tolerance: A deviation between actual size and specified size is allowed. It supports 
both positive and negative values, but always uses the absolute value of your input value. 
The tolerance is effective to both the width and length values.  

Page Box: You need to specify a proper page box if the page size is defined based on 
certain page box. A PDF page may contain more than one page box, such as Crop box, 
Media Box, Art Box, Trim Box and Bleed Box.  

 Page Contents 

To check if the PDF page contains content such as layers, shadings, patterns.  

 
Figure 2-179 
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Page is blank: To check if your PDF page is a blank page.  

Page contains layers: To check if your PDF page contains layers.  

Page contains pattern fills: To check if your PDF page contains pattern fills.  

Page contains smooth shadings: To check if your PDF page contains smooth 
shadings.  

Page contains transparent elements: To check if your PDF page contains transparent 
elements.  

Spot color is embedded with overprint property: To check if your PDF page contains 
spot colors that are embedded with overprint property. The overprint setting embedded 
for spot color may be lost during the spot color's conversion toward CMYK or Gray.  

Spot color is embedded with transparence property: To check if your PDF page 
contains spot colors that are embedded with transparence property. The transparence 
setting for spot color may cause unexpected problem during the rasterizing process.  

 Page Objects 

To check the text and line objects on your PDF page, learning such information as the font 
size, the line width, and if the text is knock-out.  

 
Figure 2-180 

Text is smaller than _ points: To check if your PDF page contains any text object that 
is smaller than the points specified here.  
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Text is smaller than _ points and is colored with _ or more separations: To check 
if your PDF page contains any text object that is smaller than the specified points and is 
colored with specified or more separations.  

Black text knockout: To check if your PDF page contains any text object that is knocked 
out.  

White text overprint: To check if your PDF page contains any text object that is 
overprinted.  

Text is invisible: To check if your PDF page contains any text object that is invisible.  

Line weight is less than _ points: To check if your PDF page contains any line object 
whose line weight is less than the points specified here.  

Line weight is less than _ points and is colored with _ or more separations: To 
check if your PDF page contains any line object whose line weight is less than specified 
points and is colored with specified or more separations.  

Line art or clipping path has more than _ nodes: To check if the nodes of the line art 
or clipping path on your PDF page are more than the specified number here. The preflight 
report returns the actual node number, if it’s bigger than specified.  

White graphics overprint: To check if your PDF page contains any white graphic object 
that is overprinted.  

3) Image 

To check the images on your PDF page.  

 Image Position 

To check the positions of the images, learning that if they are rotated, scaled, and etc.  

 
Figure 2-181 

Image is rotated over an angle that is not a multiple of 90: To check if your PDF 
page contains any image that is not rotated by an angle of a multiple of 90. The preflight 
report returns such image and its basic information, if any. The basic information includes 
width and height, bit per component, color space, coordinates, and etc.  

Image is flipped: To check if your PDF page contains any image that is flipped or 
mirrored. The preflight report returns such image and its basic information, if any. 

Image is skewed: To check if your PDF page contains any image that is skewed. The 
preflight report returns such image and its basic information, if any. 

Image is scaled non-proportionally with scale difference _ %: To check if your 
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PDF page contains any image that is scaled non-proportionally and the difference 
between the horizontal and vertical scale proportions is bigger than your specified 
percentage here. The preflight report returns such image and its basic information, if 
any.  

 Image Resolution 

To check the resolutions of various types of images. In case that the horizontal and 
vertical resolutions of an image are different, as long as one of them meets the condition 
specified here, the preflight report returns corresponding message.  

 
Figure 2-182 

Resolution of color or grayscale image is below _ dpi: To check if your PDF page 
contains any color or grayscale image whose resolution is below your specified dpi value.  

Resolution of color or grayscale image is above _ dpi: To check if your PDF page 
contains any color or grayscale image whose resolution is above your specified dpi value.  

Resolution of black and white image is below _ dpi: To check if your PDF page 
contains any black and white image whose resolution is below your specified dpi value.  

Resolution of black and white image is above _ dpi: To check if your PDF page 
contains any black and white image whose resolution is above your specified dpi value.  

Image use 16 bits per channel: To check if your PDF page contains any image that 
uses 16 bits per channel.  

 Image Compression 

To check the compression modes of various types of images.  
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Figure 2-183 

Color and Grayscale image is: To check if your PDF page contains any color or 
grayscale image that is compressed in one of the following selected compression modes, 
including JPEG, JPEG2000, ZIP, LZW and Run Length. If you select Not compressed, the 
preflight report returns even the image that is not compressed.  

Black and white image is: To check if your PDF page contains any black and white 
image that is compressed in one of the following selected compression modes.  

Image use JPEG compression and compression ratio is higher than _ %: To 
check if your PDF page contains any image that is compressed in the JPEG mode and the 
compression ratio is higher than the percentage specified here. The ratio is the file size 
after compression to that before compression. The lower the value is, the bigger the 
compression will be, vice versa. The value ranges 0-100%.  

4) Color 

To check the color setting of your PDF page.  

 Process Color 

Mainly to check the color spaces applied in your PDF page.  
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Figure 2-184 

RGB is used: To check if the RGB color space is used in your PDF page.  

Calibrated Gray or Calibrated RGB is used: To check if the Calibrated Gray or 
Calibrated RGB color space is used in your PDF page. 

Lab color is used: To check if the Lab color space is used in your PDF page. 

ICC based color is used: To check if the ICC based color space is used in your PDF 
page. 

Indexed color is used: To check if the Indexed color space is used in your PDF page. 

N channel color space is used: To check if the N channel color space is used in your 
PDF page.  

Ink coverage is higher than _ %: To check if your PDF page contains any CMYK graph 
whose total ink coverage is higher than the percentage specified here. The value ranges 
0-400%.  

 Spot Color 

To check the spot color setting in your PDF page.  
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Figure 2-185 

Spot color used: To check if your PDF page contains any spot color.  

Number of separation is above _: To check if the number of separations in your PDF 
page is above the number specified here.  

Spot color definition is ambiguous: To check if there is any ambiguous spot color 
definition in your PDF page, such as the case that two spot colors have the same name 
but different color values.  

Spot color has an alternate color space other than CMYK or Gray: To check if your 
PDF page contains any spot color that has an alternate color space other than CMYK or 
Gray, such as RGB.  

Spot color ends on a suffix _: To check if your PDF page contains any spot color that 
ends on a suffix specified here. If you enable this entry, you need to choose a suffix in the 
dropdown list, including CV, CVC, CU, CVS, CVP, C, U, and M. 

 ICC Color 

To check the ICC setting in your PDF page.  

 
Figure 2-186 

Text or line art _ tagged with ICC: To check if there is any text or line-art object is 
tagged with ICC profile in your PDF page.  

Image _ tagged with ICC: To check if there is any image object is tagged with ICC 
profile in your PDF page.  
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5) Font 

 Font Type 

To check the font types used in your PDF page, no matter if they are embedded or not, or 
if they are subset embedded or not. There are five entries, each of them representing a 
font type, TrueType, Type1, Type3, Double byte, and Multiple Master.  

 
Figure 2-187 

 Font Embedding 

To check if there is any font NOT embedded in your PDF page, and if the embedded font 
is subset.  

 
Figure 2-188 

Font is not embedded: To check if your PDF page contains any font that is NOT 
embedded.  

Ignore 14 standard PDF fonts: By default, this option is ticked. The 14 standard PDF 
fonts are Times-Roman, Times-Bold, Times-Italic, Times-BoldItalic, Courier, 
Courier-Bold, Courier-Oblique, Courier-BoldOblique, Helvetica, Helvetica-Bold 
Helvetica-Oblique, Helvetica-BoldOblique Symbol, and ZapfDingbats. In general, they 
are NOT necessarily to be embedded in the PDF document, for the PDF maker like 
Acrobat can provide these fonts.  

Embedded font is subset: To check if the embedded font in your PDF page is subset.  
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 Font Name 

To check if your PDF page uses one or more specific fonts.  

 
Figure 2-189 

To perform this check, tick the Check if the font name is option, then choose an action 
and input the font name in the corresponding edit box. You can specify at most 8 font 
names.  

6) Rendering 

 Rendering 

To check if your PDF page contains halftone, transfer curve, UCR, BG, and rendering 
intent. To further deepen the check to specific page objects, most of the check entries 
contain a dropdown list, which provide three options Image, Line and Text, and All. All 
refers to the sum of Image and Line and Text objects. Please pay attention to the 
setting of this dropdown list.  

 
Figure 2-190 

Halftone phase is used for _: To check if your PDF page contains any user-defined 
halftone screen setting, i.e. user-defined frequency, angle, and shape. In case that the 
source file of your PDF page is a PS file, to perform such a check, you need to select 
Preserve halftone info in PDF Generator setup, otherwise, the halftone information in 
the file may be removed by PDF Generator.  
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Transfer curve is used for _: To check if your PDF page contains any transfer curve. 
This curve is generally used for minimizing the dot enlargement, may be applied to only 
specific page objects, such as images, or lines and texts.  

UCR is used for _: To check if your PDF page contains any UCR information. UCR is 
named Under Color Removal. It uses K to replace lot of C, M, Y inks, reducing ink 
consumption.  

Black Generation is used for _: To check if your PDF page contains any BG information. 
BG is named Black Generation, a process of black generation during the image transfer 
from RGB to CMYK.  

Rendering intent is used: To check if your PDF page uses any rendering intent. 

Rendering intent for _ is _: To check the detailed rendering intents for various types 
of objects.  
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4.6 Trap 

4.6.1 Overview 
Founder’s Trap is designed to meet the practical needs for trap process from customers 
and the market, enhancing ElecRoc’s trap process capability.  

Trap can be a stand-alone ElecRoc processor that may be installed on the server or any 
other connected LAN computer. In workflow, Trap can be connected with other node, or 
exists as a stand-alone node. If connected, it can stay behind PDF Generator, Preflight, 
PDF CMS, or before Imposer, PDF Export, or PDF Rasterizer, to form an automated trap 
process workflow.  

 
Figure 2-191 

There are two file queues, input and output, under the Trap node. After the process, you 
can see the trapped PDF files in the output queue. The result can be viewed through high 
resolution thumbnail image, by way of quick preview in the job window, or in an 
independent preview window. Moreover, as to the files in the output queue, you can 
choose right-click menu item Download to open the output file in Acrobat, checking the 
result with the trap plug-in, which is provided with ElecRoc and can be integrated into 
Acrobat.  

4.6.2 Trap Basics 
Trapping is a prepress technique. It consists of creating small overlaps between abutting 
colors, spread or choked, in order to mask registration problems on the printing press 
later on in the graphical production. As shown in the below, the images contain two colors, 
the light and dark grays. The left image represents the original design; the middle 
represents misregistration, small gaps showing up as a result of inaccuracies; the right 
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shows trapping effect, overlaps being created to fill up the gaps by way of spreading or 
choking the two colors.  

 
Original design  Misregistration  Trapped 

Figure 2-192 

 Definitions 

Trapping objects refer to the image, graph, bitmap, text, line, shading objects in different 
colors on the PDF page. The trapping happens at the edges or joints between two 
abutting objects. The overlapping area formed by spreading or choking objects are 
trapping area, or trapping placement.  

 Trapping Types 

Trappings are generally sorted into normal and black trappings. Both of them are applied 
to all page objects, including the images and small objects mentioned later on in the 
image trapping and small object protection.  

Normal trapping: It refers to the trapping in general sense, apart from the black 
trapping.  

Black trapping: Black trapping is special for black objects. If the density for the black 
separation is comparatively high, the trapping area should spread underneath the black, 
i.e. the black remains unchanged, while the other colors are spread or choked. On the 
contrary, if the black is spread or choked, it will cover other colors and make them nearly 
invisible. To avoid such case, a special rule is thus applied to the black objects.  

 Difference of the Two Types 

1) Normal trapping is object-level trapping, happening between the two abutting objects, 
and not limited to specific separation of the objects. Black trapping is separation-level 
trapping, happening between the black separation and other separation of the black 
object, or between the black separation of the black object and the non-black separation 
of the abutting object.  

2) Trapping placement of normal trapping is controlled by Sliding Trap Limit, and all the 
separations of the object may be spread or choked. The trapping area of black trapping 
spreads wholly underneath the black separation, i.e. the non-black separations are 
spread or choked, the Sliding Trap Limit value doesn’t work.  

Sample: The image below contains two abutting objects, one is the yellow square of Y100, 
and the other is the black circle of C60 K100. The right is the result after separation.  

 
Figure 2-193 
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If normal trapping happens between the yellow square and the black circle, the C, Y 
separations of the black circle and the Y separation of the yellow square may all be spread. 
Part of the trapping area may be under the black circle; while part may be over the yellow 
square (specific placement can be controlled by parameters).  

 
Figure 2-194 

If the black circle is considered as a black object, and thus the black trapping happens 
between the yellow square and the black circle, the K separation of the black circle will 
then keep unchanged, the non-black separations, including the C of black circle and the 
Y of the yellow square, are spread or choked underneath the K separation.  

3) The trapping width of black trapping is generally bigger than that of normal trapping 
(usually multiplied with a factor of 1.5 or 2).  

 Normal trapping Condition 

As the prerequisites for an occurrence of normal trapping between two abutting objects, 
on the one hand, there must be enough color difference between the two objects, 
controlled by Trap parameter Ink Settings > Step Limit, the higher the value, the less 
the objects qualified to be trapped; on the other hand, the common density of the two 
objects must be within a certain range, less than the specified Trap Rules > Common 
Density Limit, the higher the value, the more the qualified objects be.  

 Black trapping Condition 

The Black Color Limit and Black Density Limit parameters under the Trap Rules tab 
control the range of the objects for black trapping. The higher the two values are, the less 
the qualified objects would be. Black trapping is applied to opaque spot color objects, but 
that whether it is also applied to normal spot colors is controlled by the two parameters.  

 Trapping Placement 

Black trapping: The trapping area locates between its own black separation and other 
separations of the black object, or between the black separation of the black object and 
non-black separations of its abutting object. The area spreads entirely under the black 
separation, in other words, the non-black separations are spread or choked.  

Normal trapping: The trapping area always spreads from the lighter to the darker colors. 
Most or all of the area locates under the darker objects, the detailed placement being 
controlled by the parameter Sliding Trap Limit. The effect is most obvious when it 
happens to a shading object, for that each location in the shading has a distinct color 
value, producing a continuous change from darker to lighter colors, or from lighter to 
darker, and thus the trapping placement changes subsequently.  

1. When Sliding Trap Limit is 0%:  
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Figure 2-195 

2. When Sliding Trap Limit is 100%:  

 
Figure 2-196 

3. When Sliding Trap Limit turns to 70%:  

 
Figure 2-197 

 Trapping Width 

The width of the trapping area is controlled by Founder trap parameter Geometry > 
Trap Width. Normal controls the normal trapping width while Black controls that for 
black trapping.  

Take the following factors into consideration when you specify the trapping width: 1) the 
black trapping width is usually bigger than normal trapping (1.5~2 times); 2) obviously 
affected by paper quality, generally speaking, the normal trapping width for offset 
/coated paper is 0.1~0.3 pt, offset /offset paper is 0.3~0.8 pt, rotary offset/newspaper 
0.4~0.8 pt, flexo-printing 0.7~5 pt, and etc; 3) the screen lines per inch also affects, 
usually 0.5~2 times of the line width, e.g. if the line width is 0.48 pt in 150 lpi, the 
trapping width can then be set to 0.24~0.96 pt; 4) for higher printing quality, the width 
should be set to the strict minimum.  

Note: In order to highlight the effect of each parameter, the sample figures in this 
manual are generated with comparatively higher trapping width, which may be evidently 
different from the result in actual production.  

 Trapping Color 

Normal trapping: The color of the trapping area is controlled by Founder trap parameter 
Ink Settings > Color Scaling. The higher the values are, the deeper the color will be.  

Black trapping: It is a simple color addition of the black separation and the non-black 
separations.  

4.6.3 Trap Parameter Setup 
1. How to Configure 

Double-click the Trap item in Administrator > Processor Management, or 
double-click the Trap node in job window, to open the Trap parameter setup window. 

Like any other ElecRoc processor, Trap also supports parameter template. To create a 
template, choose Administrator > Processor Management > Trap to open the 
parameter setup window, configure the parameters as needed, and then choose Load 
Parameters > Save As at the lower-left corner of the window.  
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Figure 2-198 

2. Trap Parameters 

1) Trap Rules 

Parameters under this tab are mainly in three groups, Trap Thresholds, Image Trapping, 
and Zone Trap. They make rules for the normal, black and image trappings in terms of 
the trapping condition, trapping placement, default trapping colors, and control if to 
enable the predefined zone trap setting in job.  

 Trap Thresholds 

These thresholds or limits are used to judge if a trapping happens, the trapping 
placement and the default trapping color.  

Default Step Limit: The step limit is one of the factors in determining if a normal 
trapping happens. The normal trapping happens between two abutting objects only when 
their relative color differences on at least two separations are no less than the 
corresponding step limits. The Default Step Limit here only defines a default step limit 
for each newly-added color separation. ElecRoc finally uses the step limits under the Ink 
Settings tab to perform the trapping process.  

Common Density Limit: This is one of the factors in determining if a trapping happens. 
The normal trapping happens only when the common density of two abutting objects is 
no more than the limit specified here. And this limit is also applied to black trapping.  

Black Color Limit: One of the factors affecting if a black trapping happens. To be viewed 
as the black object qualified for black trapping, the percentage in black color separation 
of the object must be no less than the value specified here.  
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Black Density Limit: Also one of the factors affecting if a black trapping happens. To be 
viewed as the qualified black object, the neutral density of the object must be no less 
than the value specified here. The object that meets both the requirements of Black 
Color Limit and Black Density Limit will be viewed as black object, and a black 
trapping can then happen to it.  

Sliding Trap Limit: This parameter controls the trapping placement. Its value ranges 
from 0 to 100%. It doesn’t work on the black trapping, or when the trapping placement 
between image and graph is set to Center, Choke or Spread.  

Default Color Scaling: It is the default value for the Color Scaling parameter 
whenever you create a new separation under the Ink Settings tab. The color scaling 
controls the color in the trapping area when a normal trapping happens between two 
abutting objects. 

 Image Trap 

Placement: This parameter controls the trapping placement when trapping happens 
between an image and another abutting object. Here the image may be a 1-, 8- or 16-bit 
image; another object may be an image, a graph or a text object. Therefore, this 
parameter works on the Trap image to object and Trap image to image, mentioned 
follow-up, but the Trap 1 bit image is NOT affected in most cases. That whether an 
image and its abutting object are qualified for a normal or black trapping, is determined 
by rules mentioned previously. When qualified, whether a trapping happens is yet 
controlled by the three checkboxes, Trap image to object, Trap image to image and 
Trap 1-bit image.  

1) Automatic. The image is viewed as a normal object, and trapped as per normal or 
black trapping rules, but the trapping placement is calculated based on the colors at the 
image edge, spread from lighter to deeper colors, unrelated to Sliding Trap Limit.  

2) Center. This option is applied to most of the image trappings. The trapping always 
happens at the middle between the image and its abutting object, unrelated to the 
objects’ densities and color values.  

     
Automatic          Center 

Figure 2-199 

3) Choke. For the trap between image and graph, the trapping area is based on the 
image, and choked inside the image; for that between image and image, the area is 
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based on the top image, and choked inside the top image.  

4) Spread. For the trap between image and graph, the trapping area is based on the 
image, and spread outside the image; for that between image and image, the area is 
based on the top image, and spread outside the top image.  

Note: Irrespective of what option is enabled, if the black trapping conditions are met, 
then the trapping happens as per the black trapping rule, i.e. other separation is spread 
or choked under the black separation. The black trapping is prior to normal trapping.  

Quality: The quality of image trapping falls into three levels, normal, higher and best. 
Normal easily produces large trapping area, while Best enables higher color 
preciseness.  

Trap image to object: Controls if a trapping happens between an image and a graph or 
text object, when the trapping conditions are met.  

Trap image to image: Controls if a trapping happens between two images, when the 
trapping conditions are met.  

Trap 1-bit image: Controls if a trapping happens between a 1-bit image and an abutting 
object, when the trapping conditions are met. Here, the abutting object may be an image, 
a graph, a text or a 1-bit image; and the 1-bit image is an object different from image, 
graph and text, because its color is NOT limited only to black or white, each of its pixels 
is either colored or colorless, the colored pixels are colored with the same color, the 
colorless pixels can reveal other object underneath, if any.  

1) When trapping happens between 1-bit image and other image, the trapping 
placement is controlled by Image Trap > Placement. If the placement is set to center, 
or spread, or automatic, the other image is spread; if the placement is set to choke, the 
1-bit image is spread. The following figure shows that the 1-bit image is spread.  

   
Figure 2-200 

2) When trapping happens between 1-bit image and a graph, or a text, or a 1-bit image, 
the trapping placement is always under the deeper object, similar to the case when the 
Sliding Trap Limit is set to 100%.  

1-bit image and a graph:  
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Figure 2-201 

1-bit image and text:  

 
Figure 2-202 

Two 1-bit images:  

    
Figure 2-203 

Fine Bitmap: It becomes available when the Trap 1 Bit image option is selected. If 
checked, it can enhance the preciseness of the 1 bit image trapping, especially that at the 
common boundary of multiple overlapping 1 bit images. This option may increase the 
trap processing time.  

Image internal trapping: This option is recommended for vector images or images 
with edges in sharply transitional colors (like cartoons). If checked, the trapping happens 
inside the darker edge, to keep better visual effect.  

 Zone Trap 

Before you use ElecRoc, you may use a front-side application, such as Founder’s ElecRoc 
trapping plug-in that can be integrated in Acrobat, to predefine trap settings in the source 
file. In this case, you can check the options here to enable the predefined trap settings. 
For details on ElecRoc trap plug-in, refer to Appendix C.3 in Part 4.  

Area trapping in job: You may use a front-side application to specify some areas on 
each page of the source file, and define various trapping settings for them. Check this 
option if you want to enable such area trapping settings.  
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Global trapping in job: Check this option if you want to use the global trap settings 
predefined in the source file, if any. The global trap settings are applied to the entire page, 
not overriding the area trap settings defined separately.  

Ink settings in job: If checked, the ink settings predefined in the source file, including 
the colors, densities and types, will be used.  

By default, the three options above are all unchecked.  

2) Geometry 

 
Figure 2-204 

 Trap Width 

It refers to the width of the overlaps when trapping happens between two abutting 
objects.  

Normal: The width for normal trapping.  

Black: The width for black trapping, i.e. the width that other separation is spread or 
choked under the black separation.  

Unit: The unit of trapping width, mm, inch, or point.  

 Trap Shape 

Here you can define the geometric shapes of the two ends and joints in trapping areas.  

End: This controls the shape of the ends in trapping area. If you choose Miter, the end 
is tailored into miters; if you choose Overlap, the end is still the overlap, like the rest of 
the trapping area. See the following figures, the middle color refers to the trapping area.  

 
Figure 2-205 

Joint: This parameter controls the shape of the joint.  
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Figure 2-206 

Bevel: A triangle is tailored off at the joint to form a bevel.  

Round: To round the joint with a circle that uses the trap width as the radius and abuts 
upon the two outer edges of the cross overlaps.  

Miter: Two identical isosceles triangles are tailored off at the joint.  

3) Small Object Protection 

When trapping happens to small objects, including small texts and thin lines, these 
objects may easily become thinner and smaller, producing a visual effect deviated from 
the expectation. In this case, you can properly reduce the trap width to protect them.  

 
Figure 2-207 

 Small Text 

Settings here aim to reduce the trap width when trapping happens to the texts whose 
sizes are no more than the specified size.  

Size Limit: If the texts qualified for normal or black trapping are smaller or equal to the 
specified font size here, they will be considered as small objects, and thus their trap 
widths will then be reduced according to the percentage defined by Trap Width Scaling. 
The value range is 0.0~100.0, in the unit of Pt. The default is 6 Pt. 0 represents no 
protection.  

Trap Width Scaling: Here you can define the percentage to scale down the trap width. 
The value range is 0.0~100.0 in the unit of %. 0 represents no trapping to small texts. 

 Thin Line 

Similar to small texts, settings here can reduce the trap width when trapping happens to 
the lines whose widths are no more than the specified value.  

Size Limit: If the lines qualified for normal or black trapping are thinner or equal to the 
specified width here, they will be considered as small objects, and thus their trap widths 
will then be reduced according to the percentage defined by Trap Width Scaling. The 
value range is 0.0~100.0, in the unit of Pt. The default is 0 Pt, representing no protection.  

Trap Width Scaling: Here you can define the percentage to scale down the trap width. 
The value range is 0.0~100.0 in the unit of %. 0 represents no trapping to small lines. 

4) Ink Settings 
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Options under this tab are mainly designed for you to define the ink information used in 
trap process. Correct ink information, including the color, density, ink type, step limit, 
and color scaling, plays an important role in determining the trap condition, type, 
placement, width and the color.  

 
Figure 2-208 

 Ink Settings 

Color: Input the color separations in the file into the table, and define their ink properties. 
Cyan, Magenta, Yellow and Black are four basic separations, and thus can NOT be deleted 
or renamed. If the file contains spot color, you can click the icon  at the upper-right of 
the table to add a spot color separation. By default, the Color name of the new 
separation is spot plus a number suffix; the Density is 1; the Type is normal; the Step 
Limit and Color Scaling values are initialized according to the Default Step Limit and 
Default Color Scaling values under the Trap Rules tab. After you add a separation, 
you can re-define its properties as needed, or click the icon  to delete it, if unneeded.  

Hint: You can use the right-click menu item Page Info to view what spot colors your PDF 
page contains.  

Density: It refers to the density of the ink, with a valid range of 0-10, and a precision of 
three decimal places. The densities defined here will be applied in the calculations that 
are involved in determining the trap condition and trap placement.  

Type: The ink types for CMYK are the same Normal, and can NOT be changed. But for 
spot color inks, there are four optional types.  

1) Normal: also called semi-transparent, in which a spot color is considered as a special 
process color that has similar trap properties as CMYK colors. The objects output with the 
normal ink will either override or be override by other ink.  

As shown in the below, the red circle is a spot color object located on top of two squares. 
The relation between the circle and the squares is overprint in the left diagram and 
knock-out in the right.  

If the red circle is output with normal ink, at the left, i.e. when the relation is overprint, 
the trapping doesn’t happen between the circle and the squares, but happens between 
the two squares (specifically the joint under the circle); at the right, when the relation is 
knock-out, the trapping happens between it and the two squares.  
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Figure 2-209 

2) Transparent: No trapping happens between the transparent ink and any other ink, 
but the non-transparent ink objects underneath can be trapped. Polish oil is an example 
of transparent ink. As shown below, the trapping doesn’t happen between the circle and 
the squares in both cases, but in the left case, it happens between the two squares 
underneath.  

      
Figure 2-210 

3) Opaque: The trapping happens at the edge of the opaque ink object, but doesn’t 
happen yet between the objects underneath. Black is actually an opaque ink. The black 
trapping rule is applied between the opaque object and other ink object.  

      
Figure 2-211 

4) Opaque Ignore: The trapping never happens between this ink and any other ink, and 
never between the abutting objects underneath. This type of inks is mostly found in 
special art processes like gold and silver.  

      
Figure 2-212 

Step Limit: It is one of the factors that determine if a trapping happens between two 
abutting objects. ElecRoc uses this value to calculate if the color difference between two 
abutting object in one separation is big enough for a trapping. The default value 
whenever you add a spot color separation comes from the Default Step Limit 
parameter under the Trap Rules tab. If the default value doesn’t meet your actual need, 
you can change it as follows, click the value in the table to activate an edit box, then input 
the actual value and press Enter. You can input the value by typing, or by copying/pasting, 
or by clicking the up/down buttons  aside. Moreover, you can also change the value by 
right-clicking the separation and choosing Change Step Limit to. Values for all the 
separations may be different from each other, if needed.  
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Color Scaling: This parameter controls the trap color in the trapping area when a 
normal trapping happens between two abutting objects. The Default Color Scaling 
parameter under the Trap Rules tab determines the default value for each newly-added 
spot color separation. The method to change this value is the same as that for Step Limit, 
by way of clicking to activate an edit box, or by using the right-click menu item Change 
color scaling to. Values for all the separations may be different.  

 Trap Sequence 

If you have defined opaque inks in the table, you can then use the icons  and  at the 
upper-right to change their positions in the table, so as to adjust their trapping sequence. 
If a trapping happens between two abutting opaque inks in the table, the ink at the 
bottom side keeps unmoved, the trapping happens to the ink at the top side.  

For example, provided that you want to use two opaque inks, the gold and silver, to 
output two abutting objects, if the gold is output first, and the trapping happens to the 
silver ink, then you need to position the gold ink below the silver in the table, vice versa.  

 Trap Profile 

The introduction to trap profile aims to simplify your work on configuring the ink settings.  

This file records information on the separations and the corresponding ink densities and 
types. You can save the ink setting information in current table as a trapping ink profile 
into ElecRoc system, for public use by all the Client users. To do this, click the icon  at 
the upper-right of the table to open a dialog box, input the file name and then click OK.  

Note: The trapping profiles in your ElecRoc system can be managed centrally in 
Resources > Profile Resource > Trap. Operations like creating, editing, importing, 
exporting are all supported. The spot color related information on your PDF page can also 
be saved as a trapping profile under the PDF Generator node. Moreover, you can check 
the Ink settings in job option under the Trap Rules tab to use the pre-defined ink 
information in the file.  

To load a trapping profile, please simply choose the one you want to use from the Ink Set 
dropdown list. Note that the Step Limit and Color Scaling values will turn to their 
default values after you load an ink profile.  

 Auto Spot Color Policy 

It’s recommended that you manually define all the ink information on the spot color 
separations, including the ink densities, the types, the step limits, the color scaling, and 
the sequence, to ensure the quality and preciseness of spot color traps.  

However, at the same time, ElecRoc also provides you with an auto process mechanism. 
This mechanism can automatically detect the spot colors in the file, calculate their ink 
densities according to the spot color values and the CMYK ink densities, determine if a 
trapping happens based on the calculated densities, the default types and step limits, 
and then trap if qualified. The normal trapping is performed using the default color 
scaling value in this case.  

The Spot Color Policy parameter controls how to auto process the spot colors from the 
file, in case that these colors are not defined yet in the ink setting table.  

Use spot color table: If chosen, ElecRoc automatically calculates the ink densities of 
the undefined spot colors, and then determines if a trapping goes based on the calculated 
densities, the default types and step limits, and finally performs the trapping if qualified. 
The spot colors defined already in the ink table are processed as predefined.  

Use spot color in jobs: ElecRoc automatically calculates the ink densities of all the spot 
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colors, and then determines if a trapping goes and performs the trapping if qualified. The 
predefined ink settings in the table become ineffective. 

No trapping for spot color: ElecRoc performs no trapping at all to the spot colors 
undefined in the ink table.  

Note: When automatically detecting the spot colors, in case that the color name contains 
unidentified characters, ElecRoc will make a proper character substitution. 

5) Others 

 
Figure 2-213 

Time Out: If the trap process time for a file exceeds the value specified here, ElecRoc will 
automatically stop the process. This setting stops only the overtime files, i.e. the process 
on the follow-up file continues as usual if the current file is stopped. The unit is minute, 
and one decimal place is allowed. The default value is 0, indicating no time out setting.  

Enable Preview: If checked, a thumbnail image will be generated after the trap process, 
with the purpose for you to preview the trap result.  

4.7 Hot Folder 

A hot folder refers to a specially specified folder over network or in your local computer. 
ElecRoc can automatically identify files in this folder, and submit them to PDF Generator 
for process. Once such a folder has been specified, you can submit files to ElecRoc 
system by simply putting files into the folder. It not only provides a flexible, easy and fast 
way to submit files, but also improves greatly the working efficiency.  

To configure a hot folder, perform as follows:  

1. Create a shared folder on any PC in the local area network where ElecRoc is located. 

2. Open the General Settings window on ElecRoc Server, and then add the folder path 
under the Input Directory tab.  

3. Start up ElecRoc Client, open or create a job and add the Hot Folder node, then 
right-click it to open the parameter setup window.  
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Figure 2-214 

Please configure the parameters as needed.  

Hot Folder Path: Click Add to open a Select Hot Folder dialog box and choose a 
directory as the path of the hot folder. The dialog box lists all the source file directories 
configured from ElecRoc Server. Don’t choose the directory that has already been chosen 
as the hot folder for other job. Click Remove to delete unneeded path, while Remove 
All to delete all the added paths, if needed.  

File Format: The hot folder can detect and submit files in such formats as: PRN, TIFF, 
PDF, PS, and EPS. Check the formats you want the hot folder to detect and submit.  

Search in subdirectory: If checked, the subdirectories in the hot folder, if any, will also 
be searched for source files to be submitted.  

Priority: The default process priority for the source files entering into ElecRoc workflow 
by way of the hot folder.  

4. Return to the job window after the configuration. Add the PDF Generator node behind 
the hot folder and make them connected.  

By default, the Hot Folder is held. Right-click it and choose Resume to run it. When being 
running, the node becomes green. Now you can copy the source files into this folder to 
process them.  
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Figure 2-215 

If you choose the node, you can see all the source files detected and submitted by the hot 
folder in the job window. And if you are authorized to modify the hot folder, you can also 
delete or move these source files with right-click menu items.  
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Chapter 5 Imposer 

5.1 Imposer Parameter Setup 

 
Figure 2-216 

The imposer parameter setup window opened in job window is shown as above. Note that 
the Templates tab will disappear if this window is opened from Administrator > 
Processor Management > Imposer.  

5.1.1 Parameters 
1. General 

Max. Pages: It refers to the total amount of pages in all imposer templates you are 
using in current node (under the Templates tab you can specify the templates to be 
used). The value is unavailable for manual modification; ElecRoc automatically sums up 
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and displays it.  

Bind Type: Six binding types are available, Perfect Bound, Saddle Stitch, Inflexed Stitch, 
Nested saddle stitch, Cut and stack, Cut stack and saddle stitch.  

2. Preview 

Resolution: You can set the resolution of the signature preview. The resolution value 
has three options: 36 DPI, 72 DPI and 144 DPI. We recommend 36 DPI on Mac client and 
72 DPI on PC client. If the signature is too large, it is recommended lowering the 
resolution. 

3. Proof Line 

Generate proof line: If checked, the proof line will be printed on the signature. After 
the print, you can then fold the signature along the proof line.  

4. Creep Control 

When signatures are folded, the image area of the inside pages may move slightly. To 
compensate the movement of image area, you need to set up creep parameters. In a 
Saddle Stitch job, the creep value takes effect between signatures. 

Inner creep value: You can set the creep value of each page. Specify a positive 
Horizontal or Vertical number to move the image area toward the binding; specify a 
negative one to move the image area away from the binding.  

Outer creep value: It refers to the initial movement of the image areas on all the pages. 
Specify a positive Horizontal or Vertical number to move the image area away from the 
binding; specify a negative one to move the image area towards the binding. 

5. Location Control 

You can move the PDF pages horizontally or vertically in a page of imposition template. 

Odd Page: The Horizontal and Vertical control separately the horizontal and vertical 
movements of odd pages. If the value you entered is positive, the page moves rightward 
or upward. If the value is negative, the page moves leftward or downward.  

Even Page: The Horizontal and Vertical control separately the horizontal and vertical 
movements of even pages. If the value is positive, the page moves rightward or upward. 
If the value is negative, the page moves leftward or downward. 

6. Bleed Control 

This setting restricts the area within which bleeds are printed beyond the trim edge of the 
sheet or page.  

Top/Bottom/Left/Right: They control the bleed margins beyond the four edges. The 
bleeds can be output automatically or as per your specified values.  

Auto Bleed: If checked, only the bleed margin within gutter of a page will be output.  

7. Others 

Lacking pages and report error: When it remains unchecked, ElecRoc allows the 
imposer to automatically add blank page(s) to signature, if needed. Related operation 
message is reported in pink in the job’s process information. You can check this option to 
disable the auto-addition. The number of the pages submitted to Imposer must be 
integral times of that in the imposition template, otherwise, ElecRoc issues a warning 
message and interrupts the process.  
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Adjust layout size according to job size: If checked, you can submit pages whose 
page sizes are different from that defined in the template layout.  

For example, suppose the page size defined in template’s layout is A4, and in this case 
you can submit pages in size of A4+ or A4-. After the submission, ElecRoc will impose the 
pages according to the layout’s attributes, such as page number, page sequence, and 
page space, and in this case, ElecRoc won’t enlarge or reduce the size of the actual pages, 
and won’t cut the page content either.  

Check page size: To check up the size of the pages you have submitted to the Imposer. 
If found the size is different from that defined in the template, it issues a report and stops 
the imposing process. When checked, you can further set a tolerance value.  

Note: If you have inserted a comment mark of ($JOB) in the template, please input the 
detailed comment here.  

5.1.2 Templates 
Parameters under this tab are designed mainly for you to choose the template(s) to be 
used by the current imposer node.  

 
Figure 2-217 
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1. Job Templates 

This list shows the imposition templates available for the current job. They may come 
from the module Resources > Imposer Template > Imposer, or may be the ones 
temporarily created.  

 Choose a template 

You can choose one or more templates from ElecRoc system. Right-click anywhere in the 
list area, and then choose Select.  

 
Figure 2-218 

This dialog box lists all the templates under the current user, choose as needed.  

 Create a template 

You can launch the ElecRoc Imposer program to create an imposition template for 
temporary use in current job, by choosing the right-click menu item New. For details, 
refer to section 5.2 Create Imposer Template.  

Or you can also choose the right-click menu item New JDF to create a Preps template.  

 Edit a template 

You can launch the ElecRoc imposer program to temporarily edit a chosen template in the 
list. If the template comes from the template management module, the edition here 
doesn’t change the original template in the management module. Double-click the 
template or right-click and choose Edit to open the editing window.  
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 More right-click operations 

With the right-click menu in the list area, you can also perform the following operations.  

Delete: To delete the chosen template(s) from the list.  

Select All: To select all the templates in the list.  

Refresh: To refresh the list. E.g. you can click it if you want to immediately see the new 
template after you have created it.  

Sort: To sort the templates by the name or by the time created.  

 Preview a template 

When you choose a template in the list, you will see its thumbnail image for preview in 
the bottom area of the window. You can zoom in and out the image by clicking / , or 
by dragging the right mouse button.  

Job Template Path: The location of the job templates (i.e. the templates in the list) in 
your ElecRoc system.  

Part: Here displays the part(s) and total pages in all templates in the Signatures list.  

2. Signatures 

This list shows the imposition templates to be used by the current imposer node and the 
times they will be used.  

The right-click menu items and parameter related to this list include:  

Delete: To delete the chosen template(s) in the list.  

Empty: To remove all the templates in the list.  

Refresh: To refresh the list.  

3. Configure Template(s) 

From the Job Templates list, choose the template(s) you want to use at the current 
imposer node, and then click , to open the following dialog box. Enter the times you 
want to repeat the selected template(s) and click OK, to add the selected template(s) to 
the Signatures list.  

 
Figure 2-219 

Note: If you want to move multiple templates at once, just press the Ctrl key and select 
the templates one by one. And then click the right-headed arrow .  

Times of repetition: The times you want to use the current template(s) to repeat the 
imposition. This number is shown in brackets behind the template in the Signatures list. 
For example, suppose the current template consists of 4 pages, but we need to submit 
and process 8 pages. If we repeat only once, then only 4 pages can be imposed, while the 
rest 4 cannot. But if we repeat twice, then all the 8 pages can be imposed at one time.  
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With the button , you can delete a chosen template from the list;  can move a 
template upward in the list, and  move a template downward. In case that the list 
contains more than one template, ElecRoc uses them in sequence to impose your 
submitted pages.  

5.1.3 Name 
Here you can customize the naming rule for the signatures generated in the imposition.  

 
Figure 2-220 

Enable: If checked, the naming rule defined here is used; otherwise, ElecRoc uses a 
default rule.  

Name: Here you can specify the fields contained in the signature name, including job 
name, node ID, file name, surface name, date, signature and sheet ID. The surface name, 
date and signature ID can be customized.  

A sample name is shown below the setting.  

Note: Do not define same naming rule for the various imposer nodes in the same job.  

5.2 Create Imposer Template 

5.2.1 Quick Start 
This section brings you briefly to the usage of the imposer program.  

1. Start the Program 

Do any of the two operations as follows:  

 Right-click the Imposer node in your job and choose Template Manager;  

 Double-click the Imposer node in your job to open its parameter setup window, 
and then switch to the Templates tab, right-click in the Job Templates list 
area and choose New.  

Note: In the second way, once started, the program displays a New Template dialog 
box. You may specify the parameters and click OK (refer to the next sections for details) 
to create a template, or click Cancel to enter into the main interface of the program. 
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Figure 2-221 

2. Create Template 

1. The New Template window is shown as follows. You can click the toolbar icon  New 
Template to open it when you have entered in the program window.  
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Figure 2-222 

2. Input the template name in the Template Name edit box.  

3. Define a sheet.  

1) Input the sheet name in the Sheet Settings\Name edit box.  

2) Choose one from the two options From Paper and From Plate, located at the 
upper-left corner. Here we take From Plate as example, i.e. to create a sheet based on 
a plate. Such sheet can contain punch area, punch marks, center marks, and side guide 
marks.  

3) Choose a method from the Printing Method dropdown list.  

4) Specify the sheet size from the Plate dropdown list. You can customize this size.  

5) Specify the paper size from the Paper dropdown list. Here you can also customize the 
size. The paper size is usually less than the plate size.  

4. Click OK.  

Note: If you want your template to contain more than one sheet, you can choose the 
main menu item Resource > New Sheet to add another. The setup window for the new 
sheet is similar with that in the new template setup window.  

The new template and the sheet appear in the program window.  

Now you can add sheet objects, including layout, pages, and marks, to the sheet.  
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Figure 2-223 

Note: Some panes and panels on the program window are allowed to be hided or 
adjusted, so that there can be more space for specific pane or panel. As shown in the 
above figure, you can click the tab Template at the left, to hide the template pane, so 
that you can get more space for the sheet editing area.  

3. Add Layout 

Click the toolbar icon  New Layout.  
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Figure 2-224 

1. Specify the page size and direction in the Page Property area.  

2. Specify the rows and columns of the pages, and the alignment mode in the Layout 
Properties area.  

3. Other parameters, if needed, can also be configured, such as the margins.  

4. Click OK.  
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Figure 2-225 

After you have added a layout into the sheet, you may need to define some properties for 
the layout and the pages contained in the layout, especially the page number.  

By default, page number for all the front sides is set to 1 and that for all the back sides 
is set to 2. You have two ways to re-define the page number. 1) Choose a page, and then 
in the property panel located at the bottom of the window, re-set the number in the 
Content > Front/Back edit boxes. Or 2) choose the icon  in the toolbar, to obtain a 
Set page number dialog box, with the cursor turning to .  

 
Figure 2-226 

The Front and Back edit boxes display numbers for the front and back page sides. Click 
the page you want to number, the displayed front and back number will be assigned to 
your clicked page. By default, the two numbers in the Set page number dialog box 
increase in succession as you click on the pages. If you don’t want to use the successive 
number, you can manually input anyone else.  



                      User Guide 

 23
 

236 

Note: If you press down the Shift button at the same time, the page number for the 
pages on each side will be set to the same.  

4. Add Pages 

You can also add blank pages to the sheet, instead of a layout.  

1. Click the toolbar icon  New blank page.  

 
Figure 2-227 

2. Input the number of pages, the width and height of each page, and then click OK. 
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Figure 2-228 

Drag the pages to proper positions, and if needed, configure other properties. Properties 
for each page can be configured by way of the property panel at the bottom of the 
window, and more operations can also be performed, such as alignment, rotation, layer 
adjustment and etc, with help of the toolbar icons. Please refer to section 5.2.5 for 
details.  

5. Add Marks 

Choose the Mark tab at the left of the program window, and then choose a mark, drag 
it to proper position on the sheet. Mark properties, including position, direction, line 
width, line length, block size, can be re-defined, if needed.  
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Figure 2-229 

6. Submit & Upload Template 

Click the toolbar icon  Submit Template. Confirm the name of your template, and 
then click OK. In this way, you can submit it to the current job. 

 
Figure 2-230 

ElecRoc pops up message to inform that the template is submitted successfully. Close the 
message and switch to the job window, open again Imposer’s parameter setup window, 
then you can see the submitted template under the Templates tab.  

You can also click the toolbar icon  Upload Template to upload the template into 
ElecRoc, for public use by all other jobs.  
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5.2.2 Create Template 
All the template-related operations and functions in this program include:  

1. Template Directory 

 
Figure 2-231 

A pane is expanded when you click the tab Template at the left. It shows all the 
templates available in your ElecRoc system, i.e. those you have uploaded for public use. 
The Imposition Template directory is a dedicated directory designed for classification and 
management of the imposition templates. It is the root directory, under which you can 
store straight your templates, or you can also create a sub-directory underneath.  

To create a directory, first, choose an existing directory, e.g. the root directory, as the 
superior directory, then, click the Preference icon  or right-click, and choose Create 
Directory, and then, input the directory name, and click OK.  

With the right-click menu items or items from the Preference  menu, you can delete, 
rename, or import templates into, any sub-directory.  

Right-click menu items are also available for the templates within the template 
directories. With them, template-related operations can be performed.  

2. Create New Template 

You can create a new template by way of:  

 Click the toolbar icon ;  

 Right-click on the Template pane or the top blank part of the template 
editing area and choose New Template;  

 Open the Preference  menu and choose New Template;  

 Choose from the main menu Resource > New Template.  

3. Open/Close Template 

If you want to open one of the templates inside the template directory at the left of the 
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program window, just double-click the template to open it in the right editing area.  

If you want to open an outside template, please click the toolbar icon , or choose from 
the main menu File > Open, and then find out your template from the pop-up dialog box 
and open it.  

More than one template can be opened in the editing area. When a template is opened, 
a tab named with the template name will appear at the top of the editing area.  

You can click the icon  in front of the tab, or double-click the tab, or right-click on blank 
area and choose Close, Close Other, Close All, to close the opened template(s).  

4. Edit Template 

You need to perform a series of editing operations, such as configuring sheet properties 
or creating more sheets, configuring layout, adding pages, and adding marks.  

1) Configure and add sheet 

The sheet properties, including the plate and paper size and other properties can be 
re-defined on the property panel once you choose the sheet. Besides, you can create 
more than one sheet for your template. For details about sheet, refer to section 5.2.3.  

2) Add layout 

The layout is a group of blank pages orderly-arranged in a specific layout. You can add a 
layout into each sheet. For details on how to create and configure a layout, refer to 
section 5.2.4.  

3) Add pages 

You can add blank page separately instead of adding layout. Refer to section 5.2.5 for 
details.  

4) Add marks 

To add a mark, choose a mark under the Mark tab at the left of the program window, 
and then drag it to the sheet. After you have added a mark, you can re-define its 
properties on the property panel. For more details, refer to section 5.2.6.  

5. Save Template 

Click the toolbar icon , or choose from the main menu File > Save, to save the 
template with your specified name and destination. In this way, you will not lose the 
template even if you exit the program, the job, or ElecRoc Client.  

Click the toolbar icon , or choose from the main menu File > Save as, and you can save 
the current template with another name and destination.  

If you close the program without saving your template, ElecRoc will pop up message 
suggesting you to save it.  

6. Submit Template 

After you have finished the creating of the template, you can submit it to the current job. 
Click the toolbar icon , or choose from the main menu File > Submit to open the 
Submit Template dialog box. Confirm the template name and then click OK.  

7. Upload Template 

If you click the toolbar icon , or choose from the main menu File > Upload, you can 
upload the currently-opened template into ElecRoc, for public use by all other jobs.  
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Figure 2-232 

The dialog box lists all the templates existing in the ElecRoc system, saved under the 
dedicated directory named Imposition Template and its sub-directories.  

Choose the directory or a sub-directory and specify the name, and then click OK to 
upload. If needed, you can use the icons , ,  to create a new sub-directory, delete 
an unneeded one, or rename.  

8. Export, Import, Copy, Delete 

Choose a template or directory under the Template tab, and then right-click to open 
a short-cut menu. By using the items herein, you can export, import, copy, delete and 
clear template.  

Export a template: Export the template from ElecRoc to specified destination.  

Import a template: Import a template into ElecRoc.  

Copy a template: Copy the selected template to form a new one.  

Delete template: Delete the selected template(s).  

The above menu items can also be gained by clicking the Preference icon  at the 
upper-right of the template list.  

5.2.3 Create Sheet 
A template is composed of one or more sheets, on which you can then add objects such 
as layout, page, and mark.  

1. Create New Sheet 
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By way of the New Sheet setup window, you can create a new sheet for your current 
template.  

 
Figure 2-233 

This window can be opened by any of the following methods:  

 Every time when you create a new template; the setup window for your new 
template contains the setup parameters for a new sheet;  

 Click the toolbar icon ;  

 Choose from the main menu Resource > New Sheet;  
 At the top of the template editing area, click the toolbar icon .  

1) From Paper 

As shown above, choose From Paper at the upper-left corner of the window. In this case, 
you will create a sheet based on a paper defined by the Paper parameters.  

Choose a paper from the Paper dropdown list in the New Sheet window. This list 
provides a variety of optional papers. The paper properties, including manufacturer, color 
of paper white, paper thickness, width and height, are displayed in the below once you 
have chosen a paper, but not editable, you can switch to the Paper tab (at the left of 
the program window) to modify the paper properties, if needed.  

If the optional papers do not meet your actual need, you can choose Custom, and then 
input specific paper size in the then activated Width and Height boxes. You can click the 
button  to exchange the width and height. Manufacturer, Paper White, and Paper 
Thickness are optional parameters, in which you can input related descriptions.  

2) From Plate 

Your sheet can directly base on the plate, i.e. you can make the sheet size equal the plate 
size, and on the sheet, reserve a punch area, add the punch marks, center marks, and 
the side guide. In the New Sheet window, choose From Plate at the upper-left corner.  
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Figure 2-234 

Parameters then can be divided into two parts, Plate Property and Paper Properties. 
You need to specify a plate by way of the Plate Property parameters, at this moment, 
the Paper can be viewed as the area available for the imposing on the plate.  

In the editing window, the largest area (in a light gray background, by default) 
represents the sheet based on the Plate Property settings. It consists of a punch area, 
the punch marks, the center marks, the side guide, and the paper. The default 
background color for the punch area is slightly darker than that for the sheet. The blank 
area without any default background color is defined by the Paper Properties 
parameters, representing the area available for the imposing, and usually smaller than 
the plate. The background colors for the plate, punch area, and the paper can all be 
customized.  

The plate and paper properties include:  

 Plate properties 

Plate: Choose a plate type from the Plate dropdown list. This list provides some 
commonly-used plate sizes. The plate properties, including device type, width, height, 
punch area, side guide, center marks, punch marks, are displayed in the below once you 
have chosen a plate, but not editable, you can switch to the Plate tab (at the left of the 
program window) to re-define the plate properties.  

If there is no suitable plate for your demand, you can choose Custom, to activate the 
Plate Property and Plate Marks parameters, including:  

Device Type: Optional, here you can input any related descriptive information.  

Width, Height: Here you can input specific plate size. The button  enables you to 
exchange the width and height.  

Punch Area: If you need to punch in the later-on plate making, you can reserve a special 
area on the sheet for the punching. This parameter controls the width of the punch area. 
Its position is determined by the Benchmarks parameter below, it may be at the left, 
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right, top or bottom side of the plate. If you don’t need the punch area, you can set the 
value to 0.  

Punch Mark: ElecRoc adds a punch mark  at the center of the punch area.  

 
Figure 2-235 

Center mark: If checked, ElecRoc adds a kind of line marks at the center of the four 
paper sides. Here you can also define the line width and length for this mark.  

Side Guide: If checked, it adds a mark as  onto the sheet, for the side guide on the 
printing press to precisely position the paper. Note that this setting may be of no effect in 
case that the press model does not install the side guide. Checking it, you can further 
define the length, width, line width, position of the mark, the sheet side(s) on which it 
appear, and the separations on which it will be output. The Left and Right boxes control 
which side(s) of the sheet it appears on. The separation options include C, M, Y, K and 
Spot Color. E.g. if you do not want the mark to appear on the spot color separation, you 
can let the Spot Color box unchecked.  

Benchmarks: It controls the position of the side guide mark. There are four options: top, 
bottom, left, and right, as shown in the below. In the caption such as left/top, the former 
refers to the position of the punch area, the latter the position of the side guide mark.  

 
left/ top               right/ bottom            up/ left         bottom/ right 

Figure 2-236 

 Paper properties 

The Paper and Paper Properties settings are the same as that mentioned in the section 
on how to create a sheet based on a paper.  

Paper Position: It refers to the paper’s position on the plate. The default position is 
centering, i.e. the top and bottom margins are equal, and the left and right margins are 
equal, too. In this case, the four margins are calculated automatically by ElecRoc based 
on the plate and paper sizes. If you uncheck the Center box, you can activate the four 
margin edit boxes, in which you can input custom values. Note that, the sum of the top 
and bottom margins, as well as that of the left and right margins, limited by the plate and 
paper sizes, are fixed. Therefore, if the top margin is changed, the bottom margin will 
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change accordingly, so do the left and right margins.  

3) Printing Method 

By way of the Printing Method dropdown list in the New Sheet window, you can create 
sheets that support various printing methods. Five printing methods are supported: 
single-sided, sheetwise, work and turn, work and tumble, and perfector.  

 
Single-sided   Sheetwise   Work and Turn   Work and Tumble  Perfector 

Figure 2-237 

2. Re-define Sheet 

After you have created a sheet, you can choose the sheet in the template editing area to 
display its properties on the property panel located at the bottom of the window. Through 
these parameters, you can redefine the properties of the sheet.  

 
Figure 2-238 

If the sheet is based on a paper, it displays only the paper properties. If the sheet is based 
on a plate, it displays paper properties when you choose the paper, while plate the 
properties when you choose the plate. The property parameters are the same as those in 
the New Sheet window.  

3. Sheet Management 

Mainly with the icons located at the upper-left corner of the editing area, you can perform 
sheet related operations as follows:  

 
Figure 2-239 

Switch sheet: A template can contain more than one sheet, but only one sheet can be 
opened and edited each time in the editing area. You can choose from the sheet list to 
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switch from one sheet to another.  

New sheet: By clicking the icon , you can add a new sheet.  

Delete sheet: By clicking the icon , you can delete the currently-edited sheet. 

Copy sheet: Click the icon , and you can copy the current sheet. A dialog box then 
appears for you to input the name of the new sheet. Input the name and then click OK.  

 
Figure 2-240 

Edit sheet: Click the icon  to open a dialog box, see the left figure below, in which you 
can re-define the name and the printing method of the current sheet. For example, you 
can change the printing method from sheetwise to perfector.  

Adjust sheet order: Click the icon  to open a dialog box, see the right figure below, in 
which you can adjust the sheet order in the template. Please choose the sheet, and then 
click the button at the right to make the adjustment.  

  
Figure 2-241 

5.2.4 Create Layout 
To create a layout in your sheet, do as follow: click the toolbar icon , or choose from the 
main menu Resource > New Layout, to open the following setup window, define the 
parameters as needed, and then click OK.  
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Figure 2-242 

1. Create New Layout 

1) Layout Properties 

Rows Number: The rows number of the pages in the layout on the front side. That on 
the back side is the same, if the sheet contains the back side.  

Columns Number: The columns number of the pages in the layout on the front side. 
That on the back side is the same, if any.  

E.g. you can set to 3 rows and 2 columns, which indicates that the layout would contain 
3×2=6 pages on the front side, i.e. 3 rows of pages and each row contains 2, or 2 
columns of pages and each column contains 3. If the sheet has the back side, it contains 
6 pages as well on the back.  

Alignment: Available in 4 most popular page alignment modes, up, down, head to head, 
and foot to foot.  
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Rotate: To rotate the page and page content. Options include 0o, 90o, 180o, and 270o 
counter-clockwise.  

Offset: This setting controls the layout position on the sheet. By default it is at the center. 
When you use the nine-point diagram to choose other position, you can use the X and Y 
to define the horizontal and vertical offsets related to the anchor point.  

Lock: If checked, the layout’s position on the sheet will be locked. A locked layout cannot 
be deleted or dragged in any direction on the sheet. And a symbol  will appear at the 
upper-right corner of a locked layout.  

Part: Part is a form to classify the pages, so as to meet some special needs. For example, 
when you want to impose pages from two different books on a same sheet, you can name 
the pages from one book as part A1, and name the pages from the other book as part A2. 
If you don’t have such need, please keep the default option A1.  

2) Page Properties 

The properties include the page size and the orientation. The Size dropdown list provides 
some commonly-used standard sizes for you to choose from. You can also choose 
Custom to specify any other page size.  

Save, Delete: By clicking Save, you can save a custom size as an option into the size 
dropdown list for repetitive uses. The saved size option is named with your customized 
width and height values, e.g. 400.0mm_300.0mm. By clicking Delete, you can remove 
a saved size option from the dropdown list.  

3) Margin 

Page space: The space between two pages, as shown in the below by the area enclosed 
by red dashed lines, available in two directions, horizontal and vertical.  

The top space horizontally is shown as a1, i.e. the distance from the middle of the 
horizontal page space to the upper page. The bottom space horizontally is shown as a2, 
i.e. the distance from the middle of the horizontal page space to the lower page.  

 
Figure 2-243 
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The left space vertically is shown as b1, i.e. the distance from the middle of the 
horizontal page space to the leftward page. The right space vertically is shown as b2, i.e. 
the distance from the middle of the horizontal page space to the rightward page.  

Layout margin: The blank space bordering the layout on the sheet, as shown by the 
area enclosed by green dashed lines.  

The top margin is shown as c1, i.e. the distance between the top side and the page. The 
bottom margin is shown as c2, i.e. the distance between the bottom side and the page. 
The left margin is shown as d1, i.e. the distance between the left side and the page. The 
right margin is shown as d2, i.e. the distance between the right side and the page. 

4) Preview 

At the bottom of the New Layout window shows a thumbnail image of the layout. If you 
press down the mouse button on the thumbnail, you will get a zoomed-in thumbnail 
image floating on the window, as shown in the below. At this moment, you can drag the 
mouse to zoom in any other position on the layout.  

 
Figure 2-244 

5) Default Layout Marks 

You may see some marks on the layout when you zoom in the thumbnail image. These 
marks are automatically added by ElecRoc, and they may include cutline marks, fold 
marks, cross marks, registration marks, CMYK marks, text marks, and other marks.  
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Choose from the main menu Edit > Preference > Mark Parameter to configure what 
marks by default will be added when you create a layout.  

Only the black: If checked, the default marks will be displayed and output only on the 
black separation.  

 
Figure 2-245 

2. Layout Positioning 

Prior to this operation, you need to select the layout at first. How to select a layout?  

When the layout is not locked: move the cursor over any border of the layout, wait till it 
turns to  and then click the mouse. Or press down the left mouse button at any blank 
area on the plate, then drag to form a rectangle, ensuring the rectangle cover at least one 
page, and then release the mouse button.  

When the layout is locked: press down the left mouse button at any blank area on the 
plate, then drag to form a rectangle, ensuring the rectangle cover at least one page, and 
then release the mouse button.  

The layout position can be defined in any of the following ways:  

 Use mouse to drag freely;  

 Enable the capturing capacity;  
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 Configure parameters on the property panel;  

 Use the moving/nudging capacity.  

1) Drag Layout 

As the simplest way, you can directly choose the layout and then drag and move it freely 
on the sheet. When you move the layout in this way, you can refer to the rulers or the 
pop-up coordinates at the lower-left corner to determine the adequate position.  

2) Capture Layout 

You may notice that while the layout is being moved, it may automatically be captured to 
some specific positions, such as the plate borders and the grid lines. ElecRoc provides the 
capacity to capture the layout to auxiliary tools or other positions, so that you can 
position the layout on the sheet more easily and precisely.  

 Capture to plate and paper 

When the object approaches to the borders of the plate or the paper, or the middle lines, 
it will be aligned with them closely and automatically.  

 
Figure 2-246 

 Capture to grid 

Choose in the main menu Tools > Show Grid, to show the grid on the sheet, and 
meanwhile, choose in the main menu Tools > Capture Grid. Now, when you move the 
layout close to the grid lines, you will see two crossed register lines in red on the sheet, 
and the layout will be automatically captured to the exact position where the grid line is.  

 
Figure 2-247 
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The space between any two grid cells can be defined by way of the main menu Tools > 
Grid Spacing. And the color of the grid lines can also be defined by way of the main 
menu Edit > Preference > Color Settings.  

 Capture to guides 

You can add horizontal or vertical guiding lines to the sheet. When the layout approaches 
to the line, it will be automatically captured to the position where the line is. As the grid 
lines do, the guiding lines bring ease in layout positioning.  

1. Show guides. Choose from the main menu Tools > Show Guides.  

2. Add guides. Place the cursor over the ruler, then press down the left mouse button 
and drag toward the sheet editing area, and then release the mouse button at proper 
place. A setup dialog box appears. Input the precise coordinates, and then click OK.  

If you click the dashed cross  at the upper-left of the sheet editing area (at the left of 
the horizontal ruler, and the top of the vertical ruler), and then press down the mouse and 
drag to the editing area, you can add two cross guides at the same time.  

 
Figure 2-248 

3. Capture to the guides. Choose from the main menu Tools > Capture Guides. 
When you drag the layout and make any edge of it approach to a guide line, the layout 
will be automatically captured to the position where the guide line is located.  
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Figure 2-249 

 Capture to other positions 

You can also capture the layout to other layouts, pages or marks. Such capacity is 
enabled if you check items Capture page and other layout elements and Capture 
Mark, under the main menu Tools.  

3) Position Coordinates 

You can use the coordinates to precisely define the layout position.  

 Define the coordinate system 

The default coordinate system is originated at the lower-left corner of the sheet. In 
practice, you can choose another origin to re-build the coordinate system. Click the 
toolbar icon . The editing area then becomes entirely grayed. Move the cursor on the 
sheet, and you will see two cross lines, their crossing is the origin of the new system.  

If you press down the Ctrl or Alt key meanwhile, you can choose to use one of the 
commonly-used coordinate systems built on the plate or plate element.  

 
            Press down Ctrl                              Press down Alt 

Figure 2-250 

If you don’t press down the Ctrl or Alt key, when you move the cursor alone to proper 
position and click the left mouse button, you will open a setup dialog box. The Origin 
Location refers to the coordinates of the new origin on the default coordinate system. 
Coordinate Axis refers to the directions of the X and Y axes.  
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Figure 2-251 

 Define the coordinates 

The position parameter on the property panel controls the exact position of your layout 
on the sheet.  

Nine anchor points: They represent nine anchor points on the layout. Except the 
central point, the rest eight points are all located on the borders. Your chosen point is 
displayed in red on the layout. The X and Y are just the coordinates of this anchor point 
on the coordinate system.  

4) Move/Nudge Layout 

 Move the layout 

To move a layout (if locked, the layout cannot be moved), you can choose the layout and 
then click the toolbar icon  or choose from the main menu Edit > Move, to open a 
setup dialog box. Input the distance you want to move in the horizontal and vertical 
directions, and then click OK. You can input negative values.  

 
Figure 2-252 
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 Nudge the layout 

Choose the layout and then press the arrow keys to nudge the layout. When you click the 
key once, you move the layout one time. The layout is moved in the direction indicated by 
the arrow key, at a distance specified by the main menu Edit > Preference > 
Appearance Settings > Offset Step.  

5) Lock/Unlock 

After you have determined the layout position, you can lock it, so as to prevent it from 
being unintentionally moved. You can lock a layout in any of the following ways:  

 Click the toolbar icon ; 

 Right-click and choose Lock;  

 Choose from the main menu Object > Lock;  

 Use shortcut keys Ctrl + L.  

Being locked, a symbol  appears at the upper-right corner of the layout. The icon, the 
menu item, and the shortcut keys used for unlocking the layout are: , Unlock and Ctrl 
+ Shift + L.  

3. Layout Properties 

Layout properties here mainly refer to the parameters shown on the property panel when 
the layout is selected. Through these parameters, you can view and re-define the layout 
properties.  

 
Figure 2-253 

1) Rotate 

You can choose any of the following methods to rotate the layout.  

 On the property panel, choose the Rotate arrows , ,  or , your chosen 
arrow is then shown in highlight;  

 Choose the icons ,  or  in the toolbar;  

 Choose from the main menu Object > Rotate > Rotate 180, or Rotate 90 
degree(Clockwise), or Rotate 90 degree(Counterclockwise);  

 Use shortcut keys, press down Alt, and meanwhile press an arrow key.  

2) Layout Properties 

Properties include the number of rows, the number of columns, and the alignment mode. 
They are the same as those in the New Layout setup window. Here, if needed, you can 
re-define them on the property panel.  

3) Small page size 

The size of each small page in the layout. Here, if needed, you can also re-define it on the 
property panel. 

4. Page Properties 

Some properties for the pages in a layout can also be defined after you have created the 
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layout, mainly by way of the parameters on the property panel as well.  

 Define page number 

Choose a page and expand the Content tab on the property panel, and then input the 
page numbers in the Front and Back edit boxes.  

Click the toolbar icon , or choose from the main menu Edit > Set page number to 
open a setup dialog box. Input the page numbers for both the front and back sides, and 
then click on a page to apply the input numbers to the page. The numbers in the dialog 
box will increase incrementally after the clicking.  

 
Figure 2-254 

 Add cutline marks 

If you check External Cutline or/and Internal Cutline under the Template tab on the 
property panel, you can add cutline marks to the four page corners.  

 Configure content properties 

Properties of the page content are controlled by the parameters under the Content tab 
on the property panel. They include the offset, rotation, and the locking of the front and 
back sides. Refer to related introductions in section 8.5 for details.  

5. Other Objects 

Here mainly refer to the marks and page space on the layout.  

 Mark 

1) You can add cutline marks to the page.  

2) Choose one added mark, default mark or cutline mark, on the layout, and then you can 
view and re-define its properties on the property panel, including line width, length, 
whether it is present on the front or back sides, whether it is present only on the black 
separation, and whether it is shown.  

 Space 

Also called margins, include the horizontal and vertical page space between pages, and 
the space between the page and layout borders. When being chosen, its properties, such 
as left margin and right margin, are shown on the property panel as well. Through them, 
you can re-define the space size.  



Using ElecRoc Client 

 257 

 
Figure 2-255 

 Other layout-related operations 

1) Use the toolbar icons , , , , , , , , , , or corresponding 
commands from the main menu or right-click menu, to perform such operations to the 
layout as cutting, copying, pasting, deleting, moving, centering, rotating, and locking.  

2) As one object, when being selected together with other sheet objects, the layout can 
be in alignment with them, by way of the toolbar icons , , , , , , , or 
corresponding menu items.  

3) Click the toolbar icons , , , , or corresponding menu items, to adjust the 
sequence of the layout as a layer related to other layers.  

For details about these operations, refer to related introductions in section 5.2.7.  

6. Origami 

In determining the page sequence numbering that corresponds to an imposition pattern, 
a paper folding dummy is usually used: fold a piece of paper according to the correct 
imposition pattern, and write down the page numbers after you complete the folding, and 
then determine the page number for each page of the template as per the page number 
written on the folded paper.  

Origami is a powerful and easy-to-use electronic folding system, designed to replace the 
manual folding. With Origami’s virtual paper, folding is done on computer screen. When 
the electronic folding is completed, the page numbering for the imposition template is 
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also completed - Origami automatically determines page sequence numbering and page 
orientation. Origami’s “virtual paper” can be folded (with the Fold tool), cut (with the Cut 
tool) and combined (with the Combine tool).  

1. Before you use the Origami tool, please ensure that there is a layout in your template. 
The layout determines the sheet size, page size, page number, page orientation, and 
page space. The toolbar icon and menu item for the Origami tool would NOT be activated 
in case that you have NOT created a layout in your template.  

2. Click the toolbar icon , or choose the main menu item Edit > Origami, to enter in 
the following dialog. It will list all the layouts existing in the current template.  

 
Figure 2-256 

3. Tick the layouts you want to fold, and then click OK.  
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Figure 2-257 

The left pane of the window is designed to record all the actions you have carried out. 
Each time when you complete one folding, you will then see a diagram appearing in this 
area, illustrating the action you have just done. If, at any time, you wish to return to a 
previous action, double-click the diagram representing that action in this pane, and you 
will instantly back to the point prior to that action. The right pane of the window holds the 
“Virtual Paper” and this is where you perform the folding, cutting and combining actions.  

4. You can use three tools during the folding process, to achieve flexibly various folding 
results. They appear at the upper-left of the window. Starting at left, the tools are: 

(Fold), (Cut), and (Combine). Their usages are as follows:  

1. The Fold tool 

Choose the icon . Use it when you want to fold the sheet.  

1) As shown in figure (1) below, decide the position of the fold line. Click on the border 
line between pages, and if a folding at that position is available, the line turns to red.  

Note: The bottom line of the paper is also an acceptable fold line, which allows you to 
turn the paper front side back. The number labeled on each page of the paper represents 
the number of paper layers.  

2) As shown in figure (2) below, decide the folding direction. Hold down the Ctrl or Shift 
key, and then move the cursor onto either side of the fold line. Holding down the Ctrl key 
means to fold towards you, and holding down the Shift key means to fold away from you. 
Therefore, horizontally, you can fold towards the left or right side; vertically, you can fold 
towards the up or down side.  

3) Click the mouse button to complete one folding, as shown in figure (3). (4), (5), (6) 
shows a further vertical folding.  
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Figure 2-258 

2. The Cut tool 

Cutting can be used when you want to divide one signature into two small ones.  

Choose the icon  and click on the fold line between pages, and if a cutting at that 
position is available, the line turns to red, as shown in figure (1). Hold down the Shift or 
Ctrl key (at this moment the two keys function the same), and then move the cursor onto 
the right or upper side of the fold line (the right side when the fold line is vertical, and the 
upper side when the fold line is horizontal), as shown in figure (2). And then click the 
mouse button to cut the layout into two (3).  

 
Figure 2-259 

3. The Combine tool 

The Combine tool can be used to move one signature on top of another signature.  

Choose the icon . Drag one layout on top of another layout, and then drop it, the two 
layouts will then be combined (if you do not drop a layout “on top” of another section, it 
will spring back to its original position). The new combined layout can continue to be 
edited (i.e., folded, cut, or combined).  

 
Figure 2-260 

After the folding, cutting or combining, click OK and return to the imposer window. Now 
you can notice that the page numbers have been automatically specified.  



Using ElecRoc Client 

 261 

 
Figure 2-261 

5.2.5 Add Page 
1. Add Blank Page 

You can also add blank pages to the sheet, instead of a layout. Click the toolbar icon , 
or choose from the main menu Resource > New blank page to open the following 
dialog. Input the page numbers, the width and height of each page, and then click OK.  

 
Figure 2-262 

2. Page Properties 

The property panel located below the template editing area can show the properties of a 
page when you choose this page. The two tabs divide properties into two groups, 
Template and Content.  
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Figure 2-263 

1) Template Page 

Template page is a kind of pages used for modeling. It does not contain any real content, 
but it does define the position of the page on the sheet, the space size of the page on the 
sheet, the rotating direction, whether it contains the front and/or back side, the bleeding 
size, whether it contains cutline marks, and the position and scaling for the content it will 
contain, and etc.  

Parameters about the template page are displayed under the Template tab on the 
property panel. With them and other methods like toolbar icons or menu items, you can 
define page properties such as position, orientation, size, bleeding, and etc.  

2) Position 

Here you can use the coordinates to precisely define the page position.  

Besides this, you can also use other methods to position your page as you position your 
layout, for details, refer to section 5.2.4.  

3) Rotate 

You can choose any of the following methods to rotate the template page.  

 Under the Template tab on the property panel, choose the Rotate arrows , , 
 or , your chosen arrow is then shown in highlight;  

 Choose the icons ,  or  in the toolbar;  

 Choose from the main menu Object > Rotate > Rotate 180, or Rotate 90 
(Clockwise), or Rotate 90 (Counterclockwise);  

 Use shortcut keys, press down Alt, and meanwhile press an arrow key.  

By default, the rotating direction of the page content is the same as that of the template 
page. But you may also specify a different content direction. To do so, switch to the 
Content tab, and choose a different Rotate arrow.  

4) Front and Back 

When the printing method is set to Sheetwise, or Work and Turn, or Work and 
Tumble, or Perfector, and you add a page or mark onto the sheet or onto any side of 
the sheet, by default, both the Front and Back boxes on the property panel will be 
checked, and a relevant blank page or mark will appear on the opposite or reverse side. 
Its properties such as size, position and direction are the same as the added page or 
mark or keep relevance with each other.  

You can uncheck any of the two boxes to delete the page or mark on the converse side.  

5) Size 

The size of the template page may be not equal to the size of the page content. If the 
content size is smaller than the page size, and meanwhile the content is not scaled, then 
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part of the content may be cut off after the output. If the content size is larger than the 
page size, and still the content is not scaled, then there would be much space around the 
content.  

By default, the size of the template page is equal to that of the page content. If needed, 
you may also modify the size of the template page.  

 Choose the page and move the cursor to any anchor point on the page border, 
turning the cursor to an arrow like , and then press down the left mouse 
button and drag it. In this way, you can adjust the page size freely;  

 Under the Template tab on the property panel, input proper Size values.  

6) Bleeding 

The Bleeding parameter controls the size of the bleed box of the template page.  

1) Show bleed box: Choose from the main menu View > Show bleeding box.  

2) Color of the bleed box: The main menu Edit > Preference > Color Settings > 
Bleeding Box.  

3) Default bleeding: The main menu Edit > Preference > General Parameters > 
Default Bleeding.  

7) Cut Line 

It includes external cutline and internal cutline. If checked, ElecRoc will add 
corresponding cut line marks at the four corners of the page. The default line width and 
length of the marks are determined by main menu Edit > Preference > Mark 
Parameter > Cut Line. After you have added this mark, you can change the line width 
and length from the property panel, if needed.  

3. Page Content 

You can also configure the properties of the page content, mainly through the parameters 
under the Content tab on the property panel.  

 
Figure 2-264 

1) Page Position 

It refers to the position of the page content on the page size defined by the template page. 
The default position is at the center of the page. You can choose other position from the 
nine-point diagram, and the then activated Horizontal Offset and Vertical Offset edit 
boxes enable you to input appropriate offset values.  

Lock front and back: In case that the printing method is set to a method other than 
Single-sided, this option can then control the positional relevance between the contents 
on the front and back sides. E.g. in Sheetwise printing, if the content on the front side 
moves leftward, then the content on the back side will automatically move rightward, 
with same offset value, vice versa.  

2) Rotate 

You can control the direction of the page content on the template page through the four 
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arrows.  

3) Page Number 

If you specify the page number for the pages on your sheet, then when you manually 
submit multiple pages for imposition, ElecRoc can correctly put the pages to the right 
template pages one by one, according to the page number.  

5.2.6 Add Mark 
You can add a wide range of marks to the sheet.  

1. Mark Type 

The marks that can be added to the sheet include:  

1) Plate marks. On the sheet based on the plate, you can add punch marks  and the 
side guide marks such as . For details, refer to From Plate in section 5.2.3.  

2) Cutline marks. You can add the cutline marks such as  to the four corners of any 
page on the sheet. Refer to Cut Line in section 5.2.5 for details.  

3) Default layout marks. Whenever you create a layout, by default ElecRoc will 
automatically add some marks, including cut lines (e.g. ), fold marks ( or ), cross 
marks , registration marks ( or ), CMYK marks (e.g. ), and text 
marks (e.g. ). For details, refer to Default 
Layout Marks in section 5.2.4 and Mark Parameter in section 5.2.8.  

4) Smart marks. It’s a kind of dynamic mark that can move smartly along with other 
sheet object. The cutline marks, the most of the static marks, and the custom marks, can 
be added as smart marks into your sheet. Their positions on the sheet are based on and 
associated with specific sheet object, such as plate, paper, page, and layout. Once these 
base objects move, they move as well. In this way, you do NOT need to re-set the marks 
in cases that the pages or layout on the sheet are to be changed. This provides great 
convenience for you to create imposer template.  

5) System Static marks. The main difference from the smart marks is that this kind of 
marks is static, and will NOT move along with other sheet object. ElecRoc provides 18 
built-in marks available for you to manually add to the sheet. They include cross reverse 
mark , internal target mark , oval target mark , cross mark , external target 
mark , line mark , vertical line mark , solid target mark , rectangular reverse 
mark , T mark , three-fold mark , CMYK proof bar (three ones ,  and ), 
color bar , step scale , text mark , and signature mark .  

6) Custom marks. You can add custom marks into ElecRoc system, for use in imposition. 
For details on how to add custom marks into ElecRoc, refer to section 5.2.8 Define Marks.  

2. Smart Marks 

As shown in the following figure, the bar mark  located at the lower-left corner of 
each page is a smart mark. It will always appear at the lower-left corner of each page, 
whenever you move the layout, or modify the number of pages, or change the page size, 
or even the page space.  



Using ElecRoc Client 

 265 

 
Figure 2-265 

Method to add smart mark: as shown above, ①, at the left of the window, expand 
Mark > Smart Mark and define smart mark here; ②, choose the defined smart mark, 

drag it into the sheet; at this point you have finished the adding operation; ③, for 
convenience to choose the added smart mark for further operation, you can open the 
Layer Structure panel (from main menu View > Layer Structure) to choose the 
mark.  

1) Mark Directory 

In order to improve the usability and efficiency, ElecRoc enables you to create smart 
mark template and manage the templates by way of directory. As the default directory 
and the root directory, the directory Smart Mark can be used straight to store your smart 
marks. And if needed, you can create sub-directory under it: choose Smart Mark, 
right-click and then choose Create Directory. User-defined sub-directory can be 
deleted or renamed via right-click menu items, if needed.  

2) Define Smart Mark 

The mark setting defined here is sort of a parameter template for your smart mark, 
aiming to provide easiness for repetitive use.  

Choose a directory, right-click and choose New, and then choose a mark type. The 
mark’s property setup window then appears. Define each of the parameters, and then 
click Save to save the setting under your chosen directory. If you click Save and apply, 
you can not only save the setting, but also add the mark into the current sheet.  

1 

2 

3 
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Figure 2-266 

Here we introduce only the property parameters specific to the smart marks. As to other 
parameters, please refer to the next 4th section “Mark Properties”. 

Name: The name for the mark property setting.  

Type: The specific mark type, for example, the bar mark contains 5 specific types.  

The position of the smart mark is dynamic and associated. It’s a relative position, and 
thus needs to be defined by way of some reference variables.  

Base: Please choose a sheet object or sheet location from the Base dropdown list, only 
on which you can further define the exact position for the mark. The base could be plate, 
paper, imposition, imposition bleed, page, page bleed, gutters, and margin. For example, 
if you choose the page as base, the smart mark will then appear at certain position on 
each page; if you choose imposition, the smart mark will then appear at certain position 
on the layout. The bleed in page bleed or imposition bleed means to use the bleed box of 
the page or imposition as the base.  

Base diagram: The base position is further divided into 9 smaller points, top, bottom, 
left, right, center, upper-left, lower-left, upper-right, and lower-right. The smart mark 
will be located at one point of them.  

Target diagram: The selected base point can be further divided into 9 directions. The 
following figure shows a smart rectangle mark’s positions when the base is page and the 
base point is lower-left, but the target direction is respectively set to lower-left, bottom, 
and lower-right.  
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Figure 2-267 

X, Y: When you have defined the exact position by way of the above three parameters, 
you can still make the mark move horizontally and vertically by way of the X and Y edit 
boxes, if needed. A positive X value means to move towards the right, while a positive Y 
value means to move upwards. Negative values mean to move in reverse directions.  

3) Add 

You can add a smart mark if you click the button Save and apply in the mark’s property 
setup window.  

You can also add the smart mark after you have defined the mark, by choosing the mark 
and then dragging it to any place on the sheet.  

By using right-click menu items, you can also add smart mark after you have defined the 
mark: choose the mark, right-click and choose Add to. The sub-option current sheet 
means to add the mark into current sheet, while the sub-option all sheets means to add 
the mark into all the sheets of the current template.  

4) Edit, Delete 

To edit an added smart mark: we recommend you to open the Layer Structure panel 
when you are using the smart marks, see the figure ① in the below. This panel lists all 
the smart marks that have been added onto the sheet. Choose a mark, right-click and 
choose Edit, to open its property setup window. Re-define the parameters and then click 
Save.  

      
Figure 2-268 

1 
2 
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To edit a smart mark parameter template: at the location as shown in above figure ② 
you can also edit the smart marks, by way of right-click menu items. In this way, you can 
re-define the properties of the mark template, for repetitive use.  

Delete a mark: The right-click menu item Delete enables you to delete an unneeded 
smart mark. The already-added smart mark on your sheet can also be deleted by using 
the Delete key on your keyboard.  

5) Import, Export, Copy 

ElecRoc supports you to import and export the smart mark templates. This operation can 
be completed with the right-click menu items.  

3. System and Custom Marks 

The way to add the static and custom marks is as follows. Click the toolbar icon  , or 
check the Mark tab at the left of the program window to expand the optional static or 
custom marks. Then choose one mark and then directly drag it to the right sheet editing 
area, and release the mouse at proper position.  

Note: The custom marks are from PDF pages, thus are in two types, composite and 
pre-separation. ElecRoc does not support you to combine these two types of marks onto 
one same sheet.  

4. Mark Properties 

You can define the mark properties through the parameters on the property panel. But 
the properties for various marks are different. E.g. the property panel for the mark  is 
shown as follows.  

 
Figure 2-269 

While that for the CMYK proof bar 3  turns to: 

 
Figure 2-270 

The property parameters for the static mark include:  

 Position 

It refers to the position of the mark on the sheet coordinate system.  

 Rotate 

The orientation of the mark on the sheet.  

 Front, Back 

They control if the mark appears on the front side, or the back side, or both sides.  

 Line width, Line height 

The line width and height of the mark. The default line width and height can be defined 
from the main menu Edit > Preference > Mark Parameter > Other Mark.  
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 Color 

This parameter is available only for the line marks ,  and step scale mark . Optional 
colors include black (cmyk or mono), cyan, magenta, yellow, red, green, and blue. 
Besides, you can also use custom color.  

Customize mark color: If you choose Custom, you can customize a color in CMYK 
mode. 

 Only on black 

This option is available for such marks as , , , , , ,  and . If checked, 
the mark will be displayed and output only on the black separation.  

 Bar mark features 

The following parameters are specific to the CMYK proof bars and color bars.  

Color block size: Each color bar is composed of multiple same-sized square blocks. This 
parameter controls just the side length of such blocks. In this way, it controls the size of 
the whole color bar.  

Throughout the layout: If checked, the bar is repeated backwards throughout the 
layout, starting from the place where the bar is located.  

Spot Color: If checked, it adds the spot color block(s) at the end of the color bar. The 
spot colors are those contained in the current sheet.  

Insert 50% color blocks: This option is available only for the CMYK proof bar 3. If 
checked, it adds the 50% K, C, M and Y blocks, and if the Spot Color option is checked 
at the same time, it also adds 50% spot color block(s).  

 Text mark features 

Width, Height: The text size is controlled by Height. After you have defined the height, 
you should define a width big enough to wholly display the text.  

Comments: You can randomly input any text, or you can also add variables such as 
surface name, time and date, which separately refer to the name of the current sheet, 
the current time, and the current date.  

Surface: Two options, Front/Back and A/B, are available for you to indicate the front 
plate and back plate. Choose the style you prefer. Take the option Front/Back as example, 
if the Comments parameter has contained the variable Surface, at the time being 
output, the comments appearing on the front side of the your sheet will then contain the 
text Front, while the back side contains the text Back.  

Font: Font for the comments, Song Typeface, Boldface, Tahoma, Batang, or MingLiu. 
And if needed, you can check Bold to make the comments boldfaced.  

Swap: If checked, the text Front/Back or A/B in the mark will be swapped each other.  

Sheet ID: The ID of the sheet. You can customize the first ID, and control if to number 
in sequence algorithm. When the Comments parameter has contained the variable 
Sheet ID, at the time being output, the comments appearing on the sheet will then 
contain the ID defined here.  

Binding > Signature ID: If checked, when the Comments parameter contains the 
variable Signature ID, the ID will be bound with the signature specified in the dropdown 
list below.  

Vertical text: the characters are arranged vertically.  
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 Signature mark features 

To avoid error in assembling, a square mark is added between the first page and the last 
page on a signature. Signature mark can be added on both the saddle-stitched and 
perfect-bound signatures. In saddle-stitched signatures, the signature mark is located in 
the header. In perfect-bound signatures, the mark is located in the binding side of the 
outer signature; while in the inner signature, the mark is located in the header.  

 
Figure 2-271 

First ID: The ID of the first signature mark. For example, if the First ID is 3, the mark will 
be added to the height of the third mark, and the signature ID is 3.  

Step: The step between signature marks.  

Group: You can set certain signature marks as a group; groups are divided by a space of 
a signature mark’s height. This helps to avoid signature missing from happening, and to 
calculate the total signature number in an imposition process.  

Use sequence algorithm: If checked, all the signature marks on the sheet are 
numbered in a sequence. If not checked, they are numbered separated on each 
signature.  

Shape: The shape of the signature mark may be rectangle or circle.  

Color: The signature mark is displayed and output in the color specified here.  

Negative: The signature mark is composed of a number and a background. If checked, 
the number is white, while the background is colored.  

Positive: If checked, the number is colored, the background turns white.  

Range: The range within which the signature mark is allowed to creep.  

Up: The signature mark creeps upward. If you check Horizontal, the signature mark 
creeps leftward.  

Down: The signature mark creeps downward. If you check Horizontal, the signature 
mark creeps rightward.  

Reflex: When the creep of the signature mark reaches the limit, the mark will reflex.  

Inner Reflex: Here you can input the step of inner reflex. When the creep reaches the 
step limit, the creep will creep to the opposite direction. The beginning position is decided 
by the Step minors 1. This setting cannot be used together with Group and/or Reflex. 

Vertical: The signature mark creeps vertically.  

Horizontal: The signature mark creeps horizontally.  
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Example: Height of the signature mark is 5, the Range is 75, and Inn Reflex is 5 steps, 
the output of the signature mark is shown as follows:  

 
Figure 2-272 

Comments: You can add some comments in the signature mark. If needed, input the 
comments in the text box.  

Show Number: It controls whether to show the number in signature mark. 

5.2.7 Sheet Object Operations 
The objects on the layout include layouts, pages and marks. ElecRoc provides you with 
some functions or enables you to perform some operations to them after you have added 
them into the sheet.  

1. Layer Structure 

You need to be quite clear about the up and down relations in case that two or more 
layouts (or pages/marks) are overlapping each other. ElecRoc views each layout (or 
page/mark) as a unique layer. And the upper layer always overlaps the lower one. By 
default, ElecRoc judges if a layer is old or new by the time it is created, the newer layer 
always overlaps the older one, i.e. the newer layer is in the upper, the older one is in the 
lower. This sequence can be customized.  

The layer sequence and classification can be viewed in the Layer Structure pane. 
Choose from the main menu View > Layer Structure to display this pane.  

 
Figure 2-273 
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To change the layer position in the sequence, choose the sheet object, and then do any 
of the following:  

 Click the toolbar icons , , , ;  

 Choose from the main menu Object > Arrangement > Bring to front, or 
Send to back, or Bring forward, or Send backward.  

2. Efficient step & repeat 

Copy repeatedly one single page so as to produce multiple pages arranged according to 
certain sequence and page space.  

Click the toolbar icon , or choose from the main menu Edit > Efficient step and 
repeat, to get a floating setup dialog box, with the cursor turning to .  

 
Figure 2-274 

And then, choose the page, press down the left mouse button and drag it on the sheet. 
You will then see new pages being formed on the sheet around the base page. Release 
the mouse when it has produced the number of pages you want to produce.  

 
Figure 2-275 

Parameters related include:  

Benchmarks: Trim box to trim box refers to use the distance between the trim boxes 
of the two pages as the page space, while Media box to media box refers to that 
between the media boxes of the two pages.  

Space: The page space between any two pages in the horizontal and vertical directions.  
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Locked Page: To lock the base and new pages after the step and repeat.  

External/Internal CutLine: To include cutline marks on all the new pages after the 
step and repeat.  

Only Front: The cutline marks only appear on the pages in the front side of the sheet.  

Bypassing page: To bypass the existing page on the sheet. I.e. at the place where an 
existing page is located, it does not produce any new page.  

Bypassing mark: To bypass the existing mark on the sheet.  

3. Smart step & repeat 

Choose from the main menu Edit > Smart Step and Repeat, and you will open a setup 
window as shown in the below, so as to perform a smart step & repeat operation.  

 
Figure 2-276 

More options become available, compared to the rapid step & repeat setup window.  

Direction of step and repeat: Starting from one corner, step and repeat toward the 
opposite corner. Thus there are 4 directions. By default, ElecRoc can automatically 
choose a proper direction, but if needed, you can choose any other direction.  
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Fill the entire paper: To generate multiple pages till they fill the entire paper.  

Page Arrange: To generate a specified number of pages in both the horizontal and 
vertical directions, as defined here.  

Fill Area: To generate multiple pages till they fill the area as specified here.  

Center Page: To center the base page and generated pages on the sheet.  

4. Alignment 

After you have added multiple layout objects into the sheet, you may need to align them.  

1) Selection of multiple objects 

To choose or select more than one sheet object at one time, you can do any of the 
following:  

 Press down the Ctrl key at the same time;  

 Press down the left mouse button on any blank area inside or outside the sheet, 
and then drag it in any direction to form a rectangle. In this way you can choose 
all the pages inside the rectangle.  

After you have chosen multiple objects, you can perform not only the alignment, but also 
the operations like moving, cutting, copying/pasting, deleting, rotating, and configuring 
the bleed, the size, and etc.  

2) Align objects 

You can align objects in any of the following ways:  

 Click the toolbar icons , , , , , , ; 

 Choose the menu items corresponding to the above icons: Object > 
Alignment > Vertical align top/ Vertical align center/ Vertical align 
bottom/ Horizontal align left/ Horizontal align center/ Horizontal align 
right, and Object > Center > Horizontal and vertical/ Horizontal/ 
Vertical.  

The default benchmark is the firstly selected object, but this can be re-defined manually. 
After you have chosen multiple objects, click one of them once again to make it the 
benchmark object. The anchor points on the benchmark object are shown in dark, while 
those on the rest objects are in white.  

5. Cut, Copy, Paste, Paste Hold, Delete 

Among them, Paste Hold refers to an operation in which the original object and the 
copied one will be in a same location after the pasting, producing an visually overlapping 
effect. These operations can be performed in one of the following ways:  

 Choose the object and then click the toolbar icons , , , ;  

 Right-click and choose Cut, Copy, Paste, Paste Hold, Delete;  

 Choose from the main menu Edit > Cut/ Copy/ Paste/ Paste Hold/ Delete;  

 Shortcut keys. Cut: Ctrl+X; Copy: Ctrl+C; Paste: Ctrl+V; Paste Hold: 
Ctrl+Shift+V; Delete: Delete.  
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5.2.8 More Features 
For more flexibility and convenience, and higher efficiency, ElecRoc imposer also provides 
you with the following functions and features.  

1. About User Interface 

1) The Program Window 

 
Figure 2-277 

In full view mode, as shown above, the program window consists of the following parts:  

Main menu: Provides operational commands for you to use.  

Toolbar: Consists of multiple icons or buttons that can substitute for some 
commonly-used commands, for you to quickly perform the operations.  

The resource management pane: The pane located at the left of the window is 
designed for you to manage the related resources, such as templates, plates, paper, and 
marks. They are grouped into four tabs, each with a unique operating interface.  

The template editing area: The body of the program window is an area special for you 
to edit your template.  

Property panel: Lists the property parameters of your selected sheet or selected object 
on the sheet for you to configure.  

Layer Structure pane: a floating pane, displayed after selection, listing the layer 
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structure of current sheet. In layer structure, each sheet object is considered as a layer.  

Navigator pane: a floating pane, displayed after selection, showing the thumbnail 
image of the current sheet for you to navigate.  

Status bar: Displays the plate size, paper size, unit, number of the selected objects, and 
the cursor position. In addition, it contains two buttons at the rightmost, which can be 
used to control the display of the front and/or back sides and the display percentage.  

You can use the mouse dragging to adjust the sizes of the resource management pane, 
the template editing area, and the property panel. But when you re-open the program 
window, their sizes restore to a default setting. When you have expanded any tab of the 
resource management pane, you can hide the tab and the pane by clicking the tab once 
again. The property panel can be displayed or hidden by clicking the buttons / . The 
template editing area can hold more than one opened template, each one with a tab 
locating on the top, named with the template name. You can click these tabs to easily 
switch between them.  

2) Toolbar icons 

 the position of the icons in the toolbar 

The icons in the toolbar are classified into several groups, separated by the symbol . 
Press down the left mouse button at the blank area between the icons within a group, 
then drag forward or backward and drop at any other , you can move the group of icons 
to the place where you drop the mouse button.  

 Show/hide toolbar icons 

Choose from the main menu Edit > Preference, and then choose Custom Toolbar 
from the pop-up window.  

 
Figure 2-278 
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The window lists all the toolbar icons that can be displayed and used and how they are 
grouped. Expand each group of icons. A tick in front indicates to show, while a cross in 
front indicates to hide. If needed, you can cross the icons that are less used or not used. 

For your convenience, ElecRoc provides buttons such as Unfold, Fold, Select All, Clear, 
Reset Default and Reset all to default. By default, all the icons are shown in the 
toolbar.  

 The toolbar right-click menu 

You can right-click on the blank area in the toolbar to get a shortcut menu, and then use 
the options to control if to show or hide a whole group of icons. If you check Lock 
Toolbars, then you cannot move the groups of icons. The Custom option enables you to 
separately control if to show or hide each of the icons.  

 
Figure 2-279 

3) Display of the front and back sides 

The controller  at the bottom of the program 
window controls the display of the front and back sides on the editing area. If you 
choose or , only one side (front or back) is displayed, and if you choose , both sides 
are displayed.  

Transparency: This option is applied to the sheet that contain both the front and back 
sides. It refers to the transparency of the front side on the back side, or that of the back 
side on the front side.  

4) Display proportion 

The sheet display proportion can be adjusted in the following ways:  

1) Use the Zoom tool . Choose this toolbar icon. The cursor turns to  after you 
choose. 

 Press down the left mouse button and drag the mouse, to form a rectangle in 
dashed-line on the sheet. The content inside the rectangle will be zoomed in on 
the editing area in the possibly biggest proportion.  

 Scroll up and down with the mouse wheel;  

2) Use the toolbar icons , , ,  and . The icon  zooms in, the icon  zooms 
out, and each click on these two icons zooms in/out in a fixed scaling factor, which can be 
defined with the Preference parameter Appearance Settings > Zoom Step. The 
icon  zooms to display the whole sheet in fitting proportion, and the icon  zooms to 
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display the currently-selected object in fitting proportion. The object may be the sheet, 
the layout, a page, or a mark. The icon  zooms to a specified display proportion. Click 
it, and you can choose from the optional proportions, such as 2:1, 1:1, 1:2, or you can 
choose Custom to specify other proportion.  

ElecRoc also provides menu commands corresponding to the above icons, under the 
View menu.  

3) Press down the Ctrl key and meanwhile scroll the mouse wheel to-and-fro to zoom in 
and out the view. The cursor turns to  if you press down the Alt key. At this time, you 
can zoom in and out the view as you do with the Zoom tool .  

4) Use the zoom controller at the lower-rightmost of the program window “Zoom: 61% 
  ”. Here you can not only know the current zoom proportion, but also 

can click the icons and  to zoom out and in incrementally (5% each click), or adjust 
the sliding bar to zoom in and out.  

5) Sheet Navigation 

For your convenience to browse the sheet when the view has been zoomed in, i.e. only 
part of the sheet content is displayed in the editing area, ElecRoc provides you with the 
following 4 optional capacities.  

 Use the mouse wheel to scroll the sheet up and down;  

 Drag the horizontal or vertical scroll bar;  

 Choose the toolbar icon , and then you can press down the left mouse button 
to drag the sheet freely; 

 Make use of the Navigator pane.  

Choose from the main menu View > Navigator to display the Navigator pane.  

 
Figure 2-280 

In this area, ElecRoc displays the thumbnail images of the front and back sides of the 
sheet. When the zoom proportion increases to a certain extent, you will see a red 
rectangle box on the thumbnail image (the bigger the proportion, the smaller the box 
would be). The content inside the box are just the zoomed-in content in the editing area. 
Therefore, if you move the red box by clicking anywhere outside it on the thumbnail 
image, or if you drag and drop the box directly, you can subsequently change the content 
currently displayed in the editing area. In this way, by clicking or dragging on the 
thumbnail image, you can easily zoom in and browse the sheet in the editing area.  
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6) Layer Structure 

ElecRoc introduces the concept of the layer. Each object on the sheet is considered by 
default as a unique layer. From the Layer Structure pane, you can adjust the sequence 
of the layers, to correctly deal with some issues come from the case when the objects 
overlap each other.  

7) Layout Object 

ElecRoc provides such commands under the View menu as Display Page, Display Part, 
Show Marks, Show bleeding box, Show trim box, and Show layout box, for you to 
control whether to show the layout object or element including page number, part, mark, 
bleed box, trim box, and layout box. by default, all of them are shown on the window.  

 
Figure 2-281 

8) Other Display 

By using the commands Simple View and Operator View under the View menu, you 
can hide the property panel and the resource management pane from the program 
window, and by using the commands Show Guides and Show Grid under the Tools 
menu, you can control whether to show or hide the guide or grid on the window.   

2. Define Papers 

You can create or define the paper options that are available for selection in creating a 
sheet.  

Mark 
 

Bleeding box 

Page number 

Trim box    Part 
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Figure 2-282 

The operations related to defining a paper are all performed under the Paper tab. By 
using the commands from the right-click menu or the Preference  menu, you can 
finish such common operations as creating, editing, copying and deleting.  

As shown in the above figure, each paper has six properties, among which the Name, 
Height and Width are compulsory. The button  enables you to exchange the width 
and height. The Manufacturer, Paper White, and Paper Thickness are optional 
properties. If needed, you can input related descriptions.  

Now that you have defined the papers, you can quickly define the sheet size and save the 
time to set the paper properties, by choosing the pre-defined paper options from the 
Paper dropdown list, at the time when you open the New Sheet window to create a 
sheet, or expand the property panel to edit the sheet.  

3. Define Plates 

The purpose, method of operation, and the application of the plates, are basically similar 
to the papers mentioned above. The difference lies in that you need to define more 
properties as to the plates.  
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Figure 2-283 

 Punch area 

If you need to punch in the later-on plate making, you can reserve an area on the sheet 
special for the punching. Punch Area controls the width of the punch area. Its position 
is determined by the Benchmarks parameter, it may be at the left, right, top or bottom 
side of the plate. If you don’t need this area, you can set the value to 0.  

 Punch marks 

ElecRoc can add a punch mark  at the center of the punch area.  

 Side guide marks 

ElecRoc can add the marks such as  onto the sheet, for the side guide on the printing 
press to position the paper, in case the press model installs the side guide.  

Checking it, you can further define the length, width, line width, position of the mark, the 
sheet side(s) on which it appear, and the separations on which it will be output. The Left 
and Right boxes control which side(s) of the sheet it appears on. The separation options 
include C, M, Y, K and Spot Color. E.g. if you do not want the mark to appear on the spot 
color separation, you can let the Spot Color box unchecked. The Benchmarks box 
provides four options, representing the mark position, shown as follows.  
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Figure 2-284 

 Center marks 

A line mark appears at the center of the four sides on the paper, if checked.  

 Other parameter 

Device Type: Optional property. You can input related description here.   

4. Define Marks 

Marks here refer to the user-defined marks. Steps for adding custom marks into ElecRoc 
are as follows:  

1. Use third-party software to make the mark, and save it as a file that can be supported 
by ElecRoc, e.g. PDF, PS, TIFF, PRN, and etc.  

2. Enter in ElecRoc’s job window and submit the mark file to PDF Generator. After the 
process is completed, choose the generated PDF page, right-click and choose Add as 
Mark.  

Note: After PDF Generator’s process, the mark file can be further processed by nodes 
like PDF Tools and Page Clipper. Under such node or when the toolbar icon  is selected, 
you can still use the right-click menu item Add as Mark to perform the operation.  

3. Input the name of the custom mark, and then click OK.  

4. Return to the program window. Expand the Custom mark list under the Mark tab, 
right-click and choose Refresh, and then you will see the newly-added mark.  

5. Auxiliary Tools 

We mentioned previously how to position pages by help of the auxiliary tools. There are 
two auxiliary tools, grid and guide.  

1) Grid 

 Show the grid 



Using ElecRoc Client 

 283 

When you have enabled the menu item Tools > Show Grid, you can see regularly 
spaced horizontal and vertical dashed lines on the sheet, forming a multitude of equal 
squares. Meanwhile if you have enabled another menu item Tools > Capture Grid, then 
when you move a sheet object close to any grid line, you can see two crossed red lines 
appearing and the object being captured to the place where the grid line is located. If you 
don’t want to use the grid as a reference for positioning, please disable the two menu 
items above.  

 Define the grid spacing 

Choose from the main menu Tools > Grid Spacing. The grid is composed of many 
identical squares. The spacing actually refers to the side length of such square. The value 
by default is 50 mm, with a range from 10~1000 mm.  

 
Figure 2-285 

2) Guide 

 Show the guide 

Choose from the main menu Tools > Show Guides. The display color of the guide lines 
can be defined from the main menu Edit > Preference > Color Settings.  

 Capture to the guide 

Choose from the main menu Tools > Capture Guides. When you drag a sheet object 
close to a guide line, ElecRoc will automatically capture the object to the place where the 
guide line is located.  

 Track the guide 

Choose from the main menu Tools > Track Guides. In this case, if you move the guide 
line, you will move the objects captured to the guide line at the same time.  

 Add a guide 

1. Do any of the following:  

 Double-click anywhere on the horizontal or vertical ruler;  

 Place the cursor on the ruler, and then press down the left mouse button and 
drag towards the sheet editing area;  

 Click the toolbar icon ;  

 Choose from the main menu Tools > Add Guides.  

2. The Add Guides dialog box appears. Choose the direction, horizontal or vertical, and 
input the exact coordinate, and then click OK.  

 Move a guide 

Place the cursor on the guide line, the cursor then turning to an arrow-like shape, such 
as , and then press down the left mouse button and drag the mouse. In this way you 
can move the guide line anywhere easily. If you press the Ctrl key meanwhile, you can 
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move the guide line to one of the commonly-used positions on the sheet. You can also 
double-click the guide line to re-locate it.  

 Lock the guides 

Choose from the main menu Tools > Lock Guides. The locked guide line can no longer 
be moved randomly. To unlock, please cancel the selection of this menu item.  

 Delete/Clear guides 

You can delete a guide line by simply dragging it outside of the sheet editing area. Or if 
needed, you can also click the toolbar icon  to clear all the guide lines.  

6. Resource Explorer 

ElecRoc enables you to export such resources as papers, plates, templates and smart 
marks out of ElecRoc system by way of the resource explorer.  

Choose from the main menu Resource > Explorer to open the operating interface. The 
left of the window lists the four resource categories, paper, plate, template and smart 
mark, and at the right it shows all the resources of a selected category.  

Check the resources you want to export, and then click Export. And in the follow-up 
dialog box, specify the name and destination for your exported resources.  

You can also click the Import button in the explorer to import paper, plate and template 
resources into ElecRoc system.  

 
Figure 2-286 

7. Preference 

Here refers to the parameters that can be defined according to your preference. Choose 
from the main menu Edit > Preference to enter in the setup interface, which contains 
five group of parameters.  
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Figure 2-287 

1) General Parameter 

 Alignment 

It refers to the benchmark for the page alignment. Pages can be aligned with each other 
based on the trim box or the media box.  

 Other 

Small page and template alignment: It controls the default position of the page 
content on the template page, i.e. the default positioning setting under the Content tab 
of the property panel, when you choose a layout or page.  

Default Bleeding: The default bleeding setting of the page on the sheet.  

External/Internal CutLine: Controls if by default the External/Internal CutLine 
options are enabled for each newly-added page, not available to layout page. If checked, 
when you add a page to the sheet, the property parameter Template > External 
/Internal CutLine for the page will be checked by default. The default setup of the 
External/Internal CutLine options for the layout page is controlled by the parameter 
Preference > Mark Parameter > Cut Line.  

2) Mark Parameter 

Here you can define the default marks that would be added automatically when you 
create a layout. These marks include: 

Category sample Location 

Cut Line  the four corners of the layout 

Fold mark Single line , three lines  middle points on the four sides of 
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the layout 

Cross mark  Center of the layout 

Registration 
mark 

External target mark , solid target 
mark  

middle points on the four sides of 
the layout, or the four corners 

CMYK mark  the top of the layout 

Text mark  the bottom of the layout 

Table -12 

Under the Mark Parameter tab, you can control if the above marks are automatically 
added when you create a new layout. A tick means to add the corresponding mark. 
Moreover, you can define the default line width, height, and the specific type.  

 
Figure 2-288 

Other Mark: They are the marks you manually add to the sheet. Here you can define the 
default line width and height for such mark.  

Only the black: If checked, the default marks above will be displayed and output only 
on the black separation.  

3) Appearance Settings 
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Figure 2-289 

Offset Step: The moving distance of each nudge when you use the arrow keys (、、
、) to nudge the selected object on the sheet.  

Grid Spacing: The spacing between any two grid lines.  

Sub Grid: After you have redefined the grid by using the main menu item Tools > Grid 
Spacing, you can use this parameter to further form a sub grid in each square of the old 
grid. The parameter here controls the number of the sub squares in horizontal (or vertical) 
direction.  

Undo Step: The times to perform the Undo operations.  

Zoom Step: The scaling factor for each click on the toolbar icons , , or on the zoom 
controls at the lower-right corner of the window. The default value is 5%.  

4) Color Settings 

You can define the display color of many objects, including the page’s bleeding box and 
trim box, guides, grid, workspace background, plate, punch area, and paper.  

In the Preference > Color Settings window, if you want to change the display color for 
some object, click the color block corresponding to the object to open a color setup dialog 
box. In this dialog box, you can choose a new color from samples or in the HSB or RGB 
mode. The preview area at the bottom of the dialog box displays the display effects.  
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Figure 2-290 

5) Toolbar 

Settings here control what toolbar icons are shown in the program window. For details, 
refer to section 5.2.8.  

5.3 Terms 

Before we move to the detailed capabilities, we provide you with some referential terms 
or concepts related to imposition.  

1. Signature. Refers to the sheet on which pages are arranged in special orders. 

2. Bind Margin. Refers to the edge where the folded press product is bound. 

3. Cut Edge. Refers to the edge where the product is trimmed. 

4. Flat Stitched Registration. There are two folding methods: one is folding the first 
two signatures separately, and pile the folded signatures together. The other is piling the 
first two signatures, and folds the two signatures together.  

          
Figure 2-291 

The relative information about page number in the template will not be loaded to job. 
System requires you to assign page numbers again. You only need to assign the page 
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numbers of the first two signatures. System will generate the other page numbers. 

5. Come-and-Go. After printing, folding, binding and cutting, two identical products will 
be generated from one signature. See the following figure at the left.  

                 
Figure 2-292 

6. Cut-and-Stack. The Cut-and-Stack is used primarily for jobs printed on on-demand 
output devices to produce different parts of a job simultaneously. The sheets are cut and 
one side is stacked on the other for a complete book. See the above figure at the right.  

7. Tiling. If the press sheet is larger than the device’s media size, TPL Editor divides the 
press sheet into tiles that can be stripped together.  

8. Signature Collation Mark. The marks added on a signature to avoid errors in 
assembling.  

 
Figure 2-293 
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Chapter 6 Composer 
Composer is an effective use of independent pages, composing several different small 
jobs on a single press sheet, and optimizing the use of film or media, with an aim to lower 
cost and improve the efficiency.  

6.1 Quick Start 

This section introduces you briefly to the usage of the Composer module.  

6.1.1 Preparation 
As an independent processor node in job or workflow, Composer always stands alone, 
disconnected with any other node fore-and-aft. It accepts files processed after the node 
such as PDF Generator, Margin Adjustment, PDF Merger, and PDF Tools. Before you start, 
you need to manually submit the pages to the node.  

 
Figure 2-294 

Steps to get readiness:  

1. Open or create a job.  

2. Add the nodes, ensuring that the job contains at least a PDF Generator and Composer 
node. 
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3. Choose source files, and submit them to PDF Generator.  

4. Choose the page files that the PDF Generator has generated, and manually drag them 
to the Composer node as input files.  

In case that you need to choose the input files from the nodes other than PDF Generator, 
e.g. Margin Adjustment, switch to these nodes and choose from their output file queues. 
Or you can also check the toolbar icon Pages , then choose from the listed page files.  

After you submit the input pages, ElecRoc will automatically open the composer window 
(also can be opened by double-clicking the Composer node). The input pages you 
submitted are listed under the  Page tab at the left of the window. By default, they are 
displayed in thumbnails. You can click the icon  at the upper-right of the thumbnails to 
change to the list view.  

6.1.2 Create Signature 
The steps are as follows:  

1. Double-click the blank area at the right of the window, or choose from the main menu 
File > New Signature, to open the New Signature window.  

 
Figure 2-295 

2. Input signature name in the Signature Name edit box.  

3. Define a sheet.  

1) Choose an option from the two options From Paper and From Plate, located at the 
upper-left corner. Here we take From Plate as example, i.e. to create a sheet based on 
a plate. Such sheet can contain punch area, punch marks, center marks, and side guide 
marks.  

2) Choose a method from the Printing Method dropdown list.  

3) Specify the sheet size from the Plate dropdown list. You can customize this size.  
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4) Specify the paper size from the Paper dropdown list. Here you can also customize the 
size. The paper size is usually less than the plate size.  

4. Click OK.  

The new signature then appears in the ganging window.  

 
Figure 2-296 

6.1.3 Add Pages 
Switch to the Page tab, choose the pages to be ganged (with Ctrl or Shift key you can 
choose more than one page one time), and then press down the left mouse button, drag 
them to the blank area on the sheet.  
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Figure 2-297 

In the default ganging mode, i.e. manual ganging, after having been added to the sheet, 
the pages may scatter, or even overlap with each other. In such case, you may need to 
perform some ganging operations as follows:  

1. Page positioning 

Choose one or more pages (click in any blank area on the sheet to cancel the selection), 
and drag them to proper location and then release the mouse button. In this way, you can 
re-position the pages quickly.  

 
Figure 2-298 
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Note: When moving the pages, ElecRoc can capture the pages to the borders of the plate 
and paper, i.e. when the pages approach the plate or paper border, they will be captured 
automatically to the border. If you don’t need this capacity, you can disable it by 
un-checking the menu item Tools > Capture plate and paper.  

The page position can also be defined with the coordinates in the property panel, located 
at the bottom of the window.  

 
Figure 2-299 

2. Rotate the pages 

In the property panel, as shown in the above figure, by using the icons , , , or by 
choosing from the main menu Object > Rotate, you can rotate the pages.  

 
Figure 2-300 

3. Align the pages 

If you want to align the pages, you can press down the Ctrl key to choose multiple pages, 
and then click the toolbar icons , , , , , , or .  

By default, the pages are aligned with the first chosen page, but you can also specify 
other reference page with which the pages are aligned. When you have chosen multiple 
pages, click one of them once again to make it the new reference page. The anchor points 
on its borders then turn dark cyan.  
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Figure 2-301 

Note: After you have aligned multiple pages with one page, you can further use the 
toolbar icon  to team them into a group. And then, you can also use the toolbar icon  
to center the group on the sheet.  

4. Configure properties of page content 

Choose a single page, and then choose the Content tab on the property panel. Here you 
can configure the properties related to the page content.  

 
Figure 2-302 

1) Position the content on the page. You can change the position through the nine-point 
diagram. By default it is centered, i.e. if the page size reduces, the edges of the content 
may be cut off; if the page size increases, blank spaces may be added to the edges.  

 
Figure 2-303 

2) Rotate the content. By default, the content is rotated along with the page, as shown in 
the middle. By clicking the four rotation icons under the Content tab, you can separately 
control the orientation of the content, which may be different from that of the page, as 
shown at the right.  
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Figure 2-304 

3) Scale the content. You can input the scaling percentages in the Horizontal and 
Vertical boxes, or click the toolbar icon  to open an independent setup window.  

 
Figure 2-305 

6.1.4 Add Marks 
Choose the Mark tab at the left of the composer window (if your monitor resolution is 
not big enough, click the symbol  below the Paper tab to find out the Mark tab), 
and then choose a mark, drag it to proper position on the sheet.  

 
Figure 2-306 
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Mark properties, including position, direction, line width, line length, block size, can be 
re-defined through the parameters on the property panel.  

6.1.5 Ganging on Back Side 
When your sheet is composed of both the front and back sides, if you add a page or mark 
to any side, both the Front and Back boxes under the Template tab of the property 
panel will be checked, and in this case, a relevant blank page or mark will be created on 
the reverse side. Therefore, after the ganging on the front side is done, an identical 
ganging consisting of blank pages and marks will appear on the back side.  

 
Figure 2-307 

Switch to the Page tab, and drag other pages to these blank pages one by one.  

 
Figure 2-308 

By this way, you can greatly improve the ganging efficiency on the back side. You can 
disable this relevance by un-checking the Back boxes of all the front-side pages or marks. 
In this case, there would be no relevant blank page or mark appears on the back side.  
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6.1.6 Submit Signature 
Click the toolbar icon  to open the following dialog box. Check the signature sheet(s) 
you want to submit, and then click OK.  

 
Figure 2-309 

ElecRoc pops up message to inform that the operation is successfully. Close the message 
and switch to the job window, then you can see the generated surface(s) in the output file 
queue under the Composer node.  

The ganged surface(s) can then be sent for further process by nodes like mono or color 
printer, pre-RIP Proof, Rasterizer (then can be further sent to post-RIP proof, 1 Bit TIFF 
Export), PDF Merger (merged file can be further processed as standard PDF file by PDF 
Export), and etc.  

6.2 Create Signature 

6.2.1 About Signature 
A pane on the ganging window is designed for you to view, manage, or perform other 
related operations to the signatures. It can be expanded when you click the Signature 
tab at the left edge of the window.  
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Figure 2-310 

Here shows all the signatures you have created. The signature-related operations can be 
performed with the right-click menu items, or the menu items popped-up when the 
icon  is clicked. Take the item Sheet Info as example, if you choose it, you will then 
open an independent window, learning the information such as printing method, plate 
size, paper size, file type, color mode, and so on.  

6.2.2 Create New Signature 
You can create a new signature by way of:  

 Choose from the main menu File > New Signature;  

 Use the key combination Alt + T;  

 Click the toolbar icon ;  

 Right-click on the Signature pane or the top blank part of the signature editing 
area and choose New Signature;  

 Open the Preference  menu and choose New Signature;  

 When no signature or template is opened in the composer window, double-click 
the signature editing area;  

 If you have already opened a signature or template, right-click the blank area 
above the signature editing area and choose New Signature. If you 
double-click at this moment, you can create a signature based on the latest 
signature settings.  

6.2.3 Signature Properties 
The setup window for creating a new signature is as shown in the below, most of the 
parameters are about the signature’s property.  
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Figure 2-311 

1. From Paper 

From Paper means that the sheet is in the general sense, usually output on the paper. As 
shown above, choose From Paper at the upper-left corner of the window. In this case, 
you will create a signature based on a paper defined by the Paper parameters, i.e. the 
width and height of the paper become the width and height of the signature. Such 
signature appears as follows in the ganging window and the job’s surface preview 
window.  

  
Figure 2-312 

Choose a paper type from the Paper dropdown list in the New Signature window. This 
list provides a variety of optional papers. The paper properties, including manufacturer, 
color of paper white, paper thickness, width and height, are displayed in the below once 
you have chosen a paper, but not editable, you can switch to the Paper tab (at the left of 
the composer window) to modify the paper properties, if needed.  

If the optional papers do not meet your actual need, you can choose the option Custom, 
and then input specific paper size in the then activated Width and Height boxes. You can 
click the button  to exchange the width and height. Manufacturer, Paper White and 
Paper Thickness are optional parameters, with which you can input related descriptive 
information, if needed.  

2. From Plate 
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Your signature can directly base on the plate, i.e. you can make the sheet size equal the 
plate size, and on the sheet, reserve a punch area, add the punch marks, center marks, 
the side guide marks. In the New Signature window, choose From Plate at the 
upper-left corner.  

 
Figure 2-313 

Parameters then can be divided into two parts, Plate Property and Paper Properties. 
You need to specify a plate by way of the Plate Property parameters, at this moment, 
the Paper can be viewed as the area available for the ganging on the plate. Such 
signature appears as follows in the composer window and the job’s preview window.  

  
Figure 2-314 

In the composer window, the largest area (in a light gray background, by default) 
represents the signature based on the Plate Property settings. It consists of a punch 
area, the punch marks, the center marks, the side guide marks, and the paper. The 
default background color for the punch area is slightly darker than that for the signature. 
The blank area without any default background color is defined by the Paper Properties 
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parameters, representing the area available for the ganging, and usually smaller than 
the plate. The background colors for the plate, punch area, and the paper can all be 
customized. The background colors are displayed in the composer window, only for ease 
in the ganging operations; they will not be output on the finally generated signature.  

The plate and paper properties include:  

 Plate properties 

Plate: Choose a plate type from the Plate dropdown list. This list provides some 
commonly-used plate sizes. The plate properties, including device type, width, height, 
punch area, side guide, punch and center marks, are displayed in the below once you 
have chosen a plate, but not editable, you can switch to the Plate tab (at the left of the 
composer window) to re-define the plate properties, if needed.  

If there is no suitable plate for your demand, you can choose Custom, to activate the 
Plate Property and Sheet Marks parameters, including:  

Device Type: Optional, here you can input any related descriptive information.  

Width, Height: Here you can input specific plate size. The button  enables you to 
exchange the width and height.  

Punch Area: If you need to punch in the later-on plate making, you can reserve a special 
area on the sheet for the punching. This parameter controls the width of the punch area. 
Its position is determined by the Benchmarks parameter in the below, it may be at the 
left, right, top or bottom side of the plate. If you don’t need the punch area, you can set 
the value to 0.  

Punch Mark: ElecRoc adds a punch mark  at the center of the punch area.  

 
Figure 2-315 

Center mark: If checked, ElecRoc adds a kind of line marks at the center of the four 
paper sides. Here you can also define the line width and length for this mark.  

Side Guide: If checked, it adds a mark as  onto the sheet, for the side guide on the 
printing press to precisely position the paper. Note that this setting may be of no effect in 
case that the press model does not install the side guide. Checking it, you can further 
define the length, width, line width, position of the mark, the sheet side(s) on which it 
appear, and the separations on which it will be output. The Left and Right boxes control 
which side(s) of the sheet it appears on. The separation options include C, M, Y, K and 
Spot Color. E.g. if you do not want the mark to appear on the spot color separation, you 
can let the Spot Color box unchecked.  
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Benchmarks: It controls the position of the side guide mark. There are four options: top, 
bottom, left, and right, as shown in the below. In the caption such as left/top, the former 
refers to the position of the punch area, the latter the position of the side guide mark.  

 
left/ top              right/ bottom      up/ left           bottom/ right 

Figure 2-316 

 Paper properties 

The Paper and Paper Properties settings are the same as that mentioned in the above 
section on how to create a signature based on a paper.  

Paper Position: It refers to the paper’s position on the plate. The default position is 
centering, i.e. the top and bottom margins are equal, and the left and right margins are 
equal, too. In this case, the four margins are calculated automatically by ElecRoc based 
on the plate and paper sizes. If you uncheck the Center box, you can activate the four 
margin edit boxes, in which you can input custom values. Note that, the sum of the top 
and bottom margins, as well as that of the left and right margins, limited by the plate and 
paper sizes, are fixed. Therefore, if the top margin is changed, the bottom margin will 
change accordingly, so do the left and right margins.  

3. Printing Method 

By way of the Printing Method dropdown list in the New Signature window, you can 
create signatures that support various printing methods. Five printing methods are 
supported: single-sided, sheetwise, work and turn, work and tumble, and perfector.  

 
Single-sided   Sheetwise   Work and Turn   Work and Tumble  Perfector 

Figure 2-317 

6.2.4 Signature Operations 
The signature-relevant operations include:  

1. Open/Close Signature 

Under the Signature tab at the left of the window, you can double-click any of them to 
open it in the signature editing area. If you want to open an outside signature, please 
click the toolbar icon , or choose from the main menu File > Open, and then find out 
your signature from the pop-up dialog box and open it.  

More than one signature can be opened in the editing area. When a signature is opened, 
a tab named with the signature name will appear at the top of the editing area. You can 
click the tabs to switch between the signatures.  
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You can click the icon  in front of the tab, or double-click the tab, or right-click on blank 
area and choose Close, Close Other, Close All, to close the opened signature(s).  

2. Edit Signature 

You need to perform a series of editing operations, such as configuring signature 
properties, adding pages, adding layout, and adding marks.  

1) Configure signature 

The signature properties, including the plate and paper size and other properties can be 
re-defined on the property panel once you choose the signature.  

2) Add pages and marks 

Pages and marks are to be added onto the signature to form a surface. You can add pages 
and marks, configure their properties, perform operations such as alignment, rotation, 
zooming, so as to gang them exactly as you need.  

3) Add layout and blank pages 

The layout is a group of blank pages orderly-arranged in a specific layout. You can add a 
layout or separately blank pages into each signature, and then drag real pages onto the 
layout or blank pages to complete the ganging.  

3. Save Signature 

Click the toolbar icon , or choose from the main menu File > Save, to save the 
signature in current job. In this way, you will not lose the signature data even if you close 
the composer window, the job, or ElecRoc client.  

Click the toolbar icon , or choose from the main menu File > Save as, and you can save 
the current signature with another name and destination.  

If you close the composer window without saving your signature, ElecRoc will pop up 
message suggesting you to save it.  

4. Submit Signature 

After you have finished the ganging of the pages on your signature, you can submit the 
signature to the current job. Click the toolbar icon , or choose from the main menu 
File > Submit Signature to open the Submit Signature dialog box. Check the 
signatures you want to submit, and specify the signature preview resolution, and then 
click OK.  
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Figure 2-318 

The dialog box lists all the signatures existing in the composer window, those checked by 
default are opened ones. If you check Only display the current opened signature, it 
lists only those that have been opened. The buttons Select All and Clear enable you to 
select or unselect all the signatures one time. The valid range for the preview resolution 
is 10~144 DPI. If you have enabled the settings through the main menu Edit > 
Preference > General Parameters > Signature Checking, it can examine the sheets 
and label the error ones. Details on the error, such as the surface is a blank, are displayed 
at the bottom of the dialog box when you choose an error sheet. ElecRoc supports you to 
submit blank signature sheets, but it will pop up message for you to confirm such 
submission in advance.  

The submission starts once you click OK, and a progress bar then appears to show the 
progress. During the progress, you can click Cancel to stop the submission. It pops up 
message informing the result when the submission is completed.  

 
Figure 2-319 

Switch to the job window, and you will then see the submitted surfaces in the output file 
queue under the Composer node.  

5. Copy, Delete and Clear 
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Choose a signature under the Signature tab, and then right-click to open a short-cut 
menu. By using the items herein, you can copy, delete and clear signature. 

Copy a signature: Copy the selected signature to form a new one.  

Delete Signature: Delete the selected signature(s).  

Clear Signature: Delete all the signatures under the tab.  

The above menu items can also be gained by clicking the Preference icon  at the 
upper-right of the signature list.  

6.3 Add Pages 

6.3.1 Ganging Modes 
The interactive manual ganging is the main ganging mode, but in order to improve the 
ganging efficiency, ElecRoc provides also the automatic ganging. The two modes can be 
combined for use.  

1. Manual Ganging 

In this case, the Manual Ganging icon  in the toolbar is checked. It is the default 
mode. Under this mode, you can make various interactive operations and configurations 
to the pages added on the sheet, such as positioning, rotation, and alignment.  

2. Automatic Ganging 

This mode automatically gangs the pages as per your specified page space and margin, 
so as to save your ganging time and improve the efficiency.  

 
Figure 2-320 

Check the toolbar icon  or  to gang pages automatically. The two icons represent two 
sub-modes, re-ganging and additional ganging. A setup window then appears when 
you check any of the two icons. In this window, you can specify the space between pages 
and the margin. Keep the window opened when you have specified the two settings, and 
then add pages to the sheet. The newly-added pages will then be automatically ganged 
as per the specified space and margin.  

1) Re-ganging (check ) 

Each time when you add new pages, it always automatically gangs all the pages on the 
sheet. Under this mode, pages will be arranged towards the lower-left corner of the sheet 
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as close as possible. The setup window is shown as follows:  

 
Figure 2-321 

Page Space: It is the space between any two abutting pages in the horizontal and 
vertical directions. It may be the space between the trim boxes of the two pages, or that 
between the media boxes. The unit for the space can be mm, inch or point.  

Page Margin: It is the margin between the page and the paper edge.  

Rotate 90: If checked, newly-added pages will be rotated 90 degrees before the 
automatic ganging.  

Allow Replacement: If checked, page replacement happens when you drag new pages 
onto the existing pages.  

New Arrange: Arrange all pages on the sheet as per the specified space and margin.  

2) Additional ganging (check ) 

Each time when you add new pages, it only automatically gangs the new pages, i.e. the 
existing pages on the sheet remain unchanged. The parameters are the same as those 
mentioned above.  

E.g. suppose we need to gang an A4 page and an A3 page, each time we add only one 
page, and A4 is prior to A3. In the “re-ganging” mode, as shown at the left, ElecRoc 
re-calculate the positions of all the pages, even if A3 is added later, it may be placed in 
front of A4, at the lower-leftmost corner. In the “additional ganging” mode, as shown at 
the right, ElecRoc only arranges the newly-added pages each time, A3 is added later, so 
it is placed behind A4.  

 
Figure 2-322 
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6.3.2 Add Pages 
To add pages to the sheet, you need only to choose the pages at the left of the window, 
and then drag them to the sheet.  

1. Page Sources 

At the left of the ganging window, you can choose the pages to be ganged under the 
Page tab.  

Here lists all the pages you have submitted to the Composer node. In case that you 
submit pages once again while the composer window is opened, please manually refresh 
so that you can see the newly-submitted pages under this tab in time.  

By default, the pages are shown in form of the thumbnail images. You can click the icon  
at the upper-right of the pane to switch to the list view.  

 
Figure 2-323 

Note: The composite and pre-separation pages cannot be ganged on a same sheet. 
Choose a page, right-click and choose Page Info, and you can then see if the page is a 
composite or a pre-separation one.  

2. Page Sequence 

Under the manual or automatic ganging mode, if you choose multiple pages one time and 
drag them to the sheet, their default page numbers on the sheet are dependent on their 
sequence in the page list.  

Methods to adjust the page sequence are as follows:  

1) Under the list view, available under the Page tab:  
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 Click column head in the table to sort it in ascending/descending order;  

 Choose one or more pages, and then click the icons /  to adjust;  

 Choose one or more pages, and then use the commands Up, Down, Move to 
top, Move to bottom, and Move to, from the right-click menu or the 
Preference  menu.  

2) Under the thumbnail view, available under the Page tab:  

 Choose one or more pages, and then click the icons / , or use the following 
commands from the right-click menu or the Preference  menu.  

Up: To move the selected page up one row in the table.  

Down: To move the selected page down one row in the table. 

Move to top: To move the selected page to the top row of the table. 

Move to bottom: To move the selected page to the bottom row of the table. 

Move to: To move the selected page to a specified row of the table.  

Note: The page sequence will be reset according to their sequence in the input file queue 
under the Composer node, when you reboot the composer window.  

3. Intelligent Page Selection 

For your convenience to choose multiple pages one time for ganging, both the 
Preference  menu and the right-click menu, under the Page tab, provide the 
following four commands.  

Select All: To select all the pages in the page list one time.  

Select odd page: To select all the odd pages in the page list one time.  

Select even page: To select all the even pages in the page list one time. 

Reverse Select: To select all the unselected pages in the page list one time.  

4. Add Blank Page 

ElecRoc supports you to add blank page to the sheet. Click the toolbar icon , or choose 
from the main menu Resource > New blank page to open the following dialog. Input 
the page numbers, the width and height of each page, and then click OK.  

 
Figure 2-324 
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6.3.3 Page Positioning 
The page position can be defined in any of the following ways:  

 Use mouse to drag freely;  

 Enable the capturing capacity;  

 Configure parameters on the property panel;  

 Use the moving/nudging capacity.  

1. Drag Page 

As the simplest way, you can directly choose the page and then drag and move it freely 
on the sheet. When you move the page in this way, you can refer to the rulers or the 
pop-up coordinates at the lower-left corner to determine the adequate position.  

2. Capture Page 

You may notice that while the page is being moved, it may automatically be captured to 
some specific positions, such as the plate borders and the grid lines. ElecRoc provides the 
capacity to capture the page to auxiliary tools or other positions, so that you can position 
the page on the sheet more easily and precisely.  

1) Capture to plate and paper 

When the object approaches to the borders of the plate or the paper, or the middle lines, 
it will be aligned with them closely and automatically.  

 
Figure 2-325 

2) Capture to grid 

Choose in the main menu Tools > Show Grid, to show the grid on the sheet, and 
meanwhile, choose in the main menu Tools > Capture Grid. Now, when you move the 
page close to the grid lines, you will see two crossed register lines in red on the sheet, 
and the page will be automatically captured to the exact position where the grid line is.  
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Figure 2-326 

The space between any two grid cells can be defined by way of the main menu Tools > 
Grid Spacing. And the color of the grid lines can also be defined by way of the main 
menu Edit > Preference > Color Settings.  

3) Capture to guides 

You can add horizontal or vertical guiding lines to the sheet. When the page approaches 
to the line, it will be automatically captured to the position where the line is. As the grid 
lines do, the guiding lines bring ease in page positioning.  

1. Show guides. Choose from the main menu Tools > Show Guides.  

2. Add guides. Place the cursor over the ruler, and then press down the left mouse 
button and drag toward the sheet editing area, and then release the mouse button at 
proper place. A setup dialog box appears. Input the precise coordinates, and then click 
OK.  

If you click the dashed cross  at the upper-left of the sheet editing area (at the left of 
the horizontal ruler, and the top of the vertical ruler), and then press down the mouse and 
drag to the editing area, you can add two cross guides at the same time.  

 
Figure 2-327 
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3. Capture to the guides. Choose from the main menu Tools > Capture Guides. 
When you drag the page and make any edge of it approach to a guide line, the page will 
be automatically captured to the position where the guide line is located.  

 
Figure 2-328 

4) Capture to other positions 

You can also capture the page to other pages or marks. Such capacity is enabled if you 
check items Capture page and other layout elements and Capture Mark, under the 
main menu Tools.  

3. Position Coordinates 

You can use the coordinates to precisely define the page position.  

1) Define the coordinate system 

The default coordinate system is originated at the lower-left corner of the sheet. In 
practice, you can choose another origin to re-build the coordinate system. Click the 
toolbar icon . The editing area then becomes entirely grayed. Move the cursor on the 
sheet, and you will see two cross lines, their crossing is the origin of the new system. 

If you press down the Ctrl or Alt key meanwhile, you can choose to use one of the 
commonly-used coordinate systems built on the plate or plate element.  

 
            Press down Ctrl                              Press down Alt 

Figure 2-329 
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If you don’t press down the Ctrl or Alt key, when you move the cursor alone to proper 
position and click the left mouse button, you will open a setup dialog box. The Origin 
Location refers to the coordinates of the new origin on the default coordinate system. 
Coordinate Axis refers to the directions of the X and Y axes.  

 
Figure 2-330 

2) Define the coordinates 

The Position parameter on the property panel controls the exact position of your page 
on the sheet. The coordinates define the position of actual page content, irrespective of 
whether it contains bleed or not.  

Nine anchor points: They represent nine anchor points on the page. Except the central 
point, the rest eight points are all located on the borders. Your chosen point is displayed 
in red on the page. The X and Y are just the coordinates of this anchor point on the 
coordinate system.  

4. Move/Nudge Page 

1) Move the page 

To move a page, you can choose the page and then click the toolbar icon  or choose 
from the main menu Edit > Move, to open a setup dialog box. Input the distance you 
want to move in the horizontal and vertical directions, and then click OK. You can input 
negative values.  
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Figure 2-331 

2) Nudge the page 

Choose the page and then press the arrow keys to nudge the page. When you click the 
key once, you move the page one time. The page is moved in the direction indicated by 
the arrow key, at a distance specified by the main menu Edit > Preference > 
Appearance Settings > Offset Step.  

5. Lock/Unlock 

After you have determined the page position, you can lock it, so as to prevent it from 
being unintentionally moved. You can lock a page in any of the following ways:  

 Click the toolbar icon ; 

 Right-click and choose Lock;  

 Choose from the main menu Object > Lock;  

 Use shortcut keys Ctrl + L.  

Being locked, a symbol  appears at the upper-right corner of the page. The icon, the 
menu item, and the shortcut keys used for unlocking the page are , Unlock and Ctrl + 
Shift + L.  

6.3.4 Page Properties 
The property panel located below the sheet editing area can show the properties of a 
page when you choose this page. The two tabs divide properties into two groups, 
Template and Content.  

 
Figure 2-332 

1. Template Page 

Template page is a kind of pages used for modeling. It does not contain any real content, 
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but it does define the position of the page on the sheet, the space size of the page on the 
sheet, the rotating direction, whether it contains the front and/or back side, the bleeding 
size, whether it is knocked out, whether it contains cutline marks, and the position and 
scaling for the content it will contain, and the page number, and etc.  

For your convenience to create ganging template, each time after you create a sheet and 
drag real pages into it, ElecRoc will automatically base on the properties like size and 
position of the real pages to generate corresponding template pages, so that you can 
extract a template from these pages easily, if needed. Therefore, by default, the 
properties of the template page are entirely the same as those of the real page.  

2. Rotate 

You can choose any of the following methods to rotate the template page.  

 Under the Template tab on the property panel, choose the Rotate arrows , , 
 or , your chosen arrow is then shown in highlight;  

 Choose the icons ,  or  in the toolbar;  

 Choose from the main menu Object > Rotate > Rotate 180, or Rotate 90 
(Clockwise), or Rotate 90 (Counterclockwise);  

 Use shortcut keys, press down Alt, and meanwhile press an arrow key.  

By default, the rotating direction of the page content is the same as that of the template 
page. But you may also specify a different content direction. To do so, switch to the 
Content tab, and choose a different Rotate arrow.  

3. Front and Back 

When the printing method is set to Sheetwise, or Work and Turn, or Work and 
Tumble, or Perfector, and you add a page or mark onto the sheet or onto any side of 
the sheet, by default, both the Front and Back boxes on the property panel will be 
checked, and a relevant blank page or mark will appear on the opposite or reverse side. 
Its properties such as size, position and direction are the same as the added page or 
mark or keep relevance with each other.  

You can uncheck any of the two boxes to delete the page or mark on the converse side.  

4. Size 

The size of the template page may be not equal to the size of the page content. If the 
content size is smaller than the page size, and meanwhile the content is not scaled, then 
part of the content may be cut off after the output. If the content size is larger than the 
page size, and still the content is not scaled, then there would be much space around the 
content.  

By default, the size of the template page is equal to that of the page content. If needed, 
you may also modify the size of the template page.  

 Choose the page and move the cursor to any anchor point on the page border, 
turning the cursor to an arrow like , and then press down the left mouse 
button and drag it. In this way, you can adjust the page size freely;  

 Under the Template tab on the property panel, input proper Size values.  

5. Bleeding 

The Bleeding parameter controls the size of the bleed box of the template page.  

1) Show bleed box: Choose from the main menu View > Show bleeding box;  
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2) Color of the bleed box: The main menu Edit > Preference > Color Settings > 
Bleeding Box.  

3) Default bleeding: The main menu Edit > Preference > General Parameters > 
Default Bleeding.  

6. Cut Line 

It includes external cutline and internal cutline. If checked, ElecRoc will add 
corresponding cut line marks at the four corners of the page. The default line width and 
length of the marks are determined by main menu Edit > Preference > Mark 
Parameter > Cut Line. After you have added this mark, you can change the line width 
and length from the property panel, if needed.  

7. Knock out 

If not checked, after the surface has been screened by PDF Rasterizer, at the overlapping 
area between two pages, the content from the lower page will be covered, as shown at 
the left. If checked, the content from the lower page will appear at the transparent 
overlapping areas.  

 
Figure 2-333 

6.3.5 Page Content 
You can also configure the properties of the page content in the ganging, mainly through 
the parameters under the Content tab on the property panel.  

 
Figure 2-334 

1. Page Position 

It refers to the position of the page content on the page size defined by the template page. 
The default position is at the center of the page. You can choose other position from the 
nine-point diagram, and the then activated Horizontal Offset and Vertical Offset edit 
boxes enable you to input appropriate offset values.  

Lock front and back: In case that the printing method is set to a method other than 
Single-sided, this option can then control the positional relevance between the contents 
on the front and back sides. E.g. in Sheetwise, if the content on the front side moves 
leftward, then the content on the back side will automatically move rightward, with same 
offset value, vice versa.  
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2. Rotate 

You can control the direction of the page content on the template page through the four 
arrows.  

3. Zoom 

Here refers to the scaling ratio of the page content to its original size.  

 Input the percentages in the Horizontal and Vertical edit boxes on the 
property panel;  

 Click the toolbar icon ;  

 Choose from the main menu Object > Zoom.  

When you choose the latter two methods to scale the page content, you will open an 
independent setup window. In this window, you will not only see information on the page 
name and size, but also choose more flexible scaling options.  

 
Figure 2-335 

No Zoom: To cancel the scaling setting, i.e. to restore the content to its original size.  

Content scaled to fit the template: To automatically scale the content according to 
the size of the template page, making the content fully fill in the page.  

Custom Zoom: You can customize the scaling percentages in the horizontal and vertical 
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directions, or you can specify the width and height of the content after the scaling. If you 
check Same proportion scaling, the scaling percentages in the horizontal and vertical 
directions will remain the same.  

4. Page Clipper 

Choose a page and use any of the following methods to open the Page Clipper window.  

 Click the toolbar icon ;  

 Choose from the main menu Edit > Page Clipper;  

 Right-click and choose Page Clipper.  

 
Figure 2-336 

What you need to do is to define a suitable crop box. The page content outside of the crop 
box is cut off at last. To adjust the size and position of the crop box, you can freely drag 
the box or its anchor point, or you can also input the precise coordinates, width and 
height. The toolbar at the top also provides some control icons for you to define the 
position and size with ease.  

Click the toolbar icon  when you have defined a proper crop box. For more information, 
refer to the section 4.3.2 Page Clipper.  

5. Front & Back Content Swap 

ElecRoc supports you to swap the content between the front and back pages.  

On the front or back side of the sheet, choose the page(s) and then click the toolbar 
icon , or choose the main menu Edit > Front Back swap, and then you can do the 
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content swapping.  

6. Page Swap 

ElecRoc supports you to swap the content between any two pages.  

On the sheet, choose any two pages and then click the toolbar icon , or choose the 
main menu Edit > Swap, and then you can do the content swapping.  

7. Manual Swap 

ElecRoc supports you to manually swap the content between two pages.  

Choose the toolbar icon , and then drag a page onto another page, and you will see the 
cursor turning to , release the mouse button and then you do the content swapping.  

8. Fit Page 

This function can re-set the page size according to the content size. It is usually applied 
to the case when the content size becomes different from that of the page.  

To do so, choose the page and then click the toolbar icon  or choose the main menu 
Object > Fit.  

6.3.6 Page Operations 
1. Layer Structure 

You need to know about the up and down relations in case that two or more pages are 
overlapping each other. ElecRoc views each page as a unique layer. And the upper layer 
always overlaps the lower one. By default, ElecRoc judges if a layer is old or new by the 
time it is created, the newer layer always overlaps the older one, i.e. the newer layer is 
in the upper, the older one is in the lower. This sequence can be customized.  

The layer sequence and classification can be viewed in the Layer Structure pane. 
Choose from the main menu View > Layer Structure to display this pane.  

 
Figure 2-337 
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To change the layer position in the sequence, choose the page, and then do any of the 
following:  

 Click the toolbar icons , , , ;  

 Choose from the main menu Object > Arrangement > Bring to front, or 
Send to back, or Bring forward, or Send backward.  

2. Efficient step & repeat 

Copy repeatedly one single page so as to produce multiple pages arranged according to 
certain sequence and page space.  

Click the toolbar icon , or choose from the main menu Edit > Efficient step and 
repeat, to get a floating setup dialog box, with the cursor turning to .  

 
Figure 2-338 

And then, choose the page, press down the left mouse button and drag it on the sheet. 
You will then see new pages being formed on the sheet around the base page. Release 
the mouse when it has produced the number of pages you want to produce.  

 
Figure 2-339 

Parameters related include:  

Benchmarks: Trim box to trim box refers to use the distance between the trim boxes 
of the two pages as the page space, while Media box to media box refers to that 
between the media boxes of the two pages.  

Space: The page space between any two pages in the horizontal and vertical directions.  
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Group: To combine the base and new pages into a group after the step and repeat.  

Locked Page: To lock the base and new pages after the step and repeat.  

External/Internal CutLine: To include cutline marks on all the new pages after the 
step and repeat.  

Only Front: The cutline marks only appear on the pages in the front side of the sheet.  

Bypassing page: To bypass the existing page on the sheet. I.e. at the place where an 
existing page is located, it does not produce any new page.  

Bypassing mark: To bypass the existing mark on the sheet.  

Bypassing group: To bypass the existing group on the sheet. 

3. Smart step & repeat 

Choose from the main menu Edit > Smart Step and Repeat, and you will open a setup 
window as shown in the below, so as to perform a smart step & repeat operation.  

 
Figure 2-340 

More options become available, compared to the rapid step & repeat setup window.  

Direction of step and repeat: Starting from one corner, step and repeat toward the 
opposite corner. Thus there are 4 directions. By default, ElecRoc can automatically 



                      User Guide 

 32
 

322 

choose a proper direction, but if needed, you can choose any other direction.  

Fill the entire paper: To generate multiple pages till they fill the entire paper.  

Page Arrange: To generate a specified number of pages in both the horizontal and 
vertical directions, as defined here.  

Fill Area: To generate multiple pages till they fill the area as specified here.  

Center Page: To center the base page and generated pages on the sheet. 

4. Alignment 

After you have added multiple pages into the sheet, you may need to align them.  

1) Selection of multiple pages 

To choose or select more than one page (or page object) at one time, you can do any of 
the following:  

 Press down the Ctrl key at the same time;  

 Press down the left mouse button on any blank area inside or outside the sheet, 
and then drag it in any direction to form a rectangle. In this way you can choose 
all the pages inside the rectangle.  

After you have chosen multiple pages, you can perform not only the page alignment, but 
also the operations like moving, cutting, copying/pasting, deleting, rotating, and 
configuring the bleed, the size, and etc.  

2) Align pages 

You can align pages in any of the following ways:  

 Click the toolbar icons , , , , , , ; 

 Choose the menu items corresponding to the above icons: Object > 
Alignment > Vertical align top/ Vertical align center/ Vertical align 
bottom/ Horizontal align left/ Horizontal align center/ Horizontal align 
right, and Object > Center > Horizontal and vertical/ Horizontal/ 
Vertical.  

The default benchmark is the firstly selected page, but this can be re-defined manually. 
After you have chosen multiple pages, click one of them once again to make it the 
benchmark page. The anchor points on the benchmark page are shown in dark, while 
those on the rest pages are in white.  

The alignment is applied to all page objects, including pages, marks, and groups.  

5. Grouping 

You can combine multiple pages or marks as one group. The relative positions of the 
objects each other within the group are fixed, so that they can be ganged as a whole.  

1. Choose the pages you want to group.  

2. Click the toolbar icon , or choose from the main menu Object > Group.  

To break the group, you can choose the group and then click the toolbar icon , or choose 
from the main menu Object > Ungroup.  

6. Cut, Copy, Paste, Paste Hold, Delete, Delete Contents 

ElecRoc supports some basic and commonly-used operations on the pages such as 
cutting, copying, pasting, and deleting. In fact, these operations are also applied to the 
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page groups and marks on the sheet. Besides, ElecRoc also supports two other 
operations on the pages, pasting hold and deleting content.  

Paste Hold: The new page and the original one will be located at the same position after 
the pasting, visually overlapping each other.   

Delete Contents: Delete the content of the page, making the page a blank one.  

These operations can be performed in many ways:  

 Choose the page and then click the toolbar icons , , , , ;  

 Right-click and choose Cut, Copy, Paste, Paste Hold, Delete, Delete 
Contents;  

 Choose from the main menu Edit > Cut/ Copy/ Paste/ Paste Hold/ Delete/ 
Delete Contents;  

 Shortcut keys. Cut: Ctrl+X; Copy: Ctrl+C; Paste: Ctrl+Shift+V; Paste Hold: 
Ctrl+V; Delete: Delete; Delete Contents: Ctrl+Delete.  

6.4 Add Marks 

You can add a wide range of marks to the sheet.  

6.4.1 Mark Type 
The marks that can be added to the sheet include:  

1) Plate marks. On the sheet based on the plate, you can add punch marks , the side 
guide marks such as , and center marks. For details, refer to From Plate in section 
6.2.3.  

2) Cutline marks. You can add the cutline marks such as  to the four corners of any 
page on the sheet. Refer to Cut Line in section 6.3.4 for details.  

3) Default layout marks. Whenever you create an imposition, by default ElecRoc will 
automatically add some marks, including cut lines (e.g. ), fold marks ( or ), cross 
marks , registration marks ( or ), CMYK marks (e.g. ), and text 
marks (e.g. ). For details, refer to Default 
Layout Marks in section 6.5.3 and Mark Parameter in section 6.6.7.  

4) Smart marks. It’s a kind of dynamic mark that can move smartly along with other 
sheet object. The cutline marks, the most of the static marks, and the custom marks, can 
be added as smart marks into your sheet. Their positions on the sheet are based on and 
associated with specific sheet object, such as plate, paper, page, and layout. Once these 
base objects move, they move as well. In this way, you do NOT need to re-set the marks 
in cases that the pages on the sheet are to be changed. This provides great convenience 
for you to create imposer template. 

5) Static marks. ElecRoc provides 17 built-in marks available for you to manually add to 
the sheet. They include cross reverse mark , internal target mark , oval target mark , 
cross mark , external target mark , line mark , vertical line mark , solid target 
mark , rectangular reverse mark , T mark , three-fold mark , CMYK proof bar 
(three ones ,  and ), color bar , step scale , and text mark . 

6) Custom marks. You can add custom marks into ElecRoc system, for use in ganging. For 
details on how to add custom marks into ElecRoc, refer to the section 6.6.4 Define Marks.  
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6.4.2 Smart Marks 
As shown in the following figure, the bar mark  located at the lower-left corner of 
each page is a smart mark. As an example, it will always appear at the lower-left corner 
of each page, whenever you move the layout, or modify the number of pages, or change 
the page size, or even the page space.  

 
Figure 2-341 

Method to add smart mark: as shown above, ①, at the left of the window, expand 
Mark > Smart Mark and define smart mark here; ②, choose the defined smart mark, 

drag it into the sheet; at this point you have finished the adding operation; ③, for 
convenience to choose the added smart mark for further operation, you can open the 
Layer Structure panel (from main menu View > Layer Structure) to choose the 
mark.  

1. Mark Directory 

In order to improve the usability and efficiency, ElecRoc enables you to create smart 
mark template and manage the templates by way of directory. As the default directory 
and the root directory, the directory Smart Mark can be used straight to store your smart 
marks. And if needed, you can create sub-directory under it: choose Smart Mark, 
right-click and then choose Create Directory. User-defined sub-directory can be 
deleted or renamed via right-click menu items, if needed.  

2. Define Smart Mark 

1 

2 

3 



Using ElecRoc Client 

 325 

The mark setting defined here is sort of a parameter template for your smart mark, 
aiming to provide easiness for repetitive use.  

Choose a directory, right-click and choose New, and then choose a mark type. The 
mark’s property setup window then appears. Define each of the parameters, and then 
click Save to save the setting under your chosen directory. If you click Save and apply, 
you can not only save the setting, but also add the mark into the current sheet.  

 

Figure 2-342 

Here we introduce only the property parameters specific to the smart marks. As to other 
parameters, please refer to the section 6.4.4 “Mark Properties”.  

Name: The name for the mark property setting.  

Type: The specific mark type, for example, the bar mark contains 5 specific types.  

The position of the smart mark is dynamic and associated. It’s a relative position, and 
thus needs to be defined by way of some reference variables.  

Base: Please choose a sheet object or sheet location from the Base dropdown list, only 
on which you can further define the exact position for the mark. The base could be plate, 
paper, imposition, imposition bleed, page, page bleed, gutters, and margin. For example, 
if you choose the page as base, the smart mark will then appear at certain position on 
each page; if you choose imposition, the smart mark will then appear at certain position 
on the layout. The bleed in page bleed or imposition bleed means to use the bleed box of 
the page or imposition as the base.  

Base diagram: The base position is further divided into 9 smaller points, top, bottom, 
left, right, center, upper-left, lower-left, upper-right, and lower-right. The smart mark 
will be located at one point of them.  

Target diagram: The selected base point can be further divided into 9 directions. The 
following figure shows a smart rectangle mark’s positions when the base is page and the 
base point is lower-left, but the target direction is respectively set to lower-left, bottom, 
and lower-right.  
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Figure 2-343 

X, Y: When you have defined the exact position by way of the above three parameters, 
you can still make the mark move horizontally and vertically by way of the X and Y edit 
boxes, if needed. A positive X value means to move towards the right, while a positive Y 
value means to move upwards. Negative values mean to move in reverse directions.  

3. Add 

You can add a smart mark if you click the button Save and apply in the mark’s property 
setup window.  

You can also add the smart mark after you have defined the mark, by choosing the mark 
and then dragging it to any place on the sheet.  

By using right-click menu items, you can also add smart mark after you have defined the 
mark: choose the mark, right-click and choose Add to. The sub-option current sheet 
means to add the mark into current sheet, while the sub-option all sheets means to add 
the mark into all the sheets of the current template.  

4. Edit, Delete 

To edit an added smart mark: we recommend you to open the Layer Structure panel 
when you are using the smart marks, see the figure ① in the below. This panel lists all 
the smart marks that have been added onto the sheet. Choose a mark, right-click and 
choose Edit, to open its property setup window. Re-define the parameters and then click 
Save.  

      
Figure 2-344 

1 
2 
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To edit a smart mark parameter template: at the location as shown in above figure ② 
you can also edit the smart marks, by way of right-click menu items. In this way, you can 
re-define the properties of the mark template, for repetitive use.  

Delete a mark: The right-click menu item Delete enables you to delete an unneeded 
smart mark. The already-added smart mark on your sheet can also be deleted by using 
the Delete key on your keyboard.  

5. Import, Export, Copy 

ElecRoc supports you to import and export the smart mark templates. This operation can 
be completed with the right-click menu items.  

6.4.3 System and Custom Marks 
The way to add the static and custom marks is as follows. Click the toolbar icon  , or 
check the Mark tab at the left of the composer window to expand the optional static or 
custom marks. Then choose one mark and then directly drag it to the right sheet editing 
area, and release the mouse at proper position.  

Note: The custom marks are from PDF pages, thus are in two types, composite and 
pre-separation. ElecRoc does not support you to combine these two types of marks onto 
one same sheet.  

6.4.4 Mark Properties 
You can define the mark properties through the parameters on the property panel. But 
the properties for various marks are different. E.g. the property panel for the mark  is 
shown as follows.  

 
Figure 2-345 

While that for the CMYK proof bar 3  turns to: 

 
Figure 2-346 

The property parameters for the static mark include:  

 Position 

It refers to the position of the mark on the sheet coordinate system.  

 Rotate 

The orientation of the mark on the sheet.  

 Front, Back 

They control if the mark appears on the front side, or the back side, or both sides.  

 Line width, Line height 
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The line width and height of the mark. The default line width and height can be defined 
from the main menu Edit > Preference > Mark Parameter > Other Mark.  

 Color 

This parameter is available only for the line mark , vertical line mark , and step scale 
mark . Optional colors include black (cmyk or mono), cyan, magenta, yellow, red, 
green, and blue. Besides, you can also use custom color.  

Customize mark color: If you choose Custom, you can customize a color in CMYK 
mode.  

 Only on black 

This option is available for such marks as , , , , , ,  and . If checked, 
the mark will be displayed and output only on the black separation.  

 Bar mark features 

The following parameters are specific to the CMYK proof bars and color bars.  

Color block size: Each color bar is composed of multiple same-sized square blocks. This 
parameter controls just the side length of such blocks. In this way, it controls the size of 
the whole color bar.  

Throughout the layout: If checked, the bar is repeated backwards throughout the 
layout, starting from the place where the bar is located.  

Spot Color: If checked, it adds the spot color block(s) at the end of the color bar. The 
spot colors are those contained in the current sheet.  

Insert 50% color blocks: This option is available only for the CMYK proof bar 3. If 
checked, it adds the 50% K, C, M and Y blocks, and if the Spot Color option is checked 
at the same time, it also adds 50% spot color block(s).  

 Text mark features 

Width, Height: The text size is controlled by Height. After you have defined the height, 
you should define a width big enough to wholly display the text.  

Comments: You can randomly input any text, or you can also add variables such as 
surface name, time and date, which separately refer to the name of the current sheet, 
the current time, and the current date.  

Surface: Two options, Front/Back and A/B, are available for you to indicate the front 
plate and back plate. Choose the style you prefer. Take the option Front/Back as example, 
if the Comments parameter has contained the variable Surface, at the time being 
output, the comments appearing on the front side of the your sheet will then contain the 
text Front, while the back side contains the text Back.  

Font: Font for the comments, Song Typeface, Boldface, Tahoma, Batang, or MingLiu. 
And if needed, you can check Bold to make the comments boldfaced.  

Swap: If checked, the text Front/Back or A/B in the mark will be swapped each other.  

Sheet ID: The ID of the sheet. You can customize the first ID, and control if to number 
in sequence algorithm. When the Comments parameter has contained the variable 
Sheet ID, at the time being output, the comments appearing on the sheet will then 
contain the ID defined here.  

Binding > Signature ID: If checked, when the Comments parameter contains the 
variable Signature ID, the ID will be bound with the signature specified in the dropdown 
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list below.  

Vertical text: If checked, the characters will be arranged vertically.  

6.4.5 Edit Marks 
The mark-related operations, such as moving, copying, pasting, deleting, grouping, are 
the same as those related to the page. For details, refer to the introductions above.  

6.5 Use Ganging Template 

You can gain powerful ganging and folding capacities approximate to the imposer.  

6.5.1 Extract Template 
You can extract the sheet setting, as well as the properties of the pages on the sheet, to 
form a ganging template, for repetitive uses. Click the toolbar icon , or choose from the 
main menu File > Extract Template to open the following setup dialog box. Choose a 
template directory and input the template name, and then click OK.  

 
Figure 2-347 

The icons , ,  in the dialog box are used separately to create, delete and rename 
the template directory.  

6.5.2 Create Template 
Instead of extracting a template, you can separately create a new template, especially a 
one containing a layout, through a special user interface. Generally, you need to go 
through the following operations.  

1. Choose Directory 

This directory is designed for classification and management of the ganging templates. 
Choose the Template tab at the left of the ganging window to expand the directory 
structure. The Ganging Template is the root directory, under which you can directly 
store your ganging template.  
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ElecRoc supports you to create a directory. First, choose an existing directory, e.g. the 
root directory, as the superior directory of the new one. Then, click the Preference 
icon  or right-click, and choose Create Directory. And then, input the directory name 
in the pop-up dialog box, and click OK.  

 
Figure 2-348 

2. Create Template 

Steps for creating a template are as follows:  

1. Choose a template directory. As mentioned above, please choose one directory under 
the Template tab, and if needed, you can create a new one. The default is the root 
directory, i.e. the Ganging Template.  

2. Do any of the following:  

 Click the toolbar icon ;  

 Right-click and choose New Template;  

 Open the Preference  menu and choose New Template;  

 Choose from the main menu Resource > New Template.  

3. Now you will open the New Template window. This window is very similar to the New 
Signature window. Please define the template name, printing method, plate size, paper 
size, and other properties, and then click OK.  

 
Figure 2-349 
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4. The newly-created template then appears in the ganging window.  

 
Figure 2-350 

At the left, you see the name has been added to the template directory, while at the right 
ElecRoc spreads the editing interface.  

3. Edit Template 

It is basically a blank template after you have completed the above steps. Therefore, you 
may need to perform further a series of editing operations, such as configuring the sheet 
properties, creating a layout, adding pages, and adding marks.  

1) Sheet properties 

If your sheet is based on a plate, you can see the size and other properties of the plate 
on the property panel once you choose it, and you can re-define all of its properties.  

Same as the plate, the size and other properties of the paper can also be re-defined.  

2) Add a layout 

The layout here refers to a group of pages orderly arranged in a specific layout. For 
details, refer to the section 6.5.3 Create Layout.  

3) Add pages 

Add blank page: Click the toolbar icon , or choose from the main menu Resource > 
New blank page.  
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From real pages: Choose pages to be ganged from the Page tab at the left of the 
ganging window, and then drag them to the sheet. You can base on these real pages to 
form the template pages.  

For page-related operations and configuration of the page properties, refer to relevant 
introductions in section 6.4 Add Pages.  

4) Add marks 

To add a mark, choose a mark under the Mark tab at the left of the ganging window, 
and then drag it to the sheet. After you have added a mark, you can re-define its 
properties on the property panel.  

4. Save Template 

Click the toolbar icon  , or choose from the main menu File > Save.  

6.5.3 Create Layout 
To create a layout in your template, do as follow: click the toolbar icon , or choose from 
the main menu Resource > New Layout, to open the following setup window, define 
the parameters as needed, and then click OK.  

 
Figure 2-351 

Note: You can also directly create a layout on the sheet of your signature.  
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1. Layout Properties 

Rows Number: The rows number of the pages in the layout on the front side. That on 
the back side is the same, if the template contains the back side.  

Columns Number: The columns number of the pages in the layout on the front side. 
That on the back side is the same, if any.  

E.g. you can set to 3 rows and 2 columns, which indicates that the layout would contain 
3×2=6 pages on the front side, i.e. 3 rows of pages and each row contains 2, or 2 
columns of pages and each column contains 3. If the template has the back side, it 
contains 6 pages as well on the back.  

Alignment: Available in 4 most popular page alignment modes, up, down, head to head, 
and foot to foot.  

Rotate: To rotate the page and page content. Options include 0o, 90o, 180o, and 270o 
counter-clockwise.  

Offset: This setting controls the layout position on the template sheet. By default it is at 
the center. When you use the nine-point diagram to choose other position, you can use 
the X and Y to define the horizontal and vertical offsets related to the anchor point.  

Lock: If checked, the layout’s position on the sheet will be locked. A locked layout cannot 
be deleted or dragged in any direction on the sheet. And a symbol  will appear at the 
upper-right corner of a locked layout.  

2. Page Properties 

The properties include the page size and the orientation. The Size dropdown list provides 
some commonly-used standard sizes for you to choose from. You can also choose 
Custom to specify any other page size.  

3. Margin 

Page space: The space between two pages, as shown in the below by the area enclosed 
by red dashed lines, available in two directions, horizontal and vertical.  
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Figure 2-352 

The top space horizontally is shown as a1, i.e. the distance from the middle of the 
horizontal page space to the upper page. The bottom space horizontally is shown as a2, 
i.e. the distance from the middle of the horizontal page space to the lower page.  

The left space vertically is shown as b1, i.e. the distance from the middle of the 
horizontal page space to the leftward page. The right space vertically is shown as b2, i.e. 
the distance from the middle of the horizontal page space to the rightward page.  

Layout margin: The blank space bordering the layout on the sheet, as shown by the 
area enclosed by green dashed lines.  

The top margin is shown as c1, i.e. the distance between the top side and the page. The 
bottom margin is shown as c2, i.e. the distance between the bottom side and the page. 
The left margin is shown as d1, i.e. the distance between the left side and the page. The 
right margin is shown as d2, i.e. the distance between the right side and the page. 

4. Preview 

At the bottom of the New Layout window shows a thumbnail image of the layout. If you 
press down the mouse button on the thumbnail, you will get a zoomed-in thumbnail 
image floating on the window, as shown in the below. At this moment, you can drag the 
mouse to zoom in any other position on the layout.  

 
Figure 2-353 
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5. Default Layout Marks 

You may see some marks on the layout when you zoom in the thumbnail image. These 
marks are automatically added by ElecRoc, and they may include cutline marks, fold 
marks, cross marks, registration marks, CMYK marks, text marks, and other marks.  

Choose from the main menu Edit > Preference > Mark Parameter to configure what 
marks by default will be added when you create a layout.  

Only the black: If checked, the default marks will be displayed and output only on the 
black separation.  

6.5.4 Configure the Layout 
After you have created the layout, you can continue to configure its properties.  

1. Layout Properties 

 How to select a layout 

Move the cursor over any border of the layout, wait till it turns to  and then click the 
mouse. Or press down the left mouse button at any blank area on the plate, then drag to 
form a rectangle, ensuring the rectangle cover at least one page, and then release the 
mouse button.  

 The property panel for a layout 

The property panel shows the layout-related properties once you have selected the 
layout. Through these parameters, you can view and re-define the layout properties.  

 
Figure 2-354 

 Layout-related operations 

1) Make use of the capturing capacities to change the layout position by drag-and-drop;  

2) Use the toolbar icons , , , , , , , , , , , or corresponding 
commands from the main menu or right-click menu, to perform such operations to the 
layout as cutting, copying, pasting, deleting, moving, centering, rotating, ungrouping, 
and locking.  

Note that, it is no longer a layout after being ungrouped, and all its pages would then 
become independent from each other.  

3) As one group object, when being selected together with other sheet objects, the layout 
can be in alignment with them, by way of the toolbar icons , , , , , , , or 
corresponding menu items.  

4) Click the toolbar icons , , , , or corresponding menu items, to adjust the 
sequence of the layout as a layer related to other layers.  

2. Page Properties 

After you have created a layout, you can still re-define part of the page properties.  

 Define page number 
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Choose a page and expand the Content tab on the property panel, and then input the 
page numbers in the Front and Back edit boxes.  

Click the toolbar icon , or choose from the main menu Edit > Set page number to 
open a setup dialog box. Input the page numbers for both the front and back sides, and 
then click on some page to apply the input numbers to the page. The numbers in the 
dialog box will increase incrementally after the clicking.  

 
Figure 2-355 

 Configure content properties 

Properties of the page content are controlled by the parameters under the Content tab 
on the property panel. They include the offset, rotation, and the locking of the front and 
back sides. Refer to related introductions in section 6.4 for details.  

3. Other Objects 

Here mainly refer to the marks and page space.  

 Mark 

1) You can add cutline marks to the page.  

2) Choose one added mark, default mark or cutline mark, on the layout, and then you can 
view and re-define its properties on the property panel, including line width, length, 
whether it is present on the front or back sides, whether it is present only on the black 
separation, and whether it is shown.  

 Space 

Also called margins, include the horizontal and vertical page space between pages, and 
the space between the page and layout borders. When being chosen, its properties, such 
as left margin and right margin, are shown on the property panel as well. Through them, 
you can re-define the space size.  

6.5.5 Manage Templates 
1. Template Directory 

The directory is used for classification and management on the ganging templates. 
Choosing the Template tab, you expand the directory structure. The Ganging 
Template is the root directory.  

Choose a directory, and then click the Preference icon  or right-click to get a menu, in 
which you can obtain the directory-related operating commands.  

 Create a directory 

Choose Create Directory. In the pop-up dialog box, input the directory name, and then 
click OK, to create a new directory.  
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 Directory management 

Delete a directory: Choose Delete and then click OK in the follow-up confirm dialog 
box. 

Rename a directory: Choose Rename and then input the new name in the follow-up 
dialog box and click OK.  

2. Copy, Delete, Rename template 

After you have chosen one template, you can use the commands from the Preference  
menu or the right-click menu such as Copy Template, Delete Template and Rename 
Template to copy, delete and rename the chosen template.  

3. Export/Import template 

The right-click menu item Export Template enables you to export the 
currently-selected template out of ElecRoc, while the Import Template item enables 
you to import a template into ElecRoc, under the currently selected directory.  

By using the Explorer (main menu Resource > Explorer), you can also export the 
ganging templates out of ElecRoc system to your specified location, or import outside 
ganging templates into ElecRoc system.  

6.5.6 Apply the Template 
The steps to apply a ganging template are as follows.  

1. Open the template in the composer window. The templates are located under the 
Template tab, and can be opened by double-click.  

2. Submit pages to the template.  

Switch to the Page tab, choose multiple pages and drag them onto any blank page of 
the template, such as the no. 1 page. Release the mouse button, and then ElecRoc will 
automatically place your pages into the blank pages according to the page sequence 
under the Page tab and the page number defined in the template.   

Therefore, please check up the page sequence under the Page tab before the ganging, 
and if needed, you can use the right-click menu items or the Preference menu items, 
such as Up and Down, to change the page sequence.  

3. Submit signature.  

6.6 More Features 

For more flexibility and convenience, and higher efficiency, ElecRoc ganging also provides 
you with the following functions and features.  

6.6.1 About the User Interface 
1. The Composer Window 
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Figure 2-356 

As shown above, the composer window is composed of the following parts:  

Main menu: Provides operational commands related to the ganging for you to use.  

Toolbar: Consists of multiple icons or buttons that can substitute for some 
commonly-used commands, for you to quickly perform the operations.  

The resource management pane: The pane located at the left of the window is 
designed for you to manage the ganging-related resources, such as pages, signatures, 
templates and marks. They are grouped into eight tabs, each with a unique operating 
interface.  

The editing area: The body of the ganging window is an area special for you to edit your 
signature and sheet, or perform various ganging operations.  

Property panel: Lists the property parameters of your selected sheet or selected object 
on the sheet for you to configure.  

Layer Structure pane: a floating pane, displayed after selection, listing the layer 
structure of current sheet. In layer structure, each sheet object is considered as a layer.  

Navigator pane: a floating pane, displayed after selection, showing the thumbnail 
image of the current sheet for you to navigate.  

Status bar: Displays the plate size, paper size, unit, number of the selected objects, and 
the cursor position. In addition, it contains two buttons at the rightmost, which can be 
used to control the display of the front and/or back sides and the display percentage.  
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You can use the mouse dragging to adjust the sizes of the resource management pane, 
the editing area, and the property panel. But when you re-open the ganging window, 
their sizes restore to a default setting. When you have expanded any tab of the resource 
management pane, you can hide the tab and the pane by clicking the tab once again. The 
property panel can be displayed or hidden by clicking the buttons / . The signature 
editing area can hold more than one opened signature or template, each one with a tab 
locating on the top, named with the signature or template name. You can click these tabs 
to easily switch between them.  

2. Toolbar icons 

 the position of the icons in the toolbar 

The icons in the toolbar are classified into several groups, separated by the symbol . 
Press down the left mouse button at the blank area between the icons within a group, 
then drag forward or backward and drop at any other , you can move the group of icons 
to the place where you drop the mouse button.  

 Show/hide toolbar icons 

Choose from the main menu Edit > Preference, and then choose Custom Toolbar 
from the pop-up window.  

The window lists all the toolbar icons that can be displayed and used and how they are 
grouped. Expand each group of icons. A tick in front indicates to show, while a cross in 
front indicates to hide. If needed, you can cross the icons that are less used or not used. 

 
Figure 2-357 

For your convenience, ElecRoc provides buttons such as Unfold, Fold, Select All, Clear, 
and Reset Default. By default, all the icons are shown in the toolbar.  

 The toolbar right-click menu 
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You can right-click on the blank area in the toolbar to get a shortcut menu, and then use 
the options to control if to show or hide a whole group of icons. If you check Lock 
Toolbars, then you cannot move the groups of icons. The Custom option enables you to 
separately control if to show or hide each of the icons.  

 
Figure 2-358 

3. Display of the front and back sides 

The controller  at the bottom of the ganging window 
controls the display of the front and back sides on the editing area. If you choose or , 
only one side (front or back) is displayed, and if you choose , both sides are displayed.  

Transparency: This option is applied to the sheet that contain both the front and back 
sides. It refers to the transparency of the front side on the back side, or that of the back 
side on the front side.  

4. Display proportion 

The sheet display proportion can be adjusted in the following ways:  

1) Use the Zoom tool . Choose this toolbar icon. The cursor turns to  after you 
choose.  

 Press down the left mouse button and drag the mouse, to form a rectangle in 
dashed-line on the sheet. The content inside the rectangle will be zoomed in on 
the editing area in the possibly biggest proportion.  

 Scroll up and down with the mouse wheel;  

2) Use the toolbar icons , , ,  and . The icon  zooms in, the icon  zooms 
out, and each click on these two icons zooms in/out in a fixed scaling factor, which can be 
defined with the Preference parameter Appearance Settings > Zoom Step. The 
icon  zooms to display the whole sheet in fitting proportion, and the icon  zooms to 
display the currently-selected object in fitting proportion. The object may be the sheet, 
the layout, a page, or a mark. The icon  zooms to a specified display proportion. Click 
it, and you can choose from the optional proportions, such as 2:1, 1:1, 1:2, or you can 
choose Custom to specify other proportion.  

ElecRoc also provides menu commands corresponding to the above icons, under the 
View menu.  
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3) Press down the Ctrl key and meanwhile scroll the mouse wheel to-and-fro to zoom in 
and out the view. The cursor turns to  if you press down the Alt key. At this time, you 
can zoom in and out the view as you do with the Zoom tool .  

4) Use the zoom controller at the lower-rightmost of the ganging window “Zoom: 61% 
  ”. Here you can not only know the current zoom proportion, but also 

can click the icons and  to zoom out and in incrementally (5% each click), or adjust 
the sliding bar to zoom in and out.  

5. Sheet Navigation 

For your convenience to browse the sheet when the view has been zoomed in, i.e. only 
part of the sheet content is displayed in the editing area, ElecRoc provides you with the 
following 4 optional capacities.  

 Use the mouse wheel to scroll the sheet up and down;  

 Drag the horizontal or vertical scroll bar;  

 Choose the toolbar icon , and then you can press down the left mouse button 
to drag the sheet freely;  

 Make use of the Surface pane.  

Choose from the main menu View > Navigator to display the Navigator pane.  

 
Figure 2-359 

In this area, ElecRoc displays the thumbnail images of the front and back sides of the 
sheet. When the zoom proportion increases to a certain extent, you will see a red 
rectangle box on the thumbnail image (the bigger the proportion, the smaller the box 
would be). The content inside the box are just the zoomed-in content in the editing area. 
Therefore, if you move the red box by clicking anywhere outside it on the thumbnail 
image, or if you drag and drop the box directly, you can subsequently change the content 
currently displayed in the editing area. In this way, by clicking or dragging on the 
thumbnail image, you can easily zoom in and browse the sheet in the editing area. 

6. Layer Structure 

ElecRoc introduces the concept of the layer. Each object on the sheet is considered by 
default as a unique layer. From the Layer Structure pane, you can adjust the sequence of 
the layers, to correctly deal with some issues come from the case when the objects 
overlap each other. 

7. Sheet Object 
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ElecRoc provides such commands under the View menu as Show preview image, 
Show file name, Display Page, Show Marks, Show bleeding box, Show trim box, 
and Show layout box, for you to control whether to show the sheet object or element 
including preview image, file name, page number, mark, bleed box, trim box, layout box, 
and etc. by default, all of them are shown on the ganging window.  

8. Other Display 

By using the commands Simple View and Operator View under the View menu, you 
can hide the property panel and the resource management pane from the program 
window, and by using the commands Show Guides and Show Grid under the Tools 
menu, you can control whether to show or hide the guide or grid on the window. 

6.6.2 Define Papers 
You can create or define the paper options that are available for selection in creating a 
sheet.  

 
Figure 2-360 

The operations related to defining a paper are all performed under the Paper tab. By 
using the commands from the right-click menu or the Preference  menu, you can 
finish such common operations as creating, editing, copying, and deleting.  

As shown in the above figure, each paper has six properties, among which the Name, 
Height and Width are compulsory. The button  enables you to exchange the width 
and height. The Manufacturer, Paper White, and Paper Thickness are optional 
properties. If needed, you can input related descriptions.  

Now that you have defined the papers, you can quickly define the sheet size and save the 
time to set the paper properties, by choosing the pre-defined paper options from the 
Paper dropdown list, at the time when you open the New Signature window to create 
a signature, or expand the property panel to edit the sheet.  
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6.6.3 Define Plates 
The purpose, method of operation, and the application of the plates, are basically similar 
to the papers mentioned above. The difference lies in that you need to define more 
properties as to the plates.  

 
Figure 2-361 

 Punch area 

If you need to punch in the later-on plate making, you can reserve an area on the sheet 
special for the punching. Punch Area controls the width of the punch area. Its position 
is determined by the Benchmarks parameter, it may be at the left, right, top or bottom 
side of the plate. If you don’t need this area, you can set the value to 0.  

 Punch marks 

ElecRoc can add a punch mark  at the center of the punch area.  

 
Figure 2-362 

 Side guide 

ElecRoc can add the marks such as  onto the sheet, for the side guide on the printing 
press to position the paper, in case the press model installs the side guide.  
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Checking it, you can further define the length, width, line width, position of the mark, the 
sheet side(s) on which it appear, and the separations on which it will be output. The Left 
and Right boxes control which side(s) of the sheet it appears on. The separation options 
include C, M, Y, K and Spot Color. E.g. if you do not want the mark to appear on the spot 
color separation, you can let the Spot Color box unchecked. The Benchmarks box 
provides four options, representing the mark position, shown as follows.  

 
Figure 2-363 

 Center marks 

A line mark appears at the center of the four sides on the paper, if checked.  

 Other parameter 

Device Type: Optional property. You can input related description here.  

6.6.4 Define Marks 
Marks here refer to the user-defined marks. Steps for adding custom marks into ElecRoc 
are as follows:  

1. Use third-party software to make the mark, and save it as a file that can be supported 
by ElecRoc, e.g. PDF, PS, TIFF, PRN, and etc.  

2. Enter in ElecRoc’s job window and submit the mark file to PDF Generator. After the 
process is completed, choose the generated PDF page, right-click and choose Add as 
Mark.  

Note: After PDF Generator’s process, the mark file can be further processed by nodes 
like PDF Tools and Page Clipper. Under such node or when the toolbar icon Pages is 
selected, you can still use the right-click menu item Add as Mark to perform the 
operation.  

3. Input the name of the custom mark, and then click OK.  

4. Return to the composer window. Expand the Custom Mark list under the Mark tab, 
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right-click and choose Refresh, and then you will see the newly-added mark.  

6.6.5 Auxiliary Tools 
We mentioned previously how to position pages by help of the auxiliary tools in section 
6.3.3. There are two auxiliary tools for the ganging, grid and guide.  

1. Grid 

 Show the grid 

When you have enabled the menu item Tools > Show Grid, you can see regularly 
spaced horizontal and vertical dashed lines on the sheet, forming a multitude of equal 
squares. Meanwhile if you have enabled another menu item Tools > Capture Grid, then 
when you move a sheet object close to any grid line, you can see two crossed red lines 
appearing and the object being captured to the place where the grid line is located. If you 
don’t want to use the grid as a reference for positioning, please disable the two menu 
items above.  

 Define the grid spacing 

Choose from the main menu Tools > Grid Spacing. The grid is composed of many 
identical squares. The spacing actually refers to the side length of such square. The value 
by default is 50 mm, with a range from 10~1000 mm.  

 
Figure 2-364 

2. Guide 

 Show the guide 

Choose from the main menu Tools > Show Guides. The display color of the guide lines 
can be defined from the main menu Edit > Preference > Color Settings.  

 Capture to the guide 

Choose from the main menu Tools > Capture Guides. When you drag a sheet object 
close to a guide line, ElecRoc will automatically capture the object to the place where the 
guide line is located.  

 Track the guide 

Choose from the main menu Tools > Track Guides. In this case, if you move the guide 
line, you will move the objects captured to the guide line at the same time.  

 Add a guide 

1. Do any of the following:  

 Double-click anywhere on the horizontal or vertical ruler;  

 Place the cursor on the ruler, and then press down the left mouse button and 
drag towards the sheet editing area;  
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 Click the toolbar icon ;  

 Choose from the main menu Tools > Add Guides.  

2. The Add Guides dialog box appears. Choose the direction, horizontal or vertical, and 
input the exact coordinate, and then click OK.  

 Move a guide 

Place the cursor on the guide line, the cursor then turning to an arrow-like shape, such 
as , and then press down the left mouse button and drag the mouse. In this way you 
can move the guide line anywhere easily. If you press the Ctrl key meanwhile, you can 
move the guide line to one of the commonly-used positions on the sheet. You can also 
double-click the guide line to re-locate it.  

 Lock the guides 

Choose from the main menu Tools > Lock Guides. The locked guide line can no longer 
be moved randomly. To unlock, please cancel the selection of this menu item.  

 Delete/Clear guides 

You can delete a guide line by simply dragging it outside of the sheet editing area. Or if 
needed, you can also click the toolbar icon  to clear all the guide lines.  

6.6.6 Resource Explorer 
ElecRoc enables you to export such resources as papers, plates, templates, and smart 
marks out of ElecRoc system by way of the resource explorer.  

Choose from the main menu Resource > Explorer to open the operating interface. The 
left of the window lists the four resource categories, paper, plate, template, and smart 
mark, and at the right it shows all the resources of a selected category.  

 
Figure 2-365 

Check the resources you want to export, and then click Export. And in the follow-up 
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dialog box, specify the name and destination for your exported resources.  

You can also click the Import button in the explorer to import paper, plate, template and 
smart mark resources into ElecRoc system.  

6.6.7 Preference 
Here refers to the ganging-related parameters that can be defined according to your 
preference. Choose from the main menu Edit > Preference to enter in the setup 
interface, which contains five group of parameters.  

 
Figure 2-366 

1. General Parameters 

 Alignment 

It refers to the benchmark for the page alignment. Pages can be aligned with each other 
based on the trim box or the media box.  

 Signature Checking 

ElecRoc enables you to check up the signature at the time you submit it to ElecRoc 
workflow, and if finding out error, it labels the error sheet in red, and shows detailed error 
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information once you choose the error sheet.  

Settings here control the items to be checked, including is it a blank layout, is it 
exceeding the plate, and is it exceeding the paper.  

 Other 

Small page and template alignment: It controls the default position of the page 
content on the template page, i.e. the default positioning setting under the Content tab 
of the property panel, when you choose a page or template page.  

Default Bleeding: The default bleeding setting of the page on the sheet.  

Knock Out: Controls if the Knock out option is enabled by default for each newly-added 
page. If checked, when you add a page to the sheet, or when you add a layout to the 
template, the property parameter Template > Knock out for the page in the sheet or 
layout will be checked by default.  

External/Internal CutLine: Controls if by default the External/Internal CutLine 
options are enabled for each newly-added page, not available to layout page. If checked, 
when you add a page to the sheet, the property parameter Template > External 
/Internal CutLine for the page will be checked by default. The default setup of the 
External/Internal CutLine options for the layout page is controlled by the parameter 
Preference > Mark Parameter > Cut Line.  

2. Mark Parameter 

Here you can define the default marks that would be added automatically when you 
create a layout. These marks include: 

Category sample Location 

Cut Line  the four corners of the layout 

Fold mark Single line , three lines  
middle points on the four sides of 
the layout 

Cross mark  Center of the layout 

Registration 
mark 

External target mark , solid target 
mark  

middle points on the four sides of 
the layout 

CMYK mark  the top of the layout 

Text mark  the bottom of the layout 

Table -13 

Under the Mark Parameter tab, you can control if the above marks are automatically 
added when you create a new layout. A tick means to add the corresponding mark. 
Moreover, you can define the default line width, height, and the specific type.  
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Figure 2-367 

Other Mark: They are the marks you manually add to the sheet. Here you can define the 
default line width and height for such mark.  

Only the black: If checked, the default marks above will be displayed and output only 
on the black separation.  

3. Appearance Settings 

 
Figure 2-368 
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Offset Step: The moving distance of each nudge when you use the arrow keys (、、
、) to nudge the selected object on the sheet.  

Grid Spacing: The spacing between any two grid lines.  

Sub Grid: After you have redefined the grid by using the main menu item Tools > Grid 
Spacing, you can use this parameter to further form a sub grid in each square of the old 
grid. The parameter here controls the number of the sub squares in horizontal (or vertical) 
direction.  

Undo Step: The times to perform the Undo operations.  

Zoom Step: The scaling factor for each click on the toolbar icons , , or on the zoom 
controls at the lower-right corner of the window. The default value is 5%.  

4. Color Settings 

You can define the display color of many objects, including the page’s bleeding box and 
trim box, group object’s border, guides, grid, workspace background, plate, punch area, 
and paper.  

In the Preference > Color Settings window, if you want to change the display color for 
some object, click the color block corresponding to the object to open a color setup dialog 
box. In this dialog box, you can choose a new color from samples or in the HSB or RGB 
mode. The preview area at the bottom of the dialog box displays the display effects.  

 
Figure 2-369 

5. Custom Toolbar 

Settings here control what toolbar icons are shown in the composer window. For details, 
refer to section 6.6.1.  
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Part 3 Appendixes 

Appendix A: Working Principle of ElecRoc 
In Founder ElecRoc, the objects that need to be processed include PS files, single page 
PDFs and signatures. The engine for processing these data objects is called Processor. 
Actually, the content we submitted to processor is a control file, which describes the data 
features of the objects. We call this control file Job Ticket. Therefore, processor is also 
called Job Ticket Processor (JTP).  

Each job ticket processor will take certain processing on some or all the pages of a job. 
According to processing objects and functions, job ticket processors are divided into PDF 
Generator, Imposer, Printer, Proof and Output processors, and etc.  

Besides job ticket processors, Founder ElecRoc has a control center. By using database 
with large capacity and high function, the control center provides a job ticket interpreting 
system, serves as the storage center and works with the controller efficiently. The 
workflow is handed down by job tickets. First job ticket interpreter obtains the workflow 
of a certain job by explaining job ticket files of this job, and then arranges the job to be 
processed to go through each job ticket processor.  

The job ticket processors in Founder ElecRoc run in parallel with each other. Thus, the 
workflow can process multiple jobs or multiple files in a job at the same time. In this way, 
system is able to optimize the workload efficiently.  

In Founder ElecRoc, it’s not necessary to install all processors in one server. Theoretically, 
the processors can run on any computer in the local area network. That means Founder 
ElecRoc is a distributed workflow management system.  

Normally there are two methods to improve the performance of the system. One is to use 
a PC server or a workstation with advanced configuration; the other is to set up a 
distributed workflow system by adding more inexpensive computers.  

The first way involves higher investment and puts greater demands on users. Computer 
with special parts running with advanced operating system is difficult to maintain and the 
users usually have to be specially trained.  

The second way employs the distributed system, which enables cheaper computers to 
take important task. If a job has 100 pages, the processing time of one page on a 
common PC is one minute; while on a high-performance server it is 20 seconds. If you 
use three computers to generate dot matrix at the same time, the total time is about 33 
minutes, closing to that on a high-performance server. However, the total price of these 
three computers is much lower. The advantage of the distributed system is distributing 
many time-taking operations to different computer and fulfilling the complicated work 
with cheaper hardware devices. 

To make full use of the distributed system, Founder ElecRoc allows its inner processing 
module - RIP (contained in PDF Generator and each output processor) - to run many 
objects at the same time.  
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Appendix B: Open Formats of ElecRoc 
Founder ElecRoc employed three open document formats: JDF, PDF and TIFF. 

JDF is the acronym of Job Definition Format, which is published by CIP4 organization on 
April 10, 2001. JDF is a job description file based on XML. Different from other electronic 
format, JDF not only describes the parameters to be processed of a job, but also 
describes the workflow of a job. In another word, JDF is able to provide a whole set of 
controlling system for printing workflow without any additional support. Besides that, 
JDF has the ability of monitoring and tracking a job. Taking the advantage of JDF, Founder 
ElecRoc surpasses its competitors for its excellent workflow management capability. 

JDF is a technical standard co-created by scores of the largest device and solution 
providers in printing industry. It is independent from any particular manufacturer and 
more and more manufacturers begin to take JDF as the standard for communicating with 
each other. The emergence of JDF connects the separate processes in previous printing 
industry seamlessly together. Founder ElecRoc is the first output workflow product that 
employs JDF in the world.  

PDF has been widely accepted in the industry. Its smart and powerful description ability, 
especially the high compatibility and stability are recognized universally. However, when 
it comes to the application of PDF, the answers will be uncertain. Some people even 
regard PDF only as a file format in electronic publishing. The development of Founder 
ElecRoc once again proves that PDF is a very suitable page description format in both 
lower-level printing and the highest-level commercial printing industry. Besides the high 
quality, PDF also brings a brand new prepress working fashion. As PDF can be previewed 
immediately, a user no longer needs to check his work after proofing. He can convert his 
work into PDF, and check on the PDF. This greatly improves the efficiency of printing and 
publishing. 

The final file submitted by Founder ElecRoc to output device is in TIFF format. The TIFF 
file is a dot matrix after rasterizing and can take exposure by any device drive. Founder 
ElecRoc recommends its option Founder EagleBlaster that drives various types of 
imagesetters and CTP. There is an interface between ElecRoc and EagleBlaster, 
transmitting information about the status of their devices and operations.  

 



Appendixes 

 353 

Appendix C: Acrobat Plug-Ins 
ElecRoc provides three plug-ins designed to be used in Adobe Acrobat. With them, you 
can gain the preflight positioning, zone trap, and free screen capabilities.  

C.1 Install Acrobat Plug-ins 

The methods to install the plug-ins in PC and Mac are different.  

C.1.1 For ElecRoc Client in Mac 
1. Open the ElecRoc install DVD and enter into the install directory \Tools\Acrobat 
plug_ins\MAC\, find out and copy the folder PFPosition.acroplugin (for preflight plug-in), 
ElecrocTrapPlugIn.acroplugin (for trap plug-in), and/or XScreenPI.acroplugin (for screen 
plug-in), see① in the following figure.  

2. Now open Adobe Acrobat’s Plug-ins folder (for instance, right-click Adobe Acrobat Pro 
on the desktop and choose Show Package Contents, see②, and then in the follow-up 
window choose Contents > Plug-ins, see③), paste the folder(s) you have copied above.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4-1 

Note: Please restart your Acrobat in case that you are running it during the installation. 

For the screen plug-in, after the installation, please open the file config.ini under the 
Acrobat directory Plug-ins\XScreenPI.acroplugin\Elecroc\, and input the ElecRoc server 
name, the client login user name and password (if any) you login ElecRoc, behind 
"Server=", "UserName=" and "Password=".  

1 

2 
3 
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Figure 4-2 

C.1.2 For ElecRoc Client in PC 
Run the install program AcrobatPluginSetup.exe under the install directory 
\Tools\Acrobat plug_ins\PC. During the installation, pay attention to:  

1. At the time when you choose the destination location, make sure that the path at 
Destination Folder is the correct one for your Acrobat.  

 
Figure 4-3 

2. At the time when you choose the setup type, note that Complete means to install all 
the three plug-ins, while Custom indicates that you can customize the plug-ins to be 
installed.  
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Figure 4-4 

3. In case that you choose Custom, then you can choose what plug-in to be installed in 
the follow-up dialog box. The one(s) being ticked will be installed. 

 
Figure 4-5 
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The other steps during the installation are very simple, please follow the instructions and 
click Next step by step to perform.  

C.2 Preflight Plug-in 

This plug-in requires that the version number of your Acrobat cannot be lower than 9. It 
provides the preflight positioning capability.  

Note: If your ElecRoc Client is running on Mac computer, before you use the preflight 
plug-in, please choose from the Client main menu Tools > Preferences > Net Config, to 
provide a user with whom you can access the ElecRoc server machine from the current 
MAC computer (refer to section 1.3.2 System Preferences in Part 2 for details). ElecRoc 
pops up a hint in case that you haven’t made this configuration.  

 
Figure 4-6 

 
Figure 4-7 
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Under the Preflight node in the job workflow, after the preflight check, right-click a 
checked page (any page in case of multiple-page mode) and choose Preflight 
Navigator, to open the file in Acrobat. And then you can use the plug-in to locate the 
objects with Error, Warning or Notification in the file.  

The user interface, a floating panel, is opened by default. You can also open it manually 
by choosing from the main menu Founder Plug-Ins > ElecRoc Preflight > 
Positioning. Another item under the same menu is Settings, designed for you to 
configure the language, the type and width of the lines constituting the rectangle that 
label the object. You can choose Tools > Customize Toolbars > Advanced Editing 
Toolbar to add these two items into the toolbar, which are shown as / .  

C.2.1 Positioning 
The Positioning panel is shown as follows. If you check the Individual Browser option, 
you can open one more panel named Browser.  

 
Figure 4-8 
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1. Show preflight results 

The top of the positioning panel shows a summary of the preflight result. The result is 
classified into three types, Error, Warning, and Notification. The numbers behind them 
indicate the quantity of the corresponding objects in the file.  

Check Results. The errors, warnings and notifications are then displayed in the below. 
They are further sorted by check entries, with a number behind showing the quantity of 
the objects returned for each check.  

Double-click a check entry (the blank circle in front turns to solid). One or all the objects 
returned for that entry will then be highlighted on the page, in a rectangle of solid or 
dashed line. The colors of the line for error, warning and notification are separately red, 
pink and blue.  

In the Highlight dropdown list, if you choose One, you highlight the objects for a same 
check entry one by one, and in this case, you can click the buttons |<, <<, <>, >>, >| 
in the below to switch among the objects. The button <> is used to locate a specified 
object that can be input in the edit box. If you choose Page, you highlight all the objects 
on one page each time, and at this moment, you can click the buttons |<, <<, 
<>, >>, >| in the below to switch among the pages in case that the check file is 
multiple-paged.  

The Information area shows the detailed information about the highlighted object. It 
may include the object type, width and height, color space, bit per component (BPC), 
encoding, color value, and etc. specific to the object type.   

The individual Browser panel contains an additional Rules setting area. Using the 
buttons |<, <<, <>, >>, >| in this area, you can switch among the entries.  
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Figure 4-9 

2. Show preflight rules 

Check Rules. You can view the checklist defined for the current Preflight node.  

C.2.2 Setting 
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Figure 4-10 

Language: English or Simplified Chinese.  

Line Type: The lines constituting the rectangle that highlights the object may be one of 
the two types, dash or solid.  

Line Width: Four levels of line width, 4 represents the thickest while 1 the thinnest.  

The setting takes effect after you reboot the Acrobat.  

C.3 Trap Plug-in 

This plug-in is available for ElecRoc Client running on both Mac and PC platforms. It 
requires Adobe Acrobat 9 or higher version being installed on your client computer.  

But note that, for use on Mac Client, please choose from the Client main menu Tools > 
Preferences > Net Config before you use it, so as to provide a user with whom you can 
access the ElecRoc server machine from the current MAC computer (refer to section 1.3.2 
System Preferences in Part 2 for details).  

 
Figure 4-11 

C.3.1 View Traps 
You can use the plug-in to view the trap result produced by the Trap node. Open the 
output file by Trap (right-click the file in the output file queue and choose Download > 

Founder Trap plug-in 
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Open), and you can then use the two toolbar icons as follows to display the trap result, 
or expand the Layers panel and check Founder Trapping Layer.  

 
Figure 4-12 

View Traps : To display the trap result on the page, as the dark green areas shown in 
the above (middle).  

View Trap Highlights : To highlight the trap result on the page, as the red areas 
shown in the above (right). The highlight color can be defined in the Trap Preferences 
window (Founder Plug-Ins > ElecRoc Trap > Trap Preferences).  

C.3.2 Trap Zones 
The trap zone here differs from the trap area in Chapter 6 of Part 2. The trap area refers 
to the specific location where the trapping happens, i.e. the overlapping area between 
two abutting trap objects. Here the trap zone refers to any section of the page area. You 
can define more than one zone on one page, and each zone may contain one or more 
color objects. The size of the zone can be customized freely, and the zones can overlap 
with each other.  

The zone is designed for you to define a set of trap settings that are applied to all the 
page objects within the zone. In this way, you can specify a multitude of zones on one 
page with great flexibility and freedom, and define various trap settings as needed for 
them, so as to realize diverse trap effects.  

The zones are in two types, the global zone refers to the whole page area, and the global 
trap setting, i.e. the setting defined for the global zone, is applied to all the objects on the 
page; a local zone refers to a section of the page area. In case that the global zone and 
local zones co-exist on a page, the global trap setting is then applied to the page objects 
outside the local zones.  

 
Figure 4-13 

Note: If you have define trap settings for the PDF file with a help of this plug-in, you need 
to properly configure the processor parameters Area trapping in job, Global trapping 
in job and Ink settings in job, when you submit the file to ElecRoc’s Trap processor.  

1. Zone Tools 
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The ElecRoc Trap toolbar in Acrobat is shown as follows.  

 
Figure 4-14 

The zone tools include the Rectangular Zone tool  and the Pointer tool . Their icons 
are located at the leftmost of the toolbar.  

The Rectangular Zone tool is designed for you to add zones on the page. Check the 
icon . The cursor turns to . Then press down the left mouse button and drag the 
mouse in any direction, and you can draw a rectangular of any size on the PDF page. A 
zone is produced once you release the mouse button. The zones are named as Zone 1-1, 
Zone 1-2, Zone N-n…; N is page number, and n is the zone number on each page.  

The Pointer tool is used to choose the zone(s) on the page, so that you can further 
perform such operations as re-positioning, size adjustment and property configuration. 
Check the icon , and then directly click on the zone. Being selected, the zone border 
turns bold in appearance.  

Choose a zone, and you can then perform the following configurations or operations.  

Position: By simply dragging the zone, you can move it to anyplace on the page.  

Size: Place the cursor at any corner of the rectangular zone, turning it to an arrow e.g. , 
and then press down the left mouse button and drag the mouse, and in this way you can 
enlarge or reduce the zone in any direction and in any size.  

Delete: If you want to delete an unneeded zone, choose it and press the Delete key.  

Enable Zone: Each zone contains a little box at its lower-right corner. By default, it is 
ticked, meaning that the trap setting defined for this zone is of effect. If you click it and 
turn it to a subtraction sign, the setting will then be disabled.  

2. Zone Display 

It is the following icons that control if and how the defined zones are displayed in Acrobat.  

View Zones : To display all the local zones on the page.  

View Global Trap Zones : To display the global zone on the page, if any.  

View Zones Fill : To fill the local and global zones with a specific color. The fill color, 
and the transparency of the fill color, can be defined in the Trap Preferences window.  

View All : To check all the three icons above, i.e. to display all the zones and trap result 
that can be displayed.  

View None : To display none of the zones or trap result.  

The commands corresponding to above icons are available under the Founder 
Plug-Ins > ElecRoc Trap menu.  

3. Arrange Zones 

In case that the zones overlap each other, the objects within the overlapping area are 
subject to the trap setting defined for the upmost zone.  

Choose a zone, click the toolbar icon Bring Forward  or Send Backward , and you 
can adjust the zone’s up-and-down relation in case of overlapping with other zone.  

4. Manage Zones 
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Choose the toolbar icon Trap Spotting Zones  to enter in the zone manage window.  

The left column lists all the page numbers of the current PDF file, and the zone quantity 
that each of the pages contains. The number in blankets represents the zone quantity. All 
shows the sum of the zones from all the file pages. The quantity remains empty if no zone 
exists on one page.  

The right column lists all the zones contained in a selected page. A tick  in front 
indicates that the zone is enabled. This sign disappears if you disable the zone.  

Delete: To delete your selected zone(s).  

Disable/Enable: To disable or enable your selected zone(s).  

Add Global: To add the global zone.   

Go To: To locate the selected zone on the page.  

/ : To change the zone’s up-and-down location.  

 
Figure 4-15 

C.3.3 Trap Setting 
Choose a zone and then click the toolbar icon Trap Settings . In the follow-up window, 
you can configure the trap setting applied to the zone.  
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Figure 4-16 

The parameters in this window have been introduced previously in Chapter 6 of Part 2. 
The settings for all the zones may be different from each other. The Enable option 
controls if to enable the setting defined for current zone.  

Click the Set… button to activate a dropdown menu, which provides three commands.  

Open: To open a parameter template.  

Save: To save the current trap setting as a parameter template for repeated use.  

Revert: To return to the factory setting.  

C.3.4 Trap Preferences 
From the Acrobat main menu, choose Founder Plug-Ins > ElecRoc Trap > Trap 
Preferences.  
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Figure 4-17 

Default Parameter: The default trap setting for each newly-added zone. The default is 
the factory setting named as Initial. It supports you to use the templates saved at the 
time you configure the zone trap settings. Specify first the directory where the templates 
are located in the Folder box, and then choose the template you want to use from the 
Default Parameter dropdown list.  

Spot Policy: Choose Keep to maintain the spot colors. If you choose Remove, the spot 
colors in the file would not be included in the Ink Settings window.  

Global Zone to: To what boundary of the page the global zone spreads, Trim Box, Media 
Box, Crop Box, Art Box or Bleed Box.  

Zone Area Color: Here you can define the colors filled in the global and local zones, and 
the color filled when the trap result is highlighted. Colors hare are all for the display 
purpose only. Click a color block to open the color setup dialog box, from which you can 
change the color. Zone Fill refers to the transparency of the fill color that can be adjusted 
by way of the sliding button.  

C.3.5 Ink Settings 
Click the toolbar icon  to open the Ink Settings window.  

This window lists the color separations in your file, and if you set the Spot Policy to 
Keep, it lists the spot colors as well, if any. It also lists the ink densities and ink types. 
Types of the four process colors are not editable, but those of the spot colors can be 
changed. The spot color ink densities are calculated based on the spot color values and 
the CMYK densities. You can change the densities and types as needed, and after that, it 
saves the settings as an ink profile named as default.  
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Figure 4-18 

Settings here can be applied into job workflow if you enable ElecRoc Trap processor’s 
parameter Ink settings in job.  

C.4 Screen Plug-in 

Zone screening is developed to enhance Founder ElecRoc’s local screen capability. It 
enables the screening towards particular objects in the file, including texts, images, 
graphs, and shadings. This feature is provided as a plug-in that can be integrated into 
Adobe Acrobat version 8 or 9, available for both the Windows and Mac platforms. 

C.4.1 Use Zone screening 
The method to use the plug-in in ElecRoc workflow is as follows.  

1. Double-click the PDF Rasterizer node in job workflow to open the parameter setup 
window. Check the option Zone Screen First under the Screen tab.  

2. From the output file queue under the PDF processor (before Imposer, Composer, and 
PDF Rasterizer, such as PDF Generator, PDF Tools), use the right-click menu item 
Download > Open to open up the PDF page file in Adobe Acrobat.  

3. Use the plug-in to define screen settings for the particular objects in the file. For details, 
refer to the next section.  

4. Save and close the PDF file.  

5. Now you can submit the PDF file to the Imposer and PDF Rasterizer nodes. The PDF 
Rasterizer will screen the file as per the screen settings made by the Acrobat plug-in.  
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Note: As to the objects in the file that you haven’t defined screen settings with the 
plug-in, ElecRoc will screen as per the screen settings made to the PDF Rasterizer node.  

C.4.2 Use the Plug-in 
1. Choose Objects 

The object refers to any object of the four object types contained in the file: text, image, 
graph, or shading. To choose one or more objects from the file, you need to use any of the 
two icons ( / ) in the toolbar.  

 
Figure 4-19 

: Check it, and you can choose an object by way of a simple click on it with your left 
mouse button. If you want to choose more than one object, use the Ctrl or Shift key.  

: When checked, it enables you to choose the object(s) within a rectangle area. You 
can hold down the left mouse button on the file page and move freely to form the 
rectangle. You can also use the Ctrl or Shift key in this case to choose more objects. 

Note: The toolbar can be displayed or hidden with the right-click menu item Founder 
Free Screening in the toolbar blank area.  

The objects being chosen are highlighted with a border, whose line color, line shape and 
width can be customized by way of the Preference parameters.  
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Figure 4-20 

You can learn the information about your chosen objects by right-clicking and choosing 
Properties. The pop-up window can then show the object-related information including 
the path’s fill & stroke color spaces and colors, the shading’s color space and type, the 
text’s fill & stroke color spaces, colors, font name, font type, and the image’s width, 
height, bits per channel, color space, and etc.  

If you choose an object from the object list, the plug-in will highlight it on the page for 
your reference.  

 
Figure 4-21 

Note: For multiple-paged file that has same object repeatedly appearing on some of the 
pages, if you zoom out to show these pages, and then choose one object, the same 
objects on other pages will be highlighted as well. And in this case, if you define screen 
settings for one object, the settings take effect on the same objects on other pages, too. 
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And when you open multiple files that contain a same object, if you choose one object in 
a file, the same objects in other files will also be highlighted. 

2. Define screen setting for object(s) 

To define the screen setting for your chosen object(s), perform as follows:  

1. Click the toolbar icon  or choose the right-click menu item New Object or Group 
Setting after you have chosen one or more objects on the page.  

A dialog box shown as follows appears.  

 
Figure 4-22 

The main body of the dialog box is a table. It lists all the objects you have chosen before 
you open the dialog box. From the list, you see which page the objects come from, their 
types, and their status. In case that an object has been defined the screen setting, its 
status would be labeled as Modified. And the bottom of the dialog box can show more 
information about the object, as long as you choose it in the list. 

2. Tick the object(s), give an identity name, and then click Setting.  

You can tick at one time not only one object, but also a group of objects. By default, all 
the undefined objects are ticked. The initial identity name, if you have chosen only one 
object before you open the above dialog box, appears as Object1, Object2, and 
Object3 … and if you have chosen a group of objects, appears as Group1, Group2, and 
Group3 …. However, as to this name, you can replace it with anyone else if you want.  

3. Now the screen parameter setup window pops up.  
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Figure 4-23 

Please define the screen parameters and specify proper curves, as you do in defining the 
PDF Rasterizer’s screen setting. The options in the four Curve dropdown lists are from 
ElecRoc server database, and can be updated manually with the button Connect to the 
server and update in the Preference window (by clicking the toolbar icon ). 

Separation Use Default Params: If checked, spot colors contained in currently-chosen 
objects will be screened as you define for the “Default spot” color in the table below. And 
in this case, the spot colors (if any) are not displayed in the table. If not checked, the 
table displays the spot colors (if any) for you to separately define their screen settings.  

To save the screen settings you have made, click Apply or OK.   

Buttons at the bottom function as:  

ReSet: To reset all the screen settings to the factory settings.  

OK: To save the screen settings you made, and close the setup window.  

Cancel: To cancel your screen settings, and close the window.  

Apply: To save your screen settings.  

4. If you need, you can choose part of the objects from the list and then click New to 
create a new object group, and then define the screen settings for this group of objects.  
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Figure 4-24 

5. Click OK to save your settings and exit.  

3. Add object to group 

Click the toolbar icon  or choose the right-click menu item Add to Group after you 
have chosen one or more objects on the page.  

 
Figure 4-25 

Choose a group and then click OK. The screen settings defined already for the group will 
then take effect on your currently-chosen objects.  

Before you click OK, you can click View to see the detailed screen settings that have 
been defined for the group.  

4. Screen Manager 
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You can modify or delete the defined screen settings for the objects or group objects, and 
edit what objects belong to a group.  

Click the toolbar icon , or choose from the menu Founder Plug-Ins > Free Screen > 
Screen Manager.  

 
Figure 4-26 

To modify the screen settings for an object or group, choose the object or group from the 
left table, and then make changes as needed in the parameter setup area at the right. 
After this, click Apply or OK to save the modification.  

To delete the screen settings for an object or group, choose the object or group, and then 
click Delete.  

Click Edit when you have chosen a group in the left table.  

You can rename the group in the Group name edit box. The table below lists all the 
objects that are belonging to the group. If needed, you can choose some of them, and 
then click the Delete button to delete them out of the group.  

If you choose some of the objects and then click New Group, you can create a new 
group. The Inherits option controls if the screen settings for the new group inherit that 
for the current group. If checked, they keep the same; if not checked, the default factory 
screen settings are then applied to the new object group.  
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Figure 4-27 

5. Preference 

Click the toolbar icon , or choose from the menu Founder Plug-Ins > Free Screen > 
Screen Preferences.  
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Figure 4-28 

Here you can define the properties of the border that is used for highlighting your chosen 
object(s) on the page.  

The properties include line color, line shape, and line width. Click the color thumbnail to 
open a color palette, from which you can choose or customize another color. The line 
shape can be solid or dashed, and the width can be 1~6 pixels.  

Connect to the server and update: By clicking this button, you can manually retrieve 
the latest screen-related data from ElecRoc server, mainly i.e. the available curve 
options.  
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Appendix D: Tools and Options 

D.1 1 Bit Tiff to PDF 

Using the 1 Bit Tiff to PDF tool, you can convert multiple 1 bit tiff files representing the 
various separations of a same page file, into a single PDF file.  

D.1.1 Install the tool 
The 1 Bit Tiff to PDF tool is delivered for use together with Founder ElecRoc system. But 
as a standalone program, you need to perform a separate and manual installation, on a 
computer in the LAN where you have deployed ElecRoc system.  

Recommended configuration: Pentium 4, 1 GB of RAM, 20 GB free disk space, 15’’ 
color monitor, CD-ROM drive, network connectivity.  

Operating system: Windows XP, Windows Server 2003 

Follow the steps below to install (on Windows XP as example).  

1. Double-click the file setup.exe to run the install program. The install program starts 
collecting system related information, and after this, it displays the welcome window.  

 
Figure 4-29 

2. Click Next. The install program shows the license agreement. Accept the terms and 
click Next to continue.  
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Figure 4-30 

3. Input the user name and company name, and click Next.  

 
Figure 4-31 

4. The install program prompts you to specify a destination. You can use the default folder, 
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or specify another with the Change button. And then, click Next.  

 
Figure 4-32 

5. Choose ElecRoc 6 and then click Next.  

 
Figure 4-33 



                      User Guide 

 37
 

378 

6. Specify the program folder.  

 
Figure 4-34 

7. The program prompts that it’s ready to begin the installation. Click Install.  

 
Figure 4-35 
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8. It starts the installation. The bar shows the progress.  

 
Figure 4-36 

9. When the bar reaches 100%, it shows that the installation is completed. Click Finish.  

 
Figure 4-37 
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D.1.2 About the tiff files 
This tool accepts the 1 bit tiff files from Founder ElecRoc. In ElecRoc, you can use the 1 
Bit TIFF Export processor to generate 1 bit tiff files under a specified directory. The output 
directory can be defined in the processor’s parameter setup window.  

  

Figure 4-38 

1. An ElecRoc workflow containing the processor 1 Bit Tiff Export;  

2. The 1 Bit Tiff Export processor parameter setup window.  

Note: The 1 Bit Tiff Export processor can name the output tiff files in 3 modes, by way of 
the 3 parameters, Simple display name, Full display name, and Rename as. Please 
note that, when you choose Rename as, the output tiff files must be in such a format: 
<JobName>_<Resolution>_<FullSepName> for the 1 Bit Tiff to PDF tool to accept.  

D.1.3 Start the tool 
Double-click the shortcut icon  for the tool on the desktop, or choose Start > All 
Programs > Founder > 1 Bit TIFF to PDF > 1 Bit TIFF to PDF, to start the tool.  

For use in ElecRoc environment you will need to provide the name or the IP of the 
computer where the ElecRoc dongle is installed.  

 
Figure 4-39 

Click OK. The main window of the tool appears.  

1 2 
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Figure 4-40 

D.1.4 Submit tiff files 
There are two ways for you to submit the tiff files to this tool.  

1. Use the Open command 

Click the toolbar icon , or choose from the menu File > Open…. In the follow-up dialog 
box, locate the tiff files and open them.  

The opened files are then shown in the upper-right queue of the main window, i.e. the 
Waiting… queue.  

 
Figure 4-41 

Note: In case that the till file name contains characters such as *, which is not supported 
by this tool, you need to manually delete such characters.  

2. Use a hot folder 

Define a hot folder and put the tiff files into the folder. The tool can automatically detect 
and process the tiff files entered into the hot folder.  
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To define a hot folder, perform as follows:  

1. Click the toolbar icon , or choose from the menu File > Add Hot Folder.  

 
Figure 4-42 

Input the name for your hot folder setting, and click OK.  

2. The setup window for your hot folder appears. Configure the parameters as needed, 
and then click OK.  

 
Figure 4-43 
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You need to specify the input and output folders.  

Input Folder: The folder where the tool receives the tiff files. After you put the tiff files 
into this folder, the tool can then automatically and regularly detect them, and process 
them upon the detection. If you check Include Subfolders, the tool can search for the 
tiff files in the subfolders (if any). In practice, for example, you can specify the output 
directory of ElecRoc’s 1 Bit Tiff Export processor as the input folder.  

PDF Output: The folder where the tool generates, i.e. outputs the PDF files.  

Resolution: The resolution of the final generated PDF files. If you want the resolution to 
be same as that of the input tiff files, check Original Resolution. If not, you can choose 
a resolution from the dropdown list or enter a custom one, ranging from 72 to 1440 dpi.  

Submit Jobs: The multiple tiff files screened from a same file may not arrive to the input 
folder simultaneously. In this case, you can check The jobs will be submitted when 
waiting time exceeds, and specify a time value, when no tiff files arrives within the 
specified time period (10 seconds), the tool will stop waiting and submit the files, even if 
some of the tiff files may have not arrived. Or you can check The jobs will be 
submitted when planes number equals to, and specify a number value, when the 
number of the arrived tiff files equals to the specified number, the tool will also stop 
waiting and submit the files, even if some files may not have arrived.  

You may specify other relevant parameters, if needed.  

Interval: The time interval at which the tool regularly detects in the folder.  

Finished File is Deleted or Moved to: If you check Deleted, the tiff files in the input 
folder will be deleted after the generation of the PDF file. If you check Moved to, you can 
specify a destination and the tiff files will then be moved to this destination.  

Click OK when you have defined the above parameters.  

3. You will then see the hot folder setting in the left queue of the main window. Check it 
to run the hot folder.  

 
Figure 4-44 

Note: When a hot folder is not running, i.e. unchecked, you can use the right-click menu 
items Modify and Delete to modify its setting or delete it.  

4. By clicking, make sure that the button in the upper-right queue (i.e. the Waiting… 
queue), has turned from  to . Now you can put tiff files under the hot folder, and the 
tiff files will soon enter into the file queue of the tool.  

 
Figure 4-45 
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D.1.5 Output PDF file 
1. Before the output 

The submitted jobs are listed in the Waiting… queue. The separations it contains are 
indicated at the end of the job name, such as (K|C|M|Y|S). “S” indicates spot color. 
Right-click a waiting job and you can get a shortcut menu. The menu items and their 
functions are as follows.  

About Job: To view the detailed information about the job, including job name, submit 
type, time, tiff files it contains, color names, and job status.  

Setting: To define the output setting.  

Retry: To output once again in case that the output is failed. For instance, if your job 
contains a spot color tiff file but you haven’t defined the spot color in advance, it would 
turn back the job (showing the job as No Setting) at the time of being output. In such 
case, you can define the spot color, and then choose this menu item to re-output the job. 

Delete Selected Item: To delete the selected job in the queue.  

Clear All Items: To delete all the jobs in the queue.  

2. Output setting 

Right-click the job and choose Setting.  

 
Figure 4-46 

Under the PDF Setting tab:  

PDF Name: If you choose Keep, the name of the generated PDF file keeps the same as 
that of the input tiff files. You can also choose Custom to define a custom file name.  

Resolution: Here you can separately define the resolution. Otherwise, it remains the 
resolution setting as defined in the hot folder or that defined by choosing from the menu 
Preferences > System Preferences > PDF Setting.  
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PDF Output: Here you can also separately define the output folder.  

If PDF file(s) exists: In case that a PDF file with same name exists in the output folder, 
if you choose Skip, a prefix will be added to the name of the newly-generated PDF file; 
and if you choose Overwrite, the existing file will be overwritten by the newer one.  

 
Figure 4-47 

Under the Spot Setting tab: 

If the job contains spot color separation, you need to define the values of the spot color, 
so that the tool can correctly output the spot color.  

Choose a spot color (if any), and manually enter the cmyk values, and then click Add. 
You can also define the spot colors by choosing Preferences > System Preferences > 
Spot Setting.  

3. Output 

Click the button  in the lower-right queue, i.e. the Processed… queue, turning it to . 
And the tool then starts generating the PDF files.  
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Figure 4-48 

4. After the output 

Switch to the output folder, and now you can see and open the generated PDF files.  

 
Figure 4-49 



Appendixes 

 387 

In Adobe Reader or Acrobat, when you have opened the generated PDF file, choose from 
the main menu Advanced > Print Production > Output Preview to show all the 
separations of the file. If you don’t check Output Preview, by default, it shows only one 
of the separations.  

In the Processed… queue, you can use right-click menu items Delete Selected Item 
or Clear All Items to delete the finished jobs from the queue.  

D.1.6 System Preferences 
Click the toolbar icon , or choose from the menu Preferences > System Preferences.  

1) Under the System Setting tab:  

Maximum Jobs for Processing: The maximum number of jobs in the two job queues.  

Warning Free Space: To issue warning when the free disk space in the partition where 
the tool is installed is less than the value specified here.  

Information Window Buffer: The size of the buffer that stores the messages in the 
information window.  

 
Figure 4-50 

2) Under the Spot Setting tab:  
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Figure 4-51 

Here you can define the spot colors for all the jobs, so that they can be properly output.  

Moreover, here you can import spot colors as system spot colors. But before this, you 
need to manually copy the spot color file (e.g. .sts file) into the System Spots directory 
(e.g. c:\Program Files\Founder\1 Bit TIFF to PDF\System Spots). To import system spot 
colors, choose System Spot Color, and click Load, and then choose the system spot 
color in the follow-up dialog box.  

System Spot Color First: When checked, if two colors from the Custom Spot Color 
and the System Spot Color lists have a same name, the system one will be used first, 
otherwise the custom one first.  

3) For settings under the PDF Setting tab, refer to the previous section.  

D.2 Load Balancing Tool 

This tool is designed to distribute the workload for PDF Rasterizer and Proof processors, 
so as to avoid any overload on them.  

On the computer where you have installed the PDF Rasterizer or Proof processor, 
double-click the file LoadBalanceTool.exe under the install directory \Tools\Load 
Balancing Tool\ to start up the tool.  
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Figure 4-52 

For the PDF Rasterizer processor:  

1. Stop PDF Rasterizer on ElecRoc Server.  

2. Run this tool, and input the ID of PDF Rasterizer in the Processor’s ID edit box. 

3. Specify a proper load balancing number.  

On the premise that your computer CPU has enough cores, with this tool, your computer 
can simultaneously start the specified number of PDF rasterizing processes. And 
moreover, it can distribute the multiple jobs submitted to your PDF Rasterizer processor 
to these synchronously running processes, improving the processing efficiency.  

4. Click Apply.  

5. Start PDF Rasterizer.  

For the Proof processor:  
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1. Stop Pre-RIP Proof or Post-RIP Proof on ElecRoc Server.  

2. Run this tool, and input the ID of the Proof processor in the Processor’s ID edit box.  

3. Click Device Querying, the proof devices installed on current computer will be listed.  

4. Check the device that your proof processor is connecting, and the devices of that same 
model, if any. ElecRoc can then distribute the multiple jobs submitted to your proof 
processor across these devices.  

5. Click Apply.  

6. Start your Proof processor.  

D.3 Unzip Manager 

With ElecRoc’s remote 3D preview capability, you can email your PDF pages as a single or 
a series of .zip files to a remote receiver for preview purpose. After receiving these .zip 
files, the remote user can use this tool to unzip them, so as to realize the 3D preview.  

1. Double-click the file UnZipManager.exe under the install directory 
\Tools\UnZipManager\ to start up the tool.  

 
Figure 4-53 
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Note: To use this tool, you need to install .NET Framework 3.5 or later version in your 
computer.  

2. Specify the target path. After the unzipping, a PhotoBook.exe file and related resource 
files and folders will be generated under this path.  

3. Click Browse to locate the .zip files. You can open multiple .zip files, and if needed, 
click Up or Down to change their sequences, which effect the sequences of the PDF 
pages in the final preview.  

4. Click OK.  

5. Now you can visit the target path, and click the file PhotoBook.exe to start the preview.  
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Appendix E: Glossary of Terms 
Prepress 

In press industry, the prepress refers to the work before printing. That involves every 
procedure during processing a document generated by layout application prior to its 
going to the press to be printed.  

PostScript 

PostScript is shortened as PS. It is a page description language developed by Adobe in US. 
PS is the universally accepted page description standard in printing industry. So far its 
latest version is PostScript 3.  

PDF 

PDF is the acronym of Portable Document Format, which is a document description 
format rather than a language. The latest version is PDF 1.5 based on PS 3 technology 
which possesses the same description ability as PostScript 3 and fully meets the 
requirements of printing. PDF is Cross Platform, Navigational, Ultra-Printable, 
Ultra-Viewable and Smaller than other conventional document formats.  

TIFF 

In prepress environment, TIFF is a widely used format for storing image data.  

EPS 

EPS is acronym for Encapsulate PostScript, which is a standard file format for importing 
and exporting PostScript files. In many applications, image and text information can be 
output in the form of EPS. The purpose of an EPS file is to be included in other pages, 
scaled and moved etc. like an image, but the contents of the EPS cannot be modified. EPS 
is the subset of PostScript, and is used for describing page contents. 

Normalizing 

To convert some documents that are not single-page PDF format into documents of PDF. 
Without particular requirements, the converted PDF documents will have the same 
printing results as the original documents. The particular requirements refer to 
requirements such as lowering the image resolution, etc. 

NORM 

NORM is the acronym of Normalizing Once, RIP Many. A job must first be normalized. The 
converted PDF has nothing to do with devices. Ripping will be processed for each output 
operation to ensure printing quality. 

Imposition 

In producing a publication with multiple pages, each page is imposed on one sheet 
following a special order. When the sheet is printed out, it will be folded to represent the 
intention of designer.  

OPI 

OPI is the acronym of Open Prepress Interface. In graphic design, if the size of some 
image is too large, user can replace the large image with a smaller one, and in the 
process before printing, replace the smaller image with the original one to have a good 
printing effect. The process of replacing the smaller image with the large image is OPI. 

Trapping 
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Trapping is a way to compensate for mis-registration, and it’s also a criterion that many 
people use to judge "quality" printing. Trapping is the intentional overlapping of colors 
that adjoin each other to prevent the stock or substrate from showing through when 
maintaining tight register is difficult or impossible. 

RIP 

Abbreviation for raster image processing, a hardware and/or software system that 
translates page description command into bitmaps for output to a laser printer or 
imagesetter. 

Color Management 

In prepress environment, color management refers to the transformation from user color 
space to device color space. 

Proofing 

Proofing is to preview the effect of the printing material to ensure the effect of the final 
products. Proofing includes sheet proofing, imposition proofing and color proofing. Sheet 
proofing is for checking the content on a sheet, such as fonts, figures and images; 
Imposition proofing is for checking the result of imposition; Color proofing is for checking 
the color effect on a sheet. 

Print 

In prepress environment, printing is a special form of sheet proofing. 

Output 

In printing industry, output refers to the final output, which sends the raster image to 
output devices. Different output devices generate different results. The output of 
imagesetter is film, while that of CTP is plate. 

Output Device 

Output device refers to the device for final output.  

Client 

Client is the program that uses the functions provided by ElecRoc Server to process a job. 
A user can accomplish all works related to a workflow through Client. Client may be 
installed in a PC or Mac that is in the same domain or group with Server. Founder ElecRoc 
allows more than one Client working at the same time. 

Server 

Server refers to the service programs on one PC or a group of PC with high configuration. 
These PCs are networked in a local area network. Server is able to accomplish the 
prepress output operation of the jobs that are submitted by users. Server has the 
Internet service function, which enables each Client to communicate with server. Server 
also has a SQL database, which, on one hand, controls the operations of jobs, on the 
other hand, saves all the operation information and provides reports for users’ work. 

Job Ticket (JT) 

Job ticket is a document that describes the process mode and settings of one or a series 
of operations. Job ticket is global and has nothing to do with a particular job. A job ticket 
can serve many jobs at the same time. 

Job Ticket Processor (JTP) 

Job ticket processors provide prepress processing functions. In Founder ElecRoc system, 
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there are many processors, such as PDF Generator, Imposition, Proofer and Output. 

File 

A file is the minimum data processing unit. The following types of files can be accepted by 
Founder ElecRoc workflow management system: PS, PDF, EPS, PRN, etc. 

Job 

Job is an aggregation of files that will be processed by system. All the operations are 
about job. In general, each one of the files in a job has relationship with each other. For 
example, all the files belong to the same transaction. 

In Founder ElecRoc system, a job is the object of various processes. All the works are 
about jobs. 

Process 

Submitting the data of a job to a JT forms a process. A process is only aimed at the data 
of one job, while the data of one job can be processed by many processes. 

Page 

After normalizing, the page description document is divided into single pages. A page is 
a PDF document. 

Sheet 

The large piece of paper used for printing is a sheet. The Sheet in ElecRoc TPLEditor is the 
front side and back side of a signature. 

Signature 

One side of a sheet is a signature. 

Section 

To fold the signature according to the page number and content to form a section. 
Sections need to be assembled and bound to form a book. 

DPI 

Dots Per Inch describes the resolution of device. DPI refers to precision of laser beam. 
The higher the resolution, the thinner the laser beams. In printing the resolution of 
information on the output of a print job is a measure of the density of that information 
and is measured as dots or lines per linear measure.  
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